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ACE Translator 3000 V7 
 

HELP GUIDE 

INTRODUCTION 
ACE Translator 3000 is the most robust CAD translator tool available on the market today, allowing you to 

easily convert over 100 common EDA and CAD formats. Supporting built in translation, viewing, and editing 

capabilities, ACE Translator 3000 combines efficiency and value in one application. 

 Seamless Conversion Between common EDA and CAD Formats with over 100 

supported common EDA, CAD, and 3D translators in one software package. Convert between DXF, 

Gerber, GDS-II, DWG, Postscript, PDF, HPGL, NC Drill/Rout, OASIS, Image files, and more.   

 

 Built-In CAD Viewer allows you to view and/or print all common EDA and CAD formats under a 

single unified viewer, saving thousands of dollars in time and software.  Easily view any format 

without the need to convert files.  

 

 Built-In CAD Editor giving you the ability to make modifications, fix, and repair any translation 

before committing to export. ACE 3000 includes powerful editing and repair tools that automatically 

clean and edit zero width lines, self-intersections, and redundancy. This will save time and prevents 

additional errors. 

 

 Advanced Tools Included for a variety of operations, including Boolean, Composite Editing, 

Polygon De-Embedding, and more. 

 

 High Resolution Output with the ability to work with images of up to 25,400,000 DPI accuracy 

in either bi-level TIFF or Bitmap format. Ideal for high-resolution output used in maskless 

lithography, materials deposition onto substrates, and other manufacturing solutions. Features 

such as Mirror, Invert Polarity, Trim edges, and data compression are included! 

 

 Import and Export ODB++ Files using ACE 3000’s built-in ODB++ plugin. Easily convert your 

ODB++ data to a multitude of design formats typically not supported by Mentor Graphics or any 

other commercial tool on the market.  
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 3D Plugin that allows you to import your 2D designs into 3D tools such as SolidWorks, 

ProEngineer, and Rhino3D for mechanical analysis, prototyping, and visualization. Quickly import or 

export .STL files, or just export DXF and IGES files.  

ACE TRANSLATOR 3000 V7: WHAT’S NEW 

New Features (v7.3.2) 
 

 DWG Import now supports AutoCAD 2015 DWG files.  

 Modernized graphical interface with improved usability; allowing ACE to be the most user-friendly 

CAD conversion software on the market.  

 New Multi-Line Text command added to CAD Viewer. 

 New and improved layer control in the CAD Viewer.  

Improvements (v7.3.2) 
 

 Improved Join Automatic and Interactive Commands. 

 Improved handling of Elliptical Arc edges with Solid Hatches during DXF/DWG Import.  

 Improved drawing tools options in the CAD Viewer 

Bug Fixes (v7.3.2) 
 

 Over 35 minor bugs have been fixed. 

 

To learn more about ACE 3000’s latest features, improvements, and fixes please visit the revision history 

page at: http://www.numericalinnovations.com/pages/ace-translator-3000-revision-history 

To view a summary of ACE 3000’s translation capabilities, including a complete list of file types, please view 

the following: http://cdn.shopify.com/s/files/1/0160/7198/files/ace3000v7_brochure.pdf?184 

 

 

 

 

 

 

 

 

http://www.numericalinnovations.com/pages/ace-translator-3000-revision-history
http://cdn.shopify.com/s/files/1/0160/7198/files/ace3000v7_brochure.pdf?184
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ACE 3000 HELP GUIDE INTRODUCTION 

The ACE 3000 Help menu is divided into 9 sections. Within each section, it is broken down by topic. For 

example, Section 4 would be the section number of the help document. Section 4.1 would be section 4, 

topic 1. There are also subtopics; for example, section 4.1.1 (section 4, topic 1, subtopic 1).  

ACE 3000 SECTION SUMMARY  

Section 1 - Getting Started: Setup and installation, license registration, and support.  

Section 2 - Working with ACE 3000: An overview of the ACE 3000 GUI for both the Convert window and  

       CAD Viewer window. 

Section 3 - ACE 3000 Basics: Introduction to the basics of ACE 3000 including viewing & control, file   

       conversion, and exporting basics for images and PDF.  

Section 4 - Frequently Asked Questions: The most common questions related to using ACE 3000.  

Section 5 - Supported File Formats: A concise list of ACE 3000 supported files that can be converted using  

       ACE 3000. 

Section 6 - Understanding CAD Formats: An explanation of the most popular CAD formats that can be  

       converted using ACE 3000.  

Section 7 - Convert: A detailed explanation of the Convert menus and settings for the most popular file  

       formats, including exporting and importing files such as DXF, Gerber, ODB ++, STL, and more. 

Section 8 - CAD Viewer: A detailed explanation of the CAD Viewer menus.  

Section 9 - Purchase and Support: Discusses purchasing, licensing, and support options for ACE 3000. 

FORUM & VIDEO HELP 

        Below each topic or subtopic, you’ll find forum and video links relevant to the 

 discussion.  For additional help on topics beyond this manual, look for this symbol. 

 We’ll include links to the ACE 3000 video library on YouTube as well as direct 

 navigation to relevant ACE 3000 forum topics. 
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SECTION 1: GETTING STARTED 

1.1 Minimum System Requirements 

 OPERATING SYSTEMS 

 Windows (32-bit and 64-bit) XP/2003/Vista/7 

 Linux (32-bit) Kernel 2.4 

 Linux (64-bit) Kernel 2.6 

 HARDWARE 

512+ MB RAM  

 120+ MB Free Hard Disk Space 

 Super VGA (1024x768) Display 

 High Color (16 bit) Graphics Card 

 4x CD-ROM Drive with 32-bit Drivers 

 Mouse w/ Center Wheel Button (Intelli-mouse) 

 Keyboard 

 Internet Connection Recommended 

1.2 ACE 3000 v7 Installa tion 

 WINDOWS 

 1.  Download ACE 3000 for Windows at: 

      http://www.numericalinnovations.com/pages/download-page 

a. For a full featured trial license, fill out the download request form and use a valid email 

address.   

b. Upon verification, an email will be sent to your address with download link and trial license 

key included.  

 

2.  Click the download link included in the email address. 

 

http://www.numericalinnovations.com/pages/download-page
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3.  Unzip the installation file ace3000v7.zip, and run the installer ace3000v7.exe.  

 3.  Follow the install wizard procedures and choose a location for ACE 3000.   

  

 LINUX 

 1.  Download ACE 3000 for Linux at http://www.numericalinnovations.com/pages/download-page 

 2.  Select ACE 3000 v7 – FREE TRIAL 

a. For a full featured trial license, fill out the download request form and use a valid email 

address.   

b. Upon verification, an email will be sent to your address with download link and trial license 

key included.  

 3.  Click the download link included in the email address.  

 4.  Uncompress the file and select a folder where you have read/write permission. 

 5.  We recommend installing to /opt/ace3000. 

Registered Customers Only – Windows 

For those who have already purchased an ACE 3000 license 

1. Start ACE 3000 and navigate to the Help > Enter License Key > Activate menu 

2. Enter your activation code(s) below and complete the registration process. 

Note: Create a unique password that you will remember. To transfer or reinstall your copy of ACE 3000, 

you will be asked for your password to recover your activation code. 

Registered Customers Only – Linux  

For those who have already purchased an ACE 3000 license 

1. Start ACE 3000 

2. If a license key dialog box does not appear, go to the Help > Enter License Key menu. 

3. In the dialog box, select Get Permanent License Key.  

4. Upon filling out the form, a new key will be sent to you  

http://www.numericalinnovations.com/pages/download-page
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Forum: ACE 3000 for Linux 

 

 

1.3 Understanding Licensing & Registration  

ACE 3000 offers several license types: Single User, Multi User, Numerical Cloud, and FLEXnet licensing.  

SINGLE USER - ACTIVATION CODE (INTERNET ACTIVATED):  

Enter your activation code and it will be automatically verified over the internet. When you are ready to 

move to another computer, simply de-Activate from your old computer, and Activate on your new 

computer.  

MULTI USER - ACTIVATION CODE (INTERNET ACTIVATED):  

Enter your activation code one-time and registration is performed automatically over the internet. This is 

then repeated for multiple users.  You also have access to an online License Control Panel (LCP) allowing 

you to manage multiple licenses (activate/deactivate). 

NUMERICAL CLOUD - ACTIVATION CODE (INTERNET ACTIVATED):  

Enter your activation code and it will be automatically verified over the internet. When you are ready to 

move to another computer, simply de-Activate from your old computer, and Activate on your new 

computer.  

ACTIVATION PROCEDURE FOR SINGLE/MULTI/NUMERICAL CLOUD (INTERNET ACTIVATED)  

1. Start ACE 3000. 

2. Go to ACE 3000 menu Help > Enter 

 License Key > Activate  

3. Paste your activation code into the 

 edit box (use key CTRL + V). 

4. Create a password that is easy to 

 remember (at least 4 characters). 

5. Enter your email address. Single/Multi 

Users only. 

6. Select “Next” and follow the 

 activation prompts.  

 

 

http://forums.numericalinnovations.com/post/ace-3000-for-linux-6462163
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HOW FLEXNET WORKS 

ACE 3000 uses FLEXnet Publisher for license 

management. You can use either a valid 

license key file or physically install the file 

(*.lic). If no license is detected, ACE 3000 will 

start in unregistered mode.  

 

 

 

 

 

 

 

 

Single User - FLEXnet License  

A hardware locked license where the software is locked per machine (no internet activation required). A 

FLEXnet “Node-Locked” license is also referred to as a single user license.   

Copy/Paste an ACE 3000 License Key Via FLEXnet: 

1. Start ACE 3000  

2. In the Help menu, select Enter License Key > Enter FLEXnet Key 

3. Your Product Name and Host ID will already be filled in with relevant registration information.  

4. In the window titled License Key, paste your license key information. 

 

Your license key information will contain the following format: 

 

FEATURE ace3000 numinno 7.0 3-aug-2014 uncounted HOSTID=ANY \ 

    ISSUED=4-jul-2014 \ 

    NOTICE=E49814636-WR@workroom.elance.com;ace3000;8191;0 TS_OK \ 

    SIGN="0F4F BF09 9E6F F9C3 D926 C08B 1DF9 3B37 291F 833C 4A35 \ 

    44A8 1BFA A7E7 0AAC 019D E7E2 E6CF 44FB F6E6 B6CE 2409 C09B \ 

    3530 2B3A ACFB E221 1CB3 4E49 58E4" 
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FEATURE: This contains information of your product, version number, and licensed duration. For 

a single user license, HOSTID=ANY.  

ISSUED: This is the date of license issue. 

NOTICE: The address listed is the email address from which the license was sent to you. 

SIGN: This includes the string of key characters which make up the license key. Quotation marks 

should be included. Backslashes are also included.  

       Notes: 

c. Copying and pasting may produce random characters that replace certain text in the license. 

Make sure to replace these characters with the original text included in the license.  

d. Copying and pasting may produce inaccurate spacing of your license characters. Make sure 

to duplicate the spacing above for proper activation. 

e. Your operating system’s clock must be set to the exact date. If the date is not correct, the 

license key file will not activate.  

 

5. Once the license information is properly pasted and formatted, select Activate. 

6. If your key is valid, you’ll receive the following message: 

 

In the case your license key is not valid, you will receive an error message. 

Check to make sure your key is properly formatted and there are no phantom characters or 

spaces. For additional help, contact sales@numericalinnovations.com.  

ALTERNATIVE OPTION: INSTALLING A LICENSE KEY FILE 

You can also install your FLEXnet license key file (*.lic) by copying the .lic file to the following directory: 

Windows 

C:\Numerical Innovations\ACE3000V7 

Linux 

/opt/Numerical/ACE 3000 

ACE 3000 will automatically check this directory for a license key upon startup.  

FLEXNET PUBLISHER LICENSING FOR ENTERPRISE ENVIRONMENTS 

mailto:sales@numericalinnovations.com
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FLEXnet Publisher offers easier management for concurrent licensing environments. With FLEXnet, multiple 

licenses can be deployed from a central server (FLEXnet Server) located onsite. The maximum number of 

seats (concurrent users) and access location of the server computer will be indicated by the invoice issued 

from Numerical Innovations. Numerical Innovations will provide a Network Bundle Package which contains 

all necessary files, utilities, and instructions. There are two types of licenses under this program: 

Network/Floating - FLEXnet (Concurrent):         

This option is ideal for companies that want to manage the number of engineers using ACE 3000 but do not 

want to manage the individual users of the product.  

Enterprise/Site - FLEXnet (Unlimited):         

The ultimate freedom in software licensing because it grants your company the right to install UNLIMITED 

seats of our software onto your workstations, networks, laptops, or home computers.  

INSTALLING NETWORK & ENTERPRISE LICENSES VIA FLEXNET 

Supported Platforms 

Microsoft Windows XP/2003/Vista/7 (32-bit) 

Microsoft Windows XP/2003/Vista/7 (64-bit) 

Linux 2.4 Kernel or Higher (32-bit) 

Linux 2.4 Kernel or Higher (64-bit) 

Getting FLEXnet Server 

Upon purchase, the Network Bundle Package will be sent to the appropriate administrator. This package 

contains the following files: 

c. network.txt (document) 

d. lmgrd (Server Daemon) 

e. nummino (Vendor Daemon) 

f. lmtools, lmutils (FLEXnet supplied utilities) 

g. FLEXnet_licensing_end_user_guide.pdf (FLEXnet Publisher instructions) 

h. vcredist_x86.exe (for Windows 32-bit only) 

1. Extract the files above to a temporary folder. 

2. Copy all files to a designated folder of your choice on the FLEXnet server. This folder will also be 

known as the FLEXnet server.  

 Note: For Windows platforms, the default copy location is C:/FLEXnet.  

          For Unix/Linux platforms, you will create your own folder and select a location. 



ACE Translator 3000 V7 

 

Page 10 

If you have an existing FLEXnet installation, you can choose whether or not to overwrite the 

old files.  

GENERATE YOUR LICENSE FILE (*.LIC)  

3. To generate your license file, the following is required: Platform, Hostid, & Hostname. 

4. Choose your FLEXnet server platform: Windows-32, Windows-64, Linux-32, or Linux-64. 

5. Determine your Hostid by using the following procedure: 

 a. Open a command line window and navigate to your designated FLEXnet folder. 

 b. Type the following command: lmutil lmhostid 

 c. This will return one or more options for hostid. Choose the first one that appears in the list. 

6. Enter the hostname. To find the hostname of the FLEXnet server, run hostname from a command 

line on the FLEXnet server. Save this information as it will be required for step 14. 

7. Complete the Numerical Innovations “Request License Form” at 

http://www.numericalinnovations.com/license_request.html 

8. After completing the form, the license key will be emailed to you in one business day. 

SAVING AND CONFIGURING YOUR LICENSE FILE (*.LIC) 

Upon receiving the license file (license.lic), perform the following: 

9. Save license.lic to the FLEXnet folder. 

10. In the FLEXnet folder, open license.lic in a text editor. 

11. In text editor, edit the vendor path to match the path for the FLEXnet folder. For example: 

 In Windows 

 VENDOR numinno C:\FLEXnet\numinno.exe 

 C:\FLEXnet is the path to the FLEXnet folder 

 numinno.exe is the daemon that authorizes each license installation with Numerical Innovations 

 In UNIX/Linux 

 The path should be the exact same path that you chose in Step 2. 

12. Save and close license.lic within the text editor. 

STARTING THE FLEXNET SERVER AND INSTALLING A CLIENT  

http://www.numericalinnovations.com/license_request.html
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13. To start FLEXnet server, open a command line on the FLEXnet server while in the FLEXnet folder.  

 Type the following: lmgrd –c license.lic 

14. The environment variables must be set as follows: 

 In Windows 

 a. Select Control Panel > System > Advanced Tab > Environment Variables. A dialog box  

  will appear. 

 b. Under System Variables, select New. A new dialog box will appear. 

 c. In the top entry field, enter LM_LICENSE_FILE. 

 d. At the bottom field, enter port@hostname. 

 e. For default port, enter 27000. 

 f. Enter the FLEXnet server hostname (see step 6). This may or may not be necessary.  

 g. Click OK and close all dialog boxes. 

 In UNIX/Linux 

 a. Type LM_LICENSE_FILE=port@hostname in the command line.  

 b. The default port is 27000. 

 c. Enter the FLEXnet server hostname (see step 6).  

INSTALLING TO A CLIENT 

14. On each licensed local client machine, install ACE 3000 by following the instructions included with 

 the CD (or download file). 

15.  Copy the license file (*.lic) in the ACE 3000 installation folder. Typically this would be labeled as: 

 C:\Program Files\Numerical Innovations\ … (whatever directory you installed the software into). 

Congratulations! You may now start the ACE 3000 product on each licensed client machine. 

Note: For Windows installations, the error message “Missing MSVCR80.dll” (or similar) may or may not 

occur when starting the vendor daemon numinno.exe. If it does occur, please install the Microsoft 

Redistribution Utility known as: vcredist_x86.exe. This utility will repair any missing .dll files that you 

require.  

     Forum: How do I move my license to another computer? 

  Forum: How do I install my license file? 

 Forum: How do I install a Network/Floating License? 

http://forums.numericalinnovations.com/post/How-do-I-move-my-license-to-another-computer-4903592
http://forums.numericalinnovations.com/post/how-do-i-install-my-license-file-lic-2490865?highlight=license
http://forums.numericalinnovations.com/post/how-do-i-install-a-networkfloating-license-2490871?highlight=license
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  Forum: ACE 3000 keeps telling me my software is unregistered. 

 

 

 

 

1.4 Launching ACE 3000 

WINDOWS 

1. In the Start menu, select All Programs. 

2. Search for Numerical Innovations. 

3. Select ACE 3000 v7. 

The ACE 3000 startup screen will appear. 

LINUX 

1. Run the shell file: ace3000v7.sh 

2. The script will automatically assign ACE 3000 library paths using LD_LIBRARY_PATH. 

The ACE 3000 startup screen will appear. 

If ACE 3000 does not startup, it is most likely due to the LD Linker not able to locate the required ACE 3000 

shared libraries (*.so). In this case, manually assign the libraries by performing the following: 

 a. Execute the Shell/Terminal program. 

 b. Type the following commands: 

  LD_LIBRARY_PATH=/opt/ace3000/lib 

  export LD_LIBRARY_PATH 

  ./opt/ace3000/ace3000 

 The example above assumes ACE 3000 was placed in folder/opt/ace3000  

 If ACE 3000 still does not startup, then your Linux distribution may be missing certain required 

 packages/libraries. 

 To verify if you have the included packages/libraries installed perform the following: 

 a. Execute the Shell/Terminal program. 

 b. Type the following commands: 

http://forums.numericalinnovations.com/post/ace-3000-v7-keeps-telling-me-my-software-is-unregistered-6922736
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  ldd /opt/ace3000/ace3000 

 The example above assumes ACE 3000 was placed in folder/opt/ace3000  

 c. Review the output of this command. If any library files are missing they will be referenced  

  here. 

 d. Install any missing packages/libraries required to install ACE 3000. 

 For additional installation help, contact support a 

 http://www.numericalinnovations.com/pages/customer-support 

 In your support inquiry, make sure to include the output from the command Idd. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.numericalinnovations.com/pages/customer-support
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SECTION 2: WORKING WITH ACE 3000 

2.1 ACE 3000 GUI Overview  

The ACE 3000 Translator is divided into two primary sections: Convert 

and Viewer. Using the tabs at the top right corner of ACE 3000, you 

can seamlessly switch between sections for converting or viewing.  

  

 

 

2.1.1 Convert Window  
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2.1.2 Convert Window Menus 

The ACE 3000 conversion window provides a seamless ‘two-way’ convert center for over 100 common EDA, 

CAD, and Mechanical 3D file formats. Below is a summary of each graphical menu. 

 

 

Menu Bar 

This includes File, Setup, and Help located at the top left corner of the conversion 

center. This is used for saving or restarting ACE workspaces, setup, and general help 

on using ACE 3000. 

Help Bar  

Used to query help questions through the 

Numerical Innovations online forums for ACE 3000.  

Import & Export Format 
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Choose the format of the file you currently have using Import Format. In Export Format, choose the file 

which you intend to convert to. In the picture above, a file in DXF format will be converted to Gerber 

format.   

Conversion Mode offers two sub-modes: Normal and Batch. Normal conversion mode performs a single 

conversion. Batch conversion mode performs multiple conversions on a group of files. Simply click the blue 

arrow to toggle between Normal and Batch conversions.  

Information Window 

Along the top of this 

window, there are 

several tabs to choose 

from which offer 

general information, 

tutorials, and help for 

converting file formats. 

They include What’s 

New, Watch YouTube 

Tutorials, Learn Basics, 

FAQ, and User Forum 

Posts. 

Bottom Buttons 

 

Exit: Exits ACE 3000 

Back / Next: Once Import/Export and Conversion Mode is defined, the Next button will proceed with the 

file translation process.  
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ACE Tutorial Wizard 

As you progress along the conversion process by selecting Next, the ACE 

Tutorial Wizard on the right will offer information to help you define and 

understand the settings used in each step. The Tutorial is extremely helpful 

for understanding definitions and settings while progressing along the 

conversion process.  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2.2 Viewer Window  

Job Editor 

Menus 
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2.2.1 Viewer Window Menus  

 

Located directly above the editor and layer display, the workspace menus provide a graphical illustration of 

functions that are also listed throughout the Job Editor menus (File, Edit, View, Add, etc.). Below is a 

summary of each graphical menu. In Section 8: CAD Viewer, we’ll discuss every menu function in detail.  

Workspace Menu 

The workspace menu provides immediate functions for Restarting ACE 3000, Saving 
Workspaces, Cell Information, Cell Browser, Plotting & PDF, Export Screen Capture. 
It also includes access to the switch Back to Conversion Setup, Export Bitmap, and  

   Export Tiff. 

Draw Menu 

With the draw menu, access important CAD drawing functions such as Pads, Traces, 
and Poly. The draw menu pull down offers access to additional shapes such as 
Circle/Arc, Rectangle, Ellipse, Wide Path, Text, Multi-Line Text.  

Workspace 

Menu 

Layers Panel 

Editor/Viewer 

Convert 

and 

Viewer 

Tabs 
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Modify Menu 

The modify menu provides for editing of existing objects. This includes Rotate, Flip, and 
Undo/Redo. Using the modify menu pull down, access additional edits such as Delete, 
Move, Copy, Copy to Layers, Scale, Stretch, Split, Chamfer, Fillet, and Properties. 

  

Display Menu 

The display menu provides viewing functions within your design. The most prominent 
are Re-Draw, Zoom In/Out, Zoom Window, and Zoom All. Using the display menu pull 
down, access additional views such as Pan (Left, Right, Up, Down) and Object View  

         Filter.  

 

Selection Menu 

The selection menu provides selection functions for the objects and shapes within the 
editor. This includes Select All, Standard Selection, Add Selection, Subtract Selection, 
Selection Filter, and Clear Selection. The selection drop down menu adds additional  

      selection manipulations such as Select Display, Select Window, Select Crossing Window,  
      Select Fence, and Select Window Polygon, and Select Crossing Polygon. Group or  
      Ungroup is also available to create independent groups of polygons.  

 

Utilities Menu 

The utilities menu provides an array of various features to use within your design. This 
includes Query, Find, Measure, Add Rulers, Backside View, Translucent View, and Fill. 
From the selection menu pull down, you can Add Ruler, Clear Rulers, or select an  

                    Apertures Report or Nets Report.    

Featured Tools Menu 

The featured tools menu includes all of ACE 3000’s most significant tools for 

editing your design. This includes Join, De-Embed, Bool Layers, and Clip Area.  

             Using the featured tools dropdown menu reveals additional ACE 3000 special  

             features such as View Join Errors, Join Interactive, Convert to Polygon,  

             Convert to Flash (Automatic), Convert to Cell, Remove Tiny Segments, Chop  

             Polygons, and Fix Invalid Polygons.  
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SECTION 3: ACE 3000 BASICS 
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3.1 Introduction  

ACE 3000 is the leading CAD, EDA, and 3D file format translator in existence today. For electronic products 

and components, there are three primary levels of design: Mechanical, Electrical, and Manufacturing. At 

each phase of the design process, different software applications are employed. This results in a lack of 

interoperability between file formats as the product advances in development. Integrated file format 

communication and translation between each level of design becomes inefficient, cost prohibitive, and 

error-prone.  

ACE 3000 acts as a “conduit” or “two-way” translator between files. It allows for the instant conversion of 

over 100 common file formats widely used in PCB, IC, MEM, RF/Microwave, Chemical Milling, and a host of 

other production processes for electronic design.  

In addition to file conversion, ACE 3000 includes built in CAD viewing and editing functions. This is a 

revolutionary approach to reducing costs and increasing productivity when compared to single-format CAD 

translators.  

 

 

3.2 View & Selection Control  
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With ACE 3000’s built-in CAD viewer, there are a number of ways to select, view, and zoom objects, layers, 

and cells.   

3.2.1 Mouse Control  

Right Click: Right click over the editor menu to provide a list of commands for navigating, selecting, and 

editing your design. For more information on Right Click functions, see Right Click Menu.  

Left Click: Left click to select a command or left click in editor to select an object. When left double clicking 

an object inside the editor, the properties of that object will be shown. 

Dynamic Zoom: To zoom in and out on a particular region of the editor, use the middle mouse wheel. 

Scrolling forward will automatically zoom in. Scrolling backward will automatically zoom out.  

Dynamic Pan: Pan or move around the editor by clicking and holding the middle mouse wheel down. At the 

same time, drag across the region of the editor to travel in any direction.  

Zoom Window: There are several ways to enable Zoom Window: 

 1. Select View > Zoom > Window. 

 2. Right click in the editor display menu then select Zoom > Window.  

 3. Press the hot key “W” to enable Zoom Window.  

By left clicking and dragging anywhere around the region of the editor, a zoom window is enabled over the 

selected region. Alternatively, by simply left clicking in the editor ACE 3000 will automatically zoom by 2x.  

Select an Object: As the mouse hovers over an object in the editor it will add a highlight surrounding the 

object. Left click to select the object. The object will stay highlighted.   

Select Multiple Objects: As the mouse hover over an object in the editor it will add a highlight surround the 

object. Hold down the SHIFT or CTRL key and left click to select multiple objects at once.    

With your selection(s) active (highlighted), they are now part of the Active Selection Set. 

Leave or Reset Function or Selection Set: Use the ESC key at any time or right click inside the editor and 

select Cancel.  

3.2.2 Workspace Display Modes 

 Redraw: Redraws or refreshes the display in the editor menu. 

Zoom In: Zooms in using 2x magnification.  

Zoom Out: Zooms in at half magnification.  

Zoom All: Shows the entire design area within the editor. 

Zoom Window: Allows users to pick a window around an area to be zoomed.  
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3.2.3 Workspace Selection Modes  

Standard Selection Mode: This is the default setting for ACE 3000 upon startup. This 

selects an individual object. Each time you select an object, all previous objects will be 

unselected. 

Add Selection Mode: This button allows you to add and highlight multiple objects at once; 

similar to using the SHIFT or CTRL key to add a group of objects to the Active Selection Set.  

Sub Selection Mode: This button allows you to subtract highlighted objects from the Active Selection Set.  

Clear Selection Mode: This button will subtract all objects from an active selection set. Alternatively, you 

can use the ESC key or Right Click on the mouse and select Cancel.   

Selection Filter: The selection filter box helps control the content of an active object by allowing you to 

include or exclude Dcodes, Layers, Composite Levels, NC Tools, Polygons, or Text from being selected. 

Simply highlight an object then choose the Filter icon. This will open the Selection Filter dialog box for that 

layer.  

3.2.4 Using Selection Windows  

There are several selection window options for selecting multiple objects over a specified area of your 

design. They include: 

Select Window (Blue Box Highlight): The selection window allows 

you to click and drag over a specific area of a group of objects in 

order to highlight what is required. Any object contained inside 

this window will be selected only. Left Click anywhere within the 

editor and then drag across the editor to the Right. The selection 

box is highlighted in blue.  

Dynamic Selection Window (Blue Box Highlight): Using dynamic 

selection, Left Click on an empty area in the editor and drag 

across to the Right to cover any selection area you require. The  

          selection box is highlighted in blue.  

Select Crossing Window: Any objects contained inside or intersecting this window will be selected. 

To activate, use Right Click Menu > Selection > Crossing Window. Left Click on an empty area in the 

editor to define the first point, then Left Click again to define the next point.  
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Dynamic Selection Crossing Window (Green Box Highlight): Any object 

contained inside or intersecting this window will be selected. Left Click on 

any area in the editor and drag over the selection area you require to the 

Left. The crossing window will be highlighted in green.  

 

 

Quick Query Selection: Move the mouse over any object and Left Click. A status window will appear 

with information about the object. Alternatively, the same information will also appear at the status 

bar in the bottom of the screen.  

Note: When selecting polygons and traces, make sure to select their Edges.  

3.2.5  Right Click Menu  

Right clicking the mouse while in editor is an alternate way to access menu 

options related to editor mode.  

Repeat Print: Opens printer and PDF setup window.  

Cancel: Cancels the current action. For example, “canceling an object selection”. 

Zoom: Several zoom functions 

available such as Zoom All 

(zooms back to entire design), 

Zoom In/Zoom Out, Zoom 

Window, Zoom Previous, Zoom 

to Point, and Zoom to Selection. 

 

 

Pan: Pan includes Left, Right, 

Up, Down, and To Point. 

Redraw: Redraws the object.  
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3.2.6  Right Click - Selection Options  

All: Selects and highlights all objects within the editor. 

Display: Selects all objects within the Editor. 

Window: The selection window allows you to click and drag over 

a specific area of a group of objects in order to highlight what is 

required. Objects contained inside this area will be selected 

only.  

Crossing Window: Specify selection by dragging mouse from 

corner to corner over area of objects. Objects contained inside 

or intersecting this window will be selected. 

Fence: Create a custom selection fence around the area of 

objects you wish to define as selected. 

Window Polygon: Create custom polygon around the area of 

objects you wish to define as selected. 

Crossing Polygon: Specify selection by dragging mouse from corner to corner over area of objects to 

produce a polygon window. Objects contained inside or intersecting this polygon will be selected. 

Clear All: Will subtract all objects from an active selection set. Alternatively, you can use the ESC key or 

Right Click on the mouse and select Cancel.   

Filter: The selection filter helps control the content of an active object by allowing you to include or exclude 

Dcodes, Layers, Composite Levels, NC Tools, Polygons, or Text from being selected. Simply highlight an 

object then use Right Click > Selection > Filter. This will open the Selection Filter dialog box for that layer.  

Reset Filter: Resets the selection filter.  

Clipboard Options 

Cut to Clipboard: Cuts selected object(s) to 

clipboard. 

Copy to Clipboard: Copies selected object(s) to  

         clipboard. 

Paste from Clipboard: Pastes selected object(s) 

from clipboard. 

Delete: Deletes selected object. 

Move: Moves selected object.  

Copy: Copies selected object. 
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Mirror Options 

Mirror: Includes Flip Horizontal, Flip Vertical, Flip Horizontal (Line), 

Flip Vertical (Line). 

Rotate Options 

Rotate: Rotates 90o, 180 o, 270 o or Via a specified base 

and angle using the command line editor. 

 

 

Array: Edit for rectangular or polar array. 

 

Open Selected Cell: Opens a selected objects.   

Query: After selecting query, select an object. A dialog box will display the object’s properties. 

List: Opens the command line log. 

Properties: Edit the properties of an object. This includes layer attributes and point list.  

 

3.3 Layer Basics  

There are two ways to display the layers table: 

1.  Select Setup > Layers or select the “L” hot  

     key. 

2.  View the Layers table located directly to         

     the right of the editor/viewer.   

3.  Within the Layers table, select the Layers  

      Table icon.  
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3.3.1  Turn Layers On / Off  

Next to each layer name is a light bulb icon that represents the current view state of the layer in a design. 

The light bulb indicates the status of each layer. Click the light bulb to activate/deactivate each layer.  

 If the light bulb is dark, the layer is inactive.  

 If the light bulb is yellow, the layer is active.  

3.3.2  Adjusting Layer Color  

Individual layer color can be adjusted for easier viewing.  

To adjust layer color, left click the adjacent color box. Choose or adjust to a different layer color from the 

color selection box. 

3.3.3  Isolating Layers  

You can isolate a particular layer for viewing while hiding              

the remaining layers.  

To isolate a layer, right click within the layers panel and select Isolate Layers from the menu.  

3.3.4  Add Layer  

To add a layer, select the   symbol. The Add Layer 

dialog box will appear. Enter the new layer name 

and layer type. Select OK. 

 

 

 

 

 

3.3.5  View Individual Layers  

To view an individual layer within the editor, double click the layer within the layers panel. To cycle through 

the list of individual layers, use the  arrows.  
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3.3.6  Right Click Layer Menu  

Right click within the layers panel to activate a number of functions for layer 

manipulation. The standard options include: 

Isolate Layer: You can isolate a particular layer for viewing while hiding the 

remaining layers.  

All Layers On: Turns all layers on. 

All Layers Off: Turns all layers off. 

Add: Adds a new layer. 

Rename: Renames a selected layer. 

Delete Layer: Deletes selected layer.  

Clear Layer: Clears a selected layer. 

3.4 Cell  Basics  

Please note that this feature is only available when importing data that contains a hierarchy (i.e. GDSII, 

OASIS, and DXF). This is an excellent feature for previewing designs in the workspace.  

To activate the Cell Browser, select View > Cell Browser. 

 

 

 

 

1.  Select any cell item to 

 preview it in the right 

 window.  

2.  Using the Cell Browser, 

 you can easily navigate 

 through the designs 

 using the Up/Down 

 arrow keys. 

3.  To open a cell in the 

 viewer, highlight the 

 cell item and select 

 Open Cell in Viewer.  
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3.5 Conversion Quick Start  

Convert over 100 common file formats using ACE 3000. Use the summary below to quickly convert file 

formats. For a more detailed description of each import/export option, see Section 7: Convert.  

Step 1: Configure Formats and Select File 

 

From the drop down lists, select the Import and Export Formats.  

 

Note: Since ACE Translator can import and export different file types, each format will offer a different set      

of configurable options as you progress through the conversion process.  

 

Once both the Import and 

Export formats are selected, as 

well as a Conversion Mode 

chosen, select Next. You’ll be 

prompted to select files for 

conversion (Import). Once 

selected, choose “Open”.  
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Step 2: Verify Import Options 

 

Review and modify import options. Notice the ACE Tutorial Wizard to the right, as it will provide guidance 

and definitions for each import/export option as you progress through the conversion.  

Remember, with each file format chosen for either import or export, there will be different options listed 

throughout the menu. We’ll talk more about each of these options in Section 7: Convert. In most cases you 

will not need to modify import options. 

Select Next when complete. 
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Step 3: Verify Export Options 

 

Review and modify export options. Notice the ACE Tutorial Wizard to the right, as it will provide guidance 

and definitions for each import/export option as you progress through the conversion.  

Remember, with each file format chosen for either import or export, there will be different options listed 

throughout the menu. We’ll talk more about each of these options in Section 7: Convert. In most cases you 

will not need to modify the import options. 

Select Next when complete. 

If there are any warnings or errors, an Error Log List will appear. If there are no issues, ACE 3000 will 

proceed to Step 4. 
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Step 4: Configure Export Layers Map 

 

Review and modify the export layers map. Use the check boxes in the export column to select or deselect 

layers for export. To select all layers, Right Click in the Export column. Notice the ACE Tutorial Wizard to the 

right, as it will provide guidance and definitions on layers as you progress through the conversion. 

Select Next when complete. 

Step 5: Complete Export  

Select an output folder to save your newly 

exported file formats and choose OK.  

ACE 3000 will begin to write the new file(s).  
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Once the Finish! Log 

is displayed, choose 

the following: 

A.  Select the Viewer 

tab at the top right 

corner. This will take 

you to the CAD 

Editor/Viewer.  

B.  Select Open 

Output Folder to 

review your 

converted files.  

C. Press F2 to review 

the ACE translation 

log. 

 

Note: All file locations of the exported files are displayed in the Finish Log. 

Note: To convert additional file(s), select Restart.  

To save your workspace, select Save ACE Workspace.  

 

    Blog Link: DXF Conversion Secrets for Gerber, ODB++, GDS-II, etc.  

   Blog Link: DXF/DWG to Gerber Conversion Guidelines 

 

 

 

 

 

 

 

 

 

http://www.numericalinnovations.com/pages/dxf-dwg-conversion-secrets-for-gerber-gds-ii-odb-etc
http://www.numericalinnovations.com/blogs/news/6116174-dxf-dwg-to-gerber-conversion-guidelines
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3.5.1 Translation Exercise: DXF to Gerber  

Convert a PCB created in AutoCAD to Gerber(s) using ACE Translator 3000. For a complete overview on DXF 

Import options, see Section 7: Convert.  

1.  In the Import Format dropdown, select DXF.  

 

 

2.  In the Export Format dropdown, select Gerber.  

3.  Select Next. A file browser 

window will appear for you to 

choose which DXF file to import 

for conversion. 

4.  Choose the DXF file for 

conversion, then select Open 

from the file browser window. 

You’ll be taken to the Verify 

DXF Import Options window.  
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5.  Review or modify the 

DXF Import Options for 

Layers, Options, Blocks, 

and Merge. These tabs 

are located at the top left 

corner of the window.  

Note: Since DXF files are 

unit-less it is important 

to be aware of the 

imported DXF file units & 

scale. ACE 3000 needs to 

know what physical unit 

and scale to use for 1 

DXF unit. 

 

 

Note: The Layers tab is a preset feature used to optimize your DXF layer settings (such as Fill, Wide Polyline, 

Flash, Join, and DeEmbed) for the most common type of design you’re translating.  Choose whatever 

description best describes the type of DXF design.  The feature is optional. 

6.  Select Next.  

 



ACE Translator 3000 V7 

 

Page 36 

 

7. Verify the Gerber 

Export Options.  

Note: Select the 

Gerber RS-274-X 

options that will be 

suit your 

conversion 

requirements.  

 

 

 

 

 

 

 

8. Select Next.  

 

 

 

 

 

 

 

 

 

 

Video: Convert DXF to Gerber and NC Drill Data 

   Video: Convert DXF to Gerber (for a microwave coil) 

http://www.youtube.com/watch?v=QmFSISjpUrY&list=PL1E12FD2CD7FC1E6E&index=2
http://www.youtube.com/watch?v=f-Wpv4kW06Y&list=PL1E12FD2CD7FC1E6E&index=1
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Note: Each selected layer will be exported as an individual Gerber file. Using the check boxes in the Gerber 

Export column, select or deselect the layers you want to export. To select all, right-click within the checkbox 

column. You can also select Mirror or Neg (Negative Polarity) to any layer using the check boxes. 

Additionally, you can also rename layers by selecting the file name of each individual layer.  

Note: If you have selected Negative or Mirror options for any layers, they are placed in the Gerber file you 

have selected. They will not appear in the ACE Viewer.  

9.  Select Next. You will be prompted to select 

the export folder for the Gerber file. Choose a 

file from the file browser window.  

Note: If you choose a folder that does not 

exist, ACE 3000 will create one for you 

automatically. 

10.  Once you’ve selected a Gerber file to 

export, select OK. ACE will begin to write the 

Gerber files.  

 

 

 

11.  After the conversion is complete, the Finish Log is displayed. At this point you may: 

A.  Select the Viewer 

tab at the top right 

corner. This will take 

you to the CAD 

Editor/Viewer.  

B.  Select Open 

Output Folder to 

review your 

converted files.  

C. Press F2 to review 

the ACE translation 

log. 
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Note: The file location of the exported folder for the Gerber files is displayed in the Finish Log. These Gerber 

files can now be used with any CAM program such as FAB 3000, Valor, Graphicode, etc. 

3.5.2 Translation Exercise: DXF to GDSII  

Convert a PCB created in AutoCAD to Gerber(s) using ACE Translator 3000. For a complete overview on DXF 

Import options, see Section 7: Convert.  

1.  In the Import Format dropdown, select DXF.  

 

 

2.  In the Export Format dropdown, select Gerber.  

3.  Select Next. A file browser 

window will appear for you to 

choose which DXF file to import 

for conversion. 

4.  Choose the DXF file for 

conversion, then select Open 

from the file browser window. 

You’ll be taken to the Verify 

DXF Import Options window.  
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5.  Review or modify the 

DXF Import Options for 

Layers, Options, Blocks, 

and Merge. These tabs 

are located at the top left 

corner of the window.  

Note: Since DXF files are 

unit-less it is important 

to be aware of the 

imported DXF file units & 

scale. ACE 3000 needs to 

know what physical unit 

and scale to use for 1 

DXF unit. 

 

 

Note: The Layers tab is a preset feature used to optimize your DXF layer settings (such as Fill, Wide Polyline, 

Flash, Join, and DeEmbed) for the most common type of design you’re translating.  Choose whatever 

description best describes the type of DXF design.  This feature is optional. 

Note: When converting DXF to GDSII all DXF layers are assumed to be filled, so there is no need to 

display the Layers page. 

6.  Select Next.  
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7. Verify the GDSII Export Options.  

Note: Select the GDSII Export Options that will be suit your conversion requirements.  
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8. Select Next.  
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Note: Each selected layer will be exported as an individual GDSII file. Using the check boxes in the GDSII 

Export column, select or deselect the layers you want to export.  

9.  Select Next. You will be prompted to select 

the export folder for the GDSII file. Choose a 

file from the file browser window.  

Note: If you choose a folder that does not 

exist, ACE 3000 will create one for you 

automatically. 

10.  Once you’ve selected a GSII file to export, 

select OK. ACE will begin to write the GDSII 

files.  

 

 

 

 

11.  After the conversion is complete, the Finish Log is displayed. At this point you may: 
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A.  Select the Viewer tab at the top right corner. This will take you to the CAD Editor/Viewer.  

B.  Select Open Output Folder to review your converted files.  

C. Press F2 to review the ACE translation log. 

3.5.3 Translation Exercise: Image to GDSII  

Converts an image file (gif, jpeg, tiff, bmp) to GDSII using ACE Translator 3000. This is an excellent way to 

incorporate your company logo into a design or for converting photos taken from microscopic devices back 

to GDSII for comparison purposes against the original CAD data. 

1.  In the Import Format dropdown, select Image.  

 

2.  In the Export Format dropdown, select GDS-II.  
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3.  Select Next. A file browser window will appear for you to choose which Image file to import for 

conversion. 

4.  Choose the Image file for conversion, then select Open from the file browser window. You’ll be taken to 

the Verify Image Import Options window.  
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5.  Review or modify the Image Import Options.  

Note: Since image files are unit-less, and a pixel can theoretically represent any physical size, it’s important 

that you specify the proposed units and scale for a pixel’s physical size. Choose from Micron, Inch, 

Millimeter, Centimeter, and more.  

Note: Logical pixel size defined by Pixel Units * Image Scale 

6.  Select Next.  
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7. Verify the GDSII Export Options.  

8. Select Next.  
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9.  Select Top Cell and Layers to Export Menu 

Note: Each selected layer will be exported as an individual GDSII file. Using the check boxes in the GDSII 

Export column, select or deselect the layers you want to export. To Select All, right-click within the GDSII 

Export column. You may also map the Layer Numbers and Data Types used in the exported file by clicking 

each column to assign values. 
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10.  Select Next. You will be prompted to select the export folder for the GDSII file. Choose a file from the 

file browser window.  

Note: If you choose a folder that does not exist, ACE 3000 will create one for you automatically. 

11.  Once you’ve selected a GSII file to export, select OK. ACE will begin to write the GDSII files.  

 

11.  After the conversion is complete, the 

Finish Log is displayed. At this point you 

may: 

A.  Select the Viewer tab at the top right 

corner. This will take you to the CAD 

Editor/Viewer.  

B.  Select Open Output Folder to review 

your converted files.  

C. Press F2 to review the ACE translation 

log. 
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3.5.4 Translation Exercise: Postscript to Gerber  

Converts a PostScript file created in various graphics program to Gerber using ACE Translator 3000.  

1.  In the Import Format dropdown, select PostScript.  

 

 

2.  In the Export Format dropdown, select Gerber.  

 

 

3.  Select Next. A file browser window will appear for you to choose which PostScript file to import for 

conversion. 

4.  Choose the PostScript file for conversion, then select Open from the file browser window. You’ll be 

taken to the Verify PostScript Import Options window.  
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5.  Review or modify the PostScript Import Options.  

6.  Select Next.  

Note: Ghostscript must be 
installed on your 
workstation or server to 
import PostScript. 
Ghostscript is freely 
available and distributed 
under the GNU General 
Public License.  If you do 
not have Ghostscript 
installed you may download 
it from the following 
websites (or from other 
available mirrors): 

http://www.cs.wisc.edu/~ghost/doc/gnu/index.htm 

http://www.cs.wisc.edu/~ghost/doc/gnu/index.htm
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http://www.ghostscript.com/ 

 

7. Verify the Gerber Export Options.  

8. Select Next.  

 

 

 

 

 

 

 

 

 

http://www.ghostscript.com/
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9.  You’ll be taken to the Select Top Cell and Layers to Export Menu 

Note: Each selected layer will be exported as an individual Gerber file. Using the check boxes in the Gerber 

Export column, select or deselect the layers you want to export. To Select All, right-click within the Gerber 

Export column. You may map the Layer Numbers and Data Types used in the exported file by clicking each 

column to assign values. 

Note: You may Mirror and/or assign Negative polarity to any layer by selecting the appropriate check 
boxes. Layers may also be renamed.  

Negative and Mirror options are placed set the Gerber file (if you have selected), however they will not 
appear in the ACE Viewer. 
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10.  Select Next. You will be prompted to select the export folder for the Gerber file. Choose a file from the 

file browser window.  

Note: If you choose a folder that does not exist, ACE 3000 will create one for you automatically. 

11.  Once you’ve selected a folder to export to, select OK. ACE will begin to write the Gerber files.  
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11.  After the conversion is 

complete, the Finish Log is 

displayed. At this point you 

may: 

A.  Select the Viewer tab at 

the top right corner. This will 

take you to the CAD 

Editor/Viewer.  

B.  Select Open Output Folder 

to review your converted files.  

C. Press F2 to review the ACE 

translation log. 

 

 

3.5.5 Translation Exercise: Convert GDS-II to TIFF File  

Convert a GDSII file to TIFF using ACE Translator 3000. 

 

1.  In the Import Format dropdown, select GDS-II.  

 

2.  In the Export Format dropdown, select TIFF.  
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3.  Select Next. A file browser window will appear for you to choose which GDS-II file to import for 

conversion. 

4.  Choose the GDS-II file for conversion, then select Open from the file browser window. You’ll be taken to 

the Verify GDS-II Import Options window.  
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5.  Review or modify the GDS-II Import Options.  

6.  Select Next.  
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7. Verify the TIFF Export Options.  

8. Select Next.  
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9.  You’ll be taken to the Select Top Cell and Layers to Export Menu 

Note: Each selected layer will be exported as an individual TIFF file. Using the check boxes in the TIFF Export 

column, select or deselect the layers you want to export. To Select All, right-click within the TIFF Export 

column. You may map the Layer Numbers and Data Types used in the exported file. 

Note: You may Mirror and/or assign Negative polarity to any layer by selecting the appropriate check 
boxes. Layers may also be renamed.  

Negative and Mirror options are placed in the TIFF file (if you have selected), however they will not appear 
in the ACE Viewer. 
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10.  Select Next. You will be prompted to select the export folder for the TIFF file. Choose a file from the file 

browser window.  

Note: If you choose a folder that does not exist, ACE 3000 will create one for you automatically. 

11.  Once you’ve selected a folder to export to, select OK. ACE will begin to write the TIFF files.  
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11.  After the conversion is 

complete, the Finish Log is 

displayed. At this point you 

may: 

A.  Select the Viewer tab at 

the top right corner. This will 

take you to the CAD 

Editor/Viewer.  

B.  Select Open Output Folder 

to review your converted 

files.  

C. Press F2 to review the ACE 

translation log. 

 

3.6 Export Quickstart  

When in Viewer Mode, use ACE Translator 3000 to Plot to PDF choose to Export to Bitmap and TIFF files.  

 

 

 



ACE Translator 3000 V7 

 

Page 61 

3.6.1 Exporting (Plotting) to PDF  

With ACE 3000 Translator, while in Viewer Mode, you can plot active designs to an optimized PDF file.  

1.  Select File > Plot to PDF (up to E-Size) 

 

 

 

 

 

 

 

 

2.   In the Printer/Page Setup,  

     change the Paper Size from  

     A to E. Keep the rest of the  

     default settings.  

3.   Select Next. 
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Note: Use Advanced Options to set margins, centering, separated pages for layers, and compression.  

 

 

4.  In the Plot Features menu, 

keep the default settings or 

modify according to your needs.   

 

5.   Select Next.  
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6.    Verify that the Preview  

   appears correctly. 

 

7.    Select Next. ACE Translator 

 will begin to generate a PDF.  

 

 

 

 

 

 

 

 

 

8.  Once your PDF file has been    
created, the finish page will be 
displayed. The location and name of 
the PDF file will be displayed. 
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9.  Select View PDF to open the PDF in Adobe    

Acrobat (if available). 

 

 

 

 

 

 

 

 

 

 

 

 

3.6.2 Exporting to Bitmap  

With ACE 3000 Translator, while in Viewer Mode, you can plot active designs to an optimized Bitmap file.  

1.   Select File > Export Bitmap (High                    

 Resolution). 
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2. In the Export Bitmap Options menu, 

 verify or select options.  

3. Select Next. 

 

 

 

 

 

 

 

 

 

4.       The bitmap export will   

       complete and you’ll be taken  

       to the Finish! menu. 

  Note:  A file browser window  

  will appear to let you choose  

  which directory to save your  

  exported file to. 

5.        Select Output Folder to save  

        your exported bitmap or   

        choose Finish.  
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3.6.3 Exporting to TIFF  

1. Select File > Export TIFF (High 

 Resolution) 

 

 

 

 

 

 

 

 

2.   In the Export TIFF 

 Options menu, verify 

 or select options. 

3. Select Next.  
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4. The TIFF export will 

 complete and you’ll 

 be taken to the Finish! 

 menu. 

 Note:  A file browser 

 window will appear to 

 let you choose which 

 directory to save your  

 exported file to. 

5. Select Output Folder  

 to save your exported 

 TIFF or choose Finish.  

 

 

 

3.7 Understanding Composites  

How Composite Level Numbers Define Interiors 

Layers that contain one or more objects with a defined 

"Composite Level" greater than zero are considered 

composite layers.  Composite levels make it easy to define 

the fill rules for objects without the construction of 

complex polygons or geometries.  Essentially, objects are 

drawn per layer in the order of their composite level, 

starting with 0 and increasing to a maximum composite 

level of 1000. All "even" (and zero) composite levels are 

filled dark (i.e. Paint), while "odd" composite levels are 

drawn clear (i.e. Scratch). 

   

 

 

To change the composite level of any object: 

  1. In ACE 3000 Viewer mode, select the Objects  you wish to change.  

  2. Select Edit > Properties. The properties dialog box will appear. 
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 3.  In the properties dialog  

       box, locate the item  

       Composite Level.  

 4.  Use the pull down to select  

       a value for composite level. 

 Note: You can also select 

 values for Layer, Datatype, 

 and Dcode. 

 5.  Select Apply or OK to close  

      the properties box. 

 Note: If any changes were 

 made incorrectly, select Undo.  

 

 

 

Note: To automatically change the composite level of a group of objects, based on their interior location 

relative to other objects, see section 3.7.1: Polygon De-Embedding.  

3.7.1 Using De-Embedding to Automatically Create Composites  

 De-Embedding automatically solves the polygon-inside-polygon for objects selected. 

To use de-embedding to automatically create composites, perform the following: 

1. Select the objects you wish to de-embed.  

2. Select Edit > De-Embed.  

3. The Object Composite Levels will be automatically defined.  

 Note: Objects must reside on the same layer.  

4. If the command is incorrect, use Edit > Undo.  
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SECTION 4: FREQUENTLY ASKED QUESTIONS 

During DXF Import, the boundaries do not fill-in.  

This is most likely because DXF boundaries contain lines, arcs, and open 0-width polylines. To fill an area 

requires a continuous closed boundary. In the DXF import layers options, check both "Fill" and "Join" for 

each layer that contains open boundaries. If for any reason ACE cannot join the boundaries consisting of 

lines/arcs (due to endpoints not touching, etc.), ACE will warn you and show the open locations. 

During DXF Import, small islands are not appearing. 

This is most likely because DXF files contain boundaries placed inside-each-other (for example, similar to 

the letter "O"). Unless you tell ACE to detect the inner boundaries and make it a hole/island, the outer-filled 

boundary will dominate and fill-in the entire area. This detection procedure is called "Polygon De-

Embedding" 

During DXF import, check the layer option "De-Embed" and "Fill" for each required layer. It is also a good 

idea to check the layer option "Join". 

During DXF Import, converted DXF circles with different diameters have a different 

number of segments. 

Most other translators use the standard "ARC Resolution" which lets you choose a degree (such as 3). Each 
circle regardless of the diameter will be converted with 120 segments. If you have a small circle, 120 
segments will probably be too many vertices causing overlapping and wasted data. If you have a circle too 
large, 120 segments may not be enough.  The circle will look segmented (i.e. more like a "Stop Sign" than a 
true circle). 

With ACE 3000, the number of vertex (segments) for a circle will vary for two reasons: 

(1) Diameter of the Circle 

(2) Value for the Arc Deviation 

Note: The arc deviation controls the "tangent distance" from the DXF arc/circle to the GDS-II line segment 
(since GDS-II cannot support arcs). 

The smaller the "Arc Deviation" the more vertex (segments) that will be used in the resulting GDS-II 
polygon. What also controls the number of vertex (segments), is the diameter of the circle. If a circle has a 
large diameter it will contain more segments than a circle with a smaller diameter. The advantage of using 
"Arc Deviation" is that ACE will intelligently optimize each circle to use the perfect amount of vertices.  This 
results in reduced data size (for small circles) & improves overall quality (for large circles).  
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During DXF import, is there a size limit to DXF circles becoming Gerber flashes? 

When converting DXF to Gerber, using "Flashes" is the best for all circles. To control what DXF circles get 

flashed when converted to Gerber using DXF import, go to DXF Import Options "Flash Circle/Rects Less 

Than (mil)" and increase the value. The maximum value is 1000 (i.e. one inch is the largest Gerber flash 

allowed by the photoplotters). 

The Exported DXF (from ACE) doesn't load into AutoCAD. 

If you are unable to load an exported DXF file into AutoCAD, this is most likely because either the layer 

name or block name (i.e. job name) in the DXF file exceeds 32 characters.  Another cause could be illegal 

characters such as “$%#\" in the layer or block name (i.e. job name) of the DXF file.  To fix this problem 

make sure to limit your layer & job names to 32 characters or less, and eliminate any invalid characters. 

Where can I find Ghostscript (to Import Postscript & PDF)? 

GhostScript version 8.53 or higher is available for free and may be downloaded from the following 
webpage: http://pages.cs.wisc.edu/~ghost/doc/AFPL/get853.htm 

I can't view small objects on the screen. 

To improve the viewing resolution, please change the "Level of Detail (LOD)".  The LOD is located in the 
ACE Viewer toolbar.  Try decreasing the number of LOD to "1 Pixel", "2 Pixel", or "All". 

When importing a DXF, it is not using our custom SHX font. 

Most DXF files use the standard font .SHX (supplied with AutoCAD).  ACE 3000 has matching font files 
(*.FNT) for all of those.  However in many cases a DXF file may use a custom AutoCAD .SHX font (or 
TrueType font) developed by a third party company, which ACE does not have a corresponding font file. In 
these cases, you have two options: 

1. Map that custom font to another ACE font (ex. *txt.FNT)  

2. Get the custom .SHX file (or TrueType TTF file) and compile that font so ACE may use it. To do this, 
 Select Help > Compile AutoCAD SHX Fonts and proceed with the DXF Import. 

 Note: When importing a DXF file, you can determine the font mapping by clicking on the tab "Styles". 

 Note: ACE Font files have a *.FNT suffix and are located in the ACE fonts folder. 

 

 

http://pages.cs.wisc.edu/~ghost/doc/AFPL/get853.htm
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How can I improve the results when I convert from Gerber to DXF? I need a DXF file 
with clean outlines for all Gerber geometries. 

A common problem when converting Gerber files to other CAD formats is that Gerber files are generally 
messy (i.e. contain overlapping objects, use multiple line strokes to fill in metal areas, etc.) that can 
potentially cause poor results in the final translated file. 

 ACE 3000 has the ability to "clean-up" these messy Gerber files using its editing command "Merge 
Overlapping Objects". 

 After importing Gerber data and getting to the menu "Export Cell and Layers", try the following: 

  1.  Select the "CAD Viewer" Tab (located in the upper right area of ACE 3000 or below the Top Cell  
      export tree). 

 Note: This takes you into the ACE 3000 CAD editor, which allows you to modify data before 
 exporting. 

 2.  Select all objects using View > Selection > All  

Note: You can also place ACE 3000 in 
"Selection Mode" by pressing the selection 
mode button  ("Arrow icon" - second button 
to the left), and pick a window around your 
Gerber objects. 

 

 

 

 

 

  

 3.  Select Tools > Merge Overlapping Objects 

 Note: ACE will now convert messy overlapping Gerber files into "clean outline boundaries". 

 Note: Depending on the size of your Gerber files, it may be more effective to clean one layer at a 
 time. To do this go to the layers table by selecting Setup > Layers Table and turn off all layers 
 except one.  Then repeat steps 2 & 3. 
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 4. When finished, select "Back to Conversion Setup", which takes you back to the ACE 3000   
      Conversion setup so you can then export your files. 

How do I convert a DXF file to a NC Drill file using ACE? 

While NC Drill is not a primary output, ACE can convert DXF to NC Drill data. Here's how: 

  1.  Start ACE 3000 and select "DXF" for Import and "Gerber" for Export. 

 2.  Press "Next" and select DXF file. 

 3.  In DXF "Import Options", make sure to check layer option "Flash" for each layer that   
      contains the drill file and then select "Next". 

 4.  Verify Gerber export options, and press "Next". 

 5.  Once you have arrived at the "Export Cell and Layers" menu, make sure the "Drill" option is  
       checked for each Gerber file containing drill information. 

  Note: ACE 3000 scans each Gerber file that had the layer option "Drill" checked.  Every Gerber flash 
 that ACE finds will be considered a Drill Hole (using the flash size as the diameter and the X/Y 
 location as the center of the drill hole). Once all the drill holes have been determined, a drill file 
 with the extension "*.DRL" will be created. 

  Note: If you want to generate NC Drill files from any data format, select "Gerber". Check the option 
 "Drill" in the "Export Cell and Layers" page. 
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SECTION 5: SUPPORTED FILE FORMATS  

ACE 3000 is capable of handling over 100 common EDA, CAD, and 3D translators in one tool, resulting in 

significant cost savings for file translation when compared to traditional single-format commercial CAD 

packages. Below is a complete list of file formats, with more added to each version of ACE 3000.  

5.1 DXF Translators  

DXF to Gerber 

DXF to GDSII 

DXF to ODB++ 

DXF to OASIS 

DXF to STL 

DXF to IGES 

DXF to Large Bitmap (Any Resolution) 

DXF to Image (GIF, TIFF, JPEG, etc.) 

DXF to DWG 

DXF to Postscript 

DXF to PDF 

5.2 Gerber Translators  

Gerber to DXF 

Gerber to DWG 

Gerber to GDSII 

Gerber to ODB++ 

Gerber to OASIS 

Gerber to STL 

Gerber to IGES 

Gerber to Large Bitmap (Any resolution) 
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Gerber to Image (GIF, TIFF, JPEG, etc.) 

Gerber to Postscript 

Gerber to PDF 

5.3 GDS-II Translators  

GDSII to DXF 

GDSII to Gerber 

GDSII to OASIS 

GDSII to ODB++ 

GDSII to STL 

GDSII to IGES 

GDSII to DWG 

GDSII to Large Bitmap (Any resolution) 

GDSII to Image (GIF, TIFF, JPEG, etc.) 

GDSII to Postscript 

GDSII to PDF 

5.4 OASIS Translators  

OASIS to GDSII 

OASIS to DXF 

OASIS to DWG 

OASIS to Gerber 

OASIS to ODB++ 

OASIS to STL 

OASIS to Large Bitmap (Any resolution) 

OASIS to Image (GIF, TIFF, JPEG) 



ACE Translator 3000 V7 

 

Page 75 

OASIS to Postscript 

OASIS to PDF 

5.5 DWG Translators  

DWG to Gerber 

DWG to GDSII 

DWG to ODB++ 

DWG to OASIS 

DWG to STL 

DWG to IGES 

DWG to Large Bitmap (Any resolution) 

DWG to Image (GIF, TIFF, JPEG, etc.) 

DWG to DXF 

DWG to Postscript 

DWG to PDF 

5.6 ODB++ Translators  

ODB++ to Gerber 

ODB++ tp DXF 

ODB++ to DWG 

ODB++ to GDSII 

ODB++ to OASIS 

ODB++ to STL 

ODB++ to IGES 

ODB++ to Large Bitmap (Any resolution) 

ODB++ to Image 
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ODB++ to Postscript 

ODB++ to PDF 

5.7 STL Translators  

STL to Gerber 

STL to DXF 

STL to DWG 

STL to GDSII 

STL to OASIS 

STL to ODB++ 

STL to IGES 

STL to Large Bitmap (Any resolution) 

STL to Image 

STL to Postscript 

STL to PDF 

5.8 Postscript/PDF Translators  

Postscript to STL 

Postscript to Gerber 

Postscript to DXF 

Postscript to DWG 

Postscript to GDSII 

Postscript to OASIS 

Postscript to ODB++ 

Postscript to IGES 

Postscript to Large Bitmap (Any resolution) 
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Postscript to Image (GIF, TIFF, JPEG, etc.) 

Postscript to PDF 
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SECTION 6: UNDERSTANDING CAD FORMATS 

ACE 3000 supports many file formats, such a GDSII, DXF, OASIS, Postscript, Gerber, and more. 

6.1 DXF Format  

DXF stands for Drawing Exchange Format, and it is a format for transferring drawings between Computer 
Aided Design systems.  DXF is widely used as the de facto standard in the engineering and construction 
industries.  The DXF format is a tagged data representation of all the information contained in an AutoCAD® 
drawing file. Tagged data means that each data element in the file is preceded by an integer number that is 
called a group code. A group code's value indicates what type of data element follows. This value also 
indicates the meaning of a data element for a given object (or record) type. Virtually all user-specified 
information in a drawing file can be represented in DXF format. 

Bi-directional translation of DXF files into the Workspace.  Excellent for anyone using software products 
such as AutoCAD, SolidWorks or ProEngineer to design complex masks, MEMs, RF/Microwave, MCM, 
Hybrid Packages, etc. 

Standard AutoCAD DXF File:                                Same DXF file Imported into ACE 3000: 

    -  

 The Problem:  DXF files can be tricky to handle 

DXF data is probably the most extensive and difficult format to work with; especially when converting to 
other EDA formats. However it is the de facto standard file format among most engineering CAD tools. 

Here is a list of some common difficulties found inside DXF files: 

 Entities found in a Block that are drawn on layer '0', usually need to be moved to the blocks new 
 Inserted layer. If the block is Inserted onto multiple layers, the '0' layer entities from that block must 
 be moved each time. 
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 A solid hatch with internal geometries, does not explicitly define the polarity of the internal 
 geometries. 

 Non-Manhattan geometries, angles, and non-uniform scaling are permitted. 

 Invalid, self-intersecting polygons are permitted. 

 Identical, overlapping entities on the same layer can be stacked on top of each other. These 
 identical entities are impossible to see, and can cause problems during conversions, etc. 

 The DXF format specifications change almost every year, with the latest releases of AutoCAD. 

 Nested Non-Manhattan transformations. 

 Tapered polylines with non-uniform widths are permitted. 

 Some boundaries may appear closed, but internally are still open. 

 Filled pads are drawn as outlines of circles, donuts, or rectangular. 

 Extraneous data such as UCS, and 3D object extrusions can be found in many files. 

 AutoCAD will not display filled areas on-screen, such as polygons, and other closed boundaries (only 
 solid hatch). Making it tough to determine the final results. 

 Fonts can be difficult to handle, especially MText (Multi-line text) 

Most vendors and mask houses stay away from accepting DXF files as input. They have a hard time dealing 
with this data and there are only a few decent software products on the market today that can reliably 
handle DXF. 

 Why ACE 3000 is the Perfect Solution 

 Since Software products such as AutoCAD, SolidWorks or ProEngineer provide an excellent way to draw 
complex masks, MEMs, RF/Microwave, MCM, Hybrid Packages, as well as drafting mechanical information 
related to the design; ACE 3000 was developed with this in mind. 

Here's how DXF Plug-In handles common difficulties found inside DXF files: 

 Block entities drawn on layer '0', are automatically handled by the option: ByBlock/ByLayer.  

 Polygon De-Embedding is used to process entity polarity for solid hatches with internal geometries. 

 All angles, and non-uniform scaling are supported. 
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 Invalid, self-intersecting polygons are either automatically corrected or may be fixed using the 
 editor. 

 Identical overlapping entities are either automatically deleted, or may be fixed using the editor. 

 Every year the DXF Plug-In is updated to support the latest versions of DXF. 

 Unlimited nested transforms are supported. 

 Outlines are generated for tapered polylines with non-uniform width. 

 Open boundaries will be automatically closed when it is possible. 

 Recognizes outlined pads: round, donut & rectangular. When requested these pads are 
 automatically filled & flashed. 

 Most extraneous 3D data is ignored. 

 Direct support for TrueType fonts 

ACE 3000 is powerful, yet very easy to use, and it operates seamlessly inside of the platform.  If you design 
or work with complex masks, MEMs, RF/Microwave, MCM, Hybrid Packages, as well as mechanical drafting, 
then ACE 3000 is for you! 

 ACE 3000 also supports polygon de-embedding. 
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6.2 Gerber Format  

Bi-directional translation of Gerber format (RS-274D, RS-274X, Fire9000, BarcoDPF) files into the 
Workspace.   Excellent for anyone who needs to make photoplots from their artwork.  

Sample Gerber screen capture inside the workspace. 

 

Gerber data is a simple, generic means of transferring printed circuit board information to a wide variety of 
devices that convert the electronic PCB data to artwork produced by a photoplotter. Virtually every PCB 
CAD system generates Gerber data because all photoplotters read it. It is a file structure consisting of X,Y 
coordinates supplemented by commands that define where the PCB image starts, what shape it will take, 
and where it ends. In addition to the coordinates, Gerber data contains aperture information, which defines 
the shapes and sizes of lines, holes, and other features.  

Gerber RS-274X: 

Extended Gerber Format, which is also called RS-274X, provides enhancements that handle polygon fill 
codes, positive/negative image compositing, and custom apertures, and other features. RS-274X also 
encapsulates the aperture list in the header of the Gerber data file and therefore allows files to pass from 
one system to another without the need to re-input the aperture table. RS-274X produces a variety of 
Gerber data called X data. 

The Problem - Gerber files can be Difficult to Handle: 

Gerber data is unique in the fact that each file usually represents a single layer, something different from 
most other EDA formats that may contain multiple layers & designs/blocks all inside a single file.  Many 
Gerber files are not written to specification; thus many "unwritten rules" must be made to properly load in 
these files to the author’s intention. 
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Here is a list of some common difficulties found inside Gerber files: 

 Transcoding of apertures - when multiple Gerber files define the same aperture Dcode, but require 
 different shapes,  

 Handle complex custom aperture definitions. 

 Handle 'user-defined' custom aperture macros ($). 

 Circular Interpolation: Arcs (G75), & Quadrant Arcs (G74) 

 Poly-Fill routines (G36, G37) 

 Support composite merging (LPD/LPC) 

 Photo Expose mode (G55) 

 Step/repeat codes (SR) 

 Offsets (OF), Units (G70, G71), Mirror (MI) 

 Zero Suppression with leading or trailing zeroes. 

 Format type: Incremental (G91) 

 Most software products have a hard time loading, & rendering Gerber files attributes properly (i.e. 
 rounded paths, custom flashes, composite layers, and step/repeat). 

Why ACE 3000 is the Perfect Solution 

ACE 3000 successfully handles all features of the Gerber (RS-274X) format.  Custom apertures, composite 
layers, and step/repeat are all correctly processed.  
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6.3 ODB++ Format  

ODB++ is the most intelligent CAD/CAM data exchange format available today. It captures all CAD/EDA, 
assembly, and PCB fabrication knowledge in one single, unified database. Originally developed by Valor 
Computerized Systems for use in its own PCB CAD/CAM systems, Genesis 2000, Enterprise 3000 and 
Trilogy , ODB++ has already become widely accepted as the de facto industry standard providing 
unprecedented power to PCB design, fabrication, and assembly with the flexibility to expand as required. In 
parallel, ODB++ is providing most of the technological basis for the new IPC2581 standard for data 
exchange in the PCB fabrication and assembly industry. 

6.4 DWG Format  

ACE 3000 supports bi-directional translation of native AutoCAD DWG format. Similar to the DXF format 
except in a binary file. 

6.5 IGES Format  

IGES (Initial Graphics Exchange Specification) is a neutral graphics database format designed primarily for 
data exchange between mechanical CAD systems. The IGES file format links mechanical CAD systems to the 
2D EDA design world. Two-dimensional geometry can be used to interchange layout, or package outline 
information.  The IGES format can represent both mechanical and electrical design data in two and three 
dimensions. 

6.6 Image Format  

ACE 3000 supports bi-directional translation of image (TIFF, PNG, GIF, BMP, etc.) files into the Workspace. 
Once these image pixels are imported into the workspace, they can be handled just as any other geometry 
(i.e. change layers, copy, export to GDSII, DXF, etc.). This is perfect for anyone who wishes to produce 
optical filters, convert company logos into a common EDA format, create grey scales, or plot images to a 
higher resolution than on an image setter. 

6.7 GDSII Format  

GDSII is a binary file format which is classified as a "data interchange format" and used for transferring 
mask-design data between the IC designer and the fabrication facility ("Fab"). 

6.8 Postscript Format  

PostScript is the industry standard for sending documents to high-resolution printers. 

Please note that Ghostscript must be installed on your workstation or server to import PostScript!  
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Ghostscript is freely available and distributed under the GNU General Public License.  If you do not 
have Ghostscript installed you may download it from the following websites (or from other available 
mirrors):  

http://www.cs.wisc.edu/~ghost/doc/gnu/index.htm 

http://www.ghostscript.com/ 

6.9 Large Monochrome Bitmap Format  

 

ACE 3000 bi-directionally translates large sized Bitmap files (*.bmp) with unlimited pixels.  This is very 

useful when someone wants to convert a high-resolution image into a true vector format.   

 

Image files are unit-less. A pixel can theoretically represent any physical size. It is important that you specify 

the proposed units and scale for a pixel’s physical size. Choose from DPI, Micron, Inch, Millimeter, 

Centimeter, and more. Logical pixel size is defined by Pixel Units * Image Scale. 

6.10 Drill/Rout Format  

NC code used to control Drill and Rout CNC machines. 

6.11 STL Format  

STL is a file format native to the stereolithography CAD software created by 3D Systems. This file format is 
supported by many other software packages and is widely used for rapid prototyping and computer-aided 
manufacturing. STL files describe only the surface geometry of a three dimensional object without any 
representation of color, texture, or other common CAD model attributes. The STL format specifies both 
ASCII and binary representations. Binary files are more common since they are more compact. ACE 3000 
only supports binary formats. 

STL (Stereolithography) binary format is outputted by almost every 3D design/modeling software tool. This 
includes SolidWorks, ProEngineer, and many other design packages.  STL files are unit-less and objects can 
be assigned any scale. It is important that you are aware of the imported STL file units & scale.  ACE 3000 
needs to know what physical unit and scale to use for 1 STL unit. 

 

 

 

 

 

http://www.cs.wisc.edu/~ghost/doc/gnu/index.htm
http://www.ghostscript.com/
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SECTION 7: CONVERT 

 

7.1 File, Setup, & Help  

Located in the top left corner of the ACE Convert page, these drop 

down menus provide basic functions for the file conversion process. 

 

 

 

7.1.2  File Menu 

Includes the following options: 

File > Save ACE Workspace Saves current ACE 3000 Workspace.  

File > Restart ACE Restarts ACE 3000.  

File > Exit ACE Exits ACE 3000.  
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7.1.3 Setup Menu 

Includes Aperture Rules Editor, ACE Console, and Preferences. 

 

 

 

 

Setup > Aperture Rules Editor Creates custom rules to load-in any aperture list file.  

Aperture Rule: This drop down contains all available 

aperture rules.  Each aperture rule is stored as a file 

(*.rul) in the ACE 3000 sub-folder "aptrules". 

File Extension: Aperture files generated from a CAD 
system usually have a defined file extension.  This helps 
ACE 3000 determine which aperture rule to use during 
Gerber import. 

Move To: Aperture files generally have non-essential text 
at the beginning (such as part number, time created, 
etc.).  This lets ACE 3000 ignore all text lines until the 
defined "Move To" text is found. If left empty, ACE 3000 
will start reading apertures at the first line. 

Skip Additional Lines: This allows ACE 3000 to skip additional lines after Move To.  

Stop At: Tells ACE 3000 to stop reading aperture lines once this text has been detected. 

Units: Units for aperture sizes.  Choose from:  Inch, Mil, or Millimeter.  

Scale: Scale value used for aperture sizes (1 is default). 

Tolerated Warnings: Determines how many warnings (per Aperture Rule File) ACE 3000 will allow before 
choosing to use another aperture rules file.  
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Line Format Tab 

This tab will help show Line Format parameters 
with a legend of Line descriptions.  

Line Parameters: 

 [S] = Skip 

 [D] = Dcode 

 [X] = X-Size 

 [Y] = Y-Size 

 [R] = Rotation 

[T] = Thermal Tie Width 

 [I] = ID 

 [O] = OD 

 [A] = Aperture 

 [M] = Misc 

 Line Example #1: 

 RECTANGLE     100.5      20      Flash     D100 

 "RECTANGLE" [X] [Y] [S] D[D] 

 Line Example #2: 

 D35     Thermal    80     Yes     55 

 D[D] "Thermal" [O] [S] [I] 
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Setup > Display ACE Console: Opens ACE 3000 

Command Console. Can also be activated by pressing 

F2.  

 

 

 

 

 

 

 

 

 

Setup > Preferences: General settings and preferences for ACE 3000.  

Divided into three tabs 

which include General, 

Viewer, and Misc.  

Reset will reset all values to 

default. 

 

 

 

 

 

 

 

General Tab 

Home Folder: The location of the ACE executable file.  Many necessary files are located relative to the 
location of the ACE executable.  

Temporary Folder: The location of the temporary files used by ACE 3000 during conversions.  Please make 
sure this folder has Write permissions, and keep it local to your machine (i.e. not over a network). 
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Web-Browser Executable: Use this browser to display any HTML or XML files.   

Visual Chip Executable: The location of Visual Chip (Optional).  Allows you to view GDS-II directly from ACE 
3000 by selecting the "View files with Visual Chip" button (located on the Finish Page). 

Export Folder: Optional.  If you would like to have a defaulted folder where all exported files are saved to, 
you may define it here. 

Display Font: Sets font for menus & text boxes. 

Output a Log File during export: Outputs a log file during the export process for review.  

Gerber Import Resets 274D values at New Layer: 

Use FOX Style Dialogs:  

Hide Background Wallpaper: Hides the background wallpaper in the ACE 3000 conversion window. 

Viewer Tab 

Sets preferences for the ACE 3000 Viewer tab.  

 

Object Snap:  

 None: Turns off all snap modes. With snap modes off, you define points by simply clicking.  

 Grid: Snaps cursor to the nearest grid point.  



ACE Translator 3000 V7 

 

Page 90 

 Figure: Snaps to the nearest vertex on a figure. A vertex can be an endpoint of a line or line 
 segment, corner of a polygon, or endpoint of an arc or curve.  

M-Button Click for Zoom All: If you would like to simply click the middle mouse button to zoom all, then 
check this option. 

View Origin: View origin symbol.  

Display Full-Screen Cursor: Displays full-screen cursor in the viewer.  

PixBox Size (Pixels): The invisible selection box used to determine if your cursor is directly over a figure. 

Selection limit for display Grips: Grips are the “blue squares” that occur at all vertices of selected objects 
while in the Viewer. After selecting a large number of objects, there are so many blue squares drawn it can 
become confusing when objects are selected. If a selection set exceeds this value, the Grips (i.e. blue 
squares) will not be drawn. 

Application Color: Chooses application menu color in viewer.  

Background Color: Chooses background menu color in viewer.  

Level of Detail (Pixels): Defines level of detail for pixels in viewer.  

Display Hierarchy Level: Displays the Hierarchy level. 

Display Mouse Object Hover: Displays mouse objects during hover.  

Misc. Options 

Set miscellaneous options for ACE 

3000.  

Default Arc Precision: Default Arc 
Precision and Default Arc Precision 
Units are related. If no other option is 
available, this default value will be 
used to approximate points on an 
arc.  
 

Default Arc Precision Units: Default 

Arc Precision and Default Arc 

Precision Units are related. 

 

Examples: 
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Segments/360 Degrees 
A value of 120 signifies to approximate points every 3 degrees of an arc (i.e. 360 degrees / 120 = 3 degrees). 
If a user chose the default value to be 360, then the default Arc precision would be 1 degree 
approximation.  
 
Inch, mil, nanometer, cm,... 
The maximum error allowed when calculating points on an arc. This feature allows designs with large and 
small radius arcs to equally maintain high-resolution and quality. The smaller the Arc Deviation, the more 
accurate your final arcs will become. However, exported file sizes may become larger. 
 
Arc Detection Min. Chord Angle: Some CAD/EDA formats support arcs while most do not. During export, 
ACE can determine if connected line segments form an arc. Once ACE has determined a series of line 
segments forms an arc, it will measure the chord angle of the arc against this value. If the chord angle is 
less, ACE will not output those segments as an arc. Typically, to accurately detect an arc from line segments 
requires a chord angle of 10 degrees or more (30+ degrees is recommended). 
 
Max. Polygon Points: The maximum number of vertices allowed per polygon. Smaller numbers require ACE 
to slice larger polygons into smaller ones. 
 
Default Font: Selects default font for ACE 3000 viewer.  

Database Accuracy: Database accuracy is the maximum numerical rounding error that may occur during a 

file conversion. ACE converts a wide variety of formats. Some formats like GDSII have standard units in 

nanometers (1/1000 micron) while other formats like Postscript have units stored in Points (1/72 inch). 

When working with numbers, there is always a potential for rounding errors.  

Example 

A rounding error of 0.01 micron (1/100 micron) will have almost no effect on formats such as Gerber, 

Postscript, ODB++, HPGL, etc. However that same 0.01 micron rounding error could be devastating for 

other formats like GDSII, OASIS. 

Optimized:  

Depending on the format types you are converting ACE will automatically adjust its internal database 

accuracy. This is the recommend setting for 99% of all users as we only recommend experienced  

users modify this setting with the following: 1/10 micron, 1/100 micron, 1/1000 micron, and 1/10000 

micron. 

Typically, if you're working with very small units (like nanometers), and experience rounding errors it can be 

ideal to manually optimize the ACE database accuracy to 1/10000 micron. The same if you're working with 

very large units (say a postscript file with 100" X 100" extents), you may benefit by setting the database 

accuracy to 1/10 micron allowing ACE to handle much larger dimensions. 

Disable Units Warning Message: As a helpful hint, ACE may warn users that there may be a potential 
mismatch between conversion units. 
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Compile TrueType Font Quality (310 to 8000): ACE converts all TrueType fonts to vector (i.e. lines). When 
processing TrueType fonts, this value controls the final appearances of the outputted font. A lower value 
results in a coarse font with less vertices used. A higher value results in a more detailed font with more 
vertices used -- resulting in larger data output. 
 
Disable Dynamic Editing: The CAD viewer uses the latest user GUI features such as Object hovering (for 
easy selection), Grips (which permit easy dragging of vertices), and more. Check this option to disable these 
features. 
 
Remember Layer Name/Color Relationship: Many designers relate certain layers with a specific color. 
When checked, ACE will remember the viewer color used for each layer that was exported. Whenever a 
similar conversion is performed (i.e. using the same layer names), ACE will remember and assign the same 
viewer colors used in the previous conversion. 
 
Verify Gerber files before Import: Allows ACE to preview each Gerber file before importing. In many cases 
selected files to import are not Gerber and this option will prevent importing files it cannot detect as 
Gerber – limiting potential error messages, etc. 

7.1.4 Help 

ACE 3000 offers a number of resources for help, 

troubleshooting, and additional configuration. 

 

 

 

 

 

 

 

 

 

Help > Help Guide – Online 

Links to ACE 3000 online help manual. 
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Help > Online Tutorials and Demos 

 Links to the ACE 3000 YouTube Channel with dozens of 

video tips and resources.  

 

 

 

 

 

 

 

Help > Online User Support Forum 

Links directly to the Numerical Innovations 

support forum at 

www.numericalinnovations.com.  Use this 

forum for questions, tips, and support help. 

The ACE 3000 community users are 

available to answer beginner and veteran 

questions. 

Need Help? Type a Question in ACE 3000! 

 

Use this question box in the corner of 

the ACE 3000 window as a shortcut to 

the   Numerical Innovations support 

forum. 

 

http://www.numericalinnovations.com/
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Help > Visit ACE 3000 on Facebook 

Stay tuned for important updates, tips, and 

links on the ACE 3000 Facebook page.  

 

 

 

 

 

 

 

 

 

 

Help > Visit Numerical Innovations 

Directly links to the ACE 3000 home page. 

From here, you can access: 

- Downloads 

- Feature Comparison 

- PDF Help Guide 

- ACE 3000 User Forum 

- ACE 3000 YouTube Page 

- ACE 3000 Facebook Page 
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Help > Become a Numerical Reseller or Partner 

Want to be a Reseller or Partner with Numerical Innovations? Select this menu option for more information 

on Numerical Innovations partnerships and alliances. 

 

Help > Compile TrueType Fonts 

  TrueType Font selector for ACE 3000.  

  

 

 

 

 

 

 

 

 

 

Help > Compile AutoCAD SHX Fonts 

Import and add AutoCAD SHX Fonts to the workspace. 

Help > Enter License Key 

Enter ACE 3000 license keys. For more information on licensing and registration, see section 1.3: 

Understanding Licensing & Registration. 

Help > Check for Updates 

This feature will send you to the Numerical Innovations web page for ACE 3000 revision history. 

 

 

 

 

 

 

 

 



ACE Translator 3000 V7 

 

Page 96 

Help > About 

General information on ACE 3000, Numerical Innovations, Copyrights, Trademarks, and License Status. 
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7.2 Import Process Options  

In this section we’ll explore the most import processes (located in the ACE Convert Tab) for popular file 

formats such as DXF, GDS-II, Gerber, ODB++, ODB++ (Directory), HPGL, NC Drill/Rout, OASIS, Image, Large 

Bitmap, Postscript/PDF, STL, ACE Workspace, and for New Designs. 

7.2.1  DXF Import Options 

 

DXF files are unit-less and objects can be assigned to any scale. It is important that you are aware of the 
imported DXF file units & scale.  ACE needs to know what physical unit and scale to use for 1 DXF unit. For 
example:   

If a DXF file was designed in inches, set 1 DXF UNIT to "Inch" with a scale of "1.0" 

If a DXF file was designed in microns with a 10X scale, set 1 DXF UNIT to "micron" with a scale of "10.0" 

If you have selected potentially wrong DXF units, ACE will issue a warning and make a suggestion. 

If your DXF file contains MInserts (multi-Inserts), ACE can output Step/Repeat data (for Exported Gerbers), 
or Arrayed Cells (for Exported GDSII & OASIS) - which drastically reduces file size and processing time. 
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When translating from DXF to Gerber, four additional option pages (Layer, Block, Text, & Merge) are 
activated.  For all other formats these option pages are hidden. 

Use Polygon De-Embedding automatically solves the polygon-inside-of-polygon problem found in many 
mask designs.  The polygon-inside-of-polygon is often the hardest mistake to catch and many times there 
are 1000s of overlapping polygons on a layer. It's almost impossible to visually determine the polarity for 
each. A mask operator can sometimes take hours attempting to repair or redraw the data so that re-entrant 
polygons are created with voids or has to break up the polygons into slices. 

Layers Tab 

The DXF Layer Configuration Wizard is a preset feature used to optimize your DXF layer settings (such as Fill, 

Wide Polyline, Flash, Join, & DeEmbed) for the most common type of design you’re translating.   

In “What Type of Drawing are you converting?” Choose whatever description best describes the type of 

DXF design.  This feature is optional. 

 

1 DXF Unit = Units/Scale 

DXF files are unit-less, so it is vital to specify the proposed units & scale for 1 DXF physical unit. Choose 
from Micron, Inch, Millimeter, Centimeter, and more.  The Logical DXF unit size will be defined by defined 
by DXF Units * Scale.  
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Import: 

  

If "checked" this layer will be imported. If "unchecked", this layer will 
be omitted. 

DXF Layer Name: 

  

The DXF layer name.  This is merely for reference, and cannot be 
changed. 

Fill: 

  

If "checked", all closed boundaries for this layer will become filled 
polygons.  If "unchecked", all closed boundaries for this layer will be 
open paths and use the Default Line Width.  

Wide Polyline: 

  

This setting controls the End caps for open-polylines with width on 
this layer. 

Default: Same appearance as AutoCAD. Output as segments. 

 
Polygon: Same appearance as AutoCAD. Output as a single polygon. 
 
Note: This may cause overlapping or self-intersecting polygon.  

Round: Round End cap, 1/2 width extension. 

Flash: 

  

If "checked", all Rectangles and Circles on this layer which are smaller 
than the setting "Flash Circle/Rects Less Than", will be converted to 
Gerber Flashes. (For Gerber Export Only) 

Join: 

  

Adjacent lines and arcs that form a boundary are automatically 
joined.  This is very useful for creating polygons from separate lines 
and arcs entities in the DXF file. 

DeEmbed: Automatically solves the polygon-inside-of-polygon polarity problem. 
Closed boundaries (on the same layer) found completely inside 
another boundary will be made clear (or dark).  Due to its complexity, 
this feature may be time consuming during the conversion.  
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Options Tab 

 

Arc Resolution: 

The maximum error allowed when calculating points on an arc.  This feature allows designs with large and 

small radius arcs to equally maintain high-resolution and quality. 

Solid Hatch Mode: 

Controls the inclusion or exclusion of Solid Hatches. Solid Hatches are primarily used as a fill reference for 

AutoCAD users, however they can lead to duplicate/overlapping data and are generally not preferred when 

converting. 

 Include All Hatches:  Hatches will be processed. 

 Ignore All Hatches:   Hatches will be omitted. 

 Import Hatches Only:  Hatches will be processed. Construction lines, arcs, circles etc. will be 
 ignored.  

All Hatches are treated as solid hatches.  Only the outlines are processed, while patterns (if any) are 
ignored. 
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Hatch Mode "Import Hatches Only" is a useful option when a DXF files contains both solid hatches depicting 
the desired image and construction geometries such as lines, arcs, and circles used to generate the 
hatch.  These construction geometries cause overlapping geometries during the translation and confuse the 
De-Embedding Engine. 

If your DXF contains hatches with "Holes" we highly recommended that you also check the DXF Import 
Layer Option "DeEmbed" for all layers containing the hatch.  

Other Options 

Explode All Inserts: Flatten All Blocks (i.e. hierarchy) resulting in single level entities. 

Respect ByBlock/ByLayer: Block entities that are on designed layer '0', will be changed to the layer of the 

respective insert. 

Respect Entity Visibility: If an entity is hidden in AutoCAD, it will not be converted. 
 
Ignore Paper Space Entities: Entities existing in Paper Space coordinates will be ignored. 
 
Use AutoCAD Layer Colors: If possible in the CAD viewer try to use the same layers colors as displayed in 
AutoCAD. Can be helpful to visualize conversion results in the CAD viewer. 

 
Force Join to Close All Boundaries: All Open Boundaries will be forced to close. Not Recommended. 

Flash Round/Donut Shapes: Detect Round and Donut shapes and output as Flashes. Optimizes and reduces 
final conversion data size. 
 
Flash Rectangle Shapes: Detect Rectangular boundaries and output as Flashes. Optimizes and reduces final 
conversion data size. 

 
Default Line Width (mil): All open 0-width entities (such as lines, arcs, 0-width polylines) will be assigned 

this width. 

Flash Pads Less Than (mil): Only convert Round, Donut, and Rectangular shapes that are less than this 
value. This feature is useful to ensure only pads are being flashed. 
 

Map Text Style 

Text Stroke Line Width (mil): Stroke - Determine a standard line width to be used for all text. 

Text Ratio (Height/Line Width): The text line width will be determined by a ratio of the text height divided 

by your supplied value. 

Default Text Style: Chooses a default text font.  
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Blocks Tab 

Selects the cells or blocks that you want to have included during the import.  

 

Import: If checked, the block will be imported. If unchecked, the block will be omitted. 

Block Name: Assigns block name. Cannot be changed.  

Substitute Block with Aperture Shape: 

Replaces every block insert with a defined 

aperture instead. By right clicking this area, the 

Aperture Table window will appear allowing 

you to edit Apertures.  
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Merge Tab 

Merge DXF/DWG layers (optional feature). To create a merge, select button Add, then enter the Merge 

Name, and then click on the adjacent row Layers to assign the DXF/DWG layers to be included in this 

merge. Repeat as necessary.  

 

Merge Name: The output name to be used for the merged layer. 

Merge Stackup: Selects all DXF Layers that will be included in this merged layer. You can merge layers as a 

composite merge, including Dark or Clear polarities. 
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Add Merge: Adds a merge. Upon activation, the Composite 

Merge menu will appear. Use this to select a new layer and 

assign polarity. 

Delete Merge: Deletes a merge.  

 

 

 

 

 

 

 

Layer Output Dropdown 

Output All Layers (Default): All DXF/DWG layers plus Merged Layers will be outputted. 

Output Merged Layers Only: Do not output any individual DXF/DWG layers, only the merged layers will be 

created. 

Output Merge and Remaining Layers: Only DXF/DWG layers that are 'not' included in the Merge and 
Merged Layers will be outputted. 
 

 

Forum: Converting DXF (non-bezier) spline entities to Gerber  

 

 

 

 

 

 

 

 

 

http://forums.numericalinnovations.com/post/dxf-import-of-spline-entities-and-convert-to-gerber-6922403
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7.2.2  GDS-II Import Options  

 

Ignore Text: Skips GDS-II text. It will not appear on exported files.  

Create Separate Layer for Data Types: If a GDS-II file contains identical layers but different datatypes, a 

separate layer will be created for each layer/datatype pair.  
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7.2.3  Gerber Import Options  

 

ACE can handle Extended Gerber file formats like: RS-274X and Fire9000.   ACE can also import older Gerber 

files in RS-274D (non-extended format) however an aperture list is required. The aperture list can be 

manually entered before importing the RS-274D Gerbers by selecting the ACE Aperture Table; or use ACE 

Translator's feature called Aperture Rule Editor (Setup > Aperture Rules Editor) which uses a template 

based detection system to automatically read-in most aperture lists. 

Gerber Detection Mode: Allows you to let ACE determine the Gerber or Drill format, Extended Gerber (RS-

274-X and Fire9000), or Standard Gerber (RS-274-D).  

Options > General Tab 

Arc Precision: Controls the accuracy of 

Gerber arcs. 

End of Gerber Block Character: Character to 

for ending Gerber blocks. Usually an asterisk. 

Use 360 Degree Arcs: Read Gerbers using 

360 degree arcs mode as a default. 
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End of Gerber Block Character: Character to for ending Gerber blocks. Usually an asterisk. 

Options > Advanced Tab 

Discard data that follows [M02]: M02 
signifies the end of a Gerber files. In some 
cases a Gerber file may continue to have 
more data that follows. Check this option to 
ignore any data after the M02 command is 
detected 
 
Perform Mirror [MI]: If a Gerber file 
contains the Mirror command in the header, 
have ACE perform the mirror on the 
converted files. In the new Gerber format  

          specifications, the Mirror command has  
          been deprecated and not recommend 
 
Allow Negative Step Distance [SR]: Step distance should always be positive. However some Gerber files 
contain negative Step Distances. Check this option to allow negative step values. For example, if X value  
is -1, objects in the step will be moved 1 unit to the left. 
 
Zero Length Draws: Zero length lines are illegal, however many Gerber files seem to contain them. This 
option allows you how to process 0-length lines. 
 
 Make Flash: Convert 0-Line draw into a Flash. 

 Ignore: Ignore 0-length draws. 

 Prompt User: Individually ask the user whether to ignore the 0-width draw. 
 

Video: Gerber to DXF Conversion 

 

Options > RS274-X 

Ignore Negative Polarity [IPNEG]: If the Gerber file 
contains the Negative polarity command in the 
header, have ACE reverse the polarity of the entire 
Gerber layer. 
 
Negative Border: Used in conjunction with “Ignore 
Negative Polarity”. If “Ignore Negative Polarity” is 
unchecked, this option adds an additional spacing 
around the resulting negative border 
 

http://www.youtube.com/watch?v=7eO3Zo6oyX0
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Explode Polygons [G36/G37]: Convert filled polygon boundary defined by G36/G37 to an outline.  

Standard Gerber (RS-274-D Only) 

Units: Imported Gerber units of English or 

Metric. (Only needed for RS-274D Gerber 

files only) 

Integer Digits: Imported Gerber integer 

digits between 1 and 6. (Only needed for RS-

274D Gerber files only) 

 

 

Decimal Digits: Imported Gerber decimal digits - between 1 and 6. (Only needed for RS-274D Gerber files 

only) 

Type: Imported Gerber type - either Absolute or Incremental. (Only needed for RS-274D Gerber files only) 

Zero Suppression: Imported Gerber Zero Suppression - choose from Trailing, Leading, or None. (Only 

needed for RS-274D Gerber files only) 

Aperture Table: Displays and edits all apertures used in the workspace.  

Aperture Rules Template: Develops a predefined template for aperture rules.  
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7.2.4  ODB++ Import Options  

 

Imports a compressed ODB++ database file.  The most common compressed file format for ODB++ data is 
.TGZ (i.e. tar ball) or .ZIP.  

ODB++ is the most intelligent CAD/CAM data exchange format available today, capturing all CAD/EDA, 

assembly and PCB fabrication knowledge in one single, unified database. 

Layer Matrix Tab 

Verify the ODB++ layers you want to import. Each layer in the ODB++ matrix contains properties for Layer 

Type and Polarity.  You may modify either of these properties by clicking either the value within the Layer 

Type or the Polarity column. Under Import, use the checkboxes to select which layers to import. To select 

or deselect all layers, right click within the Import column.  
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Steps Tab 

 

Select the ODB++ Steps that you want to have included during the import. An ODB++ Step is a container of 

related data that includes entities, electrical properties, and more.  ODB++ is hierarchal and steps may be 

nested inside one another. 

Options Tab 

 

Select the ODB++ 

options that will best 

suit your conversion 

requirements.  

Arc Precision: 

Controls the 

accuracy of ODB++ 

arcs. 
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7.2.5  ODB++ (Folder) Import Options  

 

ODB++ is the most intelligent CAD/CAM data exchange format available today, capturing all CAD/EDA, 

assembly and PCB fabrication knowledge in one single, unified database. 

Layer Matrix Tab 

Each layer in the ODB++ matrix contains properties for Layer Type and Polarity.  You may modify either of 

these properties by clicking either the value within the Layer Type or the Polarity column. Under Import, 

use the checkboxes to select which layers to import. To select or deselect all layers, right click within the 

Import column. 

When loading an ODB++ database folder (make sure to select the parent folder that contains sub-folders 

like "steps", "symbols", etc.). 
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Steps Tab 

 

An ODB++ Step is a 

container of related data 

that includes entities, 

electrical properties, and 

more.  ODB++ is 

hierarchal and steps may 

be nested inside one 

another. Under Import, 

use the checkboxes to 

select which layers to 

import. To select or 

deselect all layers, right 

click within the Import 

column. 

 

Options Tab 

 

Arc Precision: Controls 

the accuracy of ODB++ 

arcs. 
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7.2.6  HPGL Import Options  

 

Hewlett Packard's plot file format is HPGL and HPGL/2. Almost every illustration, CAE, and CAD program can 

output HPGL. HPGL is a convenient neutral format which can be useful for moving data across otherwise 

incompatible programs. ACE can load multiple HPGL files simultaneously. 

Arc Deviation: Controls the accuracy of HPGL arcs. 

Ignore Text: Skip HPGL text. Text objects will not appear on exported files. 
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7.2.7  NC Drill / Rout Import Options  

 

ACE supports all advanced NC Drill/Rout specifications such as Step/Repeat, Circular Interpolation and 

more.  

Options 

Arc Deviation: Controls the accuracy of 

Gerber arcs. 

M00 Command: M00 command may have 
various meanings. The default is to signal  

          the end of the drill program. In older NC files 
          it may be used to signify to use the next  
          available tool. Lastly it may be ignored. 
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NC Format  

It is very import that you know the correct Units, 

Integer/Decimal digits, Type, Zero Suppression to 

use before loading the NC files. If after importing NC 

files, they do not seem to be correct you will need to 

change these settings and try again. 
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7.2.8  PostScript & PDF Import Options  

 

PostScript is the industry standard for sending documents to high-resolution printers. 

Note:  Ghostscript must be installed to import PostScript/PDF. Ghostscript is freely available and distributed 

under the GNU General Public License. 

Note:  Only vector objects are translated. Embedded images are ignored. 

 

Forum: Problems with Ghostscript: Postscript Import 

 

 

 

 

 

 

http://www.numericalinnovations.com/pages/postscript-and-pdf-conversions-101
http://forums.numericalinnovations.com/post/problems-with-ghostscript-postscript-import-6252032
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Postscript Import Options 

 

PostScript is the industry standard for sending documents to high-resolution printers. All Postscript units 
are assumed to be in Points (1/72 inch). 

Options 

Page Number to Convert: Determine which 

page of the Postscript file will be converted.  

ACE can only convert 1 page at a time, for 

multiple paged Postscript files. 

Spline/Arc Precision: The maximum error allowed when computing points on curve. 

Flash Round and Rect Shapes: Convert round and rectangular shapes less than 1 inch to flashes. 

Ghostscript Commands: Request additional commands that will be sent directly to the GhostScript 

interpreter. 
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Map Layers/Colors 

Determine how to associate postscript 
objects to a layer. This includes: 

Merge All to a Single Layer: Place all postscript objects onto a single layer. 

Separate Layer per each Color: This setting creates a new layer for each object color in the  postscript file. 

Geometric Options 

 

 

 

 

Convert Paths To: Determines how to process Path objects. This includes: 

 Auto-Detect: Use the same path types found in the Postscript/PDF.  

 Polygon: Output all paths as polygons. 

 Rounded: Force all paths to be rounded. Sometimes when using Postscript/PDF's for artwork you'll 
 discover that the path quality is not very good (especially for PCB's), so a rounded path produces 
 better results. 

 Truncate: Output all paths as truncated paths (square path with no end cap). 

 Extended: Output all paths as extended paths (square path with 1/2 width end cap). 

Fill Mode: Determine how to fill objects. This includes: 

 Auto-Detect: In most Postscript drawings objects drawn with a "white" color represent a hole (or 
 transparency).  This setting will De-Embed all postscript objects that are the color "white" from all 
 remaining objects. 

 De-Embed:  Use built-in De-Embed Algorithm to determine what is transparent. 

 Fill All: Fill all objects and ignore transparency. 

 No Fill: When possible, do not fill any objects. 
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Text Output: Determines how to process Text objects. This includes: 

 None: Ignore Text 

 Polygon: Output Text as Polygons (default). 

 Polygon Adjustable: Output Text as Polygons with Adjustable spacing. 

 Use Default Font: Substitute Postscript font with an ACE font.  This may be necessary when the font 
 quality from Ghostscript is poor. 

Default ACE Font: ACE font to use when Text Output is set to "Use Default Font". 

Flash Round/ Donut Shapes & Flash Rectangle Shapes: This option will detect circles & rectangular shapes 

and convert them to Gerber flashes. Very useful when exporting to Gerber 

Ghostscript DLL/EXE: To import Postscript 

or PDF files requires Ghostscript to be 

installed. Please select the location of the  

           Ghostscript DLL or EXE file. 

7.2.9  PDF Import Options  

PDF is the industry standard for sharing documents. 

Note:  Ghostscript must be installed to import PostScript/PDF. Ghostscript is freely available and distributed 

under the GNU General Public License. 

Note:  Only vector objects are translated. Embedded images are ignored. 

Please see 7.2.8, Postscript Import Options.  

 

 

Forum: PDF to Gerber Conversion 

 

 

 

 

 

 

http://forums.numericalinnovations.com/post/pdf-to-gerber-6131443
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7.2.10  Bitmap (High Res.) Options  

 

Import Large Bitmaps file. 

If you have selected potentially wrong units, ACE will issue a warning and make a suggestion. 

Pixel Scale 

Pixel Scale:  Specify the proposed units for 

each pixels physical size. Choose from DPI, 

Micron, Inch, Millimeter, Centimeter, and 

more. 

Note: Image files are unit-less, and a pixel can theoretically represent any physical size. It is important that 
you specify the proposed units and scale for a pixels physical size. Choose from Micron, Inch, Millimeter, 
Centimeter, and more.  

Note: Logical pixel size defined by Pixel Units * Image Scale 
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Image Background Color 

Image Background Color: Select the image's 

transparent color, which will be ignored 

during importing.  Choose either Black or 

White. 

 

Optimize Pixels 

Optimize Pixels: Determines output of pixels 

as rectangles (default), flashes, or polygons. 

 

 

 

Options 

Grayscale Percentage (%): Black and White 

Images (such as images from a microscope) 

incorporate a 'grey blending' which leads to 

very few background pixels actually being 

black or white. This setting allows pixels with 

          a 'gray-scale' similar to that of the   

          background color to be treated as such. 

Vertical Scale: Allows for compensation of non-uniform images produced by a microscope or other means. 
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7.2.11  Oasis Import Options  

 

OASIS has been developed by a working group under the sponsorship of the SEMI Data Path Task Force, 

and was approved in June 2003. OASIS files offer on average a >10X reduction in size compared to GDS-II. 

Ignore Text: Skip OASIS text.  It will not appear on exported files. 

Map a Separate Layer for each Layer/Datatype Pair: If your OASIS contains objects on Layer 8 (DataType 0) 

and objects Layer 8 (DataType 4), ACE will create two unique layers (even though objects have the same 

layer number).  This is useful for engineers who want to keep objects with different layer/datatypes pairs 

separate during the conversion process. 

Default Text Height: Height to use for OASIS text objects. 
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7.2.12  STL Import Options  

 

STL (Stereolithography) binary format is outputted by almost every 3D design/modeling software tool 

including SolidWorks, ProEngineer and more. ACE automatically detects all flat surfaces used for STL to 2D 

conversions and assigns the layers respectively. 

Scale / Units 

Scale Units: STL files are unit-less, and 

objects can be assigned any scale. It is 

important that you are aware of the 

imported STL file units & scale.  ACE needs 

to know what physical unit and scale to use for 1 STL unit. 

Extraction Method 

Determines how to 2D boundaries will be extracted from a 3D STL file. A separate layer will be created for 
each depth level. 

Surface Extraction: Imported boundaries will 

consist of STL triangles Parallel to Extracted Plane. 

Edge Extraction: Imported boundaries will consist 

of STL triangles Perpendicular to Extracted Plane. 
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Output Type 

Output Type: Determines how resulting objects are outputted. Either as 

polygons with islands/holes or as connected line segments. The default 

output is polygons. 

 

 

Extracted Plane 

Choose the appropriate plane coordinates for the extracted plane. 

 

 

 

Options 

Flash Round & Rectangle Shapes: 

Automatically detect round & rectangular 

flashes. This feature saves data size and is 

required to output drill files (if needed). 
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7.2.13  Image Import Options  

 

Loads small graphic image files of formats: *.tif,*.tiff,*.png,*.bmp,*.gif,*.jpg,*.pcx,*.ico,*.rgb,*.tga. 

Size Limitation: Only small images less than 5000 x 5000 pixels are supported.  If you require importing a 

large image, use high resolution "Bitmap (High Res.)" 

Pixel Scale 

Pixel Scale:  Specify the proposed units for 

each pixels physical size. Choose from DPI, 

Micron, Inch, Millimeter, Centimeter, and 

more. 

Note: Image files are unit-less, and a pixel can theoretically represent any physical size. It is important that 
you specify the proposed units and scale for a pixels physical size. Choose from Micron, Inch, Millimeter, 
Centimeter, and more.  

Note: Logical pixel size defined by Pixel Units * Image Scale 
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Image Background Color 

Image Background Color: Select the image's 

transparent color, which will be ignored 

during importing.  Choose either Black or 

White. 

 

Optimize Pixels 

Optimize Pixels: Determines output of pixels 

as rectangles (default), flashes, or polygons. 

 

 

 

Options 

Grayscale Percentage (%): Black and White 

Images (such as images from a microscope) 

incorporate a 'grey blending' which leads to 

very few background pixels actually being 

black or white. This setting allows pixels with 

          a 'gray-scale' similar to that of the   

          background color to be treated as such. 

Vertical Scale: Allows for compensation of non-uniform images produced by a microscope or other means. 
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7.2.14  ACE Workspace Import Options  

 

Have you ever performed a translation only to find out later you needed to retranslate the same file(s) 

again? Maybe you needed to output different layers or make some edits. With ACE there's no need to start 

over, because ACE lets you open a workspace file (*.ace) that you have previously saved; so you can go 

right back to your existing translation. 
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7.2.15  New Design Import Options  

 

Create your own design using ACE and export to any file format you choose.  ACE is excellent for quickly 

drawing and visualizing simple masks and designs. With ACE 3000, there’s no need to design in another 

CAD tool. 

Note:  After completing your design, make sure to save it as an ACE workspace (*.ace), so you can re-open 

it for future use. 

Note:  Requires the Edit Plug-In. 
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7.3 Export Process Options  

7.3.1  Gerber Export Options  

 

Gerber files exported from ACE are in RS-274-X format, which is the most popular Gerber format.  All 

apertures and format information are already embedded inside the Gerber files, so no aperture list is 

required. There is also embedded support for polygon fills, composites, step/repeat, and more. To improve 

accuracy of exported Gerber files, select Decimal Digits of 4 (or higher). 

Gerber File Options (RS-274-X) 

Gerber Units: Determine exported Gerber 

units in English or Metric. 

Integer Digits: Determine exported Gerber 

integer digits between (1 to 6). 

Decimal Digits: Determine exported Gerber 

decimal digits between (1 to 6). 
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File Extension: Default extension to use for exported Gerber file names. (*.gbr) is the default. 

 

Advanced Options 

Use Step/Repeat: Use Step & Repeat codes 

when Arrayed Inserts are detected. Excellent 

for saving Gerber file sizes. 

 

Output Arcs (G75): During Gerber export, ACE will determine if any connected line segments form an arc. 
Outputting Gerber Arcs (G75) will result in smaller Gerber files with better curve quality. This option uses 
the setting in preferences called “Arc Detection Min. Chord Angle”, to help detect which line segments 
form an arc. 
 

Geometry Options 

Text Output: Specify how to output text (if 
any). Line: Text will be exploded and 
outputted as Gerber traces using the Line 
Width. Polygons: Text will be exploded, and 
output as polygons. 

Default Line Width: Default line width to assign for 0-width objects such as lines, arcs, etc. 

 

   Forum: How do I scale units when exporting to DXF? 

   Video: Convert DraftSight DWG to Gerber 

 

 

 

 

 

 

 

 

http://forums.numericalinnovations.com/post/i-need-scale-units-when-export-to-dxf-can-ace-3000-allow-me-to-do-6054603
http://www.youtube.com/watch?v=lONmd8et0h8
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7.3.2  DXF Export Options  

 

Some CAD systems may not read newer DXF files so ACE outputs an optimized DXF file that is compatible 

with most systems. 

File Options 

AutoCAD Version: Select the AutoCAD 

release to convert to.  

1 DXF Unit: Set DXF unit scale.  

 

Fill Options 
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Fill Options: Controls the ability to fill 

polygons areas a solids (i.e. triangles), or 

with a single solid hatch. 

 

 

Entity Options 

Convert Paths To: 'Endcaps' allows for a 

true appearance, 'Outlined' converts to 0-

Width Closed Polylines, 'Lines and Arcs' 

converts to lines and arcs. 

Convert Flashes To: Controls how Gerber 

flashes are ouputted either Outlines, Filled, 

or as Blocks (reduces file size). 

Convert Polygons To: This option determines the DXF/DWG output options for all polygons (i.e. filled 
boundaries). 
 
 0-Width Polyline (Outlined): Each polygon will be output as closed 0-Width polyline. When viewing 
 the converted polygons in a CAD viewer (like AutoCAD), they will appear as outlines (i.e. not filled). 
 
 SOLIDS (Filled): Each polygon will be tessellated to filled SOLIDS. When viewing the converted 
 polygons in a CAD viewer (like AutoCAD), they will appear filled. 
 
Convert Text To: This option determines the DXF/DWG output options for all text objects.  

 
 TEXT Entity: Output text objects as DXF/DWG text entities. ACE will attempt to match the closes 
 SHX or TrueType font type. 
 
 Ignore: ACE will omit all text objects when outputting the DXF/DWG file. 
 
 Explode: ACE will output all Text to outlines (i.e. closed 0-Width polyline). 
 

Options 

Flatten Hierarchy: If you require a Flat DXF 

file without blocks (may cause extremely 

large DXF files). 

 

Truncate Block Names: Limit Block Names to 30 characters (prevents problems with some CAD systems). 
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Output Arcs: During DWG/DXF export ACE can determine if any connected line segments form an arc. 

Outputting DWG/DXF Arcs will result in smaller DXF/DWG files with better curve quality. This option uses 

the setting in preferences called “Arc Detection Min. Chord Angle”, to help detect which line segments 

form an arc. 

 

 

7.3.3  GDS-II Export Options  

 

Some CAD systems cannot handle GDS-II files with large polygons (i.e. point counts).  If this is the case, you 

can define the Maximum Points per Polygon.  ACE will automatically 'chopped' into multiple polygons that 

do not exceed the point count limit. Due to its complexity, this feature may be time consuming during the 

conversion. 

GDS-II files do not support composite layers (a layer with objects that contain both dark & clear polarities - 

such as a hole inside a polygon). ACE will automatically flatten these layers into re-entrant polygons.  Due to 

its complexity, this feature may be time consuming during the conversion. 

File Options 
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Flatten All Cells: Outputs GDSII files without 

any hierarchy. Useful for GDSII files that 

must be read into older systems, or 3D 

simulation software that does not support 

hierarchy. 

Assign UNIX Naming Conventions: Limit Cell 

names to 32 characters or less, and treat  

           them with case-sensitivity. 

Geometry Options 

Text Output: Specify how to output GDSII 
text (if any). This includes: 

 

 Standard: Text will be outputted as GDSII text. 

 Ignore: Text will be omitted from the GDSII file. 

 Explode: Text will be exploded, and output as polygons. 

Maximum Points Per Polygon: GDSII Polygons can only handle a maximum of 200 points per polygon.  If 
this setting is filled in, polygons with more than defined number of points will be "chopped" into multiple 
polygons that do not exceed the point count limit. (Due to its complexity, this feature may be time 
consuming during the conversion) 

7.3.4  DWG Export Options  
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Some CAD systems may not read newer DWG files so ACE offers several versions of DWG (AutoCAD R14 to 

R2007). 

File Options 

AutoCAD Version: Select the AutoCAD 

release to convert to.  

1 DXF Unit: Set DXF unit scale.  

 

Fill Options 

Fill Options: Controls the ability to fill 

polygons areas a solids (i.e. triangles), or 

with a single solid hatch. 

 

Entity Options 
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Convert Paths To: 'Endcaps' allows for a 

true appearance, 'Outlined' converts to 0-

Width Closed Polylines, 'Lines and Arcs' 

converts to lines and arcs. 

Convert Flashes To: Controls how Gerber 

flashes are ouputted either Outlines, Filled, 

or as Blocks (reduces file size). 

Convert Polygons To: This option determines the DXF/DWG output options for all polygons (i.e. filled 
boundaries). 
 
 0-Width Polyline (Outlined): Each polygon will be output as closed 0-Width polyline. When viewing 
 the converted polygons in a CAD viewer (like AutoCAD), they will appear as outlines (i.e. not filled). 
 
 SOLIDS (Filled): Each polygon will be tessellated to filled SOLIDS. When viewing the converted 
 polygons in a CAD viewer (like AutoCAD), they will appear filled. 
 

Convert Text To: This option determines the DXF/DWG output options for all text objects.  

 
 TEXT Entity: Output text objects as DXF/DWG text entities. ACE will attempt to match the closes 
 SHX or TrueType font type. 
 
 Ignore: ACE will omit all text objects when outputting the DXF/DWG file. 
 
 Explode: ACE will output all Text to outlines (i.e. closed 0-Width polyline). 
 

Options 

Flatten Hierarchy: If you require a Flat DWG 

file without blocks (may cause extremely 

large DWG files). 

 
 

Truncate Block Names: Limit Block Names to 30 characters (prevents problems with some CAD systems). 
 

Output Arcs: During DWG/DXF export ACE can determine if any connected line segments form an arc. 
Outputting DWG/DXF Arcs will result in smaller DXF/DWG files with better curve quality. This option uses 
the setting in preferences called “Arc Detection Min. Chord Angle”, to help detect which line segments 
form an arc. 
 



ACE Translator 3000 V7 

 

Page 137 

 
 

 
Video: Convert ODB++ to GS 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

7.3.5  Postscript Export Options  

http://screencast.com/t/1Xrooba8W
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All postscript files exported from ACE are rasterized (no vector).  There are two reasons for this:  

 1. Vector PostScript files (converted from Gerber, DXF, etc.) can become cumbersome and too  

  large to be useful.   

 2.  Rasterized postscript files have been known to plot must faster and efficiently. 

Note: Determine a scale to use for Postscript output on the Import/Export conversion page.  (In most cases 

for MEMs/EDA masks a factor of 10X is used.)  

Using the pull down menu, select the following options: 

Postscript Type: Select Postscript output type either Standard or Encapsulated.  If you are unsure, contact 

your local graphic expert - in most cases we recommend "Encapsulated". 

Line Width (points): Default line width to assign for 0-width objects such as lines, arcs, etc. 

Text Fill: Specify how to output text (if any). This includes: 

 Line: Text will be exploded and outputted as Gerber traces using the Line Width. 

 Solid Fill: Text will be exploded, and output as polygons. 
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Set Color Operator: Determines the color operator used in the outputted Postscript file. 
 
 Setgray: Assign color by grayscale. The most simple color operator and uses  only one numerical 
 value.  
 
 Setrgbcolor: Assign color using RGB. The Postscript file will use three  numerical values.  
 
 Setcymkcolor: Assign color by CYMK. The most popular color operator and  uses four numerical 
 values.  

 

7.3.6  PDF Export Options  

 

To Export to PDF, you’ll first need to be in the CAD Viewer because ACE requires the viewer to render the 
pixels that will be used in the exported PDF files. ACE will automatically go to the Viewer once you have 
finished the “import” portion of the conversion.  

 With ACE 3000, while in Viewer Mode, you can plot active designs to an optimized PDF file.  

1.  Select File > Plot to PDF (up to E-Size) 
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2.   In the Printer/Page Setup,       

change the Paper Size from       

A to E. Keep the rest of the       

default settings.  

3.   Select Next. 

 

 

 

 

 

 

 

Note: Use Advanced Options to set margins, centering, separated pages for layers, and compression.  
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4.  In the Plot Features menu, 

keep the default settings or 

modify according to your needs.   

 

5.   Select Next.  

 

 

 

 

 

 

 

6.    Verify that the Preview  

    appears correctly. 

 

7.   Select Next. ACE Translator 

 will begin to generate a PDF.  
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8.  Once your PDF file has been    
created, the finish page will be 
displayed. The location and name of 
the PDF file will be displayed. 

 

 

 

 

 

 

 

 

 

9.  Select View PDF to open the PDF in Adobe    

Acrobat (if available). 
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7.3.7  Bitmap (High Res.) Export Options  

 

High Resolution BITMAP files (up to 25,400,000 DPI accuracy) are exported from ACE in monochrome 

format, which is a 1 bit Black/White pixels.  Perfect when you need to generate high-resolution images 

from your layouts, especially for maskless lithography requirements. 

Image Resolution: Select the appropriate image resolution for your Bitmap export. 

X Resolution: Output bitmap with separate X resolution.  Useful in situations where printing on the line 

would put down too much ink as there would be too much drop overlap and make the line too thick or 

wide.  Also useful with some inks that do not dry immediately and if there is too much ink they can actually 

migrate around along the line. 

Y Resolution: Output bitmap with separate Y resolution. Useful in situations where printing on the line 

would put down too much ink as there would be too much drop overlap and make the line too thick or 

wide.  Also useful with some inks that do not dry immediately and if there is too much ink they can actually 

migrate around along the line. 

Use Pixel Approximation: ACE will optimize pixels that are partially covered with data, resulting in a more 

accurate and sharp image (may be time consuming). 
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Remove Edge Pixel (Horizontal): Reduces all geometries within an image by one pixel (each side) in the  

horizontal direction. For example, if a vertical line normally has a width of 8 pixels, check this option and it 

will be reduced to a width of 6 pixels (i.e. 1 pixel is removed from each side). This is an excellent feature for 

providing manufacturing compensations to geometries within images. Note: This does reduce or change 

final overall image size unless Trim Edges is also used. 

Remove Edge Pixel (Vertical): Reduces all geometries within an image by one pixel (each side) in the  
vertical direction. For example, if a horizontal line normally has a width of 8 pixels, check this option and it 
will be reduced to a width of 6 pixels (i.e. 1 pixel is removed from each side). This is an excellent feature for 
providing manufacturing compensations to geometries within images. Note: This does reduce or change 
final overall image size unless Trim Edges is also used. 

7.3.8  TIFF Export Options  

 

High Resolution TIFF files (up to 25,400,000 DPI accuracy) are exported from ACE in bi-tonal format, which 

is a 1 bit Black/White pixels. 

Image Resolution: Select the appropriate image resolution for your Bitmap export. 

X Resolution: Output TIFF with separate X resolution.  Useful in situations where printing on the line would 

put down too much ink as there would be too much drop overlap and make the line too thick or wide.  Also 

useful with some inks that do not dry immediately and if there is too much ink they can actually migrate 

around along the line. 
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Y Resolution: Output TIFF with separate Y resolution. Useful in situations where printing on the line would 

put down too much ink as there would be too much drop overlap and make the line too thick or wide.  Also 

useful with some inks that do not dry immediately and if there is too much ink they can actually migrate 

around along the line. 

Image Compression: Shrink down the size of your TIFF by up to 97%! 

Trim Edges: Remove excess pixels around the borders of your TIFF. 

Use Pixel Approximation: ACE will optimize pixels that are partially covered with data, resulting in a more 

accurate and sharp image (may be time consuming). 

Remove Edge Pixel (Horizontal): Reduces all geometries within an image by one pixel (each side) in the  

horizontal direction. For example, if a vertical line normally has a width of 8 pixels, check this option and it 

will be reduced to a width of 6 pixels (i.e. 1 pixel is removed from each side). This is an excellent feature for 

providing manufacturing compensations to geometries within images. Note: This does reduce or change 

final overall image size unless Trim Edges is also used. 

Remove Edge Pixel (Vertical): Reduces all geometries within an image by one pixel (each side) in the  

vertical direction. For example, if a horizontal line normally has a width of 8 pixels, check this option and it 

will be reduced to a width of 6 pixels (i.e. 1 pixel is removed from each side). This is an excellent feature for 

providing manufacturing compensations to geometries within images. Note: This does reduce or change 

final overall image size unless Trim Edges is also used. 

7.3.9  ODB++ Export Options  
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ACE outputs ODB++ as a single compressed tar-gzipped file. 

Advanced Options 

Output Profile: Generate a profile for each 

ODB++ step (optional). 

Output Symbols as Polygons: Explodes 

complex flashes to simple boundaries.  This 

feature is not recommended unless you 

have another tool that has difficulty loading 

ODB++ symbols. 

Use Step/Repeat: When possible output arrayed cells as ODB++ Step/Repeat. This option drastically 
reduces ODB++ file size when arrays are used. 
 

Output Arcs: During ODB++ export, ACE can determine if any connected line segments form an arc. 
Outputting DODB++ Arcs will result in smaller ODB++ files with better curve quality. This option uses the 
setting in preferences called “Arc Detection Min. Chord Angle”, to help detect which line segments form an 
arc. 
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Geometry Options 

Text Output: Controls the output of text. 

Default Line Width: Default width to use for 

0-width lines. 

 

7.3.10  OASIS Export Options  

 

To Minimize OASIS file sizes use Compact Rectangular, Repetition, and CBlocks. However, these options will 

increase export time. 

OASIS files do not support composite layers (a layer with objects that contain both dark & clear polarities - 

such as a hole inside a polygon). ACE will automatically flatten these layers into re-entrant polygons. Due to 

its complexity, this feature may be time consuming during the conversion. 

Using the pull down menu, select the following options: 

Text Output: Specify how to output OASIS text (if any): 

 Standard: Text will be outputted as OASIS text. 
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 Ignore: Text will be omitted from the OASIS file. 

 Explode: Text will be exploded, and output as polygons. 

Compact Rectangular Shapes: Output any rectangular figure as a, Oasis rectangle record.  An example 

would be an orthogonal path with 2 points or an orthogonal polygon with 4 points that forms a 

rectangle.  This option greatly reduces the size of the final OASIS file. 

Use Repetition whenever possible: Search for any identical figures that may be repeated.  If identical 

figures are found, only the first figure is outputted followed by repetition records for the remaining 

identical figures. This option greatly reduces the size of the final OASIS file. 

Include Properties: Attach certain properties to outputted figures in OASIS.  This is an excellent feature for 

adding intelligence to the OASIS file.  You may include properties for things such as critical nets, etc. 

Use CBLOCK on each cell: Compress each cell using an RFC 1951 compression utility.  This usually results in 

a 4X reduction in OASIS file size. Available only on custom builds. 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

7.3.11  STL Export Options  
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Outputs a binary version of STL. STL (Stereolithography) format is accepted by most 3D design/modeling 

software including SolidWorks, ProEngineer and more. 

STL Units: Select the units to use for the exported STL file. Choose from Inch, Millimeter, Micron, etc. 

Merge Vertices Tolerance: Distance used to calculate whether two vertices are close enough to be merged. 

7.3.12  Screen Capture Export Options  

 

To export a screen capture, you’ll first need to be in the CAD Viewer because ACE requires the viewer to 
render the pixels that will be used in the screen capture. ACE will automatically go to the Viewer once you 
have finished the “import” portion of the conversion.  

With ACE 3000, while in Viewer Mode, you can export an image file using File > Export Screen Capture. 
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Image Format: Choose an Image Format (TIFF, PNG, BMP, JPG, ICO, PCX, RGB, and TGA) from the drop 

down menu. 

Image Area:  Choose between Display and Extents.  

Image Width (Pixels): Set pixel resolution. 

Upon selecting OK, choose a location to export your screen capture. Select Save.  

7.3.13  Viewer Only Export Options  
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This option allows you to use ACE 3000, as a "multi-format" viewer. Upon selecting import options, you’re 

file will open within the ACE 3000 CAD viewer.  

 

 

Video: DXF to STL conversion  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.youtube.com/watch?v=c08ZJ2PaopY
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SECTION 8: CAD VIEWER  

 

CAD Viewer can be accessed by clicking the tab at the top right called Viewer. To return to the file 

conversion menu, select Convert.  
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8.1 File Menu 

 The File menu presents a number of basic options for switching to the 

ACE convert menu, Plotting to PDF, exporting images, saving 

workspaces, and restarting or exiting ACE.  

 

 

 

 

 

File > Back to ACE Conversion Setup: Returns to ACE Conversion menu. 

File > Plot to PDF (Up to E-Size): Plots image to PDF. To plot an image to PDF, perform the following: 

With ACE 3000 Translator, while in Viewer Mode, you can plot active designs to an optimized PDF file.  

1.  Select File > Plot to PDF (up to E-Size) 

 

 

 

 

 

 

 

2.   In the Printer/Page Setup, change the Paper 

Size from A to E. Keep the rest of the default 

settings.  

3.   Select Next. 
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Note: Use Advanced Options to set margins, 

centering, separated pages for layers, and 

compression.  

 

 

 

 

 

 

4.  In the Plot Features menu, keep the 

default settings or modify them according to 

your needs.   

5.   Select Next.  

 

 

 

 

 

 

 

6.    Verify that the Preview appears correctly. 

 

7.    Select Next. ACE Translator will begin to   

 generate a PDF.  
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8.  Once your PDF file has been    created, the 

finish page will be displayed. The location and 

name of the PDF file will be displayed. 

 

 

 

 

 

 

 

9.  Select View PDF to open the PDF in Adobe    Acrobat (if 

available). 
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File > Export BITMAP 

With ACE 3000 you can plot active designs to an optimized Bitmap file.  

1.   Select File > Export Bitmap (High                    

 Resolution) 

 

 

 

 

 

 

 

 

2. In the Export Bitmap Options menu, 

 verify or select options.  

3. Select Next. 
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4.    The bitmap export will  

  complete and you’ll be taken  

  to the Finish! menu. 

  Note:  A file browser window  

  will appear to let you choose  

  which directory to save your  

  exported file to. 

5.    Select Output Folder to save  

  your exported bitmap or  

  choose Finish.  

 

 

File > Export TIFF   

1. Select File > Export TIFF (High 

 Resolution) 
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2.   In the Export TIFF 

 Options menu, verify 

 or select options. 

3. Select Next.  

 

 

 

 

 

 

 

 

 

4. The TIFF export will 

 complete and you’ll 

 be taken to the Finish! 

 menu. 

 Note:  A file browser 

 window will appear to 

 let you choose which 

 directory to save your  

 exported file to. 

5. Select Output Folder  

 to save your exported 

 TIFF or choose Finish.  
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File > Save ACE Workspace 

Saves an ACE workspace into a single *.wrk file. Have you ever performed a translation only to find out you 
needed to make a few minor changes? Maybe you needed to output different layers or make some edits. 
With ACE there's no need to start over, because ACE lets you open a workspace file (*.wrk) that you have 
previously saved; so you can go right back to your existing translation. 

File > Export Screen Capture 

With ACE 3000, while in Viewer Mode, you can export an image file using File > Export Screen Capture. 

 

Image Format: Choose an Image Format (TIFF, PNG, BMP, JPG, ICO, PCX, RGB, and TGA) from the drop 

down menu. 

Image Area:  Choose between Display and Extents.  

Image Width (Pixels): Set pixel resolution. 

Upon selecting OK, choose a location to export your screen capture. Select Save.  
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File > Restart ACE Restarts ACE 3000. 

File > Exit ACE Exits ACE 3000.  

 

8.2 Edit Menu 

The Edit Menu is responsible for any changes, modifications, deletions or copies 

of your design. 

Edit > Undo  

Undo the last command in the editor. 

Edit > Redo  

Redo the last command in the editor. 

Edit > Clipboard  

 Allows you to Cut, Copy, and Paste objects from the clipboard. This clipboard is 

different from an OS 

clipboard (i.e. Windows 

clipboard), because it allows 

you to cut, copy, and paste 

objects in ACE 3000. 
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Edit > Selection  

Performs a number of selection actions within the ACE 3000 editor. 

All: Selects all objects in the editor. 

Display: Selects objects that are currently displayed. This 

command will automatically place the editor in Select Mode. 

Window 

Select objects inside a user defined window.  

To select via window: 

 a. Select Edit > Selection > Window. 

 b. Pick a first point. Press left mouse button down 

 and hold. 

 c. Drag the mouse to the opposite corner of the selection window. Release the left mouse button. 

The selection window requires that you pick the first point and drag across the screen, while holding the 
left-button down. When you release the left-button, all objects that completely fit inside the defined 
window are selected. This command will automatically place the editor in Select Mode. 

Crossing Window 

Select objects inside and intersecting a user defined window. 

a. Select Edit > Selection > Crossing Window. 

b. Pick a first point. Press left mouse button down and hold. 

c. Drag the mouse to the opposite corner of the selection window. Release the left mouse button. 

The selection window requires that you pick the first point and drag across the screen, while holding the 
left-button down. When you release the left-button, all objects that completely fit inside the defined 
window are selected. This command will automatically place the CAM editor in Select Mode. 

Fence 

Select objects using a polyline. 

1. Select Edit > Selection > Fence.  

2. Pick a first point, click and hold the left mouse button. A polyline will appear. 

3. Draw a polyline or series of polylines over the objects you wish to select.  
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4. When finished, right click and select End or Close. The objects within this fenced area will be 

 selected.  

Window Polygon 

Select objects inside a user defined polygon. 

1. Select Edit > Selection > Window Polygon.  

2. Pick a first point, click the left mouse button. Guide the first line in the direction of your selection. 

3. Pick a second point, click the left mouse button. A polygon will appear surrounding your selection.  

4. Repeat this process and guide the polygon shape around the object area you wish to select.    

4. When finished, right click to Close. The objects within this polygon window area will be selected.  

Crossing Polygon 

1. Select Edit > Selection > Crossing Polygon.  

2. Pick a first point, click the left mouse button. Guide the first line in the direction of your selection. 

3. Pick a second point, click the left mouse button. A polygon will appear surrounding your selection.  

4. Repeat this process and guide the polygon shape around the object area you wish to select.    

4. When finished, right click to Close. The objects within and intersecting this window area will be 

 selected.  

Clear All 

Removes a selection.  
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Filter 

The selection filter is an extremely useful tool 

used for controlling the content of Objects 

that are selected prior to performing any 

modifications or queries.  It can be a major 

time saver as it parses out Objects that do not 

pass certain requirement that you set. 

1. Select Edit > Selection > Filter. A  

  Selection Filter dialog box will appear. 

 a.    Items here allow you to   

  include or exclude specific   

  Dcodes, Layers, Composite   

  Levels, NC Tools, Polygons, or   

  Text from being selected. For   

  items with check boxes, a   

  check means the item can be   

  selected, removing a check   

  means the item cannot be selected. 

2. Verify or Edit all Filter items. Select OK when complete. 

 a. Enter numbers and/or ranges  separated by commas as directed in the dialog box.  

The Selection Filter is only good for on selection command (i.e. Window, Crossing, All, etc.). If you wish to 

select another Crossing Window, you will need to go back to step 1, and repeat. 

Reset Filter 

Clears the selection filter. 

Add Layer 

Adds a layer.  

 a. Select Edit > Layers > Add Layer. A dialog 

  box will appear to edit by Layer Name and 

  Layer Type. 
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 b. Enter the Layer Name and layer 

  type you would like to use. If the 

  layer name already exists, a new 

  layer will be created. 

 c. Enter the Layer Type you would like 

  to use. ACE 3000 will assign the next 

  available layer type, and in most 

  cases you do not need to modify 

  this. If the layer type already exists, 

  no new layer will be created. 

  This command cannot be undone.  

 

Delete Layers 

Deletes selected Layers. 

1. Select Edit > Layers > Delete Layers. The Delete Layers 

dialog box will appear. 

2. Check the layers that you want to delete. 

3. Select OK to delete the selected layers. 

This command cannot be undone. 

 

 

Merge Layers 

Merge multiple layers simultaneously.  

This merges layers without polarity (i.e. composites). If you want to merge layers to create composites 

(dark/clear) use Tools > Composite Layer > Build Composite Layer. 
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1. Select Edit > Layers > Merge Layers. 

 The Merge Layer dialog box will 

 appear. 

2. Enter the name of the newly merged 

 layer in the Merge Layer Name box. 

3. Click the From Layer(s) entry box. A 

 Select  Layers dialog box will appear. 

 

 

 

 

4. Highlight the layers you 

 want to include for the 

 merge. 

 If you want to add 

 another layer to the 

 merge, or you made a 

 selection error, re-click in 

 the entry box and reselect 

 the layers to merge. 

5. Select OK to begin the 

 merge. 

 

Note: This command cannot be undone.  
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Edit > Delete  

Removes selected objects from the active design. This command requires that you select objects before 
proceeding. When no objects are selected, this command becomes de=activated in the menu. 
 

1. In the editor, select objects for deletion. To select polygons or traces, pick the edges of an object. 

2. Select Edit > Delete. 

 a. If an incorrect object is deleted, select Undo.  

Edit > Move  

This command moves objects to a new location. This command requires that you select objects before 
proceeding. When no objects are selected this command becomes de-activated in the menu. 

1. Select objects to move. To select polygons or traces, pick the edges of an object. 

2. Select Edit > Move. 

3. In the editor, select the base point.  

4. Enter the second point of displacement. The objects will be moved by the displacement amount. 

  a. For accurate distances, use the command line to enter distance values.  

 b. If the move is incorrect, use the Undo command.  

5. When finished, right click or select Esc to exit.  

 a. To quickly move a selection, Left-click over a selected object and drag the entire `  
  selection to any location in the editor. 

Edit > Copy  

This command allows you to copy a layer or object.  

Edit > Copy to Layers  

Copies selected object to other layers. This command requires that you select objects before proceeding. 
When no objects are selected this command becomes de-activated in the menu. 

1. Select objects to copy. To select polygons or traces, pick the edges of an object. 

2. Select Edit > Copy to Layers. The Copy to Layer dialog box will appear. 
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3. Check the layers that you want to  
  copy objects to.  

4. Select OK to begin copy. 

  a. If the copy is incorrect, use the 
   Undo command. 

  b. To add a layer, select Add  
   Layer. 

 

 

 

Edit > Mirror  

Mirror selected objects either horizontally or vertically. This 
command requires that you select objects before proceeding. 

When no objects are selected this command becomes de-activated in the menu. 

a. Flip Horizontal: Flips selection about the Y-axis.  

  

 

 

 

 

b. Flip Vertical: Flips selection about the X-axis. 
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To Mirror an object, perform the following: 

 1. Select objects to Mirror. To select polygons or traces,       
  pick the edges of an object. 

 2. Select Edit > Mirror > (*choose flip direction – Horizontal or      
  Vertical).  

 3. Specify mirror line location for objects (if using Horizontally      
  or Vertically).  

 4. Determine if you want to delete the source (original object      
  selected). 

  a. If the mirror is incorrect, use the Undo       
   command. 

Edit > Rotate  

Rotates selected objects by either 90, 180, or 270 degrees. 
This command requires that you select objects before 
proceeding. When no objects are selected this command  

                 becomes de-activated in the menu. 

 

Rotation Examples: 0, 90, 180, 270 
degrees. 

1. Select objects to rotate. To select 

 polygons or traces, pick the edges of 

 an object. 

2. Select Edit > Rotate > (*Use either 90, 180, 270, or Base Angle). Base angle refers to user defined 
 value. Enter this value in the command line underneath the editor (Specify Base Point). 

3. The select objects will now be rotated. 

4. If the rotate is incorrect, use the Undo command. 

Edit > Array  

Displays multiples of the same object in a group. This function  
                 requires that you select objects before proceeding. When no  
                 objects are selected, this command becomes de-activated in  
                 the menu. 
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There are two types of Arrays, Rectangular and Polar.  

Rectangular Array 

X Count: Number of copies in the horizontal direction.  

Y Count: Number of copies in the vertical direction.  

DX:  The offset in the X direction  

DY:  The offset in the Y direction.  

Angle of Array: The offset angle of an array. 

To perform a Rectangular Array: 

1. In the editor, select objects for the array. 

2. Select Edit > Array > Rectangular. 

3. Enter the X Count value.  

4. Enter the Y Count value. 

5. Enter the DX you want to use. 

6. Enter the DY you want to use. 

7. Enter the Angle of Array you want to use. 

8. Select OK to begin. 

 a. If the array is incorrect, use the Undo         
     command. 
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Polar Array 

 

 

 

 

 

 

Method: 

(Choose from the following) 

a. Total number of items and angle to fill 

b. Total number of items and angle between items 

c. Angle to fill and angle            
 between items 

Total # of items:   Number of copies.  

Angle to fill:  Total angle (in degrees) for polar array  

Angle between items: Individual angle between each item.  

To perform a Polar Array: 

1. In the editor, select objects for the array. 

2. Select Edit > Array > Polar. 

3. Specify a center point by clicking inside your design or enter the coordinates in the command 
 window. 

4. The Polar Array dialog box will appear. 

5. Enter the Polar Array options as defined above.  

6. Select OK to begin. If the array is incorrect, use the Undo command. 
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Edit > Scale  

Scales selected objects. This function requires that you select objects before proceeding. When no objects 
are selected, this command becomes de-activated in the menu. If you would like to scale an entire layer by 
different X&Y values, use Edit > Layers > Scale X/Y. 

1. In the editor select the objects you would like  
 to scale. 

2. Select Edit > Scale. The scale dialog box will  
 appear. 

3. Enter the scale factor you would like to use. 

4. Check the box if you want to scale apertures.  

5. Select OK.  

 a. If the array is incorrect, use the Undo  
         command. 

Edit > Stretch  

Automatically stretches objects crossing a defined rectangular area. 

1. Select Edit > Stretch. 

2. In the editor, specify first corner of an object by clicking it. 

3. In the editor, specify opposite corner of an object by clicking it.  

4. In the editor, specify a Basepoint. 

5. In the editor, specify a second point of displacement.  

 a. Alternatively, use the command line to enter exact coordinates.  

Edit > Split 

Splits a path into two segments and the selected location.  

1. Select Edit > Split. 

2. In the editor, specify split location by clicking it.   

3. In the editor, specify each point.  
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4. Right click to close the selection process or select Esc. 

Edit > Explode  

Converts selected Objects into base objects. This function requires that you select objects before 
proceeding. When no objects are selected this command becomes de-activated in the menu. 

1. Select Objects. 

2.  Select Edit > Explode 

Edit > De-Embed  

Automatically solves the polygon-inside-polygon problem for objects selected.  

1. In the editor, select the objects for de-embedding. 

2. Select Edit > De-Embed. 

3. Object composite levels will automatically be defined. 

 a. Objects must reside on the same layer. 

4. If the De-Embed is incorrect, use the Undo         
 command. 

Edit > Boolean  

Performs 2D Boolean operations on objects using Add, 
Subtract, Intersect, or Difference.  

 

Add Boolean 

1. Select Edit > Boolean > Add. 

2. In the editor, select the base object. 

3. In the editor, select the other object for Boolean operation. 

4. When finished, press the Esc key to complete. 

Subtract Boolean 

1. Select Edit > Boolean > Subtract. 
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2. In the editor, select the base object. 

3. In the editor, select the other object for Boolean operation. 

4. When finished, press the Esc key to complete. 

Intersect Boolean 

1. Select Edit > Boolean > Intersect. 

2. In the editor, select the base object. 

3. In the editor, select the other object for Boolean operation. 

4. When finished, press the Esc key to complete. 

Difference Boolean 

1. Select Edit > Boolean > Difference. 

2. In the editor, select the base object. 

3. In the editor, select the other object for Boolean operation. 

4. When finished, press the Esc key to complete. 

Edit > Set Origin  

Changes the location of the origin.  

Edit > Properties  

Edit properties allows you to view and modify the 
properties of individual or multiple objects. This 
function requires that you select objects before 
proceeding. When no objects are selected, this 
command becomes de-activated in the menu. Not 
only does this command allow you to view all 
object properties, you may also edit them. You can 
also double click any object to display this 
properties dialog. When multiple objects are 
selected, the "Multiple Objects" version of the 
Properties dialog box will be displayed 
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1. In the editor, select the object(s) that you want to view and edit properties. 

2. Select Edit > Properties. The properties dialog box will appear. 

3. Review all items displayed. Most items can be changed.  

4. Click on the tab Point List to view or edit an object’s vertices or center point. This is optional. 

5. Click OK to exit the properties dialog box. 

 a. If any changes you make are incorrect, select Undo. 

8.3 View Menu 

The view menu is responsible for the control and editing of object views, layer 
displays, workspace controls.  

 

 

 

 

 

 

 

 

 

View > Cell Browser  

The Cell Browser is an excellent 
feature to quickly preview all 
loaded cells in a workspace 
without having to open each 
one into the ACE Viewer.  
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This feature is only available when importing data that contains a hierarchy (i.e. GDSII, OASIS, and DXF).  
Double-click any item to open design in the editor. You can use the arrow keys Up/Down to scroll through 
designs.  

View > Hierarchy Browser  

 

The Hierarchy Browser is an excellent feature to easily view the design hierarchy of any design. This feature 
is only available when importing data that contains a hierarchy (i.e. GDSII, OASIS, and DXF). Double-click 
any item to open design in the editor. You can use the arrow keys Up/Down to scroll through designs.  

View > Redraw  

Refreshes/redraws the display in the Editor window.  

View > Zoom  

Increases or decreases object magnification. There are 
multiple zoom commands available:  

a. Zoom All: Shows entire design area in editor. 

b. Zoom In: Doubles the  magnification.  

c. Zoom Out: Halves the magnification.  

d. Zoom Window: Allows users to select a window around an area to be zoomed. 

e. Zoom Previous: Zooms to previous view.  

f. Zoom to Point: Zooms to point selected by user. 
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g. Zoom Selection: Zooms into the extents of the current selection. 

View > Pan  

Panning allows the user to scroll about the current view port in the editor. Pan does not change 
magnification, only movement. There are multiple pan commands available: 

Pan Left: Moves the view to the left by one-quarter of the view 
width. 

Pan Right: Moves the view to the right by one-quarter of the 
view width.  

Pan Up: Moves the view up by one-quarter of the view width.  

Pan Down: Moves the view down by one-quarter of the height of the view.  

Pan to Point: Pans to a specific point.  

View > Fill  

View > Fill toggles the fill mode. Fill mode controls the filing 
of all boundaries using a layer’s stipple pattern and color. 

 

View > Snap  

View > Snap Controls the cursor location in the editor. If 
snap is enabled, it allows the cursor to move onto the 
nearest grid point or object boundary point. The 
following snap commands are available: Snap Off, Snap 
to Grid, Snap to Edge, Snap to End, Snap to Object 
Center, Snap to Insertion, or Auto Snap. 

 

 

View > Ortho          

View > Ortho controls the cursor direction in the editor. If 
Ortho is enabled, it allows the cursor to move in 
directional increments of 90 or 45 degrees.  
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View > Highlight Mode  

Highlight Mode enables highlights for object layers.  

 

 

View > Translucent 

Creates a translucent color over object layers. 

 

 

View > Grid  

Toggles whether to display grid. 

View > View Cells  

Toggle view inside cells.  

View > Origin  

Toggles whether to display the origin icon in the editor.  The origin icon is usually used for reference in a 
layout.  

View > Display Ace Console  

Makes the ACE console visible.  The console contains 
all the feedback from ACE.  

Reviewing the console is extremely useful for 
debugging a conversion. It allows you to determine 
what options were used during the conversion, 
where (if any) problems could have occurred, and 
much more. 

You can Save all the contents in the console to a file, 
by clicking the button "Save". 

During a conversion ACE will automatically save a 
copy of the consoles information in a report file. 
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8.4 Add Menu 

The add menu adds specific CAD shapes, text, and markups to a 

design. 

 

 

 

 

 

 

 

Add > Polygon  

Adds a polygon to the active design. No defined aperture is required. 

1. Select Add > Polygon.  

2. Assign the active layer. The active layer combo box is located in the toolbar.  

3. Assign the next active layer. The active layer combo box is located in the toolbar. 

 a. New objects will be placed on the active layer. If active layer is turned off, you will not be  

  able to add the new object (until that layer is turned on). 

4. In the editor, select the first point for the polygon. 

5. In the editor, select the next point for the polygon. 

   a. End: Ends point list. To activate, press E key. 

   b. Close: End and close point list. To activate, press C key. 

   c. Back: Remove the last point from the current point list. To activate, press B  

    key. 

6. Once you have finished your trace select Close (C key) or right click. 

7. Repeat steps 2-5 for additional Polygon commands.  

8. To exit, right click or press Esc key.  

 a. If the command is incorrect, use Undo.  

 b. To add an arc/circle to a net, use Tools > Nets > Edit Nets.  
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 c. To add an arc/circle to a composite, use Edit > Properties and locate Composite Level. 

Add > Line  

Adds a 0-width line to the active design in the viewer.  

Add > Wide Path  

Adds a wide path (polygon) to 
the active design. No defined 
aperture is required. 

1. Select Add > Wide Path. 

2. Select Path Width. Width 
 cannot be 0. 

3. Select Path style. Path styles 
 include: Truncate (no path 
 extension) and Extend (extend 
 by ½ path width). 

4. Assign the active layer in the 
 Layer Display.  

 

a. New objects will be displayed on the active layer. If the active layer is turned off, you will not be able to 
add the new object (until the layer is turned on). 

5. Select the first point for the trace. 

6. Select the next point for the trace. 

 a. Additional options are available: End, Close, & Back. 

   1. End: Ends point list. Press E key. 

   2. Close: End and close point. Press C key. 

   3. Back: Remove the last point from the current point list. Press B key. 

7. Once you have finished your trace, select either End or Close. 

8. Repeat steps 4-7 for additional wide paths. 

9. To exit, right click or press Esc. 
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 a. If the command is incorrect, select Undo. 

 b. To add a wide path to a net, use Tools > Nets > Edit Nets.  

Add > Flash  

Adds a flash to the active design. At least one aperture must have been previously defined. The flash will be 

placed on the active layer.  

1. Select Add > Pad. 

2. Assign the active Dcode. The active Dcode combo box is located in the toolbar. 

3. Assign the active layer. The active layer combo box is located in the toolbar. 

 a. New objects will be placed on the active layer. If the active layer is turned off, you will not  

  be able to add the new object (until that layer is turned on). 

4. Select the center point for the flash. 

5. Repeat steps 2-4 as necessary.  

6. To exit, right click or press Esc.  

 a. If the command is incorrect, use Undo. 

 b. To add a flash to a composite, use Edit > Properties and locate Composite Level. 

Add > Trace  

Adds a trace (line) to the active design. At least one aperture must have been previously defined. 

1. Select Add > Trace.  

2. Assign the active Dcode. The active Dcode combo box is located in the toolbar.  

3. Assign the active layer. The active layer combo box is located in the toolbar. 

 a. New objects will be placed on the active layer. If active layer is turned off, you will not be  

  able to add the new object (until that layer is turned on). 

4. In the editor, select the first point for the trace. 

5. In the editor, select the next point for the trace. 

 a. You also have the following additional options when adding Trace. 

   1. End: Ends point list. To activate, press E key. 

   2. Close: End and close point list. To activate, press C key. 
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   3. Back: Remove the last point from the current point list. To activate, press B  

    key. 

6. Once you’ve finished your trace, choose End or Close. 

7. Repeat steps 2-6 for additional traces.  

8. To exit, right click or press Esc key.  

 a. If the command is incorrect, use Undo.  

 b. To add a trace to a composite, use Edit > Properties and locate Composite Level. 

Add > Rectangle  

 Adds a filled rectangle to the active design. 

1. Select Add > Rectangle.  

2. Assign the active layer. The active layer combo box is located in the toolbar.  

 a. New objects will be placed on the active layer. If active layer is turned off, you will not be  

  able to add the new object (until that layer is turned on). 

4. In the editor, select the first corner for the rectangle. 

5. In the editor, select the opposite corner for the rectangle. 

6. Repeat steps 2-5 for additional Rectangle commands.  

7. To exit, right click or press Esc key.  

 a. If the command is incorrect, use Undo.  

 b. To add an arc/circle to a composite, use Edit > Properties and locate Composite Level. 

Add > Circle Arc  

Adds a circle to the active design.  

1. Select Add > Circle / Arc.  

2. Assign the active Dcode. The active Dcode combo box is located in the toolbar.  

3. Assign the active layer. The active layer combo box is located in the toolbar. 

 a. New objects will be placed on the active layer. If active layer is turned off, you will not be  

  able to add the new object (until that layer is turned on). 

4. In the editor, select the center point for the circle. 

5. In the editor, select the radius, orientation, and degrees for the circle. 
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6. Repeat steps 2-5 for additional Circle/Arc commands.  

7. To exit, right click or press Esc key.  

 a. If the command is incorrect, use Undo.  

 b. To add an arc/circle to a composite, use Edit > Properties and locate Composite Level. 

Add > Ellipse  

Adds a filled Ellipse to the active design. 

1. Select Add > Ellipse.  

2. Assign the active layer. The active layer combo box is located in the toolbar.  

 a. New objects will be placed on the active layer. If active layer is turned off, you will not be  

  able to add the new object (until that layer is turned on). 

4. In the editor, select the first corner for the ellipse. 

5. In the editor, select the opposite corner for the ellipse. 

6. Repeat steps 2-5 for additional Ellipse commands.  

7. To exit, right click or press Esc key.  

 a. If the command is incorrect, use Undo.  

 b. To add an arc/circle to a composite, use Edit > Properties and locate Composite Level. 

Add > Text 

Adds text to the active design. 

1. Select Add > Text. 

2. Assign the active layer by selecting a layer in the layer display panel. 

 a. New objects will be displayed on the active layer. If the active layer is turned off, you will  
  not be able to add the new object (until the layer is turned on). 

3. Enter Text in the String dropdown located at the top in the workspace menu bar. 
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4. Enter Text Height in the dropdown located at the top in the workspace menu bar. 

5. Enter Text Style in the dropdown located at the top in the workspace menu bar. 

 a. The text style combo box includes all ACE 3000 compiled fonts located in the ACE 3000  
  folder fonts.  If there is not a text style available that you want, you may create your own  
  ACE 3000 compiled font from any TrueType or AutoCAD SHX font.  To do this, go to Help >  
  Compile True Type Fonts.  

6. Enter Orientation in the dropdown located at the top in the workspace menu bar. 

7. In the editor, select an origin point for text.  

8. Repeat steps 2-7 for multiple text entries. 

 a. If the command is incorrect. Select Undo. 

9. To add Text to a composite, use Edit > Properties and locate Composite Level. 

 

Add > Multi-Line  

Adds multi-line (paragraph) text to the active design. 

1. Select Add > Multi-Line Text. 

2. Assign the active layer by selecting a layer in the layer display panel. 

 a. New objects will be displayed on the active layer. If the active layer is turned off, you will  
  not be able to add the new object (until the layer is turned on). 

3. Select the first corner for multi-line text. 

4. Enter the opposite corner for multi-line text. The Add Multi-Line Text dialog box will appear. 

5.   Enter a Multi-Line text String. 

6.   Enter a text height. 
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7.  Select a text Style (font). 

 a. The text style combo box  
      includes all ACE 3000  
      compiled fonts located in  
      the ACE 3000 folder  
      fonts.   

 

 

 

 

If there is not a text style available that you want, you may create your own ACE 3000 compiled        
font from any TrueType or AutoCAD SHX font.  To do this, go to Help > Compile True Type Fonts.  

6. Select the Alignment to be used.  

 a. The alignment options are: upperLeft, centerLeft, upperCenter, centerCenter, lowerCenter, 
  upperRight, centerRight, lowerRight. 

7. Select the Orientation. 

Enter Orientation in the dropdown located at the top in the workspace menu bar. 

8. Select the Polarity of the text.  

9. Press OK to create the text.  

 a. If the command is incorrect, select Undo. 

 b. To add Multi-Line Text to a composite, use Edit > Properties and locate Composite Level. 

8.5 Cell  Menu 

This menu is used for the creating, editing, and 

deleting cells.  
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Cell > Insert Cell  

Adds an Insert into the active cell. An 
Insert represents the inclusion of one 
cell as a part of another. 

 

 

 

 

 

 

Cell Orientation: 

The default is R0 (0 degrees rotation).  Choose from:  

"R0" Represents 0 degree rotation 

"R90" Represents 90 degree rotation 

"R180" Represents 180 degree rotation 

"R270" Represents 270 degree rotation 

"MY" Represents mirror about the Y axis 

"MYR90" Represents mirror about the Y axis then 90 degree rotation 

"MX" Represents mirror about the X axis 

"MXR90" Represents mirror about the X axis then 90 degree rotation  

Cell Anchor Point: 

The default is LowerLeft.  Choose from: 

"LowerLeft" - Represents the lower left extents of the master cell. 

"Center" - Represents the center of the master cell. 

"Origin" - Represents the true origin relative to the master cell. 
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Cell > New Cell  

This creates a new cell. 

In Cell Name, make sure that you choose a unique 
name that does not current exist in the ACE 
workspace. 

 

 

 

Cell > Delete Cell  

Deletes a cell from the ACE workspace.  

 

 

 

 

 

 

 

Cell > Flatten Cell Hierarchy  

Flattens cell hierarchy.  
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Cell > Open Selected Cell  

Opens selected instance in a new editor window.  

1. Select Instance  

2. Activate command: Open Instance.  

You will now see a new editor window created with the instances' design opened. This command is also 
located in the right-click menu of the editor.  

Cell > Cell Information  

Displays all cell 
information. This 
includes Hierarchy Tree, 
Dcode information, and 
a summary of object 
count (polygons, text, 
layers, nets, etc.). 

 

 

 

 

 

 

8.6 Info Menu 

Info > Query  

Displays the information of a selected object. Depending on the 

object selected, Query reports different types of information. 
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To display information of a selected object using Info > Query, perform the following: 

1. Select Info > Query.  

2. Select an object to Query by moving 

 the cursor over the object, and left 

 clicking it. 

Note:  If you have more than one item in 

the same location and Query does not 

display the object you want to view, 

simply click the left mouse button again 

and ACE Viewer will cycle through the 

other objects in the same location until 

you see the one you want. 

 

3. The object you selected will display its information in the dynamic window on the screen.  

4. To exit the information display, right click or press Esc.  

Info > Measure: Point to Point  

Provides an interactive readout between two selected points within the editor. 

Measure provides the following 

information: 

Angle:  The angle (in degrees) between the 
two selected points.  

Distance: The total distance between the 
two selected points.  

DX: The horizontal displacement between 
the two selected points.  

DY: The vertical displacement between the  
             two selected points.  

Pt1 and Pt2: X and Y coordinates for each point selected.  
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Info > Measure: Object to Object  

Provides an interactive readout between two selected objects within the editor. 

Measure provides the following information: 

Distance: The total distance between the two 
selected points.  

DX: The horizontal displacement between the 
two selected points.  

DY: The vertical displacement between the two 
selected points.  

Pt1 and Pt2: X and Y coordinates for each point 
selected.  

Info > Rulers  

Applies ruler measurements directly to the design. 

 

 

Add Ruler 

Adds a ruler and measurement information directly to the design by selecting two points.  

Clear Ruler 

Clears all displayed rulers in the design.  

Info > Find  

Searches the editor for defined criteria. There are 
several find criteria to choose from: Open Boundary, 
Dcode, Text, Cell, and Polarity Level.  
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Find: Open Boundary(s) 

Used to detect open boundaries that ACE could not 
close during Join. This feature is most commonly 
used after DXF/DWG import when Join option has 
been selected. 
 

 

 

 

 

 

Find: Dcode 

Searches active Job for defined Dcode. 

1. Select Info > Find > Find Dcode. The Find 
 Dcode dialog box will be displayed. 

2. Select Dcode to find from the dropdown 
 menu.  

3. Select View As. Choose from Highlight, 
 Isolate, or Shadow. 

  

  a. Highlight: All net objects on visible layers highlighted. 

  b. Isolate: All net objects are visible, while all other objects are hidden. 

  c. Shadow: All net objects are shadowed. 

4. Select Zoom Extents. If checked, this zooms out to view all Dcodes. 
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Find: Text 

Searches active Job for defined Text. 

1. Select Info > Find > Find Text. The Find Text  
 dialog box will be displayed. 

2. Enter Text to find from the dialog box. 

3. Select View As. Choose from Highlight  
 Isolate, or Shadow. 

 a. Highlight: All net objects on   
  visible layers highlighted. 

       
        b. Isolate: All net objects are   
         visible, while all other objects   
         are hidden. 

        c. Shadow: All net objects are   
         shadowed. 

4. Select Zoom Extents. If checked, this zooms out to view all composite level objects. 

5. To exit, right click or press Esc.  

Find: Cell  

. Select Info > Find > Find Insert. The Find 
 Insert dialog box will be displayed. 

2. Enter Name to find from the dialog box. 

3. Select View As. Choose from Highlight,  
 Isolate, or Shadow. 

  a. Highlight: All net objects on  
   visible layers highlighted. 

       
  b. Isolate: All net objects are  

          visible, while all other objects  
          are hidden. 

c. Shadow: All net objects are shadowed.  
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4. Select Zoom Extents. If checked, this zooms out to view all composite level objects. 

Find: Polarity 

1. Select Info > Find > Find Polarity. The Find  
 Polarity dialog box will be displayed. 

2. Select Polarity to find from the dropdown  
 menu.  

3. Select View As. Choose from Highlight 
 Isolate, or Shadow. 

  a. Highlight: All net objects on  
   visible layers highlighted. 

       
         b. Isolate: All net objects are  
          visible, while all other objects  
          are hidden. 

         c. Shadow: All net objects are  
          shadowed. 

4. Select Zoom Extents. If checked, this zooms out to view all composite level objects. 

5. To exit, right click or press Esc.  

Info > List Objects  

Opens a command console, listing the information for 
each object selected. In order to use this command, 
you must first select object(s).  

Includes information on objects such as Type, Layer, 
Polarity Level, Dcode, Path Style, Path Width, Area, 
Length, Pt Count, and Pt location.  
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8.7 Tools Menu 

Includes functions such as Join Wizard, Convert to, Bonus 

Utilities, Composite Layers, and Boolean Wizard. 

 

 

 

Tools > Join Wizard  

Automatically or interactively fix and close selected 

open boundaries. This includes Automatic, Interactive, 

and View Join Errors. 

 

 

 

Automatic 

Automatically fix and close selected open boundaries. 

1. Select the boundary objects 

 (lines, traces, arcs, etc.) you 

 want to join. 

 a. This function requires  

  that you select objects 

  before proceeding. 

2. Select Tools > Join Wizard > 

 Automatic. The Join wizard 

 dialog box will  appear. 

3. Edit or verify settings. Select 

 Next. 

 

 

4. ACE 3000 will now attempt to join all selected objects. When complete, a report will appear within 

 the dialog box describing the number of open or closed boundaries created as well as the elapsed 

 time. 
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 a. If there are any open boundaries that could not be joined, ACE 3000 will automatically  

  display their locations using the Tools > Join Wizard > View Join Errors command. 

Interactive 

Selectively fixes and closes open 

boundaries. In many cases after running 

Tools > Join Wizard > Automatic, you 

may discover that several troublesome 

boundaries still cannot be joined and 

closed, this is where Join Interactive is 

used. 

1. Select Tools > Join Wizard > 

Interactive.  

 

2. Choose the Tolerance and resulting layer for the joined objects. Select OK. 

 a. Tolerance is used when join interactive attempts to join adjacent objects. 

3. Select an object (lines, arcs, traces, etc.) on the boundary you want to join. 

 a. Join Interactive will now attempt to join adjacent objects to form the closed    
  boundary.  When there is a gap or multiple objects, Join Interactive will stop and prompt  
  you to select the next object on the boundary. 

 b. Join Interactive will also accept any coordinate point to select.  This is handy when there  
  is a big gap (or missing section) of a boundary. 

 c. Join Interactive will also accept the following commands: 

   1. End – Stop and create an open boundary. 

   2. Close – Stop and create a closed polygon. 

   3. Back – Undo last object added to Join Interactive boundary. 

4. Once the boundary has been closed, it will be automatically converted to a polygon and placed on 

 the output layer. 

5. Repeat steps 3-4.  
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View Join Errors 

Searches the active job, for any Join errors (i.e. boundaries that could not be closed by Join). This function 
requires that you have already run Join beforehand, and join error markers were detected. To activate, 
select Tools > Join Wizard > View Join Errors. 

Tools > Convert To  

Automatically generate Round, Polygon, or Rectangular flashes. 

 

Flash (Automatic) 

1. Select all objects in an area that you  want 

 to have flashes detected. It does not matter if 

 pads are different sizes. 

 a. You must have at least one   

 object selected before    

 proceeding. 

2. Select Tools > Convert To > Flash    

 (Automatic). A Draw to Flash dialog box will 

 appear. 

3. Verify or edit settings for detecting new 

 flashes.  

4. Select OK. ACE 3000 will now detect all round/rectangular pads and convert them to Gerber flashes. 

 a. It’s a good idea to make sure that your Draw and Flash colors are different colors   

  respectively. This will make it easier to determine which draw pads have not been   

  converted to flashes. 
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Flash (Interactive) 

Converts drawn pads to Gerber flashes.  

1. Select the drawn pads(s) that you want to 

convert to a flash. 

 a. You must have at least one object  

  selected before proceeding. 

2.  Select Tools > Convert To > Flash  

  (Interactive). 

3.  Verify or edit settings for new flashes.  

  Select OK. A Convert to Flash dialog  

  box will appear. 

4.  ACE 3000 will now search for all  

  objects similar to your original  

  selection and convert them to Gerber  

  flashes. 

 

 a. Turn off any layers that you do not want to convert to flashes. 

 b. It’s a good idea to make sure that your draw and flash colors are different colors   

  respectively. This will make it easier to determine which draw pads have not been   

  converted to flashes. 

Flash (Selective) 

Converts a selected group of objects to Gerber flashes. 

1. Select the drawn pads(s) that you want to 

 convert to a flash. 

 a. You must have at least one object  

  selected before proceeding. 

2. Select Tools > Convert To > Flash (Selective). 

A  Draw to Flash dialog box will appear. 

3. Verify or edit settings. 

4.  Select OK.   
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It’s a good idea to make sure that your draw and flash colors are different colors respectively. This will 

make it easier to determine which draw pads have not been converted to flashes. 

Flash (Custom Aperture) 

Converts selected objects to a custom aperture 

definition.  

1. Select all the objects that you want to convert 

 to a custom aperture. 

 a. You must have at least one object  

  selected before proceeding. 

2. Select Tools > Convert To > Flash (Custom 

 Aperture). 

 

3. Enter the name you want to use as a reference for this custom aperture. You can determine if you 

 want ACE 3000 to replace the selected objects with a new custom aperture or select “All” – ACE 

 3000 will search for all similar object groups and replace them with custom apertures. 

4. ACE 3000 will now create a new custom aperture and add it to the Aperture Table. 

 a. Nothing has changed in the active Job. ACE 3000 has simply constructed a new custom  

  aperture based from the selected objects. 

 b. The new custom aperture is now current and may be added by using the command Add >  

  Flash. 

 c. ACE 3000 is intelligent enough to recognize objects with a composite attribute and construct 

  them with dark or clear fields (like a donut). 

Polygon 

Converts selected objects to polygons. 

1. Select all the objects that you want to convert to a raster polygon.  

 a. You must have at least one object selected before proceeding. 

2. Select Tools > Convert To > Polygon. 

3. ACE 3000 will now calculate all boundaries and construct clean raster polygons. 

 a. This is an excellent tool for optimizing large amounts of drawn data (like a plane layer).  

 b. ACE 3000 is intelligent enough to recognize objects with a composite attribute and construct 

  them with dark or clear fields (like a donut). 
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Rectangle 

Converts selected objects to rectangles. 

1. Select all the objects that you want to convert to a rectangle.  

 a. You must have at least one object selected before proceeding. 

2. Select Tools > Convert To > Rectangle. 

3. ACE 3000 will now calculate all boundaries and construct rectangles. 

 a. This is an excellent tool for optimizing large amounts of drawn data (like a plane layer). 

 b. ACE 3000 is intelligent enough to recognize objects with a composite attribute and construct 

  them with dark or clear fields (like a donut). 

Circle 

Converts selected objects to circles. 

1. Select all the objects that you want to convert to circles.  

 a. You must have at least one object selected before proceeding. 

2. Select Tools > Convert To > Circle. 

3. ACE 3000 will now calculate all boundaries and construct circle. 

 a. This is an excellent tool for optimizing large amounts of drawn data (like a plane layer). 

 b. ACE 3000 is intelligent enough to recognize objects with a composite attribute and construct 

  them with dark or clear fields (like a donut). 

Cell … 

Converts selected objects to cells.  

1. Select all the objects that you want to convert 

 to circles.  

2. Select Tools > Convert To > Cell… 

3. Assign a cell name, anchor point (Lower Left, 

 Origin, & Center) and check to replace data. 

4. Select OK. 
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Tools > Bonus Utilities 

A collection of utilities and tools to assist you in the 

ACE 3000 Viewer and Editor.  

 

 

 

 

 

Remove Tiny Segments 

Remove small and self-intersecting segments within 
a polygon that can cause problems downstream. 
This function requires that you select objects before 
proceeding. 

1. Select Tools > Bonus Utilities > Remove Tiny 

 Edges 

2. Choose a Minimum Segment Length (mil).  

3. Select OK. 

4. ACE 3000 will remove all tiny edges. 

 

Chop Polygons 

Split large polygons with many vertices, into many 
smaller polygons.  This features is very helpful when 
exporting data CAD/CAM systems that cannot 
handle polygons with many vertices. This function 
requires that you have already run Join beforehand, 
and join error markers were detected. 

1. Select Tools > Bonus Utilities > Chop 

 Polygons 

2. Verify the Maximum polygon vertices value 

 and press OK 
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3. Select OK. 

4. ACE 3000 will chop all selected polygons. 

Fix Invalid Polygons 

Find and correct self-intersecting polygons.  These invalid polygons 
usually go undetected, causing unexpected errors & violations that 
result in mask failure.  

 

 

 

Clip Wizard 

This command allows you to cut out a section of the design. This is very useful when exporting to 3D 
formats (for simulation), and you only require testing on a small portion of the design. To use this 
command, select a boundary around the area you wish to clip and then Right-click. A dialog box will appear 
with options. Verify those options and press Next. ACE will now remove your entire design except for the 
area that is contained within to boundary you have selected. 

 
1.     Select Tools > Bonus  

      Utilities > Clip Area Wizard. 

2.      Left Click within the editor  

      to select the first clip point.  

      Continue using left click to  

      select additional points.       

      When finished, right click to 

      exit. 

3.      The Clip Wizard Output  

      menu will appear. 

4.      Assign a Cell Name and  

      choose to Display Clipped  

      area at Finish. 

 

5.  Select Next. 

6. ACE 3000 will begin to perform clip calculations.  

7. Select Finish. In the editor, the clipped portion of your design will appear by itself.  
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Area Calculator 

Performs area calculations for your design. 

1. Select Tools > Bonus Utilities 

 > Area Calculator. 

2. The Area Calculator wizard 

 menu will appear. 

3. Choose a calculation method 

 and set units using the 

 dropdown menus. 

4. Select Next. 

 

 

 

 

In seconds, ACE 3000 will 

automatically perform all 

calculations using the method and 

unit selected.  

5. Select Finish to exit the menu.  
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Tools > Composite Layers  

Creates, converts, builds, and 

separates composites from layers. 

 

 

 

 

 

 

 

De-Embed Layer 

Automatically locate holes & islands from overlapping objects. 

1. Select Tools > Composite 

 Layers > De-Embed Layer. The 

 De-Embed Layer wizard dialog 

 box will appear. 

2. Verify or edit layer options.  

3. Select Next.  

4. ACE 3000 will automatically 

 perform polygon De-

 Embedding. 
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Flatten Composite Layer 

Converts an existing Composite into a single level layer. 

1. Select the objects you want to clean. 

  a. This function requires  you select a composite layer (a layer that has    

   objects with a composite level greater than 0). 

 

2. Select Tools > Composite Layers > Flatten Composite Layer. 

3. Edit or verify layer options.  

4. Select Next. 

5. ACE 3000 will convert an existing composite into a single level layer. 

 

Build Composite Layer 

Creates a composite from existing layers. 

1.  Select Tools > Composite   

  Layers > Build Composite   

  Layer (from existing layers). The 

  Composite Merge dialog box will  

  appear. 

2.  Verify and edit options.  

3.  Select Clear All to clear  

  selections or OK to finish. 
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Separate Composite Layer 

Converts an existing composite into multiple layers. One layer per composite level.  

 

Open Composite Layer 

Opens an existing composite layer for editing.  

Close 

Closes a previously opened composite layer for editing. 

Tools > Boolean Wizard  

Performs Boolean Operations within 

your design. 

 

 

 

 

 

1. Select Tools > Boolean Wizard > Boolean Operations (AND, OR, XOR, Subtract) …  

2. The 2D Boolean Operations Wizard will appear.  

3. Choose Boolean Type and select the layers for which Boolean will be performed. 

4. Select Next.  
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5.    In the Options menu, verify  

    and edit options.  

6.     Select Next.  

 

 

 

 

 

 

 

 

7. ACE 3000 will begin to perform Boolean Calculations and output the results to a layer.  

8. Select Finish when complete. 

Assign to Group A 

Assigns Boolean operations to Group A. 

Assign to Group B 

Assigns Boolean operations to Group B.  

 

8.8 Setup Menu 

The Setup menu provides a number of customization tools 

for apertures, NC tools, layers, and more.  
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Setup > Layers Table  

Displays all layer properties for the 

active design. Verify, sort, and edit 

the layer options you want to use. 

1. To activate Layer Table 

 select Setup > Layers Table. 

2. Verify, edit, and sort layer 

 options. 

3. Select Apply to activate edits 

 or OK when finished. 

 

 

 

 

 

Layers Table Overview 

#: ACE 3000 Layer Number.  

Visibility (Light bulb): Determines if objects on the layer are visible. 

 a. If the layer is visible, the bulb icon is on. 

 b. If the layer is not visible, the bulb icon is off.  

Layer Name: Name of the layer. Double click the entry box to edit the name. 

Draw Color: Traces and polygons on the associate layer will display that color. Click the color icon to change 

color. 

Active: Active layer. Used when adding objects (i.e. polygons, flashes, etc.). Use the checkbox to activate. 

All On: Turns all layers on. All light bulb icons will be lit.  

All Off: Turns all layers off. All light bulb icons will be unlit.  

Add Layer: Adds a new layer. A dialog box will appear. Choose a layer name and layer type, then select OK. 

Apply: Applies changes to layer. 

OK: Saves changes and closes Layer Table dialog box. 
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Layer Number: Assigns layer number.  

Layer Name: Assigns layer name. 

OK: Saves changes and closes Layer Table dialog 

box. 

 

 

 

 

Setup > Aperture Table  

Displays and edits all apertures used in the workspace.  

1. Select Setup > Aperture. The 

 Aperture Table dialog box will 

 appear. 

2. Select an aperture to edit 

 from the list. 

3. Edit or verify the aperture 

 details in the preview box on 

 the right. Use the Tab key to 

 cycle through each menu. 

4. Select OK when complete. 

 

 

 

Additional functions included in the aperture table are: 

Add Aperture: Add an aperture to the list. Enter a Dcode in the entry box. When finished select OK. 
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Delete Aperture: Deletes an unused aperture from the list. This operation cannot be undone. 

Transcode Aperture(s): Used to transcode apertures by entering starting Dcode, swell, and selecting 

specific layers. 

 

Swell Aperture: Use this entry box to swell 

apertures in mils or mm.  
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Aperture Information: Provides information on specific apertures. Highlight an 

aperture first, then select Information. Includes information such as Dcode 

selected, total count, flashes, draws and layer count.  

 

 

 

 

 

 

Delete Unused: Deletes unused apertures. This operation cannot be undone. 

Round to: Used to Round an aperture in mils or mm. 

 

Scale Aperture: Used to scale an aperture based on scale factor. 
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Notes:  

a. Use Aperture Units to select units in mil and mm.  

b. Select the Aperture Selection button to select all apertures in the list. The entire list will highlight in 

 blue.  

c. Under Aperture preview, use the Tab key to update the display after entering or selecting a value. 

 Alternatively, use the Enter or Reset keys to edit the values. 

Setup > NC Tools Table  

Displays and edits all NC Tools used in the workspace. 

1.  Select Setup > NC  

  Tools Table. 

2.  Choose Tool Units (mil  

  or mm) and Tool  

  Display (All or Used  

  Only). 

3.  Under the Basic  

  and/or Advanced tabs, 

  verify or edit settings  

  for each NC Tool. 

 

 

 

 

 

Notes:  

 a. To edit a row double click the entry box for Size, Final Size, Comments and Sort under  

  the Basic tab. Use the checkboxes for the Plated column.  

 b. To edit a row double click the entry box for Size, Comp, Plunge (IPM), Retract (IPM), Speed, 

 Depth (in), and Max Hits under the Advanced tab. 
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Setup > Set Grid  

Assign grid settings. 

1. Select Setup > Set Grid. The Set Grid dialog 
 box will appear. 

2. Verify or edit grid settings.  

 a. Display: Select from either Grid Off,  
  Quadrelle, or Point using the drop  
  down menu. 

 b. Units: Select from either mils or mm. 

 c. Enter Size for X and Y.  

d. Enter Major Count for X and Y.  

3. When finished, select OK. 

Setup > Aperture Rules Editor  

Create custom “rules” to load any aperture list file. 

1.  Select Setup >  Aperture Rules 

  Editor. 

2.  Verify and edit rules using  

  the Settings and Line Format  

  tab (below). 
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Aperture Rules Editor Settings Tab 

Aperture Rule: This drop down contains all available aperture rules.  Each aperture rule is stored as a file 
(*.rul) in the ACE 3000 sub-folder "aptrules". 

File Extension: Aperture files generated from a CAD system usually have a defined file extension.   This 
helps ACE 3000 determine which Aperture rule to use during Gerber import. 

 Move To: Aperture files generally have non-essential text at the beginning (such as part number, time 
created, etc.).  This lets ACE 3000 ignore all text lines until the defined "Move To" text is found. If left 
empty, ACE 3000 will start reading apertures at the first line. 

 Skip Additional Lines: This allows ACE 3000 to additionally skip lines after Move To. 

 Stop At: Tells ACE 3000 to stop reading aperture lines once this text has been detected. 

 Units: Units for aperture sizes.  Choose from:  Inch, Mil, or Millimeter. 

 Scale: Scale value used for aperture sizes.  1 is default. 

Tolerated Warnings: Determines how many warnings (per Aperture Rule File) ACE 3000 will allow before 
choosing to use another aperture rules files. 

Aperture Rules Line Format Tab 

ACE 3000 includes over 24 default 
Aperture Rules.  Reviewing these default 
Aperture Rules is a great way to 
determine how parameters are used to 
create a successful Aperture Rules File.  
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Line Parameters:  

[S] = Skip    [M] = Misc 

[D] = Dcode  

[X] = X-Size 

[Y] = Y-Size 

[R] = Rotation 

[T] = Thermal Tie Width 

[I] = ID 

[O] = OD 

[A] = Aperture 

 

Setup > Display Ace Console  

Opens ACE 3000 Command Console. Can also be activated by pressing F2.  

 

Line Example #1: 

RECTANGLE     100.5      20      Flash     D100 

"RECTANGLE" [X] [Y] [S] D[D] 

 

 Line Example #2:  

D35     Thermal    80     Yes     55  

D[D] "Thermal" [O] [S] [I] 
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Setup > Preferences  

General settings and preferences. There are three tabs: General, Viewer, and Misc. 

General Options 

Used for general options including folder options, executables, display fonts, export folders, log file output, 

and more. This includes: 

 

Home Folder: The location of the ACE executable file.  Many necessary files are located relative to the 
location of the ACE executable.  

Web-Browser Executable: Use this browser to display any HTML or XML files.  

ACE 3000 Executable: The location of ACE 3000 (Optional).  Allows you to view Gerbers directly from ACE 
by selecting the View Gerbers with ACE 3000 button (located on the Finish Page) 

Visual Chip Executable:  The location of Visual Chip (Optional).  Allows you to view GDSII & ACE directly 
from ACE by selecting the "View files with Visual Chip" button (located on the Finish Page) 

Export Folder: Optional.  If you would like to have a defaulted folder where all exported files are copied to, 
you may define it here. 
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Viewer Options 

These are editor settings and preferences for the ACE 3000 Viewer.    

 

Used for general view settings such as object snap, colors, cursors, zoom, and more. This includes: 

Object Snap:  

 None - Turns off all snap modes. With snap modes off, you define points by simply clicking.  

 Grid - Snaps cursor to the nearest grid point.  

 Object – Snaps cursor to the nearest object.  

M-Button Click for Zoom All: If you would like to simply click the middle mouse button to zoom all, then 
check this option. 

View Origin: View origin symbol.    

PixBox Size (Pixels): The invisible selection box used to determine if your cursor is directly over a figure. 
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Misc. Options 

Miscellaneous options such as default fonts, dynamic editing, and Gerber file import. This includes: 

 

Arc Resolution: Controls the default resolution factor for vectorized arcs. 

Max Polygon Points: Controls the default number of points allowed per polygon. 

Default Font: Controls the default font to be used. 
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8.9 Setup > Help  

ACE 3000 offers a number of resources for help, 

troubleshooting, and additional configuration. 

 

 

 

 

 

 

 

 

 

 

Help > Help Guide – Online  

Links to ACE 3000 online help manual. 

 

Help > Online Tutorials and Demos  

 Links to the ACE 3000 YouTube Channel with dozens of 

video tips and resources.  
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Help >Online User Support Forum  

Links directly to the Numerical Innovations 

support forum at 

www.numericalinnovations.com.  Use this 

forum for questions, tips, and support help. 

The ACE 3000 community users are 

available to answer beginner and veteran 

questions. 

Need Help? Type a Question in ACE 3000! 

Use this question box in the top right 

corner of the ACE 3000 as a shortcut to the  

            Numerical Innovations support forum. 

 

http://www.numericalinnovations.com/
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Help > Visit ACE 3000 on Facebook  

Stay tuned for important updates, tips, and 

links on the ACE 3000 Facebook page.  

 

 

 

 

 

 

 

 

 

 

 

Help > Visit Numerical 

Innovations  

Directly links to the ACE 3000 home 

page. From here, you can access: 

- Downloads 

- Feature Comparison 

- PDF Help Guide 

- ACE 3000 User Forum 

- ACE 3000 YouTube Page 

- ACE 3000 Facebook Page 
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Help > Become a Numerical Reseller or Partner  

Want to be a Reseller or Partner with Numerical Innovations? Select this menu option for more information 

on Numerical Innovations partnerships and alliances. 

 

 

Help > Compile TrueType Fonts  

TrueType Font selector for ACE 3000.  

  

 

 

 

 

 

 

 

 

 

 

Help > Compile AutoCAD SHX Fonts  

Import and add AutoCAD SHX Fonts to the workspace. 

Help > Enter License Key  

Enter ACE 3000 license keys. For more information on licensing and registration, see section 1.3: 

Understanding Licensing & Registration. 

Help > Check for Updates  

This feature will send you to the Numerical Innovations web page for ACE 3000 revision history. 
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Help > About 

General information on ACE 3000, Numerical Innovations, Copyrights, Trademarks, and License Status. 
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SECTION 9: PURCHASE AND SUPPORT 

9.1 How to order ACE 3000 

For product pricing, please contact our sales team below: 

Phone: 1-866-528-9274  

Hours of Operation: Monday – Friday 9:00 AM to 5:00 PM PST 

Email: sales@numericalinnovations.com 

Payment Options 

Credit Cards: We accept Paypal, VISA, MasterCard, Discover, and American Express cards. This is our 
preferred method of payment.  Additional payment methods accepted include: AMEX, Cirrus, Western 
Union, Visa (Electron), Switch, Solo, Maestro, Direct Debit, Delta, & Google Checkout. 

Purchase Orders: Company Purchase Orders are accepted. We verify company information through D&B, 
and may request trade references before processing. Terms are: Net 30 days, and the minimum order must 
exceed $750 USD. You may submit your purchase orders to our sales team by e-mail: 
sales@numericalinnovations.com or fax: (++1) 858-430-2705. 

Bank Wire Transfer: Contact us, and we will e-mail an invoice with our bank details. 

9.2 License Options  

Single User License:  A permanent license key (or activation code) that is assigned to an individual user. 

Floating (Network):  Centralized server based licensing using FLEXnet License manager (formerly FLEXlm). 
The software can be run on as many computers as needed which are connected to a centralized server 
location. The number of licenses purchased determines the number of concurrent users. 

Enterprise License (Site):  Receive a master license key that grants your company the right to install 
UNLIMITED seats of onto your workstations, networks, or on laptops without any restrictions - provided 
that our software is only used inside your company (at one Site). 

Upgrade (Existing Customers only): We offer special pricing for users who have already purchased an older 
version of our software products and now wish to upgrade to the latest version. 

9.3 What is the Numerical  Maintenance Plan?  

We offer two support/maintenance solutions:  STANDARD and LIFETIME. Standard Maintenance is 
provided free and LIFETIME Maintenance is optional. The LIFETIME Maintenance Plan is sold at a 

mailto:sales@numericalinnovations.com
mailto:sales@numericalinnovations.com
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discounted rate during your initial order placement. Please contact our sales team for more assistance 
sales@numericalinnovations.com 

 

 

 

 

 

 

 

LIFETIME MAINTENANCE PLAN:  

At the time of your order placement, you may optionally purchase our Lifetime Maintenance Plan (LMP) 
for the following benefits: 

 Secure Login Access to our website. 

 Receive every Upgrade, Update, & Bug-Fixes for life! 

 Unlimited & Priority Technical support from our staff. 

 Unlimited License Assistance in the event of a lost license, computer transfer, crash, etc. 

 Download Access 24/7. 

 Access to Pre-Released & Special Versions of all our software products.  

 Ability to Transfer your LIFETIME Maintenance to another user. 

STANDARD MAINTENANCE PLAN: 

 12-month Email Support for from the date of your purchase. 

 Access to the User Support Forum, and have the ability to post any questions directly on the User 
Support Forum. 

 A pay-as-you-need On-Demand Support is also available for additional assistance. 

mailto:sales@numericalinnovations.com
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9.4 ACE 3000 Customer Support  

 

Forum: ACE 3000 Questions & Answers 

Online Support and FAQ for CAD conversions. 

Submit a support ticket 

Can’t find an answer you’re looking for? Fill out a support ticket to receive personal assistance from our 
team. 

http://www.numericalinnovations.com/pages/customer-support 

Please include a detailed explanation of the problem. Include a sample file if possible. 

Response time is within one business day or sooner. 

License Key / Activation Code Problems 

Having issues with your license? Contact sales@numericalinnovations.com 

 

General Questions 

We welcome your questions, comments, and suggestions as one critical way to continuously improve our 

services to you. For general information, use our contact form at: 

 

http://www.numericalinnovations.com/pages/contact-us 
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9.5 Numerical Innovations 30 Day Guarantee  

Numerical Innovations (a Division of Caneberra Technologies, Inc.), offers you a risk free for 30 day money 

back guarantee on all of our software products. We are sure you will be pleased with its features, ease of 

use and reliability. If you are not completely satisfied, let us know within 30 days and if we cannot correct 

the problem, we will refund your money. Guaranteed. 

9.6 Additional Contact Information  

 

 

 

A division of Caneberra Technologies Inc. 

1888 Kalakaua Ave, Suite #C312 

Honolulu, Hawaii 96815 

Phone: 1-866-528-9274 

Fax: 1-858-430-2705 

http://www.numericalinnovations.com 

Sales Department: sales@numericalinnovations.com 

Tech. Support: support@numericalinnovations.com 

Career Opportunities: careers@numericalinnovations.com 

Partnerships / Alliances: partners@numericalnnovations.com 
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9.7 Company History 

Numerical Innovations (a division of Caneberra Technologies, Inc.) was 
founded by Simon Garrison and Steve Geiger, two veterans of the PCB 
industry with nearly 20 years of software development experience. 

Back in 1993, Simon started in the PCB industry doing CAD conversions for 
a small PCB photoplotting company in Santa Clara, California. Steve met 
Simon from a mutual friend while they were both attending San Jose State 
University – Simon in the School of Engineering, and Steve in the Business 
(Marketing) School. They immediately hit it off and became friends and 
business partners. Simon had been running his company Innovative CAD 
(Computations and Design) doing his conversion work, and Steve was 
helping with the marketing. When he explained to Steve that he was 
disappointed in how cumbersome the translation software in the market 
was, they decided to join forces to create Innovative CAD Software, Inc. 

(ICD) and they rest is history! 

Innovative CAD grew from a two man operation to one of the most recognized companies in the PCB CAM 
market with its tools AutoGERB (world's first exporting of Gerber data directly from AutoCAD) and 
CAMtastic! (CAM viewer which morphed into the first PCB DFM tool of its kind). They were the first in the 
industry to do some “cutting-edge” marketing by offering their products to be downloaded directly from 
the Web with a full 45 day trial, as well as offering complete online support. This and other sound business 
strategies positioned them for explosive growth and success. The ease of use, comprehensiveness and 
accuracy of their software tools started attracting big industry attention. ICD did a promotion with Altium, 
in which a seat of CAMtastic! was included with the purchase of their Protel software; up to that date it was 
the most successful promotion 'ever' for Altium, and subsequently ICD was acquired by Altium in 2000 for 
its remarkable technology. 

Simon (now one of the leading experts in PCB CAM software development, as well as CAD conversion 
software) went on to work with Altium for several years developing its CAM division, then started a new 
firm developing custom OEM solutions and tools for the IC/MEMs industry. Steve started a successful 
advertising and public relations firm, which he eventually sold as well. Missing that spark and passion for 
the PCB market they joined forces once again to start NI with a vision to change the landscape of the PCB 
marketplace. 

With tools like DFM Now! and ACE 3000 they are revolutionizing the way CAM and DFM are done for PCB – 
again with the philosophy of being easy to use, comprehensive and accurate, while providing exceptional 
value for their customers. 

Mission Statement:  We have become a leader in the EDA software industry by empowering electronic 
designers and engineers with clever, high quality software tools which facilitate their designs for 
manufacturing.  
 

 


