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FAB 3000 V7 
 

HELP GUIDE 

INTRODUCTION 
FAB 3000 serves the needs of a full featured CAM software that assists PCB designers in the analysis and 

preparation of their designs in Gerber, Drill, & ODB++ formats prior to manufacturing. FAB 3000 goes 

beyond traditional GUI-based CAM software; providing a set of advanced integrated tools for: 

 Merging PCB Designs to Reduce Manufacturing Costs by performing all necessary 

object transformations, Dcode, & drill tool transcoding. Using the Merge Wizard, several PCB 

designs can be placed on a single panel in order to improve efficiency and reduce manufacturing 

costs. 

 

 Intuitively Search for Manufacturing Violations in Gerber Data prior to sending a PCB 

design to manufacturing. FAB 3000’s custom built DRC/DFM analysis tools (DFM Checker) will check 

your design for all potential manufacturing problems.  

 

 Generating Netlists from Gerber and Drill Data by running a comparison against a CAD-

generated IPC-D-356 Netlist. By verifying your PCB design electrically, a Netlist comparison will 

ensure design integrity during each successive stage of PCB manufacturing. 

 

 Creating X/Y Centroid Files Automatically for rapid programming of automated surface 

mount equipment. As this feature is not offered in all CAD packages, FAB 3000 (Professional 

Version) automatically creates a Part Centroid file from your existing Gerber file.  

 

  High Resolution Image Exporting with FAB 3000’s Film Wizard allows for the creation 

of photoplots from Gerber or Postscript files. Output files in either TIFF or Bitmap format and utilize 

image options such as mirror, invert polarity, trim edges, and data compression. FAB 3000 is the 

only CAM tool available that directly outputs high-resolution RIPS.  

 

 Easily Importing DXF Files using a comprehensive set of control features. Import DXF files by 

layer, join open/arc boundaries, perform de-embedding, handles solid HATCHes, and more. 

Additionally, output files to GDS-II format for high-resolution IC artwork, MEMs, and hybrid circuits.  
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 Converting Stereolithography (STL) Files by using FAB 3000 import/export features. Convert 

your 2D design file into STL format for editing in 3D design tools such as Solidworks, ProEngineer, 

Rhino3D and more. 

 

 Creating Custom Scripts for FAB 3000 utilizing the power of an embedded LUA scripting 

engine. Many CAM tools are limited or outdated in customized application scripting. FAB 3000 

supports Open GL (3D-Modeling), IUP (Dialogs), wxWidgets (GUI), SQL, and web server applications. 

FAB 3000 V7: WHAT’S NEW 
 

New Features 

 

 Modernized graphical interface with improved usability. 

 Embedded LUA scripting engine for custom application design. 

 Generate Error Drawing - generates marker objects which may be imported into various CAD 

systems for concurrent verification. 

 Generate CSV Error Report – Generates a detailed error report in CSV format which may be 

imported in various spreadsheet applications.  

 Auto-Fix invalid polygons during Gerber import. 

 Freedom to accept any measurement units while executing commands.  

 

Improvements 

 

 Improved and easier to use DFM Check. 

 Improved rules management for DFM Check. 

 Improved Gerber file format importation. 

 Improved ODB++ file format importation. 

 Improved DXF file importation.  

 Improved Compare Layers and Compare Jobs functions. 

 Improved Ariel View Control. 

 Improved Netlist Comparison.  

 Over 50 additional improvements in functionality and usability 

 

Bug Fixes 

 

 Fixed Alt key commands to operate menu. 

 Additional 75 minor bugs fixed.  

To learn more about FAB 3000’s latest features, improvements, and fixes please visit the revision history 

page at: http://www.numericalinnovations.com/pages/fab-3000-revision-history 

http://www.numericalinnovations.com/pages/fab-3000-revision-history
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FAB 3000 HELP GUIDE INTRODUCTION 

The FAB 3000 Help menu is divided into 9 sections. Within each section, they are broken down by topic. For 

example, Section 4 would be the section number of the help document. Section 4.1 would be section 4, 

topic 1. There are also subtopics; for example, section 4.1.1 (section 4, topic 1, subtopic 1).  

 

FAB 3000 SECTION SUMMARY 

Section 1: Getting Started Offers a synopsis on system requirements, installation, and licensing.  

Section 2: Working with FAB 3000 Provides an overview of the FAB 3000 GUI, Workspace, & Workbench.   

Section 3: FAB 3000 Basics Discusses an overview of control and view manipulation within FAB 3000. 

Section 4: FAB 3000 Advanced Features A highlight of FAB 3000’s advanced features.  

Section 5: FAB3000 Job Editor Menu A complete guide to each drop down menu in the FAB 3000 Job 

Editor. 

Section 6: Import Matrix File Discusses importing Matrix Files with FAB 3000.   

Section 7: FAB 3000 Data Format A dictionary of data formats that FAB 3000 can work with. 

Section 8: LUA Scripting Engine A guide to FAB 3000’s LUA Scripting Engine for custom application 

development. 

Section 9: Purchase & Support Discusses purchasing, licensing, and support options for FAB 3000. 

 

FORUM & VIDEO HELP 

  Below each topic or subtopic, you’ll find forum and video links relevant to the 

 discussion.  For additional help on topics beyond this manual, look for this symbol. 

 We’ll include links to the FAB 3000 Video library on YouTube as well as direct 

 navigation to relevant FAB 3000 forum topics. 
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SECTION 1: GETTING STARTED 

1.1 Minimum System Requirements  

 OPERATING SYSTEMS 

Windows (32-bit and 64-bit) XP/2003/Vista/7/8 

 Linux (64-bit) Kernel 2.6 

 HARDWARE 

512+ MB RAM  

 120+ MB Free Hard Disk Space 

 Super VGA (1024x768) Display 

 High Color (16 bit) Graphics Card 

 4x CD-ROM Drive with 32-bit Drivers 

 Mouse w/ Center Wheel Button (Intelli-mouse) 

 Keyboard 

 Internet Connection Recommended 

1.2 FAB 3000 v7.0 Installation 

WINDOWS 

1. Download FAB 3000 for Windows at http://www.numericalinnovations.com/pages/download-page 

2. Select FAB 3000 v7 – FREE TRIAL 

a. For a full featured trial license, fill out the download request form and use a valid email 

address.   

b. Upon verification, an email will be sent to your address with download link and trial license 

key included.  

3. Click the download link included in the email address.  

4. Unzip FAB 3000v7.zip and run the installer FAB 3000v7.exe.  

5. Follow the install wizard procedures and choose a location for FAB 3000.  

LINUX 

1. Download FAB 3000 for Linux at http://www.numericalinnovations.com/pages/download-page 

2. Select FAB 3000 v7 – FREE TRIAL 

http://www.numericalinnovations.com/pages/download-page
http://www.numericalinnovations.com/pages/download-page
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a. For a full featured trial license, fill out the download request form and use a valid email 

address.   

b. Upon verification, an email will be sent to your address with download link and trial license 

key included.  

3. Click the download link included in the email address.  

4. Uncompress the file and select a folder where you have read/write permission. 

5. We recommend installing to /opt/FAB 3000. 

Registered Customers – Windows 

1. Start FAB 3000 and navigate to the Help > Enter License Key > Activate menu 

2. Enter your activation code(s) below and complete the registration process. 

Note: Create a unique password that you will remember. To transfer or reinstall your copy of FAB 3000, 

you will be asked for your password to recover your activation code. 

Registered Customers – Linux  

1. Start FAB 3000 

2. If a license key dialog box does not appear, go to the Help > Enter License Key menu. 

3. In the dialog box, select Get Permanent License Key.  

4. Upon filling out the form, a new key will be sent to you  

   Video: FAB 3000 in Linux 

 

1.3 Understanding Licensing & Registration  

FAB 3000 offers several license types: Single User, Multi User, Numerical Cloud, and FLEXnet licensing.  

SINGLE USER - ACTIVATION CODE (INTERNET ACTIVATED):  

Enter your activation code and it will be automatically verified over the internet. When you are ready to 

move to another computer, simply de-Activate from your old computer, and Activate on your new 

computer.  

MULTI USER - ACTIVATION CODE (INTERNET ACTIVATED):  

Enter your activation code one-time and registration is performed automatically over the internet. This is 

then repeated for multiple users.  You also have access to an online License Control Panel (LCP) allowing 

you to manage multiple licenses (activate/deactivate). 

NUMERICAL CLOUD - ACTIVATION CODE (INTERNET ACTIVATED):  

http://www.youtube.com/watch?v=FH2OU5xeTY8
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Enter your activation code and it will be automatically verified over the internet. When you are ready to 

move to another computer, simply de-Activate from your old computer, and Activate on your new 

computer.  

 

ACTIVATION PROCEDURE FOR SINGLE/MULTI/NUMERICAL CLOUD (INTERNET ACTIVATED)  

1. Start FAB 3000. 

2. Go to FAB 3000 menu Help > Enter 

 License Key > Activate  

3. Paste your activation code into the 

 edit box (use key CTRL + V). 

4. Create a password that is easy to 

 remember (at least 4 characters). 

5. Enter your email address. 

6. Select “Next” and follow the 

 activation prompts.  

 

 

 

HOW FLEXNET WORKS 

FAB 3000 uses FLEXnet Publisher for license 

management. You can use either a valid 

license key file or physically install the file 

(*.lic). If no license is detected, FAB 3000 will 

start in unregistered mode.  

 

 

 

 

 

 

 

Single User - FLEXnet License  
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A hardware locked license where the software is locked per machine (no internet activation required). A 

FLEXnet “Node-Locked” license is also referred to as a single user license.   

Copy/Paste a FAB 3000 License Key Via FLEXnet: 

1. Start FAB 3000  

2. In the Help menu, select Enter License Key > Enter FLEXnet Key 

3. Your Product Name and Host ID will already be filled in with relevant registration information.  

4. In the window titled License Key, paste your license key information. 

 

Your license key information will contain the following format: 

FEATURE FAB 3000 7.0 numinno 30-dec-2013 uncounted HOSTID=ANY \ 

    ISSUED=30-nov-2013 \ 

    NOTICE=user@demo_license_issue_address.com;FAB 3000v7 TS_OK \ 

    SIGN="1B42 076D 87E3 EAF7 F258 F0DA 3175 654D 4E63 7439 B7C4 \ 

    345A 4348 BD6F 62C6 00BA 17F6 A75E D086 6B1E DE6B 7225 E09C \ 

    86D6 13E2 A7C7 5852 C4AB D8D0 3FBB" 

 

FEATURE: This contains information of your product, version number, and licensed duration. For 

a single user license, HOSTID=ANY.  

ISSUED: This is the date of license issue. 

NOTICE: The address listed is the email address from which the license was sent to you. 

SIGN: This includes the string of key characters which make up the license key. Quotation marks 

should be included. Backslashes are also included.  

       Notes: 

c. Copying and pasting may produce random characters that replace certain text in the license. 

Make sure to replace these characters with the original text included in the license.  

d. Copying and pasting may produce inaccurate spacing of your license characters. Make sure 

to duplicate the spacing above for proper activation. 

e. Your operating system’s clock must be set to the exact date. If the date is not correct, the 

license key file will not activate.  

 

5. Once the license information is properly pasted and formatted, select Activate. 

6. If your key is valid, you’ll receive the following message: 
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In the case your license key is not valid, you will receive an error message. 

Check to make sure your key is properly formatted and there are no phantom characters or 

spaces. For additional help, contact sales@numericalinnovations.com.  

ALTERNATIVE OPTION: INSTALLING A LICENSE KEY FILE  

You can also install your FLEXnet license key file (*.lic) by copying the .lic file to the following directory: 

Windows 

C:\Numerical Innovations\FAB 3000V7 

Linux 

/opt/Numerical/FAB 3000 

FAB 3000 will automatically check this directory for a license key upon startup.  

FLEXNET PUBLISHER LICENSING FOR ENTERPRISE ENVIRONMENTS 

FLEXnet Publisher offers easier management for concurrent licensing environments. With FLEXnet, multiple 

licenses can be deployed from a central server (FLEXnet Server) located onsite. The maximum number of 

seats (concurrent users) and access location of the server computer will be indicated by the invoice issued 

from Numerical Innovations. Numerical Innovations will provide a Network Bundle Package which contains 

all necessary files, utilities, and instructions. There are two types of licenses under this program: 

Network/Floating - FLEXnet (Concurrent):         

This option is ideal for companies that want to manage the number of engineers using FAB 3000 but do not 

want to manage the individual users of the product.  

Enterprise/Site - FLEXnet (Unlimited):         

The ultimate freedom in software licensing because it grants your company the right to install UNLIMITED 

seats of our software onto your workstations, networks, laptops, or home computers.  

INSTALLING NETWORK & ENTERPRISE LICENSES VIA FLEXNET 

Supported Platforms 

Microsoft Windows XP/2003/Vista/7 (32-bit) 

Microsoft Windows XP/2003/Vista/7 (64-bit) 

Linux 2.4 Kernel or Higher (32-bit) 

Linux 2.4 Kernel or Higher (64-bit) 

Getting FLEXnet Server 

mailto:sales@numericalinnovations.com
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Upon purchase, the Network Bundle Package will be sent to the appropriate administrator. This package 

contains the following files: 

c. network.txt (document) 

d. lmgrd (Server Daemon) 

e. nummino (Vendor Daemon) 

f. lmtools, lmutils (FLEXnet supplied utilities) 

g. FLEXnet_licensing_end_user_guide.pdf (FLEXnet Publisher instructions) 

h. vcredist_x86.exe (for Windows 32-bit only) 

1. Extract the files above to a temporary folder. 

2. Copy all files to a designated folder of your choice on the FLEXnet server. This folder will also be 

known as the FLEXnet server.  

 Note: For Windows platforms, the default copy location is C:/FLEXnet.  

          For Unix/Linux platforms, you will create your own folder and select a location. 

If you have an existing FLEXnet installation, you can choose whether or not to overwrite the 

old files.  

GENERATE YOUR LICENSE FILE (*.LIC)  

3. To generate your license file, the following is required: Platform, Hostid, & Hostname. 

4. Choose your FLEXnet server platform: Windows-32, Windows-64, Linux-32, or Linux-64. 

5. Determine your Hostid by using the following procedure: 

 a. Open a command line window and navigate to your designated FLEXnet folder. 

 b. Type the following command: lmutil lmhostid 

 c. This will return one or more options for hostid. Choose the first one that appears in the list. 

6. Enter the hostname. To find the hostname of the FLEXnet server, run hostname from a command 

line on the FLEXnet server. Save this information as it will be required for step 14. 

7. Complete the Numerical Innovations “Request License Form” at 

http://www.numericalinnovations.com/license_request.html 

8. After completing the form, the license key will be emailed to you in one business day. 

 

SAVING AND CONFIGURING YOUR LICENSE FILE (*.LIC) 

Upon receiving the license file (license.lic), perform the following: 

9. Save license.lic to the FLEXnet folder. 

http://www.numericalinnovations.com/license_request.html
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10. In the FLEXnet folder, open license.lic in a text editor. 

11. In text editor, edit the vendor path to match the path for the FLEXnet folder. For example: 

 In Windows 

 VENDOR numinno C:\FLEXnet\numinno.exe 

 C:\FLEXnet is the path to the FLEXnet folder 

 numinno.exe is the daemon that authorizes each license installation with Numerical Innovations 

 In UNIX/Linux 

 The path should be the exact same path that you chose in Step 2. 

12. Save and close license.lic within the text editor. 

STARTING THE FLEXNET SERVER AND INSTALLING A CLIENT 

13. To start FLEXnet server, open a command line on the FLEXnet server while in the FLEXnet folder.  

 Type the following: lmgrd –c license.lic 

14. The environment variables must be set as follows: 

 In Windows 

 a. Select Control Panel > System > Advanced Tab > Environment Variables. A dialog box  

  will appear. 

 b. Under System Variables, select New. A new dialog box will appear. 

 c. In the top entry field, enter LM_LICENSE_FILE. 

 d. At the bottom field, enter port@hostname. 

 e. For default port, enter 27000. 

 f. Enter the FLEXnet server hostname (see step 6). This may or may not be necessary.  

 g. Click OK and close all dialog boxes. 

 In UNIX/Linux 

 a. Type LM_LICENSE_FILE=port@hostname in the command line.  

 b. The default port is 27000. 

 c. Enter the FLEXnet server hostname (see step 6).  

INSTALLING TO A CLIENT  
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14. On each licensed local client machine, install FAB 3000 by following the instructions included with 

 the CD (or download file). 

15.  Copy the license file (*.lic) in the FAB 3000 installation folder. Typically this would be labeled as: 

 C:\Program Files\Numerical Innovations\ … (whatever directory you installed the software into). 

Congratulations! You may now start the FAB 3000 product on each licensed client machine. 

Note: For Windows installations, the error message “Missing MSVCR80.dll” (or similar) may or may not 

occur when starting the vendor daemon numinno.exe. If it does occur, please install the Microsoft 

Redistribution Utility known as: vcredist_x86.exe. This utility will repair any missing .dll files that you 

require.  

     Forum: How do I move my license to another computer? 

  Forum: How do I install my license file? 

  Forum: How do I install a Network/Floating License? 

 

1.4 Launching FAB 3000 

WINDOWS 

1. In the Start menu, select All Programs. 

2. Search for Numerical Innovations. 

3. Select FAB 3000 v7. 

The FAB 3000 startup screen will appear. 

LINUX 

1. Run the shell file: FAB 3000v7.sh 

2. The script will automatically assign FAB 3000 library paths using LD_LIBRARY_PATH. 

The FAB 3000 startup screen will appear. 

If FAB 3000 does not startup, it is most likely due to the LD Linker not able to locate the required FAB 3000 

shared libraries (*.so). In this case, manually assign the libraries by performing the following: 

 a. Execute the Shell/Terminal program. 

 b. Type the following commands: 

http://forums.numericalinnovations.com/post/How-do-I-move-my-license-to-another-computer-4903592
http://forums.numericalinnovations.com/post/how-do-i-install-my-license-file-lic-2490865?highlight=license
http://forums.numericalinnovations.com/post/how-do-i-install-a-networkfloating-license-2490871?highlight=license
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  LD_LIBRARY_PATH=/opt/FAB 3000/lib 

  export LD_LIBRARY_PATH 

  ./opt/FAB 3000/FAB 3000 

 The example above assumes FAB 3000 was placed in folder/opt/FAB 3000  

 If FAB 3000 still does not startup, then your Linux distribution may be missing certain required 

 packages/libraries. 

 To verify if you have the included packages/libraries installed perform the following: 

 a. Execute the Shell/Terminal program. 

 b. Type the following commands: 

  ldd /opt/FAB 3000/FAB 3000 

 The example above assumes FAB 3000 was placed in folder/opt/FAB 3000  

 c. Review the output of this command. If any library files are missing they will be referenced  

  here. 

 d. Install any missing packages/libraries required to install FAB 3000. 

 For additional installation help, contact support a 

 http://www.numericalinnovations.com/pages/customer-support 

 In your support inquiry, make sure to include the output from the command Idd. 

 

   Video: FAB 3000 Getting Started Part 1 

Video: FAB 3000 Getting Started Part 2 

 Video: FAB 3000 Getting Started Part 3 

  Video: FAB 3000 Getting Started Part 4 

  Video: FAB 3000 Getting Started Part 5 

  Video: FAB 3000 Getting Started Part 6 

 

 

 

 

http://www.numericalinnovations.com/pages/customer-support
http://www.youtube.com/watch?v=oFSKYoav1Pw
http://www.youtube.com/watch?v=-nahRNnU35k
http://www.youtube.com/watch?v=HLbY0p-ByE8
http://www.youtube.com/watch?v=LXqJwAk3oJw
http://www.youtube.com/watch?v=BH0QzdHj0EY
http://www.youtube.com/watch?v=B1hSLxvZllg
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SECTION 2: WORKING WITH FAB 3000 

2.1 FAB 3000 GUI Overview  

 

 

 

 

 

 

 

 

 

 

 

 

 

 

The FAB 3000 GUI provides robust centralized operation for the designer or manufacturer. The graphical 

user interface aims for maximum flexibility by allowing users to instinctively select, drag, and edit objects. 

Multiple designs can be separated into tabbed windows while enhanced hierarchy control lets you work 

with individual layers. It is specifically targeted for the designers of PCB's, MEMs, Microwave and RF 

circuits, chemically milled parts and optical components; and to photo mask manufacturers.  

 

 

 

 

Job Editor Menu 

Workspace 

Menu

 
 Job Editor Menu 

Layers Panel 

Aerial View 

Type a Question?  

Provides direct 

links to the FAB 

3000 support 

forum.  

Editor 

Subject Tabs: 

Command, 

Nets, Task List, 

Find Results, 

Error List 

Editor Tabs 
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2.2 Workspace & Workbench  

FAB 3000 is divided into two primary components for operation and control: Workbench and Workspace. 

WORKBENCH  

 

Think of workbench as the central cockpit for controlling FAB 3000 workspaces. With workbench, you can 

navigate resources and you can view and edit the content and properties of these resources using the 

workbench menu bars and tool bars. The workbench contains an Editor, Editor Tabs, and 2 Views: Layer 

View, and Aerial View. 

a. Editor 
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 Editor allows the user to open, browse, edit, and save various types of data using the Workbench 

 menu bar. Tools within the editor are first opened, data is modified, saved, and then closed. 

 Multiple instances of editors may exist within a Workbench. They are individually tabbed in the 

 editor area and can be activated by clicking the tab. These are known as Editor Tabs. When an 

 editor tab is active, the Workbench menu bar and toolbar will only operate for that particular 

 editor. 

 b. Editor Tabs 

  

 Multiple editor tabs will appear above the editor window. Only one editor can be active at any 

 one time.  Clicking an individual editor tab designates that editor as active. Any editing, browsing, 

 saving, etc. using the workspace menu bar or toolbar only affect the active editor tab. 

 

c. Layer View 

Layer view organizes your design into an interactive table that controls the 

following attributes: Visibility, Draw Color, Flash Color, and Name. Layer view 

allows you to organize and control individual objects within your design. 

Visibility: Determine if Objects on the layer are visible. If the layer is visible, the 
icon used is 'bulb on'. If the layer is not visible, the icon used is 'bulb off'. 

Name: Name of the layer. (Note: Includes the layer number for reference) 

Draw Color: Objects on the associated layer will display that color for all draws 
(non-flashes)  

Flash Color: Objects on the associated layer will display that color for all  
             Flashes.  
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 d. Aerial View 

The Aerial View is a visual perspective tool providing 
an overhead view of the active editor  window.  It 
provides an excellent reference in determining the 
general location of the current editor view port within 
a design.  

 Zoom Percentage:  Ratio of the editor’s current view 
port size compared to the entire   
 design. Use zoom control to increase or decrease 
your view. 

 Interactive Panning:  Drag the current view port 
window box with your mouse to orient the   
 view location of the design.  

Alternatively, use the aerial widget located inside the aerial view window. Place the cursor just inside the 
aerial view window, and drag the mouse. 

Underneath Layer View, there are two display tabs: Display & Apps.  

 Display: Default Ariel view display of your design.  

 Apps: Displays a complete list of scripted applications available in FAB 3000. 

WORKSPACE 

A workspace consists of the Jobs, panels, custom apertures, folders, files that you create within the 
Workbench and are all stored under a single directory that represents your workspace. A workspace must 
have at least one or more libraries. Each library may contain one or more resources. 

Resources are a collective term for the designs, files, tables, etc. that exist in the Workspace.  The most 
common resources in FAB 3000 are:  Jobs, Inserts, Panels, and Custom Apertures. 

  Job: By default, a Job is the base resource of FAB 3000. All data imported and 90% of  
  editing are handled at the Job level. Essentially you can think of a Job as a single   
  design with its own unique layers, Dcodes, and other attributes. 

  Insert: An Insert represents the inclusion of one Job as a part of the contents of another.  
  The Job containing the Insert is the parent Job, and the Job that is included is the master Job 
  of the Insert.  Inserts can create hierarchical designs. The master of an Insert can contain  
  instances of other masters. This hierarchy can continue for as many levels as needed to  
  express a complete design.  
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  Inserts make it easy for the user to combine and visualize the placements of different Jobs  
  resulting in optimum configurations (like pieces of a puzzle) which will save you time &  
  money on manufacturing.  Inserts can be transformed (i.e. rotate, mirror, move, etc.) and  
  can be nested into a hierarchy of Jobs/panels. 

  Panel: The Panel resource is used to easily create and visualize a completed panel used for  
  PCB manufacturing.  Panels are essentially templates which generally use one master Insert  
  (which is step & repeated), and can include any number of Test Coupons, Pinning Holes,  
  Fiducial’s, etc. 

  Custom Aperture: The Custom Aperture resource is used to edit and visualize the elements  
  of any custom aperture. 

WORKSPACE BROWSER 

 

Workspace Browser is used to navigate resources (from the active workspace) in a hierarchy of libraries, 
designs, folders and files. From here, you can open resources for editing or select resources for operations 
such as exporting. 

Library 

Libraries are the outer containers in the Workspace hierarchy.  There are two types of libraries available: 
Layout and Document.  This has been put here as reference, and rarely will a user need to access or modify 
libraries directly. 

  Layout Library: Used for all graphical data.  Layout libraries only contain designs as child  
  items.  
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   Document Library: Contains all non-graphical files and folders (i.e. text files, etc.)  

2.3 Workspace Menus  

 

Located directly above the editor and layer display, the workspace menus provide a graphical illustration of 

functions that are also listed throughout the Job Editor menus (File, Edit, View, Add, etc.). Below is a 

summary of each graphical menu. In Section 4: FAB 3000 Job Editor Menu, we’ll discuss every menu 

function in detail.  

Workspace Menu 

The workspace menu provides immediate functions for Opening, Saving, and Closing 
workspaces. It also includes access to the Workspace Browser, Import and Export 
functions.  

Draw Menu 

With the draw menu, access important CAD drawing functions such as Pads, Traces, 
and Poly. The draw menu pull down offers access to additional shapes such as 
Circle/Arc, Rectangle, Ellipse, Wide Path, Text, Multi-Line Text.  

Modify Menu 

The modify menu provides for editing of existing objects. This includes Rotate, Flip, and 
Undo/Redo. Using the modify menu pull down, access additional edits such as Delete, 
Move, Copy, Scale, Stretch, and Split. You can also view an object’s properties by 
selecting the object and choosing Modify > Properties from the graphical pull down.  

Display Menu 

The display menu provides viewing functions within your design. The most prominent 
are Re-Draw, Zoom In/Out, Zoom Window, and Zoom All. Using the display menu pull 
down, access additional views such as Pan, Object view filters, and Layer Display. 

Selection Menu 

The selection menu provides selection functions for the objects and shapes within the 
editor. This includes Select All, Standard Selection, Add Selection, Subtract Selection, 
Selection Filter, and Clear Selection. The selection drop down menu adds additional  

      selection manipulations such as Select Display, Select Window, Select Crossing Polygon,  
      Select Window Polygon, and Select Fence.  
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Utilities Menu 

The utilities menu provides an array of various features to use within your design. This 
includes Query, Find, Measure, Add Rulers, Backside View, Translucent View, and Fill. 
Additionally, all reporting can be accessed from the utilities drop down menu (Aperture,  

        NC Tools, Dcode, Drill, Composite, & Nets Reports). 

Featured Tools Menu 

The featured tools menu includes all of FAB 3000’s most significant tools for 

use on your design. This includes DFM Checker, Netlist Tools, Compare Tools, 

& Copper Pour Tool. Using the featured tools dropdown menu reveals   

            additional FAB 3000 special features such as Convert To, Join Wizard, Film  

            Wizard, Create Fabrication Drawing, Calculate Copper Area, and Build   

            Component.  

LUA Apps Menu 

The LUA apps menu button lets you choose and run custom LUA scripting apps. Using the Apps 

pull down menu will allow you to create a new LUA app or open an existing LUA app.  

 

 

 

 Video: PCB Backside View and Flip using FAB 3000 

 

 

 

 

 

 

 

 

 

 

 

http://www.youtube.com/watch?v=d3mahZnolpY


FAB 3000 V7 

 

Page 20 

SECTION 3: FAB 3000 BASICS 

 

3.1 Introduction  

FAB 3000 extends beyond typical CAM software for PCB design and manufacturing. It offers a suite of tools 

to create, analyze, and prepare industry standard files for manufacturing. Integrated with FAB 3000 are a 

number of features aimed at increasing productivity, enhancing design control, and reducing production 

costs.  

3.2 View & Selection Control  

3.2.1  Mouse Control  

Right Click: Right click over the editor menu to provide a list of commands for navigating, selecting, and 

editing your design. For more information on Right Click functions, see Right Click Menu.  

Left Click: Left click to select a command or left click in editor to select an object. When left double clicking 

an object inside the editor, the properties of that object will be shown.  
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Dynamic Zoom: To zoom in and out on a particular region of the editor, use the middle mouse wheel. 

Scrolling forward will automatically zoom in. Scrolling backward will automatically zoom out.  

Dynamic Pan: Pan or move around the editor by clicking and holding the middle mouse wheel down. At the 

same time, drag across the region of the editor to travel in any direction.  

Zoom Window: There are several ways to enable Zoom Window: 

 1. Select View > Zoom > Window. 

 2. Right click in the editor display menu then select Zoom > Window.  

By left clicking and dragging anywhere around the region of the editor, a zoom window is enabled over the 

selected region. Alternatively, by simply left clicking in the editor FAB 3000 will automatically zoom by 2x.  

Select an Object: As the mouse hovers over an object in the editor it will add a highlight surrounding the 

object. Left click to select the object. The object will stay highlighted.   

Select Multiple Objects: As the mouse hover over an object in the editor it will add a highlight surround the 

object. Hold down the SHIFT or CTRL key and left click to select multiple objects at once.    

With your selection(s) active (highlighted), they are now part of the Active Selection Set. 

Leave or Reset Function or Selection Set: Use the ESC key at any time or right click inside the editor and 

select Cancel.  

Selection Mode Using the Workspace Menu 

Standard Selection Mode: This is the default setting for FAB 3000 upon startup. This 

selects an individual object. Each time you select an object, all previous objects will be 

unselected. 

Add Selection Mode: This button allows you to add and highlight multiple objects at once; 

similar to using the SHIFT or CTRL key to add a group of objects to the Active Selection Set.  

Sub Selection Mode: This button allows you to subtract highlighted objects from the Active Selection Set.  

Clear Selection Mode: This button will subtract all objects from an active selection set. Alternatively, you 

can use the ESC key or Right Click on the mouse and select Cancel.   

Selection Filter: The selection filter box helps control the content of an active object by allowing you to 

include or exclude Dcodes, Layers, Composite Levels, NC Tools, Polygons, or Text from being selected. 

Simply highlight an object then choose the Filter icon. This will open the Selection Filter dialog box for that 

layer.  

 

Forum: Crossing Window Selection 

 

http://forums.numericalinnovations.com/post/crossing-window-selection-is-unclear-how-to-use-5764704?pid=1272778171&highlight=crossing+window+selection#post1272778171
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USING SELECTION WINDOWS  

There are several selection window options for selecting multiple objects over a specified area of your 

design. They include: 

Select Window (Blue Box Highlight): The selection window allows 

you to click and drag over a specific area of a group of objects in 

order to highlight what is required. Any object contained inside 

this window will be selected only. Left Click anywhere within the 

editor and then drag across the editor to the Right. The selection 

box is highlighted in blue.  

Dynamic Selection Window (Blue Box Highlight): Using dynamic 

selection, Left Click on an empty area in the editor and drag 

across to the Right to cover any selection area you require. The  

          selection box is highlighted in blue.  

Select Crossing Window: Any objects contained inside or intersecting this window will be selected. 

To activate, go to View > Selection > Crossing Window. Left Click on an empty area in the editor to 

define the first point, then Left Click again to define the next point.  

 

Dynamic Selection Crossing Window (Green Box Highlight): Any object 

contained inside or intersecting this window will be selected. Left Click on 

any area in the editor and drag over the selection area you require to the 

Left. The crossing window will be highlighted in green.  

 

 

 

Quick Query Selection: Move the mouse over any object and Left Click. A status window will appear 

with information about the object. Alternatively, the same information will also appear at the status 

bar in the bottom of the screen.  

Note: When selecting polygons and traces, make sure to select their Edges.  
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3.2.2  Right Click Menu  

Right clicking the mouse while in editor is an alternate way to access menu 

options related to editor mode.  

Repeat: Repeats the last action taken.  

Cancel: Cancels the current action. For example, “canceling an object 

selection”. 

Zoom: Several zoom 

functions available such as 

Zoom All (zooms back to 

entire design), Zoom 

In/Zoom Out, Zoom 

Window, Zoom Previous, 

Zoom to Point, and Zoom 

to Selection. 

 

 

 

Pan: Pan function includes Left, Right, Up, Down, and 

To Point. 

 

 

 

Redraw: Redraws the object.  
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3.2.3  Right Click - Selection Options  

All: Selects and highlights all objects within the 

editor. 

Display: Selects all objects within the Editor. 

Window: The selection window allows you to click 

and drag over a specific area of a group of objects in 

order to highlight what is required. Objects contained 

inside this area will be selected only.  

Crossing Window: Specify selection by dragging 

mouse from corner to corner over area of objects. 

Objects contained inside or intersecting this window 

will be selected. 

Fence: Create a custom selection fence around the 

area of objects you wish to define as selected. 

Window Polygon: Create custom polygon around the area of objects you wish to define as selected. 

Crossing Polygon: Specify selection by dragging mouse from corner to corner over area of objects to 

produce a polygon window. Objects contained inside or intersecting this polygon will be selected. 

Standard Mode: This is the default setting for FAB 3000 upon startup. This selects an individual object. Each 

time you select an object, all previous objects will be unselected. 

Add Mode: Allows you to add and highlight multiple objects at once; similar to using the SHIFT or CTRL key 

to add a group of objects to the Active Selection Set.  

Sub Mode: Allows you to subtract highlighted objects from the Active Selection Set.  

Clear All: Will subtract all objects from an active selection set. Alternatively, you can use the ESC key or 

Right Click on the mouse and select Cancel.   

Filter: The selection filter helps control the content of an active object by allowing you to include or exclude 

Dcodes, Layers, Composite Levels, NC Tools, Polygons, or Text from being selected. Simply highlight an 

object then use Right Click > Selection > Filter. This will open the Selection Filter dialog box for that layer.  

Reset Filter: Resets the selection filter.  
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3.2.4  Right Click - Clipboard Options  

Cut to Clipboard: Cuts selected object(s) to 

clipboard. 

Copy to Clipboard: Copies selected object(s) to  

        clipboard. 

Delete: Deletes selected object. 

Move: Moves selected object.  

Copy: Copies selected object. 

Mirror Options 

Mirror: Includes Flip Horizontal, Flip Vertical, Flip 

Horizontal (Line), Flip Vertical (Line). 

 

 

Rotate Options 

Rotate: Rotates 90o, 180 o, 270 o or Via a specified base 

and angle using the command line editor. 

 

 

Array: Edit for rectangular or polar array. 

Query: After selecting query, select an object. A dialog 

box will display the object’s properties. 

List: Opens the command line log. 

Properties: Edit the properties of an object. This includes layer attributes and point list.  
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3.4 Layers Panel 

3.4.1  Turn Layers On / Off  

Next to each layer name is a light bulb icon that 

represents the current view state of the layer in a design. 

The light bulb indicates the status of each layer. Click the 

light bulb to activate/deactivate each layer.  

 If the light bulb is dark, the layer is inactive.  

 If the light bulb is yellow, the layer is active.   

3.4.2  Adjusting Layer Color  

Individual layer color can be adjusted for easier viewing.  

To adjust layer color, left click the adjacent color box. 

Choose or adjust to a different layer color from the color 

selection box. 

 

3.4.3  Isolating Layers  

You can isolate a particular layer for viewing while hiding              

the remaining layers.  

To isolate a layer, right click within the layers panel and select Isolate from the menu.  

3.4.4  Add Layer  

To add a layer, select the   symbol. The Add Layer 

dialog box will appear. Enter the new layer name 

and layer type. Select OK. 

 

 

 

 

 

3.4.5  View Individual Layers  

To view an individual layer within the editor, double click the layer within the layers panel. To cycle through 

the list of individual layers, use the  arrows.  
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3.4.6  Layer Display  

Use the layer display drop down menu to display layers by All, Used Only, or 

Flash Color. 

 

 

 

 

3.4.7  Layers Table  

To add, edit, and verify individual layers, select the Layers Table Icon.  
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3.4.8  Right Click Layer Control  

Right click within the layers panel to activate a number of functions for layer 

manipulation. The standard options include: 

Type: Opens parameters based on type of layer selected. 

All Layers On: Turns all layers on. 

All Layers Off: Turns all layers off. 

Negative Layer: Displays as a negative layer.  

Lock Layer: Locks an individual layer. 

Add: Adds a new layer. 

Rename: Renames a selected layer. 

Clear Layer: Clears a selected layer. 

Delete Layer: Deletes selected layer.  

Reload: Reloads a selected layer.  

Merge: Merges a new layer into the selected layer. 

Edit: Edits layer information.  

Sort Layers: Sorts layers. 

Select Layer: Selects a layer. 

Depending on the layer selected, Type options will change. For example, if right clicking over an SMT 

Stencil Layer, the menu options will change and accommodate for this type of layer. If right clicking over a 

Silkscreen Layer, the menu options will change as well. 

  

 Video: Manage Layers and Extract a Netlist 

 

 

 

 

 

 

http://www.youtube.com/watch?v=suZ_JRaegQE
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3.5 Opening & Saving Workspaces  

3.5.1  Opening a Workspace  

1. To open a workspace, go to File > Open Workspace.  

2. Choose the workspace file name you wish to open. 

3. Select Accept. 

3.5.2  Saving a Workspace  

1. To save a workspace, to File > Save Workspace. 

2. Choose a file name for your workspace. This file is in (*.wrk) format.  

3. Select Accept. 

3.6 Using Snaps  

Snaps control the cursor location within the editor. Snaps provide accurate placement of a cursor or can 

help measure an object accurately. Snaps can be activated by selecting the View > Snap menu. 

Alternatively, pressing F9 will automatically activate Auto Snap (snaps to center + end of object). 

Snap Off – Deactivates snap. 

Snap to Grid – Snaps cursor to FAB 3000 background grid.  

Snap to Center – Snaps cursor to the center of an object. 

Snap to End – Snaps to end of an object. 

Snap to Edge – Snaps cursor to the edge of an object. 

Snap to Object Center – Snaps to the center of an object. 

Snap to Insertion – Snaps to the Insertion point of an object.  

Auto – Auto snaps based on the center and end of an object. 

3.7 Using Measure  

FAB 3000’s measure feature allows you 

to measure objects from point to point, 

object to object, and net to net. To 

activate measure, select Info > Measure 

or select Measure from the toolbar under Utilities. Choose whether to measure point to point, object to 

object, or net to net.  

Note: Using the Snap feature (2.6) will help ensure accurate measurement readings.  
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3.7.1  Measuring Point to Point  

 

1. Select an anchor point within the object and Left Click.  

2. Move the mouse to the 2nd desired location. As you the mouse travels over the object, a window 

will display the distance & angle relative to the original anchor point.  

 Note: Using the Snap feature will ensure accurate measurement reading. Choose a snap variation 

depending on the type of measurement you’re doing. For example, to measure the distance of your 

anchor point to the center of an object, choose Snap to Object Center. To force orthogonal (900) 

snapping, select View > Ortho > 90 Degrees. 

3. When complete, Left Click in the editor again. This will reset your measure and allow you to define 

a new anchor point.  

 

3.7.2  Measuring Object to Object  

 

1. Select the base of an object and Left Click. You’ll notice a white boundary will outline around the 

object. Base objects can be nested within an Insert. 

2. Move the mouse over to the next object and Left Click. A window will appear displaying the 

distance & angle relative to the original anchor point.  

3. The base object you selected will stay active until you reset for a new measurement set. To reset 

the base object and start again, use the ESC key or Right Click and select Cancel. 

 

3.7.3  Measuring Net to Net  

 

1. Select the base of an object and Left Click. You’ll notice a white boundary will outline around the 

object. 

2. In order to successively measure, the base must contain a Net.  

3. Move the mouse over the next object and Left Click. A window will appear displaying the distance & 

angle relative to the original anchor point. 

4. The base object you selected will stay active until you reset for a new measurement set. To reset 

the base object and start again, use the ESC key or Right Click and select Cancel. 
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3.8 Importing Files  Basics  

With FAB 3000, PCB designers can easily import and prepare their Gerber, Drill, DXF, ODB++, and a number 

of additional file types for analysis and preparation prior to manufacturing. Using the AutoLoad Wizard, 

multiple files can be imported thereby reducing the time to load individual files. The files available for 

import are: 

Gerber DXF/DWG ODB++ & 
ODB++ 
Directory 

Drill (*.DRL) Rout/Mill 

Netlist Image HPGL/2 Postscript/PDF Large Bitmap 

STL (3D Files) GDS-II (Stream) Part Centroid 
Files 

BDM Files Aperture List 

Custom 
Aperture 
Library 

Footprints Library Text File Spreadsheet File (*.XLS) FAB 3000 Matrix 

 

For a complete overview of each file type, see SECTION 7: FAB 3000 Data Format Overview.  

3.8.1  Using the AutoLoad Wizard  

AutoLoad Wizard saves time 

and increases productivity 

by allowing you to import 

multiple Gerber and 

Excellion Drill files at once. 

To use the AutoLoad 

Wizard, perform the 

following: 

1. Select File > Import > 

AutoLoad. The FAB 3000 

AutoLoad Wizard menu will 

appear.  

2. Select a Folder Path or 

Type the folder path directly 

into the path entry box. You 

can also use the Folder 

Selection Tree to set the desired folder path for your import.  

For a complete overview of the AutoLoad Wizard, see SECTION 5: FAB 3000 Job Editor Menu.  
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3. Choose the Folder where your files are located. Below the graphical view of the folder directory 

path, you’ll notice the window: “Files Inside Selected Folder”. This reveals the current contents of 

the file you’ve chosen. 

4. Choose English or Metric measurements in the bottom left of the wizard.  

4. Select Finish. This will bypass any custom import or format settings and immediately proceed to the 

importation process. 

 

AUTLOAD FORMAT SETTINGS  

The format settings button within the AutoLoad 

Wizard allows you to setup custom import 

defaults. This option is available to you prior to 

importing your files. If you do not wish to 

change the default settings, simply skip this 

option.   

 

 

 

 

 

 

 

     Forum: How does AutoLoad Work? 

  Forum: Load Multiple Aperture Files Along with Gerbers 

 Video: FAB 3000 Basics (Part 1) – Import Zip Gerber and Drill, Edit Gerber, Align Layers,  

  Query, Measure 

  Video: FAB 3000 Basics (Part 2) – Import Zip Gerber and Drill, Edit Gerber, Align Layers,  

  Query, Measure 

  

 

 

 

http://forums.numericalinnovations.com/post/how-does-autoload-work-2399282?highlight=import
http://forums.numericalinnovations.com/post/load-multiple-aperture-files-along-with-gerbers-2399288?highlight=import
http://www.youtube.com/watch?v=Mrqnxqh2juI
http://www.youtube.com/watch?v=Mrqnxqh2juI
http://www.youtube.com/watch?v=DoqvfCYTutc
http://www.youtube.com/watch?v=DoqvfCYTutc
http://www.youtube.com/watch?v=DoqvfCYTutc
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AUTOLOAD FILE 

DESCRIPTION MENU  

If you need to fine-tune what 

will be imported Via 

AutoLoad, select Next 

instead of Finish. The File 

Description Menu will 

appear. It allows you to edit 

the following information: 

1. File Name: Name of each 

file to be imported. 

2. Aperture List: Allows you 

to optionally add a 

corresponding aperture list.  

 

3. Format: Provides you with the detected format of each file.  

4. Layer Type: Allows you to assign a layer type to each file.  

5. Import: Choose which files will be imported by selecting/unselecting each checkbox. 

AUTOLOAD DETECT LAYER TYPES  

Detect Layer Types is part of the File Description 

Menu. You can access this table by selecting Detect 

Layer Types. It provides information on each layer 

type. During import, layer types are automatically 

determined by patterns found in the Gerber file 

names. Use this feature to verify that the layer type 

detection values are compatible with your Gerber files 

names. 
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AUTOLOAD APERTURE TABLE  

The Aperture Table allows you to 

individually define the parameters for 

each polygon defined in the drawing. This 

includes adding additional apertures, 

swell, scale, swell, transcode, delete, and 

information. 

 

 

 

 

 

 

 

AUTOLOAD FINISH PAGE  

The Finish Page is the final page of the AutoLoad Wizard. It will reveal the progress of each file as it is 

imported. If no error is found during import the Autoload dialog box will automatically close. If an error is 

found, the dialog box will remain open in order to view the error log. Alternatively, you may press F2 any 

time after the import to view the FAB 3000 output log which will also contain information regarding any 

errors during the import. 

3.8.2  DXF/DWG File Import Process  

DXF and DWG files can be imported into FAB 3000. Please note that since DXF files lack units, it is important 

you verify the units & scale factor of your file prior to importing it. Each DXF import is scanned for Layers, 

Blocks, Styles, and more. The FAB 3000 import menu provides a series of separate tabs to help you control 

and verify the parameters of your import.  

To begin a DXF/DWG file import, perform the following: 

1. Select File > Import > DXF/DWG.  

2. Choose a DXF file to import.  

3. The DXF Options Menu will appear. This is where you’ll verify DXF layer options.  
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The DXF Options menu determines how a file can be imported.  Within the DXF Options menu, there are 

several tabs to help determine import parameters: 

1. Layers Tab 

Layers allow you to control how DXF 

layers are handled during import. 

a. Import Column: Check this box 

 to include the layer during 

 import. 

b. Layer Name: Name of layer.  

c. Fill Column: Converts closed 

 boundaries to filled-polygons. 

 

 

d. Wide Polyline Column: Adjusts how polylines with width are handled ruing import. 

There are three choices – Extend, Truncate, and Round. 

e. Flash Column: Detects circles & rectangles for conversion to Gerber flashes. 

f. Join Column: Check to join. 
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g. De-Embed Column: Algorithm used to verify polygons inside of polygons. Please 

note this check requires additional processing time.  

 

Video: Converting Gerber to DXF using FAB 3000 

  Video: Converting DXF to Gerber and NC Drill Data 

 

2. Options Tab 

 

Set the options which affect how a DXF file is imported. 

   

 

 

 

 

 

http://www.youtube.com/watch?v=7nKzQ0CezPM
http://www.youtube.com/watch?v=QmFSISjpUrY
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3. Text Tab 

  

 Verify the mapping of 

AutoCAD styles to FAB 

3000 fonts. 

 

 

 

 

 

 

 

 

4. Blocks Tab 

Check each box to 

include Blocks during 

import.  
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5. Merge Tab 

Merges DXF layers 

during import. 

a.  Select Add Merge 

to enter a merge 

name and then click a 

row under Layers to 

assign the layers to be 

merged during import. 

Select Delete Merge 

to remove a merge 

name and merge 

stackup. 

b.  Click a row under 

Merge Stackup to 

edit. 

 

Open/Save Config File 

Allows you to open & save an existing DXF configuration file (*.dcf) so that you may assign the exact same 

settings used previously. Reusing the DXF configuration will save time and reduce errors. 

Once these options are set, click Next to proceed.  

As the import begins, the Status window will list any warnings or errors in the log list. If there are no errors, 

the dialog box will instantly close. If there is an error, you can view the complete error log for correction.  

Select Finish to close the menu and finalize the import process. 

 

Video: DXF Import with de-embed and join checked with FAB 3000 

  

 

 

 

 

 

http://www.youtube.com/watch?v=C8AmoUn2OEw
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3.8.3  ODB++ File Import Process  

FAB 3000 allows you to load compressed (*.tgz) ODB++ databases into the workspace. To import an ODB++ 

file, perform the following: 

 

1. Select File > Import > ODB++ 

2. Choose the ODB++ file that you want to import and Select OK. The import dialog box will appear.  

3. Verify the ODB++ import options that you’ll use. This includes Steps (pictured above; also known as 

Jobs), Layers, and Options. 

 

Forum: Converting Gerber to ODB++ 
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 a. Layers:  Verify and edit the  

  ODB ++ layers you would like  

  to import. 

  

 

 

 

 

 

 

 b. Options: Set default units for  

  import. 

 

 

 

 

 

 

 

4. Select Next. 

5. Once the ODB++ loading is completes, a status & import log will be available for review fir any 

errors or warnings. 

6. Select Finish.  

FAB 3000 loads complete ODB++ databases with all steps while maintaining hierarchy. It will search the 

hierarchy to determine which is known as the “master” step. If it cannot find a master step, a dialog box 

will appear prompting you to select which step to view. You can also hit F4 to view the import log file.  

 

Video: How to Skip a Layer during ODB++ Import 

 

http://www.youtube.com/watch?v=7MbWjt_dzJI
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3.8.4  Open Zip (Compressed File)  

FAB 3000 automatically loads Gerber and Drill data from compressed files. This includes file formats such as 

*.zip, *.tar, *.gz, *.bz2, and *.7z. To import a compressed file, perform the following: 

1. Select File > Import > Zip (Compressed File).  

2. Choose the compressed file you want to import and Select OK. The import dialog box will appear.  

FAB 3000 will automatically determine the correct format and aperture rules necessary to import Gerber 

files with minimal effort. However, if you are aware of special circumstances regarding your Gerber files 

(such as 274D Gerbers using an Incremental type, End-Block-Character other than "*", etc.) or if you've have 

previously imported Gerbers loads correctly, you may want to change AutoLoad's default settings by clicking 

the button Format Settings  If you are unsure, please leave the format settings defaulted. 

3. Select Next.   

4. Once the compressed file loading is completes, a status & import log will be available for review fir 

any errors or warnings. 

5. Select Finish. 

3.9 Find Dcodes 

 

FAB 3000 includes the ability for finding Dcodes within an active Job after importing Gerber files to the 

workspace. To find Dcodes, perform the following: 

1. Select Info > Find > Find Dcode 

2. In the Find Dcode menu, choose which Dcode you want to view by selecting it from the dropdown  

 list.  

3. Choose either Highlight or Isolate to view the results. 

4. All objects that using the Dcode which you selected will be highlighted and zoomed in the editor.  
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Note: Make sure to have all layers turned ON while using Find Dcode. If the layers are deactivated you will 

not see the specified highlighted objects. 

3.10 Using the Properties Dialog  

For each object in your design, you can view and 

edit the properties of that object. In FAB 3000, 

properties of an object are divided into two 

primary categories: Attributes and Point List. 

1. To view the properties of an object, first 

 actively Select an object form the editor. 

2. Go to Edit > Properties. The properties dialog 

 box will appear. This will list the properties of 

 the active object. 

Under the Attributes Tab you may select and 

edit the Layer, Composite Level, Dcode, or Flash 

Center.  

Alternatively, you can view the properties dialog 

box of an object by double clicking (left mouse button) the object directly within the editor.  

3.11 Plotting to PDF  

PCB designs can be quickly plotted to PDF in A-size to C-size as well as user defined size formats. To Plot to 

PDF, perform the following: 

1. Go to File > Print to PDF. 

2. In the Printer/Page Setup 

dialog box, select the applicable 

plot size by clicking Paper Size. All 

other setting should remain as 

default. 
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3.  Select Next. The Plot 

 Features dialog box will 

 appear.  

4.  Keep all Plot Features settings 

 as default. 

 

 

 

 

 

 

 

5. Select Next. The Preview dialog box will appear. 

 

6. Review a print preview of the PDF file. If there are no warnings and the preview is acceptable, select 

 Next. 

7. FAB 3000 will begin to create the PDF file. 
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Once the PDF file is created, 

the Finish dialog box will 

appear and display the location 

and name of the PDF that was 

created.  

For Windows users, the Finish 

dialog box will also contain a 

View PDF button that will 

launch the PDF in Adobe 

Acrobat Reader. 

 

 

 

 

 

 

3.12 Redline Markup  

Redline markup allows designers to mark specific areas for review and reference; as well as bringing 

attention to a particular region of the design. To activate Redline Markup within your design: 

1.  First create a Markup Layer by selecting Add 

 > Markup > Markup Layers. 

2. In the Markup Layers dialog box, Select Add. 

3.  Create a layer name to assign to the marked  

   up layer. For example Markup_Layer1. 

4.  Select Apply then select OK to close the  

   dialog box. 

To change the colors of a markup layer, select 

the color theme next to the layer.  

 

 

Markup layers will also be included in PDF and Image exports, saved in the workspace, and are transferable 

to other users. 
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With a markup layer created, it is good practice to set how these markups will appear in a design. For this, 

go to Add > Markup > Markup Settings. 

The Markup Settings dialog box provides three 

custom options: 

a. Line Width (in Pixels): The width that  

 will be used for the markup objects such as 

 Line, Arrow, Rectangle, Ellipse, etc. 

b. Line Style: Chooses your markup style 

 between solid or dashed lines. Please note 

 that larger line widths will not be able to 

 display dashes properly. 

c. Highlight Mode: Allows objects to be marked  

        as solid (unchecked) or highlighted (checked). 

3.13 Markup Object Types  

There are several choices in Markup Object Types to 

choose from within the Add > Markup menu. They 

include: 

 

 

 

 

 a. Markup Line: Select Add > Markup > Markup Line 

      Left click to select the first location of your markup line. Left click again to end the  

      line or continue with additional lines using left click.   

 b. Markup Rectangle: Select Add > Markup > Markup Rectangle 

       Select a corner on the outside of the area you want to box then drag diagonally  

       across to complete the rectangle. Markup rectangle is great for boxing specific  

        regions of a design. 

 c. Markup Ellipse: Select Add > Markup > Markup Ellipse 

       Select a corner on the outside of the area you want to circle then drag diagonally  

       across to complete the ellipse. Markup ellipse is great for circling specific regions  

       of a design. 
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 d. Markup Polygon: Select Add > Markup > Markup Polygon 

        Select a corner on the outside of the area you want using left click. Continue  

        selection until forming the polygon shape you require. 

 e. Markup Text: Select Add > Markup > Markup Text 

       Select a corner for the text box location then click and drag diagonally to create  

       the box. It will then prompt you to enter text. Markup text is great for instruction  

       or explaining details of a design. 

 f. Markup Arrow: Select Add > Markup > Markup Arrow 

       Select a starting point on the outside of the area you want to circle. Add additional 

      points as needed. The starting point and second point determine the direction of  

      the arrow. Markup arrow is great for directing to specific points of a design. 
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SECTION 4: FAB 3000 ADVANCED FEATURES OVERVIEW 
In this section, we’ll highlight the advanced features of FAB 3000. For a detailed look at each individual 

menu function in FAB 3000, see SECTION 5: FAB 3000 Job Editor Menu.  

4.1 Merge Jobs  

Merge Jobs is a unique and powerful feature of FAB 3000 that lets so easily merge different PCB designs in 

order to reduce manufacturing and fabrication costs. Jobs can be merged into a single set of Gerber files for 

production. FAB 3000 will intelligently perform object transformations, Dcode, and drill tool transcoding in 

one solution. Using Merge Wizard, designers are able to fuse several PCB designs onto a single panel. 

FAB 3000 uses a hierarchal approach to merging Jobs. There are two hierarchal resources that FAB 3000 

utilizes: Jobs and Inserts. 

 

Forum: Merging Gerber Files 

   Video: Merge to Save Money on PCB Manufacturing 

4.1.1 Jobs vs. Inserts  

1. Job: A single design (i.e. PCB) with its own unique layers, Dcodes, and other attributes. (All data 

 imported and 90% of editing are handled at the Job level).   In FAB 3000 ODB++ terms, a “Step” is 

 defined as the same thing as a “Job” 

2. Insert: An Insert represents the inclusion of one Job as a part of another. The Job containing the 

 Insert is the parent Job, and the Job that is inserted into the parent is the child Job.  Using this 

 parent/child relationship, you can continue the hierarchy for as many levels as needed to express a 

 complete design. 

4.1.2 Merge Jobs Quick Summary 

Part 1: Creating a New Job 

1. Select File > New > Job. 

2. Select a name for the new Job. Be 

sure to create a descriptive name that 

allows for easy organization. For 

example, Part1212, Part 1213, etc. 

3. Once the Job is created, a blank Job 

Editor screen will appear. 

 

 

http://forums.numericalinnovations.com/post/merging-gerber-files-6635922
http://www.youtube.com/watch?v=VqKZ_6fjKog
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Part 2: Loading Gerber & Drill Files 

Automatically into the Active Job 

1. Select File > Import > 

 Autoload. 

2. Select the folder which 

 contains the Gerber and drill 

 files (for a single Job). 

3. Click Finish. 

FAB 3000 will begin to scan the 

directory and determine whether 

each file is either a Gerber or 

Aperture list. There will be a slight 

delay during scanning – then the 

File Description page will appear. The file description page provides the opportunity to define the aperture 

list to use (RS-274D only), Layer Types, and Import checkbox for each Gerber layer.  

When loading is complete, you’ll be able to view the imported data as well as be warned of any errors.  

Note: For compressed files (*.zip, *.tar, etc.), make sure to use the Importing Zip (Compressed File) 

feature.  

For multiple designs, repeat Parts 1 & 2 above. Each of your designs requires a separate Job. For a more 

detailed description of the Autoload menu, see Section 5: FAB 3000 Job Editor Menu. 

As mentioned above, all data imported and 90% of editing are handled at the Job level. Merging Jobs 

requires at least one Job in the current workspace (with data). 

4.1.3 Creating a New Panel  

1. Select File > New > Panel. 

2. Choose a name for the new panel. 

3. Verify the panel dimensions for Panel Name, 

 Width, Height, Margins, and Units. You can 

 also view and modify panel dimensions by 

 selecting Tools > Edit Panel. 

Once the new panel is created, you will see a 

blank panel editor screen with an outlined box 

representing the panel area. 
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4.1.4  MERGING JOBS AUTOMATICALLY 

1. Select Tools > Panelize 

Wizard. The panelize wizard 

dialog box will appear. 

2. Check all Jobs under the 

Select column to include in 

the panel merge. 

3. Verify Job Settings Options 

such as Job Spacing and 

Panel Options  

5. Select Next. 

  

 

 

 

6. In the next dialog box, 

choose the panelize options 

you require. 

7. Select Next to proceed. 

FAB 3000 will instantly 
calculate the best possible 
fit for all Jobs. If it finds 
multiple panel array 
options, it will allow you to 
select the panel array of 
your choice. 
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Use the Select Panel Layout 
to verify the panel sizing to 
use. 

8. Select Next to begin 
the merge. 

9. Select Finish.  

You will now see your Jobs 
merged.  

 

 

 

 

4.2 Synchronizing Layers 

In most cases the final stage of merging Jobs is to perform Synchronize Layers.  Synchronize Layers merges 
all Job layers into a common set of layers. 

Usually each Job has a different layer names used to describe the same layer types for example, 

"top02.pho", "topside.gbr", or "art01.ger”. Before exporting, all layers of similar layer type must be 

synchronized into one layer for each type. To synchronize layers: 

1.  Select Setup > Synchronize Layers. A 

 synchronize layers wizard box will appear.  

2. Define all layer types of the child Job, and 

 select Next.  

Synchronize Layers requires that you define the 
layer types for all Jobs.  If you are unsure, choose 
layer type "Graphic" to be ignored. 

 

 

 

https://s3.amazonaws.com/numerical-help-guide/fab3000v7/HTML/synchronizelayers.htm
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Use the Options button in the bottom right corner 
to set Layer Options such as Name, Color, and 
Stackup Order by Layer Type. 

 

3. Repeat steps 1-2 for each child Job. 

 

 

 

 

 

4.3 Manual Job Merge Using Inserts  

Once you have created different Jobs for each PCB design, you can merge these Jobs using the power of 

hierarchy with Inserts. To do this, you must have created at least two or more Jobs. 

CREATING A NEW “PARENT” JOB  

1. Select File > New > Job 

2. Choose a name for the new Job. Be 

sure that the name is as descriptive as 

possible. 

With the new Job created, a blank Job 

editor screen will appear. Remember, 

this new Job is considered the “parent” 

Job and contain Job Inserts. 

 

 

Video: Using Copy to Clipboard and Paste Gerber into New Job 

 

 

 

 

http://www.youtube.com/watch?v=GqC49TASOnk
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ADDING INSERTS MANUALLY 

1. Select Job > Insert Job. The  

  Insert Job dialog box will  

  appear. 

2. Select the Job to Insert. A  

  preview window will display  

  the selected Job or panel you  

  want to Insert. 

3. You may choose to assign Job  

  Orientations of R0 (rotate 0),  

  R90 (rotate 90), R180 (rotate  

  180), MX (mirror horizontal),  

  MY (mirror vertical).  

 

4. You may choose to assign Job  Anchor Points which controls  the Insert origin for the Insert.  

  Job anchor points are listed as  Lower Left, Center, and Origin  (actual 0,0 location of Inserted 

 Job). Choosing the correct anchor point helps when Inserting Jobs. 

5. Select OK to add the Inserts into the editor. 

To Insert other Jobs, repeat steps 1-5. Once the other Jobs are added, you may also edit their orientation, 

location, and make copies. FAB 3000 can handle an unlimited hierarchy.  

Once all Jobs have been inserted into the “parent Job”, you must synchronize (merge) layers as explained in 

5.2: Merge Layers. 
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4.4 Exporting a Parent Job to One Set of Gerber & Drill  Files:  

Once all Inserts are laid out into an optimal location, you can now export your merged CAM data.  

EXPORTING GERBER FILES: 

1. Select File > Export > Gerber. 

2. Verify Gerber settings and 

 select Next. 

3. Verify Gerber Layer Options 

 and select Next. 

 If you do not want to export 

 certain layers, simply uncheck 

 the corresponding layer. You 

 may also choose to output 

 individual layers with Mirror 

 or Negative polarity 

 attributes. 

4. Choose the directory where 

 the Gerber files will be written 

 to. If the directory does not  

          exist, FAB 3000 will create it  

          for you. 

EXPORTING DRILL FILES: 

1. Select File > Export > Drill. 

2. Verify Drill settings and select  Next. 

3. Verify Drill Layer Options and  select 

 Next. 

 If you do not want to export certain 

 layers, simply uncheck  the 

 corresponding layer. 

4. Choose the directory where the 

 Drill files will be written to. 

  

If the directory does not exist,  FAB 3000 will create it for you. 
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You have now created merged data from multiple printed circuit board designs into a single set of CAM 
files. 

4.5 Using Film Wizard  

Film wizard can be used to automatically setup Gerber layers for optimal film output making it ideal for 

anyone requiring Gerber or Postscript photoplots from their artwork. This plug-in is included with FAB 3000 

and will reduce photo plotting expenses by as much as 50%; providing a fast return on investment. 

Additionally, Film Wizard will also eliminate operator errors by preventing someone from wrongly mirroring 

or changing polarity and result in faster turn-around times.  

1. Go to Tools > Film Wizard. 

Assuming you have an 8 layer 
design, with an area of 5"X7" 
(120mm X 175mm).  Choose a film 
size that will be able to hold at 
least 4 design layers.  In this 
example a film size of 16" X 20" 
will work perfect.  (You may  

Make sure to contact your 
photoplotting service to determine 
what acceptable film sizes to use 
for their photoplotting process.  

  

2. Assign options that you want 
 to appear on each film layer. 

3. Select Film Setup based on 
 your required layer design and 
 sizing. Select Next. 
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4.  Assign polarity & mirror   
 options for each individual  
 layer. Select Next. 

 

 

 

 

 

 

 

 You’re finished! On the next 
page is an example screen 
capture of the outputted layer(s) 
from Film Wizard.  Notice that 
mirror and rotation have been 
included automatically!  
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At this point all you need to do now is to export these "Film Wizard" layers to either Gerber or Postscript, 
and that's it!  

 You’ve just saved 50% on your photoplotter service expenses!  

4.6 Using DFM Checker  

Prior to sending your PCB out to manufacturing, examination of your Gerber design is always required. Each 

detail should be scrutinized and checked for any manufacturing violations. This saves time, money, and 

frustration. Using FAB 3000’s DRC/DFM Checker, built in analysis tools will check your design for any 

potential problems. Many CAD systems don’t produce a “perfect” representation of your design once 

outputted. The Gerber/NC files are what is most important to manufacture your boards. FAB 3000 goes 

beyond basic checks (minimum trace & space) to perform the following: 

Silkscreen over Solder Mask - Locate if there are any locations where the silkscreen overlaps with 

openings in the solder mask layers.  Elevated Risk:  May cause contamination of the pads and make 

electrical testing plus SMT soldering more difficult. 

Non-Functional Internal Pads - Essentially these are unconnected internal pads typically found on plane 

layers.   Elevated Risk:  May break loose and cause potential drilling problems, risk of shorts, and more. 
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Isolated Connections - One of the most common problems is to determine whether your PCB CAD system 

has properly outputted good plane connections to the copper plane.   Critical:  A board will fail if any plane 

connections is not properly connect the copper plane. 

Mask Slivers - Areas in the solder mask where the resist is so narrow that it may cause small pieces of the 

resist to flake off and present soldering problems later.   Critical:  A board can fail if the resist falls in an area 

that needs to be soldered later on. 

Power/Ground Shorts - Determine any potential shorts between Power and Ground planes.   Critical:  A 

board will fail if there is a short between the power and ground planes. 

Copper Slivers - Narrow areas in the copper where the potential for over-etching is great. This typically 

happens when trace angles are 30 degrees (or less), when composites are used, and on plane 

layers.  Critical:  A board can fail if certain copper area are over-etched.  Resulting in shorts and decrease in 

board yield. 

Solder Bridges - Typically when the mask layers, contain openings which are too large, and may expose 

other adjacent conductive areas.  Critical: During fabrication, copper may get too close and form a bridge to 

other adjacent conductive areas. 

Negative Plane Thermal Conflicts - Determine if any Via or plated hole is connected to more than one 

negative plane together. Elevated Risk:  May result in poor board performance. 

Starved Thermals - Check whether a thermal connection to the copper plane has been constricted by 

overlapping or adjacent data that is way too close. Critical:  May result in poor board performance, short, 

or other undesired effect. 

Find Acid Traps - Due to the surface tension during the etching process, larger deposits of acid may get 

trapped into certain areas - resulting in over-etching. Critical:  Over-etching will directly affect your board 

yields.  

Antennas / Dangling Traces - Search for Non-terminating traces which may behave as an antenna. 

Elevated Risk:  May result in poor board performance, short, or other undesired effect. 

There are several conditions to consider prior to using DFM Checker: 

1. DFM Checker requires that you extract at least once Netlist before proceeding. However, if you 

haven’t run a Netlist extraction, DFM Checker will perform it for you first. 

2. All layer types must be defined prior to use DFM Checker.  

3. You must have at least 1drill file (2 or more for blind/buried Vias).  
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USING DFM CHECKER  

1. Select Tools > DFM > DFM 

 Check. The DFM Check dialog 

 box will appear. 

2. Verify and edit the DFM rules 

 set. To do this, select the  

 available rules set from the 

 pull down menu under DFM 

 Rule Set.  

 You may also edit the   

 DFM Rules by pressing  

 the “…” button next to  

 the DFM Rule Set drop  

 down menu (See   

 below, DFM Rules   

 Settings).         

 

 

 DFM Rules Settings dialog is used to 

 verify or edit rules individually. You 

 can also access DFM Rules Settings by 

 selecting Tools > DFM > DFM Rules 

 Management. 
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3. Select Next. 

4.  FAB 3000 will now perform an extensive analysis of your PCB design. 

  a.   Note that Job Inserts are ignored. If you wish to run a DRC/DFM check on a specific child  

        Job, make sure to open the child Job in a separate window, and then proceed. To open  

        Jobs, go to Window > Workspace Browser. 

b.    Depending on the complexity of the         

 design and the checks      

 performed, processing time     

 can take anywhere from 30   

  seconds to 5 minutes. 

 

 

 

 

 

 

 

 

5.  If any errors are detected, FAB 3000 

 will display them in the dialog box. If 

 there are no errors, the process is 

 complete.  

6. Select Finish. Any errors listed will 

 now appear in the DFM Violation 

 Browser. The browser will appear just 

 below the editor and provide you with 

 an easy to use navigation tool to 

 locate and describe each detected 

 error. For a more complete overview 

 of the DFM Violation Browser, see 

 section 4.7: Viewing DFM Violations 

 with the Error Browser. 
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7.    The browser contains a complete list of errors  

    organized in a hierarchy format. Selecting and       

    highlighting each error will provide a description of  

    the error and severity level for PCB fabrication. 

8.    For each error selected, you’ll be taken to the  

    location of that error within the drawing for closer  

    viewing and editing. 

 

 

 

 

 

 

 

 

 

9.    Create reports in PDF, Text, or CSV 

 format by selecting the appropriate 

 icon next to Error List.  

10.  You can also generate an error 

 drawing which may be exported to 

 various formats such as Gerber, DXF, 

 or ODB++ and then imported back 

 into your PCB layout tool for 

 verification or to share with 

 colleagues. 

 

 

  

Video: Performing Simple DFM/DRC Using FAB 3000 

 

http://www.youtube.com/watch?v=dQByPsgBxVs
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4.7 Saving DRC/DFM Violations into PDF Format  

To compile and save a list of DRC/DFM violations into PDF format after a DRC/DFM Check has been run, 

perform the following: 

1. Select Info > Generate PDF Error Report. 

2. Assign a filename to the report and Select Next. 

3. Once the PDF is ready, select View PDF File.  

A PDF of all warnings will launch in Adobe Acrobat.  

4.8 Extracting Netlists from Gerber and/or Dril l Data 

After importing Gerber and/or Drill files into a workspace, a Netlist should be extracted in order to do a 

comparison against a CAD-generated IPC-D-356 Netlist. There are several requirements for extracting 

Netlists: 

 1. All layer types should be defined before extracting a Netlist. 

 2. At least one drill file (2 or more for blind/buried Vias) is required before extracting a Netlist. 

 3. If your design contains blind or buried Vias, see 3.10, Extracting with Blind and Buried Vias. 

To extract a Netlist from Gerber and/or Drill files, perform the following:  

Extract a true interconnectivity map of any PCB design. 

1.  Select Tools > Nets >  

  Netlist Extraction. 

2.  Verify and select      

  extraction       

  options.  

3.  Select Next. The 

 extraction will be 

 performed. 
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4. In the Finish dialog box,  

 information will be included  

 regarding CAM Nets created  

 and elapsed time. 

The total number of extracted CAM 

Nets will be displayed in the Finish 

section. 

 

 

 

 

  

 

Video: Extract Netlist from Gerbers and View Nets using FAB 3000 

 

4.10 Extracting Netlists  from Blind and Buried Vias 

Assuming all prerequisites are complete prior to extraction (all layers types must be defined and you must 

have at least 2 or more drill files), you may also extract a Netlist from designs which contain blind and 

buried Vias.  

The first step in extracting Netlists from blind and buried Vias is to setup Blind and Buried Drill 

Relationships. 

To do this, 

perform the 

following: 

1. Select Setup > 

Blind and Buried 

Via Setup. 

2. Select and 

highlight the 

associated layers 

to form 

relationships. 

3. Select OK. 

http://www.youtube.com/watch?v=0Bn0CLFCXyo
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4. You may now proceed with Netlist extraction. 

PROCEED WITH NETLIST EXTRACTION FROM BLIND AND BURIED VIAS 

1. Select Tools > Nets > Netlist Extraction. The Netlist Extraction wizard will appear.  

 

2. Verify Netlist Extraction Options. 

3. Select Next. FAB 3000 will perform the Netlist Extraction. 

4. The total number of CAM Nets 

 will be displayed.  

5. Select Finish. 

To compare the extracted Nets 

against your own CAD generated 

Netlist, see 4.11: Comparing a 

CAM Netlist against an External 

Netlist. 

 

 

 

 



FAB 3000 V7 

 

Page 64 

 Video: Assign Layer Types & Stackup, Assign Blind & Buried Drills 

  Video: Sort Layers and Assign Blind/Buried Vias using FAB 3000 

 

4.11 Comparing a CAM Netlist against an External Netlist  

In order to compare a CAM Netlist against your external Netlist, the external Netlist (from your CAD 

system) must be in a standard format such as IPC-D-356 or IPC-D-356/A.  

IMPORTING AN EXTERNAL 

NETLIST 

FAB 3000 can import IPC Netlists 

which are generic Netlist formats 

used as a standard for the bare-

board testing environment. The 

Netlist will be loaded as the 

External Netlist for the active Job 

and it can bused to compare 

against an extracted CAM list. To 

import a Netlist: 

1. Select File > Import > Netlist 

(IPC-D-356/A).  

2. Select the Netlist file you 

 want to import. Select OK. 

3.  Choose the Netlist Format (IPC-D-356 or IPC-D-356A) you wish to import from the Import Netlist Wizard 

dialog box.  

4. Select Next to begin the import. 

Once the import is complete, the import 

wizard dialog box will disappear unless FAB 

3000 encounters any errors or warnings 

during import. An example of a Netlist 

comparison error is pictured here. Upon 

selecting Finish, FAB 3000 will immediately 

launch the Netlist error browser for further 

investigation.  

 

 

http://www.youtube.com/watch?v=aiMKTnQ6DkA
http://www.youtube.com/watch?v=TsKqouVY5v4
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Example of Netlist error 

browser. 

 

 

 

 

 

 

 

 

RUNNING THE NETLIST COMPARISON  

Compares extracted nets against an imported Netlist.  

The purpose of Net Compare check is to verify whether the PCB design has been constructed correctly (per 

the Netlist definition) and to verify the PCB layout tool has generated the Gerber files correctly  

Netlist compare is used to verify that the Gerber files have been successfully outputted from PCB Layout  

and imported into CAM software. 

1. Select Tools > Nets > Netlist 

 Compare. 

2. Verify and select compare 

 options.  

3. Select Next. The comparison 

 will be performed. 
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4. In the Finish dialog box, 

 information will be included 

 regarding comparison time 

 and any violations that were 

 detected during the 

 comparison. If there were 

 errors, you will be prompted 

 to select Finish. FAB 3000 will 

 automatically launch the 

 Netlist error browser to easily 

 identify and fix Netlist errors. 

 

 

 

4.12 Creating a PDF Report for  Net Comparison Errors  

All Netlist comparison errors can be documented and organized into a PDF file after running the 
comparison. To document in PDF, perform the following: 

1. Select Info > Generate PDF Error Report. 

2. Assign a filename to the report and Select Next. 

3. Once the PDF is ready, select View PDF File.  

A PDF of all errors will launch in Adobe Acrobat.  
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4.13 Add/Remove Objects from a Net  

After extracting a Netlist, you can edit objects from a Net. This can be done within the Netlist Table. 

1. Select Tools > Nets > Edit Nets. 

 

2. There are several features used to 

edit objects from a Net. This includes 

Create Net, Delete Net, Merge Net, and 

Transfer Net. 

 

 

 

 

 

 

 

 

Create Net - Add a new net to the Job. Select Create 

Net to enter a Net Name.  

 

 

 

 

 

Delete Net - Remove Net from Job. In the 
dropdown menu, select a Net to delete. 
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Merge Net - Combine Nets. Select the From Net and 
Into Net via dropdown menus. 

 

 

 

Transfer Net - Copy contents from one net to 
another. 
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4.14 Applying External Net Names to CAM Net  

After a Netlist is extracted from Gerber & Drill data, there is no way for FAB 3000 to know the net names 

used in your CAD design.  This allows you to import your CAD-generated Netlist, and apply the names to 

FAB 3000. After importing a Netlist into FAB 3000, perform the following: 

1. Extract a Netlist using Tools > 

Nets > Netlist Extraction (see 4.8: 

Extracting Netlists from Gerber 

and/or Drill Data). The extracted 

Netlist is pictured here. The 

Netlist information can be found 

at the bottom browser tab (below 

the editor) under “Nets”. 

You’ll notice FAB 3000 generates 

a generic Net name beginning 

with “$Net#”.  Usually, designers 

will want to use the actual design 

net names in FAB 3000. In this 

case, they will use Tools > Nets > 

Apply External Netlist. 

 

 

 

 

 

 

 

How to Apply External Net Names to CAM Net 

1. Select Tools > Nets > Apply External Netlist. 
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FAB 3000 will automatically update the existing 

CAM net names with the external net names.  

 

 

 

 

 

 

 

 

 

 

You’ll notice now in the Nets section 

tab that all Net names are no longer 

generic and refer back to the original 

names used in the CAD design.  

On some occasions you may find Nets 

in this list which may not have changed 

after running Apply External Netlist. 

This will most likely be the result of a 

Net flaw in the design.  

To identify this flaw, run Tools > Nets > 

Netlist Compare (see Section 4.11).  
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4.15 Creating Custom Apertures  

Custom apertures are used to optimize Gerber 

data. 

1.  Select File > New > Custom Aperture 

2.  Enter Custom Aperture Name and      

 select Finish.  

 

The Custom Aperture Editor will now appear as a separate tab. This is where you’ll perform all required 

drawing and editing steps in order to create a custom aperture.  

a.  The custom aperture name must be unique within the active workspace.  

b. The Custom Aperture editor is used to create special shapes that may be used as 

flashes in the current FAB 3000 workspace. Every FAB 3000 workspace has its own 

internal custom aperture library. When importing Gerber files that contain custom 

apertures, FAB 3000 adds them to the internal custom aperture library 

automatically. Custom aperture libraries may also be maintained as independent 

files for use from design to design. 

c.  The Custom Aperture editor differs from the CAM Editor in a few ways. There is only 

one generic layer. Custom apertures may contain both positive (dark) and negative 

(clear) data. For example, a donut is created by having a positive outer circle with a 

negative inner circle. Positive and negative data can be stacked in any order, as long 

as you assign the correct composite level (located in the toolbar).  

 

 

Video: Creating Custom Pads using Custom Apertures – FAB 3000 

 

 

 

 

 

 

 

http://www.youtube.com/watch?v=5b1PcX9OQW4
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4.16 Understanding Composites  

Layers that contain one or more objects with a defined 

"Composite Level" greater than zero are considered composite 

layers. Composite levels make it easy to define the fill rules for 

objects without the construction of complex polygons or 

geometries.  Objects are drawn per layer in the order of their 

composite level, starting with 0 and increasing to a maximum 

composite level of 1000.  All "even" (and zero) composite 

levels are filled dark (i.e. Paint), while "odd" composite levels 

are drawn clear (i.e. Scratch). 

 

 

 

To change the composite level of an object: 

1. Select the Object. 

2. Select Edit > Properties. 

The properties dialog box will 

appear.  

3. Locate the item “Polaity:” 

Change the composite level by 

changing the value from the pull 

down list. 

4. Select OK to exit the dialog 

box. 

You may undo any changes by 

selecting Undo using Edit > 

Undo. 

To automatically change the 

composite level of a group of 

objects based on their interior 

location relative to other 

objects, see 4.18 Polygon De-

Embedding. 
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4.17 Polygon De-Embedding  

Polygon De-Embedding solves the dilemma of changing polygons inside other polygons. This uses de-

embedding to automatically create composites. To perform Polygon De-Embedding:  

1. Select the objects for de-embedding.  

2. Select Edit > De-Embed. 

3. Object composite levels will become defined automatically in FAB 3000. 

 In order for composite levels to become defined, the objects must reside on the same layer.  

 You may undo any changes by selecting Undo using Edit > Undo. 

 

4.18 Centroid Files  

WHAT ARE CENTROID FILES?  

Automated equipment is used to place the surface mount components on your PCB. To rapidly program 

these machines, a Component Centroid file is required. Some CAD packages will automatically generate this 

file and some will not. FAB 3000 (Professional Version) can easily create this centroid file from your existing 

Gerber files. 

IMPORTANT CONSIDERATIONS WHEN GENERATING CENTROID FILES: 

Centroid files are primarily used for placement of SMT components.  For best results when generating a 
Centroid File from Gerber, use the paste layer.  If you do not have a Solder Paste Layer, please create one 
by selecting Fabrication > Generate Missing Layers > Paste Layer(s). 

All pads on the Paste Layer must be "Flashed".  If there are any pads on the Paste Layer that are not 
"Flashed" please do so by selecting Tools > Convert To > Flash (Automatic). 

To determine if all pads are "Flashes" on the Paste Layer, go to the Layers Table and try assigning a 
different color for the Flashed objects. Then when you view the Paste layer, all Flashed Pads will use the 
different color you have assigned.  You can also select Info > Query > Query All. 

ADDING COMPONENTS 

1. Turn on paste or mask layer (paste preferred).  

 a. If paste layer is not defined you must instruct FAB 3000 by going to the Setup > Layer Table. 

2. Locate a pad within the editor and select it.  

 a. FAB 3000 will try to guess Pin #1.  
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 b. You may also select a different pad for Pin #1. 

3. Select Assembly > Build Component 

4. Select Pin One.  

 a. Usually pin one is the top-leftmost pin for top side (assuming  

  no rotation) and top right most for bottom side (assuming no  

  rotation). Pin #1 is needed as it helps orient the   

  placement of the component.  

 b. Once Pin #1 is chosen, right click to accept. 

 

 

 

5. Assign component description. A Build 

 Components dialog box will appear. Select OK 

 when done. 

 a. Enter component rotation as it  

  appears on the board. If you have  

  selected a component  that is rotated  

  90 degrees on the board, than make  

  sure to enter that here. 

 b. If apply all is check (recommended),  

  FAB 3000 will go out and seek all  

  similar footprints. 

 

You will notice (if apply all is checked) that all similar 

footprints have been detected and assigned a generic 

reference designator value (for example “?21”). 

 

6. Repeat steps 2 thru 5, until all footprints on the paste 

  layer have been completed. 
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7. Review the Footprint browser and verify   

 remaining components. Select Window >   

 Footprint Browser. 

   

8. Select the Footprint to open by clicking it.   

 Select OK. 

 

 

 

 

8. In the Footprint browser you 

 may load external libraries 

 (containing footprints) or 

 make modifications here. 

Note: To perform these actions for 

the bottom side (if required), turn off 

all layers except Bottom Paste &  

     

      

Bottom Silkscreen. Repeat steps 2-6.  

 

 

 

ASSIGN REFERENCE DESIGNATORS TO COMPONENTS  

1. Disable all layers except for Top Component & Top Silkscreen. 

2. In the Components Tab Browser, select a component from the list. 

Components selected from this list will be highlighted. To zoom into the selected component, enable Zoom 

To Component by checking the corresponding box. 

Arrow Keys are helpful in navigating up and down through the Components list. 

3. Click into the edit control "RefDes:", and type-in the correct reference designator. Select Enter. 
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Keep the silkscreen visible. It’s a great way to determine which reference designator to assign the 
component. 

4. Repeat Step 3 until all Components have been assigned their reference designators. 

EXPORTING A CENTROID FILE 

In order to export a centroid file, you must have at least one or more components defined before 

exporting.  

Centroid files are comma separated files; you can load them into almost any spreadsheet program or text 

editor. 

To export a Centroid File: 

1. Select File > Export > Centroid File. 

2. View and select the available options. 

3. Select File Name & Location. The centroid file will now export.  

 

Video: Generate X/Y Centroid File from Gerber, using FAB 3000 

 Video: Generate PCB Centroid File (used in PCB Assembly) from Gerber 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.youtube.com/watch?v=TRAnZ-tTzTA
http://www.youtube.com/watch?v=TRAnZ-tTzTA
http://www.youtube.com/watch?v=ETCHDdqQfsI
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SECTION 5: FAB 3000 JOB EDITOR MENU SUMMARY 

5.1 File Menu 

The file menu is the backbone for opening, closing, importing, 

and exporting designs. It also contains features such as printing 

and plotting as well as the workspace browser; a tool used to 

navigate resources (from the active workspace) in a hierarchy 

of libraries, designs, folders and files. From here, you can open 

resources for editing or select resources for operations such as 

exporting. 

 

 

 

 

 

 

 

File > New  

When selecting File > New, you’re 

presented with a sub menu of options for 

new projects.  

Job: Creates a new Job. Enter a new Job 

name and select OK. A new Job will be 

created and also appear as an Editor Tab.  

Panel: Creates a new Panel. Enter a new 

Panel name as well as additional 

parameters such as Panel Units, Panel Width/Height, & Panel Margins.  

Custom Aperture: Creates a new Custom Aperture. Enter a Custom Aperture name and select OK. A 

new Custom Aperture will appear in the Editor Tab.  

a.  The custom aperture name must be unique within the active workspace.  

b. The Custom Aperture editor is used to create special shapes that may be used as 

flashes in the current FAB 3000 workspace. Every FAB 3000 workspace has its own 

internal custom aperture library. When importing Gerber files that contain custom 
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apertures, FAB 3000 adds them to the internal custom aperture library 

automatically. Custom aperture libraries may also be maintained as independent 

files for use from design to design. 

c.  The Custom Aperture editor differs from the CAM Editor in a few ways. There is only 

one generic layer. Custom apertures may contain both positive (dark) and negative 

(clear) data. For example, a donut is created by having a positive outer circle with a 

negative inner circle. Positive and negative data can be stacked in any order, as long 

as you assign the correct composite level (located in the toolbar).  

Footprint: Creates a new footprint and opens it up in the FAB 3000 editor. Enter a Footprint name 

and select OK. A new Footprint will also appear in the Editor Tab.  

  a. A footprint name must be unique within the active workspace. 

Text File: Opens a new Text File. Choose a Text File and select OK. A new Text File will also appear in 

the Editor Tab. 

  a. A new Text File must be unique within your computer. 

Spreadsheet File: Opens a new Spreadsheet File. Choose a Spreadsheet File and select OK. A new 

Spreadsheet File will also appear in the Editor Tab.  

  a. A Spreadsheet File must be unique within your computer.  

Application File: Opens a new Application File (such as LUA Files). Choose an Application File and 

select OK. A new Spreadsheet File will also appear in the Editor Tab.  

  a. An Application File must be unique within your computer.  

File > Open Workspace  

Opens an existing FAB 3000 Workspace using *.wrk file format. Choose a Workspace and select OK.  

File > Close Workspace  

Closes an active Workspace. If the Workspace has been modified, you’ll be prompted to Save.  

File > Save Workspace  

Saves a Workspace.  

a. If you have not saved your workspace before, you’ll be prompted to assign a Workspace 

file name and location. 

File > Save Workspace As  

Saves an existing Workspace as another file. Select or modify a Workspace File name and location then 

select OK.  
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File > Workspace Browser  

Allows you to quickly preview 

all loaded Jobs and Panels 

within an active Workspace.  

 a. Single Click: Preview 

 b. Double Click: Open 

 

 

 

 

File > Information  

Displays all Job information. 

Includes tabs for Tree 

Hierarchy, Dcode, & 

Summary.  

 

 

 

 

 

 

File > Open Folder (Gerber / NC) 

 This command automatically loads Gerber and Drill data from a specified folder. Choose the folder you 

want to import and then select OK. The entire folder is scanned – all Gerber, Drill, & Netlist files found are 

quickly imported.  

a. FAB 3000 will automatically determine the correct format and aperture rules necessary to 

bring in your Gerber files with minimal effort. However, if you are aware of special 

circumstances regarding your Gerber files (such as 274D Gerbers using an Incremental type, 

End-Block-Character other than "*", etc.) or you've had previously imported Gerbers load 

correctly, you may want to use AutoLoad. 

b. To view the log file of the import you performed, select the F2 key.  

https://s3.amazonaws.com/numerical-help-guide/fab3000v7/HTML/autoload.htm
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File > Open Compressed File (Zip, Tar, GZ, RAR)  

This command automatically loads Gerber and Drill data from a specified compressed folder. FAB 3000 will 

automatically uncompress the file while a wizard dialog box will appear. To open a compressed file, 

perform the following: 

 1. Select File > Open Compressed File (Zip, Tar, GZ, RAR). 

 2. Choose the compressed file to import. 

a. FAB 3000 will automatically determine the correct format and aperture rules 

necessary to bring in your Gerbers with minimal effort. However, if you are aware of special 

circumstances regarding your Gerber files (such as 274D Gerbers using an Incremental type, 

End-Block-Character other than "*", etc.) or you've had previously imported Gerbers load 

correctly, you may want to change AutoLoad's default settings by clicking the button Format 

Settings.  If you are unsure, please leave the format settings defaulted. 

 3. Select OK 

 4. FAB 3000 will begin the process of uncompressing the file. At the same time, an import

 wizard dialog box will appear. 

 5. Select Next to begin the import.  

 6. Upon completion review the status & import log. Any errors or warnings will be displayed 

  here.  

  b. To view the log file of the import you performed, select the F2 key. 

 

 

 

 

 

 

 

 

 

 

 



FAB 3000 V7 

 

Page 81 

File >Import 

 

The following file types are possible using File > Import: 

AutoLoad (Gerber/Drill)  Image    Aperture List 

Gerber     HPGL/2    Custom Aperture List 

Drill      Postscript/PDF   Footprints Library 

Rout/Mill    Large Bitmap   Tex File 

ODB++     STL (3D)   Spreadsheet File 

ODB++ (Directory)   GDS-II (Stream)  FAB 3000 Matrix 

Netlist     Part Centroid File 

DXF/DWG    BOM File 
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File > Import > Autoload  

AutoLoad Summary 

Autoload Wizard is an automatic import tool for Gerber and Drill files from a selected folder. It’s designed 

to make importing PCB designs an easy and time efficient by eliminating individual loading of each file. To 

perform Autoload: 

1. Put all pertaining files to a Job in the same directory. 

2. Select File > Import > Autoload. 

 a. The Autoload Wizard will appear. 

3. Choose either English or Metric Units. 

4. Choose the folder which contains the Gerber files you wish to load. There are two selection 

 options: 

 a. Immediately select Finish (fastest). This scans and loads all files in your directory without  

 any further steps. This option works for loading extended Gerber data (format & apertures are 

 already defined in the  file.  

 b. Select Next (recommended). FAB 3000 will scan the directory to determine if each file is  

  either a Gerber or Aperture list. This will display a File Description page which allows you to  

  manually define the aperture list to use, layer types, and individually import each Gerber  

  layer. Select Next to begin loading. 

5. Once loading is complete, a status & import log will be available for your review. If any errors or 

 warnings are encountered they will be displayed here.  

6. Select Finish.  

Common Issues with Gerber/Drill Importation 

Incorrect Apertures 

While importing 274D files, the most common cause for incorrect apertures is an incorrect or missing .RUL 
file. FAB 3000 tests each aperture file against all the .RUL files that are present in the aptrules directory. 
The .RUL file must be correct (less than 20% read errors) and located in the aptrules directory for this 
process to pass. 

a. Some aperture files define custom shapes and thermals in an inconsistent manner that cannot be 
 read. These apertures contribute to the 20% error limit.  
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Incorrect Format (For 274D only) 

Gerber files contain only numbers with no decimal point. Thus, a number such as X12345 could mean 
1.2345 inches, 12.345 millimeters, or 123.45 inches. To limit the possibilities of loading errors, FAB 3000 
assumes that the size of the data will probably be greater than 2 inches and less than 20.  If your imported 
Gerber files appear to have imported with the wrong scale, you may want to change AutoLoad's default 
format settings by clicking the button Format Settings. 

Incorrect Type (For 274D only) 

Gerber files contain only numbers with no decimal point. Thus, a number such as X12345 could mean 
1.2345 inches, 12.345 inches, or 123.45 inches. To limit the possibilities of loading errors, FAB 3000 
assumes that the size of the data will probably be greater than 2 inches and less than 20.  If the imported 
Gerber files appear to have incorrect lines stretching across the screen (like a rats-net), you may want to 
change AutoLoad's default settings by clicking the button Format Settings.   

Incorrect Arcs (For 274D only) 

Some Gerber generating products (like PCB layout software) assume all Gerber arcs to be of the "360-
degree type", and do not follow the proper procedure to define these arcs.   If the imported Gerber files 
appear to have incorrect arcs, you may want to change AutoLoad's default settings by clicking the button 
"Format Settings...", and check "Use 360-degree arcs as default" 

Drill Data missing Tool Definition... 

AutoLoad will automatically scan your drill files to determine if there are any missing tool definitions.  If a 
Missing Tool is detected, AutoLoad will ignore the drill file, and you will be required to load the drill 
manually Import Drill.  

a. FAB 3000 currently imports Excellon format only. 

b.  If more than one drill files is being imported simultaneously or an existing Tool table is already 
 defined, FAB 3000 will automatically map different drill tools with the same number but different 
 diameters. 

Other Loading Errors... 

Gerber files which contain numerous errors during import most likely are not properly constructed.  We 
have spent years refining our Gerber importer to accept non-standard Gerber files from all different 
software products throughout the world.  If you are having problems loading any Gerber files into FAB 
3000, please contact our support team for further assistance: support@numericalinnovations.com  (be sure 
to provide us with an accurate explanation of the problem, along with the Gerber files you are trying to 
load). 

 

https://s3.amazonaws.com/numerical-help-guide/fab3000v7/HTML/importncdrill.htm
mailto:support@numericalinnovations.com
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AutoLoad Dialog Wizard Picture Summary 

Step 1: AutoLoad Main Dialog 

In the AutoLoad Wizard, first choose the folder from which your files will be imported.  

Select units in either English or Metric. 

Choose to Format Settings or view & edit the Aperture Table. (See Format Settings & Aperture Table) 

Choose either Finish to immediately begin import or Next to individually define the aperture list, layer 

types, and individual layers to be imported (See Step 2: File Description Box).  
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Format Settings Button  

The Format Settings dialog box lets you 

setup custom defaults that AutoLoad Wizard 

will use during import. You also have the 

option to skip this format if you do not wish 

to include a particular EDA format type 

during AutoLoad.  

You can set custom defaults for Gerber, Drill, 

Netlist, and HPGL options.  

 

 

 

 

 

 

Aperture Table 

The Aperture Table is 

available as an option for 

adding/deleting apertures, 

transcoding, swell, scaling, 

and information.  

 

EDIT THIS DESCRIPTION 
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Step 2: File Description Box 

The File Description Page lets you fine-tune exactly what will be imported with AutoLoad.  Beside each file 
name is the following information: 

File Name: The name of the file located in the Autoload import directory. 

Aperture List: (Optional) Select corresponding aperture list. (For RS-274D with separate aperture lists per 
layer) 

Format: Lets you know the format that AutoLoad has detected this file as. 

Layer Type: Select the corresponding layer types for each file. You may also assign layer color by choosing 
the corresponding color box.  

Import: A Check box to determine if you want to load this file.  If you de-select a previously checked item, it 
will not be included during AutoLoad. 
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Detect Layer Types: During import, layer types are automatically determined by patterns found in the 

Gerber file names. The Detect Layer Types button summarizes all layer type detection values are 

compatible with your Gerber file names (see below).  

 

 Step 3: Finalizing Import 

Upon selecting either Finish (faster way) or Next (recommended way using File Description), the AutoLoad 

Wizard will immediately begin the import process. A progress bar will appear for each file imported. If the 

load has a problem, you will be notified of any warnings or errors which occur. If the load is successful, the 

box will immediately disappear and import your files into the workspace and editor. 

File > Import > Gerber  

FAB 3000 reads Gerber data in RS-274D, RS-274X, and Fire 9000 formats. Multiple files are read into 

multiple layers, allowing simultaneous viewing and editing of the Gerber data. The system is fully 

compatible with polygon fills, composite images, and step and repeat codes. 

a. FAB 3000 correctly displays Step & Repeat data. Most other CAM software will Crash, Ignore, or 
 draw imaginary boxes. FAB 3000 will create a separate Job for each Step & Repeat block which is 
 then Inserted into the parent Job; maintaining correct Step & Repeat hierarchy, and improving the 
 ability to edit and modify existing Step & Repeats. 

To import a Gerber file, perform the following: 
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1. Select File > Import > Gerber 

2. Choose the Gerber files you wish to import (select multiple files using the Shift or Ctrl key) Select 
 OK.  

3. The Import Gerber wizard dialog box will appear with your chosen files. 

 

4. To modify Gerber import settings, select Gerber Options. Otherwise, skip this step.  

 

    Forum: During Gerber import, I get the warning message “Invalid Gerber Quadrant Arc” 

Video: Automatically Import Gerber and Panelize 

 Video: Import Gerber files, detect layer types, assign stackup, and more 

              Video: Gerber Import with 90 degree arcs using FAB 3000 

    Video: Step and Repeat Gerber Files 

http://forums.numericalinnovations.com/post/during-gerber-import-i-get-the-warning-message-invalid-gerber-quadrant-arc-what-does-this-3401713
http://www.youtube.com/watch?v=CGRgzZDkCDw
http://www.youtube.com/watch?v=GEl_sImxmEA
http://www.youtube.com/watch?v=GEl_sImxmEA
http://www.youtube.com/watch?v=B0KG0LiWTXA
http://www.youtube.com/watch?v=hXjRXNrm4DY
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Gerber options allows you to 
edit the format for Gerbers. FAB 
3000 will automatically detect 
Gerber formatted settings and 
aperture lists. If you are unsure 
about these settings, use the 
recommended defaults.  

 

 

 

 

 

 

5.  To modify Aperture settings, 
select Aperture Table. NEED 
MORE DEFINITION HERE 

 

6.  In the Gerber Options dialog 

box, assign a layer type using 

the Choose Layer Type drop 

down box next to each Gerber 

file.   
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7. Select Next to begin the import. 

8. Once the importation is complete, FAB 3000 encounters any errors or warnings they will be 

 displayed in the dialog box. Otherwise, the dialog box will disappear and the  import is complete. 

  a. If you already had existing data opened in the current Job, any layers with the  

   same name will be merged within that Job.  It is recommended that you instead  

   create a new Job for each new "design" that you import into FAB 3000. 

Import Gerber Format Options Defined 

Units: Determine if imported Gerber's have units of English or Metric. 

Integer Digits: Determine if imported Gerber's have integer digits between (0-6). 

Decimal Digits: Determine if imported Gerber's have decimal digits between (0-6). 

Type: Determine if imported Gerber's have type of Absolute or 
Incremental. 

Zero Suppression:  Determine if imported Gerber's have zero suppression of Leading, 
Trailing, or None. 

Use 360 Degree Arcs as default:  Read Gerbers using 360 degree arcs mode as a default. 

End Gerber Block at Newline: Treat newline characters as an end of Gerber block. 

End of Gerber Block Character:  Character to for ending Gerber blocks. Usually an asterisk '*'. 

Maximum Gerber Block Size: Maximum size allowed per Gerber block. 

 

File > Import > Drill  

Import > Drill allows you to import one or more NC drill files in *.DRL format. Currently FAB 3000 only 

imports in Excellon format. If more than one drill file is imported at the same time or an existing Tool table 
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is already defined, FAB 3000 will automatically map different drill tools with the same number but different 

diameters. FAB 3000 will also automatically scan your drill files to determine if there are any missing tool 

definitions. To import drill files, perform the following: 

1. Select File > Import > Drill. 

2. Choose the Drill files you want to import and select OK. The Drill wizard dialog box will appear. To 

 select more than one file, use the Shift or Ctrl keys. 

  

3. Select English or Metric units. 

4. Select the Integer digits required. These are digits to the left of the decimal point.  

5. Select the Decimal digits required. These are digits to the right of the decimal point. 

6. Select either Absolute or Incremental format type. 

7. Select the Zero Suppression format required.  

8. Select Next to begin importing drill files.  

If a Missing Tool is detected, you will receive a warning stating that you must define all tools before 

proceeding.  In the Drill Options menu use the button, Assign Tool Sizes to display the NC Tools Table.  
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Enter in the required tools for the 

drill file(s) you wish to import.  If 

you are importing more than one 

drill file, and they use different 

tools sizes for the same tool 

number, than you will need to 

cancel the Import Drill Wizard and, 

import each drill file one at a time.  

 

 

 

 

 

 

 

9. Once the drill loading is complete, the dialog box will disappear. If there are errors or warnings 

 during import, a status and import log will appear.  

Import NC Drill Options Defined 

Units:  Determine if imported Drills have units of English or Metric. 

Integer Digits: Determine if imported Drills have integer digits between (0-6). 

Decimal Digits:  Determine if imported Drills have decimal digits between (0-6). 

Type: Determine if imported Drills have type of Absolute or Incremental. 

 Zero Suppression:  Determine if imported Drills have zero suppression of Leading, 
Trailing, or None. 

 

 

  Forum: Why does FAB 3000 assign generic tools sizes when importing drill files? 

 Video: Understanding Import NC Drill Problems using FAB 3000 

  Video: Gerber to Drill using FAB 3000 

   Forum: How can I change the drill file format without having to re-import it? 

 

http://forums.numericalinnovations.com/post/when-importing-my-drill-i-notice-that-fab-3000-assigned-generic-tool-sizes-3401130
http://www.youtube.com/watch?v=0P4uKRiSEDQ
http://www.youtube.com/watch?v=VPSoyGq5LxY
http://forums.numericalinnovations.com/post/how-can-i-change-the-drill-file-format-without-having-to-reimport-it-3429626
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File > Import > Rout/Mill  

Rout/Mill allows 

you to import 

multiple NC Rout 

(*.ROU) files 

simultaneously.  

FAB 3000 currently 

imports in Excellon 

format only.  

If more than one 

rout file is imported 

at the same time or 

an existing Tool 

table is already 

defined, FAB 3000 

will map different 

tools with the same 

number but 

different 

diameters. 

FAB 3000 will also automatically scan your rout files to determine if there are any missing tool definitions. 

To import Rout/Mill files perform the following: 

1. Select File > Import > Rout. 

2. Choose the Rout files to import. Select OK.  

 a. Click and hold the Shift or Ctrl key for multiple imports.  

3. Choose English or Metric units. 

4. Select the Integer digits required. These are digits to the left of the decimal point.  

5. Select the Decimal digits required. These are digits to the right of the decimal point. 

6. Select either Absolute or Incremental format type. 

7. Select the Zero Suppression format required.  

8. Select Next to begin importing rout files.  

Once the drill loading is complete, the dialog box will disappear. If there are errors or warnings during 

import, a status and import log will appear. 



FAB 3000 V7 

 

Page 94 

If a Missing Tool is detected, you will receive a warning stating that you must define all tools before 

proceeding.  In the Rout/Mill Options menu use the button, Assign Tool Sizes to display the NC Tools Table.  

Enter in the required tools for the 

rout file(s) you wish to import.  If 

you are importing more than one 

rout file, and they use different 

tools sizes for the same tool 

number, than you will need to 

cancel the Import Rout/Mill 

Wizard and, import each rout file 

one at a time.  

 

 

 

 

 

 

Import NC Rout Options: 

Units: Determine if imported Drills have units of English or Metric. 

Integer Digits: Determine if imported Drills have integer digits between (0-6). 

Decimal Digits: Determine if imported Drills have decimal digits between (0-6). 

Type: Determine if imported Drills have type of Absolute or Incremental. 

Zero Suppression: Determine if imported Drills have zero suppression of Leading, 
Trailing, or None. 

 

 

 

Video: Construct an NC Rout Path from a PCB Border using FAB 3000 

  Video: Create Rout for PCB Border, Slots, Cutout, and add Drill holes  

 

 

http://www.youtube.com/watch?v=Jg1HZ1Ztd3M
http://www.youtube.com/watch?v=vXAVbQyXQbQ
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File > Import > ODB++  

FAB 3000 allows 

you to import a 

compressed 

ODB++ database 

file. This file is 

usually formatted 

in *.TGZ format; 

otherwise known 

as a “tar ball”.  

Please note that 

in FAB 3000 a 

“Job” is the same 

thing as a “Step” 

in ODB++.  

 

 

 

 

To import a compressed ODB++ database file, perform the following: 

1. Select File > Import > ODB++. 

2. Select the compressed ODB++ file you would like to import. Select OK. 

3. Use the tabs at the top of the ODB++ import options menu to verify layers, steps, and options.  

 a. Steps: Choose which ODB file names to import by using the corresponding check box. 

 b. Layers: Verify the layers you want to import. Use the drop down menus for layer type and  

  polarity by double clicking each value. 

 c. Options: Choose either English or Metric units. 

4. Select Next to begin importing.  

5. Once importing is complete, the ODB++ Import Wizard dialog box will disappear. If there are any 

 errors or warnings, they will appear here. You can also view the import log file using F2.  

If there are multiple steps in the ODB++ database, FAB 3000 will search the hierarchy to determine which 
step is the "Master" step.  If it cannot find a Master Step, a dialog will appear, prompting you to select 
which step to view.  
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Unlike other CAM software products, FAB 3000 loads the complete ODB++ database including all steps 
(while maintaining hierarchy).  To view all the steps imported into FAB 3000, use the Workspace Browser 
(File > Workspace Browser).  

File > Import > ODB++ (Directory)  

Similar to 

compressed ODB++ 

files, FAB 3000 allows 

you to import ODB++ 

database directories 

using the import 

wizard.  

 

 

 

 

 

 

 

 

 

1. Select File > Import > ODB++ (Directory). 

2. A menu will appear allowing you to select the 

 ODB++ directory you would like to import. 

 Choose the directory and select OK.  

3. Use the tabs at the top of the ODB++ import 

 options menu to verify layers, steps, and 

 options.  

 a. Steps: Choose which ODB file names  

  to import by using the corresponding  

  check box. 

 b. Layers: Verify the layers you want to import. Use the drop down menus for layer type and  

  polarity by double clicking each value. 
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 c. Options: Choose either English or Metric units. 

4. Select Next to begin importing.  

5. Once importing is complete, the ODB++ Import Wizard dialog box will disappear. If there are any 

 errors or warnings, they will appear here. You can also view the import log file using F2.  

If there are multiple steps in the ODB++ database, FAB 3000 will search the hierarchy to determine which 
step is the "Master" step.  If it cannot find a Master Step, a dialog will appear, prompting you to select 
which step to view.  

Unlike other CAM software products, FAB 3000 loads the complete ODB++ database including all steps 
(while maintaining hierarchy).  To view all the steps imported into FAB 3000, use the Workspace Browser 
(File > Workspace Browser).  

 

Video: Convert Gerber to ODB++ 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.youtube.com/watch?v=5z93nkbfIZ8
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File > Import > Netlist (IPC-D-356 and IPC-D-356A) 

FAB 3000 can import IPC Netlists which are generic Netlist formats used as a standard for the bare-board 

testing environment. The Netlist will be loaded as the External Netlist for the active Job and it can bused to 

compare against an extracted CAM list. To import a Netlist: 

1. Select File > Import > 

 IPC Netlist.  

2. Select the Netlist file 

 you want to import. 

 Select OK. 

3. Choose the Netlist 

 Format (IPC-D-356 or 

 IPC-D-356A) you wish 

 to import from the 

 Import Netlist Wizard 

 dialog box.  

4. Select Next to begin 

 the import. 

 

 

 

Once the import is complete, the import wizard dialog box will disappear unless FAB 3000 encounters any 

errors or warnings during import.  

 

 Video: Import Nets, Move Origin, and Perform Netlist 

 

 

 

 

 

 

 

 

http://www.youtube.com/watch?v=rBYSx0XxTeY
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File > Import > DXF/DWG  

FAB 3000 can import DXF/DWG files into a workspace. 

 

 

 

 

 

 

 

 

 

 

 

 

 

To import DXF/DWG files, perform the following: 

1. Select File > Import > DXF / DWG. 

2. Choose the DXF file to import. 

 a. DXF files are scanned by layers, blocks, styles, and more. 

 b. DXF files are unit-less. It is import that you verify the DXF units & scale factor of your DXF  

  file before importing it.  

3. Choose DXF Design Type from the pull down menu. This feature is optional and adjusts other DXF 

 import settings to optimize conversion results. 

4. Verify the DXF Layers in the Layer Tab of the import wizard dialog box. The following columns are 

 available for your review & edit: 

 a. Import: Includes the layer during import. 

 b. Fill: Converts closed boundaries to filled-polygons. 
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 c. Wide Polyline: Adjusts how polyline width is handled during import. Choose from either  

  Extend, Truncate, or Round. 

 d. Flash: Check this box to detect circles & rectangles – then convert them to Gerber flashes. 

 e. Join: Joins layers for import.  

 f. De-Embed: Algorithm used to verify polygon-inside-of-polygon. Please note this is a time  

  consuming feature. 

5. Verify DXF Options in the Options Tab of the import wizard dialog box. There are several options 
 that can affect how a DXF file is imported (Join Adjacent Lines/Arcs, Arc-Resolution, Respect 
 Byblock/Bylayer). 
 

6. Verify DXF Text in the Text Tab of the import wizard dialog box. This allows you to verify and select 

 the mapping of AutoCAD styles to FAB 3000 fonts. 

7. Verify DXF Blocks in the Blocks Tab of the import wizard dialog box. This allows you to control how 

 each individual DXF block is handled during import. 

8. Merge DXF Layers in the Merge Tab of the import wizard dialog box. This allows you to merge DXF 

 layers during import. Create a merge and assign DWG layers to be included in this merge.  

9. Select next to begin the import.  

Opening and Saving Config Files (Optional): This feature allows you to open & save an existing DXF 
Settings file (*.ds), so that you may assign the exact same settings used previously.  If you regularly perform 
DXF conversions re-using the DXF settings will save time and limit mistakes. 

Once the import is complete, the import wizard dialog box will disappear unless FAB 3000 encounters any 
errors or warnings during import. If there are any issues, FAB 3000 will display them within the wizard 
dialog box.  

Import DXF Units: 

DXF Units/Scale: 

  

DXF files are unit-less, so it is vital to specify the proposed units & 
scale for 1 DXF physical unit. Choose from Micron, Inch, Millimeter, 
Centimeter, and more.  The Logical DXF unit size will be defined by 
defined by DXF Units *  Scale 

DXF Design Type: 

  

This is an optional convenience setting, which will optimize other DXF 
import settings such as Fill, Polyline End cap, and more.  Choose 
whatever description best describes the type of DXF design you are 
importing. 
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Import DXF Options: 

Use Polygon De-Embedding: 

  

Automatically solves the polygon-inside-of-polygon polarity problem. 
Closed boundaries (on the same layer) found completely inside 
another boundary will be made clear (or dark).  Due to its 
complexity, this feature may be time consuming during the 
conversion.  

Respect ByBlock/ByLayer: Block entities that are on designed layer '0', will be changed to the 
layer of the respective Insert. 

Ignore Dimensions: If this setting is 'checked', dimensions will be omitted. 

Hatch Mode: 

  

Determines how to process DXF "Solid" hatches:  

Ignore: All Solid Hatches will be omitted. 

Normal: All Solid Hatches will be included. 

Use De-Embedding: All holes in Solid Hatches will be separated and 
formed into a respective composite. 

Arc Resolution (Degrees): Accuracy used when mapping points to recreate arcs & circles. 

Default Line Width: 

  

All 0-width DXF entities (such as lines, arcs, 0-width polylines) will be 
assigned this physical width (if they do not form a filled-polygon).  

Flash Circle/Rects Less Than: 

  

All detected Circles & Rectangle shapes will only be flashed in their 
bounding width & length are less than this value. (For Gerber Export 
Only) 

 Import DXF Layers: 

Import: 

  

If "checked" this layer will be imported. If "unchecked", this layer will 
be omitted. 

DXF Layer Name:  The DXF layer name.  This is merely for reference, and cannot be 
changed. 

Fill: 

  

If "checked", all closed boundaries for this layer will become filled 
polygons.  If "unchecked", all closed boundaries for this layer will be 
open paths, and use the Default Line Width.  

Polyline: 

  

This setting controls the End caps for open-polylines with width on 
this layer. 

Truncate: Square End cap, no extension. 

Extend: Square End cap, 1/2 width extension. 

Round: Round End cap, 1/2 width extension. 
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Auto-Flash: 

  

If "checked", all Rectangles and Circles on this layer, which are 
smaller than the setting "Flash Circle/Rects Less Than", will be 
converted to Gerber Flashes. (For Gerber Export Only) 

Comp: 

  

If non-zero, apply the offset-compensation to all resulting boundaries 
on this layer. 

 Import DXF Blocks: 

Import: 

  

If "checked" this block will be imported. If "unchecked", this block will 
be omitted. 

DXF Layer Name: 

  

The DXF block name.  This is merely for reference, and cannot be 
changed. 

Import DXF Styles: 

DXF Style: 

  

The DXF style name.  This is merely for reference, and cannot be 
changed. 

FAB 3000 Font File: 

  

Choose which Pre-Compiled FAB 3000 Font File to use from the pull-
down.  All FAB 3000 Font files are derived from TrueType fonts 
respectively.  You may compile a FAB 3000 Font file from any 
TrueType font. 

Default Text Style: 

  

Assign the default FAB 3000 Font to use when an associated DXF font 
file cannot not be determined or located. 

Text Line Width/Fill Method: 

  

The setting controls the DXF Text Line Width & Filling options: 

Use Polygon Fill: All Text will be filled as polygons. Their widths are 
already determined in the FAB 3000 font file itself. 

Use Same Line Width for All: Determine a standard line width to be 
used for all DXF text. 

Use Ration: The text line width will be determined by a ratio of the 
text height divided by your supplied value. 

Import DXF Merge: 

Merge Name: 

  

The output name to be used for the merged layer. 
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Layers (Click to Add): 

  

Select all DXF Layers that will be included in this merged layer. 

New: 

  

Create a new "empty" merge layer. 

Delete: 

  

Delete an existing merge layer. 

Output Merged Layers Only: 

  

Do not output any individual DXF layers, only the merged layers will 
be created. 

Import DXF Open/Save: 

Open DXF Settings: This (Optional) feature allows you to open an existing DXF Settings 
file (*.ds), so that you may assign the exact same settings used 
previously.  If you regularly perform DXF conversions re-using the DXF 
settings will save time and limit mistakes. 

Save DXF Settings: 

  

This (Optional) feature allows you to save your DXF Settings to a file 
(*.ds), so that you may re-use these same settings at a later date. If 
you regularly perform DXF conversions re-using the DXF settings will 
save time and limit mistakes. 

 

File > Import > Image  

FAB 3000 will import images 

from .TIFF, .JPG, .BMP, 

& .GIF file types into a 

workspace.  
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To import an image file into the workspace, perform the following: 

1. Select File > Import > Image. 

2. Choose the images you would like to import and select OK. The Import Image wizard dialog box will 

 appear. 

 a. To select more than one image file to import, hold either the Shift or Ctrl key.  

3. Select the Pixel Size from the dropdown menu. 

4. Select the units from the dropdown menu. Units are in Meter, Mil, Inch, Millimeter, Centimeter and 

 DPI. 

5. Choose an Image Background Color of either white or black.  

 a. Background color and intensity allow “grey” pixels similar to that of the background color to 

  be treated as such. As a result, this helps with  automatic recognition of features. 

6. Choose the Background Intensity (1-100).  

 a. Try experimenting by adjusting this setting for optimum results.  

7. Select Next to begin import.  

Once the import is complete, the import wizard dialog box will disappear unless FAB 3000 encounters any 
errors or warnings during import. If there are any issues, FAB 3000 will display them  within the wizard 
dialog box.  

Import Image (TIFF, JPEG, BMP, GIF) Options: 

Pixel Unit: 

  

Specify the proposed units for each pixels physical size. Choose from 
Micron, Inch, Millimeter, Centimeter, and more. 

Pixel Size: 

  

Logical pixel size defined by Pixel Units * Pixel Size 

Image Background Color: 

  

Select the image's transparent color that will be ignored during 
importing.  Choose either Black or White. 

Background Intensity (1-100): 

  

Images such as JPEG's incorporate a type of blending which leads to 
very few pixels actually being black or white. This setting is a ratio 
which allows pixels with colors similar to the transparent color to be 
treated as such.  This setting has proved very useful for "inspection 
tools" which take photos of microscopic devices, and output them as 
jpegs; and then want these photos converted back to GDSII or Gerber 
for comparison purposes. 
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Merge Adjacent Pixels: For Advanced Users Only. This option will combine adjacent pixels to 
form polygons.  This feature is very time consuming and not 
recommend for use with complex images. 

 

File > Import > HPGL/2  

FAB 3000 is also capable of importing HPGL/2 files.  

 

 

 

 

 

 

 

 

 

 

 

 

To import HPGL/2 files, perform the following: 

1.  Select File > Import > HPGL/2.  

2.  Select the HPGL/2 files you want to import. Select OK. The Import HPGL/2 wizard dialog box will 

 appear.  

 a. To select more than one HPGL/2 file, hold down the Shift or Ctrl key.  

3. Optional: Select whether you want to scale the entire file. Use Scale Factor and enter a value for 

 scale size. 

4. Select Next to begin importing HPGL/2 files.  

Once the import is complete, the import wizard dialog box will disappear unless FAB 3000 encounters any 
errors or warnings during import. If there are any issues, FAB 3000 will display them  within the wizard 
dialog box.  
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Import HPGL/2 Options: 

Scale Factor   

Assign HPGL/2 Scale factor (default is 1). 

 

File > Import > Postscript/PDF 

This allows you to import 

a Postscript or PDF file 

into an active workspace. 

 

 

 

 

 

 

 

 

 

Note: Ghostscript is required on your workstation or server in order to import Postscript. It is freely 
available and distributed under the GNU General Public License.  If you do not have Ghostscript installed 
you may download it from the following websites (or from other available mirrors): 

http://www.cs.wisc.edu/~ghost/doc/gnu/index.htm 

http://www.ghostscript.com/ 

To import a Postscript or PDF file, perform the following: 

1. Select File > Import > Postscript/PDF. 

2. Choose the Postscript or PDF file you want to import. Select OK.  

3. Edit and verify the options in the dialog box.  
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Once the import is complete, the import wizard dialog box will disappear unless FAB 3000 encounters any 
errors or warnings during import. If there are any issues, FAB 3000 will display them  within the wizard 
dialog box. 

Import Postscript/PDF Options 

Page Number to Convert: 

  

Select the page number to convert.  Many Postscript and PDF files 
have multiple pages.  The importer will only import one page at a 
time. Usually the first page. 

Spline/Arc DeViation (mil): Approximation accuracy to use for Arcs and Spline objects. 

Map Layers:  

Convert Paths to:  

Fill Area Mode:  

Flash Round & Rect Shapes: Convert round and rectangular objects to flashes.  This results in a 
more optimized data. 

Text Output:  

Default FAB 3000 Font:  

Ghostscript Additional Options: Assign specific Ghostscript options.  Requires knowledge of the 
Ghostscript interpreter. 

 

 

    Video: Convert PDF to Gerber & Drill – Part 1 

Video: Convert PDF to Gerber & Drill – Part 2 

   Video: Convert PDF to PCB Gerber Data – Avoid Raster PDF Files 

     Video: Import PDF and Export to Gerber 

     Video: PDF to Gerber Conversion 

 

 

 

 

http://www.youtube.com/watch?v=toCaUFRj0UU
http://www.youtube.com/watch?v=tEVu1ATz-sE
http://www.youtube.com/watch?v=OYGJ-N3mrsc
http://www.youtube.com/watch?v=voIlnDGtlJg
http://www.youtube.com/watch?v=5EjqnHtSzzU
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File > Import > Large Bitmap  

 

 

 

 

 

 

 

 

 

 

 

 

To import a Large Bitmap file into the workspace, perform the following: 

1. Select File > Import > Large Bitmap. 

2. Choose the images you would like to import and select OK. The Import Image wizard dialog box will 

 appear. 

  a. To select more than one image file to import, hold either the Shift or Ctrl key.  

3. Select the Pixel Size from the dropdown menu. 

4. Select the units from the dropdown menu. Units are in Meter, Mil, Inch, Millimeter, Centimeter and 

 DPI. 

5. Choose an Image Background Color of either white or black.  

  a. Background color and intensity allow “grey” pixels similar to that of the background  

   color to be treated as such. As a result, this helps with automatic recognition of  

   features. 

6. Choose the Background Intensity (1-100).  

  a. Try experimenting by adjusting this setting for optimum results.  

7. Select Next to begin import.  
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Once the import is complete, the import wizard dialog box will disappear unless FAB 3000 encounters any 
errors or warnings during import. If there are any issues, FAB 3000 will display them  within the wizard 
dialog box.  

Import Image (TIFF, JPEG, BMP, GIF) Options: 

Pixel Unit: 

  

Specify the proposed units for each pixels physical size. Choose from 
Micron, Inch, Millimeter, Centimeter, and more. 

Pixel Size: 

  

Logical pixel size defined by Pixel Units * Pixel Size 

Image Background Color: 

  

Select the image's transparent color that will be ignored during 
importing.  Choose either Black or White. 

Background Intensity (1-100): 

  

Images such as JPEG's incorporate a type of blending which leads to 
very few pixels actually being black or white. This setting is a ratio 
which allows pixels with colors similar to the transparent color to be 
treated as such.  This setting has proved very useful for "inspection 
tools" which take photos of microscopic devices, and output them as 
jpegs; and then want these photos converted back to GDSII or Gerber 
for comparison purposes. 

Merge Adjacent Pixels: For Advanced Users Only. This option will combine adjacent pixels to 
form polygons.  This feature is very time consuming and not 
recommend for use with complex images. 
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File > Import > STL  

FAB 3000 imports 

stereolithography files 

with ease. Whether you’re 

a designer, manufacturer, 

or 3D printer, you can 

import .STL files into the 

workspace.  

 

 

 

 

 

 

 

 

To import .STL files into FAB 3000, perform the following: 

1. Select File > Import > STL (3D). 

2. Choose the STL file you want to import. Select OK. The Import STL wizard dialog box will appear. 

3. Edit and verify the Units, Scale Factor, Output Type, and Flash Round/Rect Shapes. 

Once the import is complete, the import wizard dialog box will disappear unless FAB 3000 encounters any 
errors or warnings during import. If there are any issues, FAB 3000 will display them  within the wizard 
dialog box.  

Import STL (3D) Options: 

Units: Choose the units for the imported STL. 

Scale Factor: Logical pixel size defined by Units * Scale Factor 

Output Type: Output STL boundaries as Filled Polygon, or Outlined. 

Flash Round & Rect Shapes: Convert round and rectangular objects to flashes.  This results in a 
more optimized data. 
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File > Import > GDSII  (Stream) 

Loads GDSII binary format into the active workspace. 

1. Select File > Import > GDSII (Stream). 

2. Choose the file you wish to import.  

3. Select OK.   

File > Import > Part Centroid  

Part Centroid files are 

ASCII formatted files 

that contain centroid 

data. Centroid files are 

commonly separated by 

comma or tab.  

FAB 3000 loads Part 

Centroid files into a 

spreadsheet for editing.  
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To import a Part Centroid file, perform the following: 

1. Select File > Import > Part Centroid. 

2. Choose the Centroid file you want to import. Select OK. 

3. Choose the separation character you will use for the import. This will be either Comma, Semicolon, 

 Tab or Whitespace. Select OK when complete. 

The centroid file will now be imported and displayed in a grid table.  

4. Assign the "Ref. Des" column variable, by clicking into a cell that contains the Reference Designators 
 and choose menu item: "Column: Ref. Des" 

You will now see at the top of the column a check mark and the title REFDES.  This lets you know that the 
Ref Des column has been assigned.  

5.  Assign the "Layer" column variable, by clicking into a cell that contains the Layer (usually labeled 
 either: Top or Bottom) and choose menu item: "Column: Layer" 

You will now see at the top of the column a check mark and the title LAYER.  This lets you know that the 
Layer column has been assigned. 

6.  Assign the "X" column variable, by clicking into a cell that contains the X coordinate and choose 
 menu item: "Column: X Location" 

You will now see at the top of the column a check mark and the title X.  This lets you know that the X column 
has been assigned. 

 7.  Assign the "Y" column variable, by clicking into a cell that contains the Y coordinate and choose 
 menu item: "Column: Y Location" 

You will now see at the top of the column a check mark and the title Y.  This lets you know that the Y column 
has been assigned. 

8.  Assign the "Rotation" column variable, by clicking into a cell that contains the part rotation and 
 choose menu item: "Column: Rotation" 

You will now see at the top of the column a check mark and the title ROT.  This lets you know that the 
rotation column has been assigned.  

9.  Assign the "Start Row" column variable, by clicking into a cell that contains the first centroid 
 definition and choose menu item: "Start Row" 

You will now see at the left of the row a check mark and the title ST.  This lets you know that the start row 
has been assigned. 
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10.  Assign the "End Row" column variable, by scrolling down & clicking into a cell that contains the last 
 centroid definition and choose menu item: "End Row" 

You will now see at the left of the row a check mark and the title END.  This lets you know that the start row 
has been assigned. 

11.  Verify the Import Units (located in the Lower/Left) used for the X & Y Coordinates. 

12.  Press "OK" to begin importing the centroid file. 

13.  Once the Centroid loading is complete, a dialog will appear giving you the count & status. 

You will now see the external 
centroid data displayed in the FAB 
3000 screen. To control the display of 
the external centroid files, select 
View > External Controls. 

 

  

 

 

 

 

 

File > Import > BOM File  

Loads a Bill of Materials File into the active workspace. 

1. Select File > Import > BOM File 

2. Choose the file you wish to import.  

3. Select OK.   
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File > Import > Aperture List  

FAB 3000 can import an aperture list in various 

formats.  

The loaded file overwrites the current aperture 
data, and there is no Dcode translation.  In most 
cases you will want to use this feature for loading 
specific aperture files that do not load using 
Autoload Gerber Wizard.  

FAB 3000 does not detect the aperture list format 
using this command, so you must also define which 
Aperture Wizard Rule to use during import. 

Import Aperture List provides an excellent way to 
debug Aperture Wizard Rules that you have 
created with the Aperture Rules Editor.  To verify 

results of a newly created Aperture Wizard Rule: Create a new Job, Import the aperture list, and review the 
Aperture Table. To import an aperture list, perform the following: 

1. Select File > Import > Aperture List. 

2. Choose the Aperture files you want to import. Select OK.  

 The Import Aperture List dialog box will appear. 

3. Select the Aperture Rule to use while importing the Aperture List.  

4. Select OK to begin importing the Aperture file. 

Once the import is complete, the import dialog box will disappear unless FAB 3000 encounters any errors or 
warnings during import. If there are any issues, FAB 3000 will display them within the dialog box.  

File > Import > Custom Aperture Library  

With FAB 3000, Custom Aperture Libraries can be imported into an active workspace. 

Select File > Import > Custom Aperture Library. 

2. Choose the file you wish to import.  

3. Select OK to begin importing the Custom Aperture Library file.  
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  Forum: How do I delete unwanted aperture rules? 

 Video: Reading Old Aperture Files 

            Video: Create Aperture List Reader for RS-274D Gerber Files 

File > Import > Footprints Library  

With FAB 3000, Footprints Library Files can be imported into an active workspace. 

Select File > Import > Footprints Library. 

2. Choose the file you wish to import.  

3. Select OK to begin importing the Footprints Library file.  

File > Import > Text File  

With FAB 3000, Text Files can be imported into an active workspace. 

1. Select File > Import > Text File. 

2. Choose the file you wish to import.  

3. Select OK to begin importing the Text File. 

The Text File will be created as a separate tab in the workspace and listed in 

the Tab Editor.   

File > Import > Spreadsheet File  

1. Select File > Import > Spreadsheet File. 

2. Choose the file you wish to import.  

3. Choose the separation character you will use 

 for the import. This will be either Comma, 

 Tab, Space, or Semicolon. Select OK when 

 complete. 

4. Select OK to begin importing the Spreadsheet 

File.  

 

 

http://forums.numericalinnovations.com/post/how-do-i-delete-unwanted-aperture-rules-5066956
http://www.youtube.com/watch?v=xOrwCRAAAzo
http://www.youtube.com/watch?v=R9CPS2Cr-Mc
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The Spreadsheet File will be created as a separate tab in the workspace and listed in the Tab Editor.  

 

File > Import > FAB 3000 Matrix 

The FAB 3000 Import Matrix File permits external tools (like PCB Design software) to predefine layers and 
Jobs for intelligent loading into FAB 3000 for instant Gerber Viewing & Verification.  This prevents the 
monotonous steps of loading Gerber & Drill files, assigning layer colors, assigning layer types, defining layer 
stack ups, defining blind/buried drill layers (if required), etc.; allowing PCB designers to easily use 
Gerber/CAM software for its primary purpose: to quickly verify their Gerber & Drill files are correct and 
ready for manufacturing.  

The FAB 3000 Import Matrix file also supports PANEL arrays which allow the merging of several PCB Jobs 
together so they can be manufactured simultaneously - saving $$$ on fabrication costs. In addition, FAB 
3000 will automatically performs all necessary object transformations, Dcode & drill tool transcoding. 

Loads a FAB 3000 Matrix File into the active workspace. 

1. Select File > Import > FAB 3000 Matrix. 

2. Choose the file you wish to import.  

3. Select OK.   

Note: Simply call FAB 3000 and pass the matrix file as the first argument. All FAB 3000 Import Matrix files 

must end with *.FM6. 

 

 Video: FAB 3000 Transcode Technique when Loading Multiple Drill and Gerber Files 

 

 

 

 

 

 

 

http://www.youtube.com/watch?v=pDoAHKA4Vzk&feature=c4-overview&list=UU5EDrHeKZ833JCnxuFaquUg
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File >Export 

 

 

The following file types are possible using File > Export:  

Gerber     HPGL/2 

Drill     Centroid File 

Rout/Mill    BOM File 

Export PCB    IGES 

ODB ++     STL (3D) 

Netlist (IPC-D-356/A)   PostScript 

DXF/DWG    Custom Aperture Library 

GDS-II (Stream)   Footprints Library 

Large Monochrome Bitmap 
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File > Export > Gerber  

Gerber files exported from FAB 

3000 are fully compatible with 

the Gerber specification and 

support polygon fills, composite 

images, step and repeat codes, 

and more. To export Gerber 

files, perform the following: 

1.  Select File > Export > 
Gerber.  The Export Gerber 
Wizard dialog box appears. 

2.  Verify the Export Gerber file 
options you want to use. 

 

 

   

3. Select Next to proceed to the 
Layer Options dialog box.  

To improve Gerber file accuracy 
you should select decimal digits 
of 4 (or higher). 

For description of each option, 
see next page: Export Gerber 
Options 

3. If the filenames for the layers 
need to be changed, type-in the 
desired filename in the text 
boxes. 

  

4.  Using the check boxes in the Export column, select or unselect the layers you want to export. To Set 
 all or clear all layers, right-click within the Export column. 
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5.  If you want any of the layers to have a negative polarity, select the check box for the appropriate 
 layer(s) in the Neg column.  

6. If you want to mirror any of your layers upon export, select the appropriate check boxes in the 
 Mirror column. 

  a. Polarity and Mirroring options apply only to 274X, Fire 9xxx, Barco & Gerber   
   files.  FAB 3000 will display Negative Layers but not the Mirroring    
   option on files re-imported using AutoLoad Gerber or Gerber Import will display as  
   normal, but retain their option codes in the Layers table. 

   b. If the layers previously contain Mirror or Polarity options, they will automatically be  
   checked off in  the Layer Options.  

   c. Each selected layer will be exported as an individual Gerber file. 

7.  Select the folder for Gerber export.  

  

  If you select a new folder that does not exist on your system, it will be automatically created.  It is 
 recommended that you select a single folder to export all of your files into (i.e. Gerbers, drill, 
Netlist,  notes, fab drawing, etc.)  

  a. If you would like to always export your files to a specific folder, you may define the  
   "Export Folder" in the FAB 3000 Settings Dialog. 

 

Video: Easily Convert DXF Files to Gerber 

http://www.youtube.com/watch?v=1e1igE30nlw
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8.  Click OK to begin exporting 
your Gerber files. 

9.  Once export Gerber is 
complete, a Status & Import 
log are available for your 
review.  If FAB 3000 encounters 
any errors or warnings during 
export, they will be displayed 
here.  

10. Select Finish to exit. 

 

 

 

 

Export Gerber Options: 

Export Gerber Format: Select Gerber format to export. Either RS-274-X or Fire9000. 

Units:  Determine exported Gerbers units of English or Metric. 

Integer Digits: Determine exported Gerbers integer digits between (0-6). 

Decimal Digits: Determine exported Gerbers integer digits between (0-6). 

Type: Determine exported Gerbers type of Absolute or Incremental. 

Zero Suppression: Determine exported Gerbers zero suppression of Leading, Trailing, or 
None. 

Use Step/Repeat: Use Step & Repeat codes if possible. 

Use Arcs (G75): Use arcs when available. 

Line Width (mil): Default line width to assign for 0-width objects such as lines, arcs, 
etc. 

Text Fill: 

  

Specify how to output text (if any): 

Line: Text will be exploded and outputted as Gerber traces using the 
Line Width. 

Solid Fill: Text will be exploded, and output as polygons. 

Gerber File Extension: 

  

Default extension to use for exported Gerber file names.  (*.gbr) is 
the default. 
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File > Export > Drill  

To export a Drill file, perform 

the following: 

1. Select File > Export > Drill. 

The Export Drill Wizard dialog 

box will appear. 

2. Verify the Export Drill file 

options you want to use.  

3.  Select Next. The Layer 

Options dialog box will 

appear. To improve drill file 

accuracy you should select 

decimal digits of 4 or higher.  

See the next page for a 

selection of Export Drill 

options. 

 

4. Using the check boxes in 

the Export column, select or 

deselect the layers you want 

to export. To set or clear all 

layers, right click within the 

Export column. 

 

 

 

 

 

 

 

5.  Select Next. Choose a folder to export drill files to.  

 a. If you select a new folder that does not exist on your system, it will be automatically   

  created.  It is recommended that you select a single folder to export all your files into (i.e.  

  Gerbers, drill, Netlist, notes, fab drawing, etc.)  
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  If you would like to always export your files to a specific folder, you may define the "Export  
  Folder" in the FAB 3000 Settings Dialog.  

6. Select Next to begin exporting your drill files.  

7.  Once export drill is complete, 
 a Status & Import log are 
 available for your review.  If 
 FAB 3000 encounters any 
 errors or warnings during 
 export, they will be displayed 
 here. 

8.  Select Finish to exit. 

 

 

 

 

 

 

Export Drill Options 

Units: Determine exported NC Drill units of English or Metric. 

Integer Digits: Determine exported NC Drill integer digits between (0-6). 

Decimal Digits: Determine exported NC Drill integer digits between (0-6). 

Type: Determine exported NC Drill type of Absolute or Incremental. 

Zero Suppression: Determine exported NC Drill zero suppression of Leading, Trailing, or 
None. 

Use Step/Repeat: Use Step & Repeat codes if possible. 

NC Drill File Extension: Default extension to use for exported NC Drill file names.  (*.drl) is 
the default. 
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File > Export > Rout / Mill  

The Export > Rout/Mill 

command is used to export 

layers into a Rout file.  

1. Select File > Export > 

 Rout. The Export Rout 

 wizard dialog box will 

 appear. 

2. Verify the Rout 

 options you to want to 

 use and select Next. 

 The Layer options 

 dialog box will appear. 

For a description of Export 

Rout Options, see next 

page.  

 

To improve accuracy, you should select decimal digits of 4 or higher.  

3. If the filenames for the 

 layers need to be 

 changed, type-in the 

 desired filename in the 

 text boxes. 

4. Using the check boxes 
 in the Export column, 
 select or unselect the 
 layers that you want 
 to export. To set or 
 clear all layers, right 
 click within the Export 
 column. 

5.  Select Next. A folder 
 dialog box will appear. 
 Choose a folder to 
 export rout files to. 
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If you select a new folder that does not exist on your system, it will be automatically created.  It is 
recommended that you select a single folder to export all your files into (i.e. Gerbers, drill, Netlist, notes, 
fab drawing, etc.)  

If you would like to always export your files to a specific folder, you may define the "Export Folder" in the 
FAB 3000 Settings Dialog. 

 6. Select OK to begin exporting your rout files. 

 

7. Once export rout is complete, a Status & Import log are available for your review.  If FAB 3000 
 encounters any errors or warnings during export, they will be displayed here. 

8.  Select Finish to exit. 
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Export Rout Options 

Units:  Determine exported NC units of English or Metric. 

Integer Digits:  Determine exported NC integer digits between (0-6). 

Decimal Digits: Determine exported NC integer digits between (0-6). 

Type: Determine exported NC type of Absolute or Incremental. 

Zero Suppression: Determine exported NC zero suppression of Leading, Trailing, or 
None. 

Use Step/Repeat: Use Step & Repeat codes if possible. 

NC Rout File Extension: Default extension to use for exported NC Rout file names.  (*.rou) is 
the default. 

File > Export PCB  

Using Export > PCB allows 
you to export your data in 
both Gerber and Drill formats 
simultaneously.  

 

 

 

 

 

 

 

 

1. Select File > Export > PCB 

2. Verify Gerber & Drill options using the tabs within the dialog box wizard.  

3. Choose which reports will be included in the export using the Reports tab.   

 To improve accuracy, enter a value of 4 or higher under Decimal Digits. 

4. Select Next.  You will then proceed to the Layer Options tab.  
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5.  Assign Layer options. 

 Use the check box to 

 select which layer will 

 be exported as a 

 Gerber or NC Drill file. 

 To select or deselect 

 all checkboxes, right 

 click within the Export 

 column. 

 

 

 

 

  

 

6. Select Next. A Browse Folder dialog box will appear. Choose a folder to export to.  

7.  Select OK. 

8. Once export is complete, a Status & Import log are available for your review.  If FAB 3000 
 encounters any errors or warnings during export, they will be displayed here. 
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File > Export > ODB++  

1. Select File > Export > ODB++.  
  This writes an ODB++   
  database to an external file  
  system.  

The ODB++ Matrix requires layers to 
have their types (i.e. Top, Bottom, 
Silkscreen, etc.) and sequence order 
(i.e. layer stackup) defined before 
exporting.  To define both Layer Types 
& Stackup go to the Layers Table (File 
> Setup > Layers Table) before 
exporting ODB++ data 

2.   Select Next. 

 

 

3. Assign Layer options. Use the 
 check box to select which 
 layers will be exported. To 
 select or deselect all 
 checkboxes, right click within 
 the Export column. 

4.  Select Next. A Browse Folder 
 dialog box will appear. Choose 
 a folder to export to. 

5.  Select OK. 

 

 

 

6. Once export is complete, a Status & Import log are available for your review.  If FAB 3000 
 encounters any errors or warnings during export, they will be displayed here. 
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File > Export > Netlist (IPC-D-35G/A) 

To export a Netlist, perform the 
following: 

1. File > Export > Netlist (IPC-D- 
  35G/A). The Export Netlist  
  Wizard dialog box appears. 

2. Verify the Export Netlist  
  Options you want to use. For a 
  complete list of options, see  
  Export Netlist Options below. 

3. Choose a Netlist file to create.  
  If you would like to always  
  export your files to a specific  
  folder, you may define the  

          Export Folder in the FAB  
          3000 Settings Dialog. 

4. Select OK to begin exporting your Netlist file. 

5. Once export Netlist is complete, a Status & Import log are available for your review.  If FAB 3000 
 encounters any errors or warnings during export, they will be displayed here. 

6. Click Finish.  

Export Netlist Options 

Netlist Format:  Choose export Netlist format: IPC-D-356, IPC-D-356A formats. 

Method:  Choose point method to use: All Points or End Points Only 

Sides: Determine Side to use: Top Only, Bottom Only, Top and Bottom 

Assign Unused Nets: Include Unused nets 

Output Adjacency Info: Include Adjacency Info. 

Adjacency Distance: Choose Adjacency distance. 
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File > Export > DXF/DWG  

This command is used to 
export data into a DXF or 
AutoCAD DWG file. DWG 
files are the binary 
equivalent of DXF. 

1. Select File > Export >  
 DXF. The DXF Wizard 
 dialog box will appear.  

2. Verify the Export DXF 
 file options you want 
 to use. For a 
 description of DXF 
 Layer options see 
 next page: Export DXF 
 Options. 

  

The DXF format has undergone many version changes in the past 5-10 years, and some older systems may 
not be able to read newer DXF files.  If this is the case, try selecting an older DXF format under Output 
Format. 

3. Select Next. 

4.  The layer options dialog box 
 will appear. If a layer needs 
 to be changed, type in the 
 desired filename within the 
 text entry boxes. 

5. Select Next. A file dialog box 
 will appear. 

6. Choose the DXF file to create 
 from the file dialog box. If   
 you would like to always 
 export your files to a specific 
 folder, you may define the 
 Export Folder in the FAB 
 3000 settings dialog under 
 File > Setup > General. 
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7. Click Save.  

8. Once export DXF is complete, a Status & Import log are available for your review.  If FAB 3000 
 encounters any errors or warnings during export, they will be displayed here. 

9. Select Finish.  

 

 

 

 

 

 

 

 

 

 

 

Export DXF Options: 

Text Output: 

  

Specify how to output DXF text (if any): 

Standard: Text will be outputted as DXF text. 

Ignore: Text will be omitted from the DXF file. 

Explode: Text will be exploded, and output as polygons. 

Explode Array Instances: Convert Array instances to individual instances. 

Output Paths as Boundaries: Create polygon outlines for all paths. 

Fill Option: 

 

 

 

For documentation purposes it can be desired to have the DXF file 
appear exactly the same as a Gerber file (i.e. filled polygons, 
composites).  

None:  Export with Geometries, No Filling (Default) 

Using Solid Hatch:  Export with Geometries, Fill using Solid Hatch 
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Fill Options (cont.) Using Solid Hatch (Only): Export No Geometries, Fill using Solid Hatch 

Using Multiple Solids: Export Geometries, Fill using solid triangles 

Using Multiple Solids (Only): Export No Geometries, Fill using solid 
triangles 

 

Forum:  Export a DXF File from FAB 3000 

 

File > Export > GDS-II 

This command writes a 

GDS-II stream file to an 

external file system. 

1. Select File > Export > 

 GDS-II. 

2. Verify and Edit GDS-II 

 Options for Explode 

 Text and Assign UNIX 

 Naming Conventions. 

3. Select Next. 

4. The layer options 

 dialog box will  appear. 

 If a layer needs to be 

 changed, type in the 

 desired filename 

 within the text entry 

 boxes. 

5. Select Next. A file dialog box  will appear. 

6. Choose the GDS-II file to create from the file dialog box. If   you would like to always export 
 your files to a specific folder, you may define the Export Folder in the FAB 3000 settings  dialog 
 under File > Setup > General. 

7. Click Save.  

8. Once export GDS-II is complete, a Status & Import log are available for your review.  If FAB 3000 
 encounters any errors or warnings during export, they will be displayed here. 

http://forums.numericalinnovations.com/post/export-a-dxf-file-from-fab-3000-6462206
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9. Select Finish. 

File > Export > Large Monochrome Bitmap  

This command writes a large monochrome 

bitmap (any size) file to an external file 

system.  To export a large bitmap, the 

active Job or panel needs to be displayed in 

the "editor", because FAB 3000 requires 

the editor to render the images that will be 

exported. 

1. Select File > Export > Large 

 Monochrome Bitmap. 

2.  Verify and Edit export options. 

3. Select OK. An export folder dialog box will appear. 

4. Choose the export file name for the bitmap. 

5. Select Save.  

File > Export > HPGL/2  

This command exports an 

HPGL/2 file. 

1.  Select File > Export > HPGL/2 

 an Export Wizard dialog box 

 will appear. 

2.  Verify and edit HPGL/2 

 options. For a complete list of 

 options, see HPGL Options on 

 next page. 

3.  Select Next. A layer options 

 dialog box will appear. 

4.  The layer options dialog box  

    will appear. If a layer needs  

    to be changed, type in the  

    desired filename within the  

             text entry boxes. 

5. Select Next. A file dialog box  will appear. 
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6. Choose the HPGL/2 file to create from the file dialog box. If   you would like to always export 
 your files to a specific folder, you may define the Export Folder in the FAB 3000 settings  dialog 
 under File > Setup > General. 

7. Click Save.  

8. Once export HPGL/2 is complete, a Status & Import log are available for your review.  If FAB 3000 
 encounters any errors or warnings during export, they will be displayed here. 

9. Select Finish. 

File > Export > Centroid  

This command is used to 
export data into a Centroid 
file (aka Insertion, Pick-and-
place or XY file). 

You must at least have one 
or more Components 
defined before exporting to a 
centroid file. 

The centroid file is a comma 
separated file that can be 
loaded into almost any 
spreadsheet program or text 
editor. 

 

 

To export a Centroid file, perform the following: 

1. Select File > Export > Centroid File. 

2. Verify and edit Centroid options. For a complete list of options, see Centroid Options on next page. 

3.   Select Next. A layer options dialog box will appear. 
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4.   The layer options dialog box 

 will appear. If a layer needs to 

 be changed, type in the  

 desired filename within the 

 text entry boxes. 

5. Select Next. A file dialog box 
 will appear. 

6. Choose the Centroid file to 
 create from the file dialog 
 box. If   you would like to 
 always export  your files to a 
 specific folder, you may 
 define the Export Folder in  
 the FAB 3000 settings dialog  
 under File > Setup > General. 

File > Export > BOM File  

The Export > BOM File command 

exports a Bill of Materials file.  

To export a BOM file, perform the 

following: 

1. Select File > Export > BOM 

 File. 

2. Verify and edit BOM 

 options. For a complete list of 

 options, see BOM Options 

 on next page. 

3.   Select Next. A file dialog box 
 will appear. 

6. Choose the BOM file to create 

from the file dialog box. If you 

would like to always export your files to a specific folder, you may define the Export Folder in the FAB 3000 

settings dialog under File > Setup > General. 
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File > Export IGES  

The IGES format has undergone many version changes, and some older systems may not be able to read 

newer IGES files.  If this is the case, try selecting the IGES version compatible with your system. 

To export an IGES file, perform the 

following: 

1. Select File > Export > IGES 

2. Verify and Edit IGES 

 Options.  

3. Select Next. 

4. The layer options dialog box 

 will appear. If a layer needs to 

 be changed, type in the 

 desired filename within the 

 text entry boxes. 

 

 

5. Select Next. A file dialog box 

 will appear. 

6. Choose the IGES file to 
 create from the file dialog 
 box. If   you would like to 
 always export  your files to a 
 specific folder, you may 
 define the Export Folder in 
 the FAB 3000 settings 
 dialog  under File > Setup > 
 General. 

7. Click Save.  

 

 

8. Once export IGES is complete,  a Status & Import log are available for your review.  If FAB 3000 
 encounters any errors or warnings during export, they will be displayed here. 
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9. Select Finish. 

Export IGES Options 

IGES Units: 

  

Select the units to use for the exported IGES file.  Choose from Inch, 
Millimeter, Micron, etc. 

Text Output: 

  

Specify how to output IGES text (if any): 

Ignore: Text will be omitted from the IGES file. 

Note (Type 212): Text will be output using IGES type 212. 

Outline (Type 106-63): Text will be exploded, and output using IGES 
Type 106-63. 

Path Output: 

  

Determine how to output paths with non-zero widths. 

Line Weight (106-11): Paths will be output using a centerline and 
single width. 

Outline (Type 106-63): Paths will converted to polygons using the 
IGES Type 106-63. 
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File > Export > STL (3D) 

To export an IGES file, perform the following: 

1. Select File > Export > STL (3D) 

2. Verify and Edit STL 

 options. For a complete list of 

 STL options, see STL Options 

 below. 

3. Select Next. A file dialog box 

 will appear. 

4. Choose the STL file to  save 
 from the file dialog box. If   
 you would like to always 
 export your files to a 
 specific folder, you may 
 define the Export Folder in 
 the FAB 3000 settings 
 dialog under File > Setup > 

          General. 

5.  Select Save. 

 6. Once export STL is complete, an Export Wizard log is available for your review.  If FAB 3000 
 encounters any errors or warnings during export, they will be displayed here. 
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File > Export > Postscript  

This command is used to export layers into PostScript files. To export a Postscript file, perform the 
following: 

1. Select File > Export >  

2. Verify and Edit 

 Postscript Options. For 

 a complete list of 

 options, see Export 

 Postscript Options 

 below. 

3. Select Next. 

4. The layer options 

 dialog box will  appear. 

 If a layer needs to be 

 changed, type in the 

 desired filename 

 within the text  entry 

 boxes. 

 

 

5. Select Next. A file  

 dialog box will appear. 

6. Choose the Postscript 
 file to create from the 
 file dialog box. If   you 
 would like to always  
 export  your files to a  
 specific folder, you  
 may define the  
 Export Folder in the  
 FAB 3000 settings  
 dialog  under File >  
 Setup > General. 

7. Click Save.  
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8. Once export Postscript is complete, an Export Wizard log is available for your review.  If FAB 3000 

 encounters any errors or warnings during export, they will be displayed here. 

Export Postscript Options 

Scale Factor: Determine scale to use for Postscript output.  (In most cases for 
MEMs/EDA masks a factor of 10X is used.) 

Postscript Type: 

  

Select Postscript output type either Standard or Encapsulated.  If you 
are unsure, contact your local graphic expert - in most cases we 
recommend "Encapsulated". 

Line Width (Points): Default line width to assign for 0-width objects such as lines, arcs, etc. 

Text Fill: 

  

Specify how to output text (if any): 

Line: Text will be exploded and outputted as Gerber traces using the 
Line Width. 

Solid Fill: Text will be exploded, and output as polygons. 

 

File > Export > Custom Aperture Library  

This command writes a custom aperture library to an external file system. To export a custom aperture 

library, perform the following: 

1. Select File > Export >  

  Custom Aperture  

  Library. 

2. Verify and Edit   

  Postscript Options. For 

  a complete list of  

  options, see Export   

  Aperture Options  

  on the next page. 

3. Select Next. A file  

  dialog box will appear. 
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6. Choose the Custom Aperture Library file to create from the file dialog box. If you   
 would like to always export your files to a specific folder, you may define the   
 Export Folder in the FAB 3000 settings dialog under File > Setup > General. 

7. Click Save.  

8. Once export Custom Aperture export is complete, an Export Wizard log is available for your 

 review.  If FAB 3000 encounters any errors or warnings during export, they will be displayed here. 

File > Print to PDF (Up to E Size)  

Create professional EDA 

plots in PDF format.  

1. Select File > Print to 

 PDF.  

2. Verify and edit the PDF 

 output options. For a 

 definition of each 

 option see 

 Printer/Page Setup 

 Options below. 

 

 

 

 

Printer/Page Setup Options 

Paper Size Location of outputted PDF file. 

Paper Size 

  

Size of outputted document.  

A-Size (8 1/2" x 11") (A4)  

B-Size (11" x 17") (A3)  

C-Size (17" x 22") (A2)  

D-Size (22" x 34") (A1)  

E-Size (34" x 44") (A0)  
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Page Layout Choose either portrait or landscape. 

Plot Color 

  

Choose either black and white or color. Available sizes are 300, 600, 
900, 1200, or 2400 DPI. 

Plot Area Choose either extents or display. 

Scale Choose either Fit to Page or User Defined Scale. 

User Scale If User Defined Scale is selected, this box will allow you to input a 
custom scale. 

Map Layers Select one page for all layers, a separate PDF for each layer, or a 
separate page for each layer. 

 

3.  In the same wizard dialog box, 

you may also choose advanced 

options by selecting the 

Advanced Options button. 

4. For a complete definition of 

Advanced Options, see below. 

 

 

 

 

 

Advanced Options 

Advanced options are additional options to determine proper dimensions and positioning of your plot. 

Double click any of these boxes to edit.  

 a.  Top Margin (in): Spacing on the top of the page. 

 b. Bottom Margin (in): Spacing on the bottom of the page. 

 c. Left Margin (in): Spacing on the left of the page. 

 d. Right Margin (in): Spacing on the right of the page. 

 e. Center Image on Page: If unchecked, image will be placed using Left, and Bottom   
  margins. If checked, the image is centered. 
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 f. Smart Detail (Points): This powerful feature optimizes the plotter output, by omitting  
  any objects whose overall size is smaller than this value. In most cases, small  details  are not 
  visible  when they are printed onto paper; so it serves no purpose to  include its' data in the  
  plot. The result is a much smaller, easier to manage plot output. The units for Smart   
  Detail are in points (1/72 Inch).  

 g. Use Compression (FLATE): Most PDF files that are created use compression to keep the file  

  size small.  However compressing a large or detailed PDF file can be very memory intensive,  

  so in some cases it can be easier to work with an uncompressed PDF file.  Although the  

  uncompressed pdf file is extremely large (800mb for E-Size plots), Adobe's PDF Viewer  

  actually reads these files faster because it is not required to also decompress these   

  file.  These large uncompressed PDF files can also be externally compressed with zip, tar.gz,  

  etc. for backing up, sharing via network or internet. 

5. Select Next.  

6. The Plot Features dialog box will appear. Edit and verify plot features. 

 

Add Layer Legend: Include a Layer Legend on the plot. A layer legend includes layer number, layer color & 

fill for each layer used on the plot.  

 Add Ruler (Horizontal/Vertical): Include a horizontal & vertical ruler on the plot, located on the Left & 
Bottom sides. The ruler consists of a horizontal or vertical reference line with numbered ticks.  

 Ruler "Tick" Spacing: Spacing used between ruler Ticks.  
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Display Ruler Dimensions: Determine whether to number each tick on the ruler.  

 Add Plot Header: Include standard information regarding the plot (Library/design, Scale, Plot Time, etc.)  

 Additional Text in Plot Header: Include specific or custom plot information.  

7. Select Next. A preview 
 window will appear. 
 Review the PDF 
 output. If there are 
 any potential 
 problems, and warning 
 will be placed under 
 the preview image. If 
 everything looks fine, 
 selecting next will 
 begin the creation of 
 the PDF file.  

 

 

 

 

 

8. Select Finish. FAB 3000 will begin the PDF 

 conversion.  

9. To view the PDF output, select View PDF. The 

 PDF file will open in Adobe Reader.  

 When selecting View PDF, the dialog box will 

 automatically close. 

 PDF creation is very memory intensive (due to 

 image compression).  Recommend at least 1-2 

 GB memory for creating large 'E' Size Plots. 
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   Forum: Plot to PDF (up to E size) 

Forum: Output a PDF file with each layer on a separate page 

 

File > Plot to Image  

Plot to Image writes an image file (.TIIF, .PNG, .BMP, .GIF, etc.) to an external file system. To export an 

image, the active Job or panel needs to be displayed in the editor. FAB 3000 requires the editor to render 

the images that will be exported. The maximum image width is 3000 pixels. To export a larger bitmap file, 

use File > Export > Large Monochrome Bitmap. 

To export an image, perform the following: 

1. Activate the editor and display the Job you 

 want to export to an image. 

2. Select File > Export > Plot to Image.  

 a. Choose the Image Format in the pull down 

 menu. 

 b. Choose the Image Area. 

 c. Choose the Image Width (Pixels). 

3.  Select OK. The file browser dialog box will appear. 

4. Choose the file name and & path for the image. 

File > Recent Workspaces 

When selecting Recent Workspaces, this will provide you with a list of the most recently accessed 

workspaces.  

File > Exit 

Closes FAB 3000. If any data is unsaved, a dialog box will prompt you to save your files before closing. 

 

 

 

 

 

 

http://forums.numericalinnovations.com/post/print-to-pdf-up-to-e-size-6388494
http://forums.numericalinnovations.com/post/is-it-possible-to-get-fab-it-to-output-a-pdf-file-with-each-layer-2509972
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5.2 EDIT MENU 

The Edit Menu is responsible for any changes, modifications, deletions or 

copies of your design. 

Edit > Undo  

Undo the last command in the editor. 

Edit > Redo  

Redo the last command in the editor. 

Edit > Clipboard  

 Allows you to Cut, Copy, and Paste objects from the clipboard. This clipboard is 

different from an OS 

clipboard (i.e. Windows 

clipboard), because it 

allows you to cut, copy, and 

paste objects between 

different Jobs in FAB 3000. This feature is very useful for merging parts of 

different Jobs together to build new Jobs. 

 

Edit > Selection  

Performs a number of selection actions within the FAB 3000 editor. 

Edit > Selection > All  

Selects all objects in the editor. 

Edit > Selection > Display  

Selects objects that are  

          currently displayed. This  

          command will automatically 

          place the editor in Select  

          Mode. 

Edit > Selection > Window  

Select objects inside a user defined window.  

To select via window: 

 a. Select Edit > Selection > Window. 
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 b. Pick a first point. Press left mouse button down and hold. 

 c. Drag the mouse to the opposite corner of the selection window. Release the left mouse      

button. 

The selection window requires that you pick the first point and drag across the screen, while holding the 
left-button down. When you release the left-button, all objects that completely fit inside the defined 
window are selected. This command will automatically place the CAM editor in Select Mode. 

Edit > Selection > Crossing Window  

Select objects inside and intersecting a user defined window. 

a. Select Edit > Selection > Crossing Window. 

b. Pick a first point. Press left mouse button down and hold. 

c. Drag the mouse to the opposite corner of the selection window. Release the left mouse button. 

The selection window requires that you pick the first point and drag across the screen, while holding the 
left-button down. When you release the left-button, all objects that completely fit inside the defined 
window are selected. This command will automatically place the CAM editor in Select Mode. 

Edit > Selection > Fence  

Select objects using a polyline. 

1. Select Edit > Selection > Fence.  

2. Pick a first point, click and hold the left mouse button. A polyline will appear.  

3. Draw a polyline or series of polylines over the objects you wish to select.  

4. When finished, right click and select End or Close. The objects within this fenced area will be 

selected.  

Edit > Selection > Window Polygon  

Select objects inside a user defined polygon. 

1. Select Edit > Selection > Window Polygon.  

2. Pick a first point, click the left mouse button. Guide the first line in the direction of your selection. 

3. Pick a second point, click the left mouse button. A polygon will appear surrounding your selection.  

4. Repeat this process and guide the polygon shape around the object area you wish to select.    

4. When finished, right click to Close. The objects within this polygon window area will be selected.  
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Edit > Selection > Crossing Polygon  

1. Select Edit > Selection > Crossing Polygon.  

2. Pick a first point, click the left mouse button. Guide the first line in the direction of your selection. 

3. Pick a second point, click the left mouse button. A polygon will appear surrounding your selection.  

4. Repeat this process and guide the polygon shape around the object area you wish to select.    

4. When finished, right click to Close. The objects within and intersecting this window area will be 

 selected.  

Edit Modes 

There are three Edit Modes under Edit > Selection: 

1. Standard Mode  

2. Edit Mode 

3. Subtract Mode 

Edit > Selection > Clear All  

Removes a selection.  

Edit > Selection > Filter  

The selection filter is an extremely useful tool used for controlling the content of Objects that are selected 

prior to performing any modifications or queries.  It can be a major time saver as it parses out Objects that 

do not pass certain requirement that you set. 

1. Select Edit > Selection > Filter. A Selection Filter dialog box will appear. 
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2. Verify or Edit all Filter items. Select OK when complete. 

Filter Name: 

Save and reuse your selection filters.  This feature drastically speeds up editing in between sessions. 

Object Types: 

For items with check boxes, a check means the item can be selected, removing a check means the item 

cannot be selected. By default all are checked. 

 Number/Ranges: 

Items here allow you to include or exclude specific Dcodes, Layers, Composite Levels, or NC Tools from 

being selected.  Enter numbers and/or ranges separated by commas as directed in the dialog box. 

Names: 

Items here allow you to include specific objects for selection based from matching names. Use a semicolon 

‘;’ to separate names for Nets, Shapes, Components, and Attributes. 

Example A: Select only objects with net names “Pwr_2324” and “Pwr_0010”, enter in the Nets field:  

Pwr_2324; Pwr_0010 

Example B: Select all objects with nets that begin with “Pwr_”, just enter in the Nets field: Pwr_ 

Example C: Select all Rectangle Shapes with a height less than 0.01” and all Circle shapes greater than or 

equal to 0.02” just enter in the Shapes field: rectangle,height<0.01;circle>=0.02 

Important: Each shape filter argument can accept the following:  <shape>,width=x,height=x separated by a 

semicolon if there are multiple shape filter arguments.  The units for X is the current units of the FAB 3000 

editor. 

Important: The Selection Filter is only good for one command (i.e. Window, Crossing, All, etc.). If you wish 

to select another Crossing Window, you will need to go back to step 1, and repeat. 

Edit > Selection > Reset Filter  

Clears the selection filter. 

Edit > Layers > Add Layer  

Adds a layer.  

 a. Select Edit > Layers > Add Layer. A dialog 

  box will appear to edit by Layer Name and 

  Layer Type. 
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 b. Enter the Layer Name and layer 

  type you would like to use. If the 

  layer name already exists, a new 

  layer will be created. 

 c. Enter the Layer Type you would like 

  to use. FAB 3000 will assign the next 

  available layer type, and in most 

  cases you do not need to modify 

  this. If the layer type already exists, 

  no new layer will be created. 

  This command cannot be undone.  

 

 

Edit > Layers > Delete Layers  

Deletes selected Layers. 

1. Select Edit > Layers > Delete Layers. 

The Delete Layers dialog box will 

appear. 

2. Check the layers that you want to 

delete. 

3. Select OK to delete the selected 

layers. 

This command cannot be undone. 

 

 

 

Edit > Layers > Merge Layers  

Merge multiple layers simultaneously.  

This merges layers without polarity (i.e. composites). If you want to merge layers to create composites 

(dark/clear) use Tools > Composite Layer > Build. 
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1. Select Edit > Layers > Merge Layers. The 

 Merge Layer dialog box will appear. 

2. Enter the name of the newly merged layer in 

 the Merge Layer Name box. 

3. Click the From Layer(s) entry box. A Select 

 Layers dialog box will appear. 

 

 

 

 

4. Highlight the layers you 

 want to include for the 

 merge. 

 If you want to add 

 another layer to the 

 merge, or you made a 

 selection error, re-click in 

 the entry box and reselect 

 the layers to merge. 

5. Select OK to begin the 

 merge. 

This command cannot be undone. 

Edit > Layers > Sort Layer  

Automatically sort Layers per the recommended PCB stackup. 
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Edit > Layers > Scale Layer X/Y  

This command scales a layer in the X and Y directions. 

1.  Select Edit > Layers > Scale Layer.  

2.  The Scale Layer X/Y dialog box will appear. 

3. Assign values for the X/Y directions for each 

 layer. 

 

 

 

Edit > Align Layers  

Adjusts a layer origin to become aligned with another layer based off a similar object such as a target, pad, 

border, line, etc. In order to align layers correctly, you will need to locate a similar object that exist on both 

the base layer and the other layer, such as at Target, Fiducial Point, Pad, Border, etc. 

To use Align Layers, perform the following: 

1. Select Edit > Layers > Align Layers. 

2. In the editor, select the base object.  

 a. This object must reside on the master (i.e. base) layer, and there must be a similar object  

  on the next (i.e. to be aligned) layer. 

3. In the editor, select the next object to align.  

 a. This object must be of the same object type (as the Base Object) and reside on the next (i.e.  

  to be aligned layer) layer. 

4. FAB 3000 will now instantly align the Next layer to be directly on top of the base layer, using 
 those  two objects as reference points. 

 

Video: FAB 3000 Align Gerber and Drill Layers 

 

Edit > Delete  

http://www.youtube.com/watch?v=1EoeDPPMlaI


FAB 3000 V7 

 

Page 152 

Removes selected objects from the active design. This command requires that you select objects before 
proceeding. When no objects are selected, this command becomes de=activated in the menu. 
 

1. In the editor, select objects for deletion. To select polygons or traces, pick the edges of an object. 

2. Select Edit > Delete. 

 a. If an incorrect object is deleted, select Undo.  

Edit > Move  

This command moves objects to a new location. This command requires that you select objects before 
proceeding. When no objects are selected this command becomes de-activated in the menu. 

1. Select objects to move. To select polygons or traces, pick the edges of an object. 

2. Select Edit > Move. 

3. In the editor, select the base point.  

4. Enter the second point of displacement. The objects will be moved by the displacement amount. 

  a. For accurate distances, use the command line to enter distance values.  

 b. If the move is incorrect, use the Undo command.  

5. When finished, right click or select Esc to exit.  

 a. To quickly move a selection, Left-click over a selected object and drag the entire `  
  selection to any location in the editor. 

Edit > Copy to Layers  

Copies selected object to other layers. This command requires that you select objects before proceeding. 
When no objects are selected this command becomes de-activated in the menu. 

1. Select objects to copy. To select polygons or traces, pick the edges of an object. 

2. Select Edit > Copy to Layers. The Copy to Layer dialog box will appear. 

 

3. Check the layers that you want to    copy objects to.  

4. Select OK to begin copy. 
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  a. If the copy is incorrect, use the 
   Undo command. 

 

 

 

 

 

Edit > Rotate  

Rotates selected objects by either 90, 180, or 
270 degrees. This command requires that you 
select objects before proceeding. When no 

objects are selected this command                   becomes de-activated 
in the menu. 

 

Rotation Examples: 0, 90, 180, 270 
degrees. 

1. Select objects to rotate. To select 

 polygons or traces, pick the edges of 

 an object. 

2. Select Edit > Rotate > (*Use either 90, 180, 270, or Base Angle). Base angle refers to user defined 
 value. Enter this value in the command line underneath the editor (Specify Base Point). 

3. The select objects will now be rotated. 

4. If the rotate is incorrect, use the Undo command. 

Edit > Mirror / Flip  

Mirror selected objects either horizontally or 
vertically. This command requires that you select 
objects before proceeding. When no objects are  

                  selected this command becomes de-activated in the  
                  menu. 

There are four flip commands to choose from:  
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a. Flip Horizontal: Flips selection about the Y-axis.  

 Horizontally (about Line): Flips selection via 
 reference line. 

 

 

 

 

b. Flip Vertical: Flips selection about the X-axis. 

 Vertically (about Line): Flips selection via reference line. 

  

   

 

 

 

 

 

To Mirror/Flip an object, perform the following: 

 1. Select objects to Mirror/Flip. To select polygons or traces,      
  pick the edges of an object. 

 2. Select Edit > Mirror > (*choose flip direction – Horizontal or      
  Vertical).  

 3. Specify mirror line location for objects (if using Horizontally      
  or Vertically). Using Flip Vertical or Flip Horizontal will simply  flip the  object.  

 4. Determine if you want to delete the source (original object      
  selected). 
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  a. If the mirror is incorrect, use the Undo       
   command. 

Edit > Array  

Displays multiples of the same object in a group. This function  
                 requires that you select objects before proceeding. When no  
                 objects are selected, this command becomes de-activated in  
                 the menu. 

There are two types of Arrays, Rectangular and Polar.  

Rectangular Array 

X Count: Number of copies in the horizontal direction.  

Y Count: Number of copies in the vertical direction.  

DX:  The offset in the X direction  

DY:  The offset in the Y direction.  

Angle of Array: The offset angle of an array. 

To perform a Rectangular Array: 

1. In the editor, select objects for the array. 

2. Select Edit > Array > Rectangular. 

3. Enter the X Count value.  

4. Enter the Y Count value. 

5. Enter the DX you want to use. 

6. Enter the DY you want to use. 

7. Enter the Angle of Array you want to use. 

8. Select OK to begin. 

 a. If the array is incorrect, use the Undo         
     command. 
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Polar Array 

 

 

 

 

 

 

Method: 

(Choose from the following) 

a. Total number of items and angle to fill 

b. Total number of items and angle between items 

c. Angle to fill and angle            
 between items 

Total # of items:   Number of copies.  

Angle to fill:  Total angle (in degrees) for polar array  

Angle between items: Individual angle between each item.  

To perform a Polar Array: 

1. In the editor, select objects for the array. 

2. Select Edit > Array > Polar. 

3. Specify a center point by clicking inside your design or enter the coordinates in the command 
 window. 

4. The Polar Array dialog box will appear. 

5. Enter the Polar Array options as defined above.  

6. Select OK to begin. If the array is incorrect, use the Undo command. 
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Edit > Scale  

Scales selected objects. This function requires that you select objects before proceeding. When no objects 
are selected, this command becomes de-activated in the menu. If you would like to scale an entire layer by 
different X&Y values, use Edit > Layers > Scale Layers X/Y. 

1. In the editor select the objects you would like  
 to scale. 

2. Select Edit > Scale. The scale dialog box will  
 appear. 

3. Enter the scale factor you would like to use. 

4. Check the box if you want to scale apertures.  

5. Select OK.  

 a. If the array is incorrect, use the Undo  
         command. 

Edit > Stretch  

Automatically stretches objects crossing a defined rectangular area. 

1. Select Edit > Stretch. 

2. In the editor, specify first corner of an object by clicking it. 

3. In the editor, specify opposite corner of an object by clicking it.  

4. In the editor, specify a Basepoint. 

5. In the editor, specify a second point of displacement.  

 a. Alternatively, use the command line to enter exact coordinates.  

Edit > Split 

Splits a path into two segments and the selected location.  

1. Select Edit > Split. 

2. In the editor, specify split location by clicking it.   

3. In the editor, specify each point.  
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4. Right click to close the selection process or select Esc. 

Edit > De-Embed  

Automatically solves the polygon-inside-polygon problem for objects selected.  

1. In the editor, select the objects for de-embedding. 

2. Select Edit > De-Embed. 

3. Object composite levels will automatically be defined. 

 a. Objects must reside on the same layer. 

4. If the De-Embed is incorrect, use the Undo         
 command. 

Edit > Vertex  

These are tools for modifying the vertex. They include Move, 
Insert, & Delete. 

Move Vertex 

1. Select Edit > Vertex > Move Vertex. 

2. Select the Vertex. 

3. Left click and drag to a new location.  

4. Press Esc to exit. 

Insert Vertex 

1. Select Edit > Vertex > Insert. 

2. Select Vertex Insert Location. 

3. Press Esc to exit. 

Delete Vertex 

1. Select Edit > Vertex > Delete. 

2. Select Vertex to delete. 
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3. Repeat as necessary.  Press Esc to exit. 

Edit > Trim  

Trim objects using a reference line or circle. 

Trim Using Line:  

1. Select Edit > Trim > Using Line.  

2. In the editor, select first point for trim.  

3. Select next point.  

4.   Repeat as necessary. Right click to end. 

Trim Using Circle: 

1. Select Edit > Trim > Using Circle.  

2. In the editor, select first point for trim.  

3. Select second point in circles circumference.  

4. Select trace to trim. 

5.   Repeat as necessary. Right click to end. 

 

Edit > Boolean  

Performs 2D Boolean operations on objects using Add, 
Subtract, Intersect, or Difference.  

 

Add Boolean 

1. Select Edit > Boolean > Add. 

2. In the editor, select the base object. 

3. In the editor, select the other object for Boolean operation. 

4. When finished, press the Esc key to complete. 
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Subtract Boolean 

1. Select Edit > Boolean > Subtract. 

2. In the editor, select the base object. 

3. In the editor, select the other object for Boolean operation. 

4. When finished, press the Esc key to complete. 

Intersect Boolean 

1. Select Edit > Boolean > Intersect. 

2. In the editor, select the base object. 

3. In the editor, select the other object for Boolean operation. 

4. When finished, press the Esc key to complete. 

Difference Boolean 

1. Select Edit > Boolean > Difference. 

2. In the editor, select the base object. 

3. In the editor, select the other object for Boolean operation. 

4. When finished, press the Esc key to complete. 

Edit > Explode  

Edit > Explode converts selected objects into base objects. This 
function requires that you select objects before proceeding. When 
no objects are selected, this command becomes de-activated in the 
menu. There are five explode options: All, Flashes, Traces, Insert, & 
Text. 

 

Explode All: Converts all objects into base objects. 

1. In the editor, select objects to explode. 

2. Select Edit > Explode > All. 
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3. When finished, press the Esc key to complete. 

Explode Flashes: Converts flashes into polygons. 

1. In the editor, select objects to explode. 

2. Select Edit > Explode > Flashes. 

3. When finished, press the Esc key to complete. 

Explode Traces: Converts traces and polygons into segments. 

1. In the editor, select objects to explode. 

2. Select Edit > Explode > Traces. 

 a. Polygons will be exploded into individual segments with 1-mil width. 

3. When finished, press the Esc key to complete. 

Explode Insert  

1. In the editor, select objects to explode. 

2. Select Edit > Explode > Traces. 

 a. Polygons will be exploded into individual segments with 1-mil width. 

3. When finished, press the Esc key to complete. 

Explode Text: Converts text into polygons. 

1. In the editor, select objects to explode. 

2. Select Edit > Explode > Text. 

3. When finished, press the Esc key to complete. 

Edit > Properties  

Edit properties allows you to view and modify the properties of individual or multiple objects. This function 
requires that you select objects before proceeding. When no objects are selected, this command becomes 
de-activated in the menu. Not only does this command allow you to view all object properties, you may 
also edit them. You can also double click any object to display this properties dialog. When multiple objects 
are selected, the "Multiple Objects" version of the Properties dialog box will be displayed 
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1. In the editor, select the object(s) that you want to view and edit properties. 

2. Select Edit > Properties. The properties dialog box will appear. 

3. Review all items displayed. Most items can be changed.  

4. Click on the tab Point List to view or edit an object’s vertices or center point. This is optional. 

5. Click OK to exit the properties dialog box. 

 a. If any changes you make are incorrect, select Undo. 
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5.3 VIEW MENU 

The view menu is responsible for the control and editing of object views, layer 
displays, workspace controls.  

View > Redraw  

Refreshes/Redraws the display in the editor window. 

View > Zoom  

Increases or decreases object 
magnification. There are multiple 
zoom commands available:  

 a. Zoom All: Shows entire design 
  area in editor. 

b. Zoom In: Doubles the  magnification.  

c. Zoom Out: Halves the magnification.  

d. Zoom Window: Allows users to select a window around an area to be 
 zoomed. 

e. Zoom Previous: Zooms to previous view.  

f. Zoom to Point: Zooms to point selected by user. 

g. Zoom Selection: Zooms into the extents of the current selection. 

View > Pan  

Panning allows the user to scroll about the current view port in the editor. Pan does not change 
magnification, only movement. There are multiple pan commands available: 

Pan Left: Moves the view to the left by one-quarter of the view 
width. 

Pan Right: Moves the view to the right by one-quarter of the 
view width.  

Pan Up: Moves the view up by one-quarter of the view width.  

Pan Down: Moves the view down by one-quarter of the height of the view.  
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Pan to Point: Pans to a specific point.  

View > Fill  

View > Fill toggles the fill mode. Fill mode controls the filing of 
all boundaries using a layer’s stipple pattern and color. 

 

View > Snap  

View > Snap Controls the cursor location in the editor. If 
snap is enabled, it allows the cursor to move onto the 
nearest grid point or object boundary point. The 
following snap commands are available: Snap Off, Snap 
to Grid, Snap to Edge, Snap to End, Snap to Object 
Center, Snap to Insertion, or Auto Snap. 

 

 

Video: FAB 3000 Object Snap 

 

View > Ortho          

 View > Ortho controls the cursor direction in the editor. If Ortho is 
enabled, it allows the cursor to move in directional increments of 90 or 
45 degrees.  

 

View > Object View Filter 

Assigns view filters to an object. Use the check 
box to filter Flashes, Traces, Polygons, or Text.  

Show All will automatically check all boxes. 
Hide All will automatically uncheck all boxes.  

Select Apply to assign filters. Select OK to exit.  

 

http://www.youtube.com/watch?v=N77hH-1cbFA
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View > Layer Display  

Layer Display controls the display of layers in the editor 
for easier viewing. Choose from several viewing options to 
make it easier to differentiate between layers.  

 

 

View > Highlight Mode  

Highlight Mode enables highlights for object layers.  

 

 

Additional View Options 

Additional view options within the View menu can be activated via checkbox.  

View > Translucent  

Creates a translucent color over object layers. 

View > Origin Icon  

Toggles whether to display the origin icon in the editor. The origin icon is used for 
reference in a layout. 

View > Film Box  

Toggles whether to display the film box in the editor.  The film box is usually used 
for reference before exporting Gerber or Postscript files. 

 

View > Inside Step & Repeat  

Toggles the viewing of objects inside Inserts.  

View > Job Profile  

Toggles the viewing of the Job profile. 
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View > Backside  

Views the Job from the backside. Helpful when editing needs to be performed from the reverse view of the 
board. 

View > Markup  

Toggles whether to display markup (if any). 

View > Toolbar  

Toggles the visibility of the toolbar. 

View > Status Bar  

Toggles the visibility of the status bar. The status bar is located at the bottom of the           
workbench and it displays information about your current command, units, and cursor            
location. 

View > Design Navigator  

Increases the size of the editor workspace and command line. Using this feature           
will hide the layer display and Ariel view.  

View > Full Screen  

Allows the user to increase the editor window to the full allowable size of the screen. 

View > Command Console  

Displays a pop out widget which lists all command line dialog.  

 

 Video: PCB Backside View and Flip using FAB 3000 

 

 

 

 

 

http://www.youtube.com/watch?v=d3mahZnolpY
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5.4  ADD MENU 

The add menu adds specific CAD shapes, text, and markups to a design. 

 

 

 

 

 

 

 

 

Add > Pad  

Adds a flash to the active design. At least one aperture must have been previously defined. The flash will be 

placed on the active layer. To add a pad: 

1. Select Add > Pad. 

2. Assign the active Dcode. The active Dcode combo box is located in the toolbar. 

3. Assign the active layer. The active layer combo box is located in the toolbar. 

 a. New objects will be placed on the active layer. If the active layer is turned off, you will not  

  be able to add the new object (until that layer is turned on). 

4. Select the center point for the flash. 

5. Repeat steps 2-4 for multiple pads.  

6. To exit, right click or press Esc.  

 a. If the command is incorrect, use Undo. 

 b. To add a flash to a net, use Tools > Nets > Edit Nets.  

 c. To add a flash to a composite, use Edit > Properties and locate Composite Level. 

Add > Trace  

Adds a trace (line) to the active design. At least one aperture must have been previously defined. 

1. Select Add > Trace.  

2. Assign the active Dcode. The active Dcode combo box is located in the toolbar.  



FAB 3000 V7 

 

Page 168 

3. Assign the active layer. The active layer combo box is located in the toolbar. 

 a. New objects will be placed on the active layer. If active layer is turned off, you will not be  

  able to add the new object (until that layer is turned on). 

4. In the editor, select the first point for the trace. 

5. In the editor, select the next point for the trace. 

 a. You also have the following additional options when adding Trace. 

   1. End: Ends point list. To activate, press E key. 

   2. Close: End and close point list. To activate, press C key. 

   3. Back: Remove the last point from the current point list. To activate, press B  

    key. 

6. Once you’ve finished your trace, choose End or Close. 

7. Repeat steps 2-6 for additional traces.  

8. To exit, right click or press Esc key.  

 a. If the command is incorrect, use Undo.  

 b. To add a trace to a net, use Tools > Nets > Edit Nets.  

 c. To add a trace to a composite, use Edit > Properties and locate Composite Level. 

Add > Circle Arc  

Adds a circle to the active design.  

1. Select Add > Circle / Arc.  

2. Assign the active Dcode. The active Dcode combo box is located in the toolbar.  

3. Assign the active layer. The active layer combo box is located in the toolbar. 

 a. New objects will be placed on the active layer. If active layer is turned off, you will not be  

  able to add the new object (until that layer is turned on). 

4. In the editor, select the center point for the circle. 

5. In the editor, select the radius, orientation, and degrees for the circle. 

6. Repeat steps 2-5 for additional Circle/Arc commands.  

7. To exit, right click or press Esc key.  

 a. If the command is incorrect, use Undo.  
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 b. To add an arc/circle to a net, use Tools > Nets > Edit Nets.  

 c. To add an arc/circle to a composite, use Edit > Properties and locate Composite Level. 

Add > Polygon  

Adds a polygon to the active design. No defined aperture is required. 

1. Select Add > Polygon.  

2. Assign the active layer. The active layer combo box is located in the toolbar.  

3. Assign the active layer. The active layer combo box is located in the toolbar. 

 a. New objects will be placed on the active layer. If active layer is turned off, you will not be  

  able to add the new object (until that layer is turned on). 

4. In the editor, select the first point for the polygon. 

5. In the editor, select the next point for the polygon. 

   a. End: Ends point list. To activate, press E key. 

   b. Close: End and close point list. To activate, press C key. 

   c. Back: Remove the last point from the current point list. To activate, press B  

    key. 

6. Once you have finished your trace select Close (C key) or right click. 

7. Repeat steps 2-5 for additional Polygon commands.  

8. To exit, right click or press Esc key.  

 a. If the command is incorrect, use Undo.  

 b. To add an arc/circle to a net, use Tools > Nets > Edit Nets.  

 c. To add an arc/circle to a composite, use Edit > Properties and locate Composite Level. 

Add > Rectangle  

 Adds a filled rectangle to the active design. 

1. Select Add > Rectangle.  

2. Assign the active layer. The active layer combo box is located in the toolbar.  

 a. New objects will be placed on the active layer. If active layer is turned off, you will not be  

  able to add the new object (until that layer is turned on). 

4. In the editor, select the first corner for the rectangle. 
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5. In the editor, select the opposite corner for the rectangle. 

6. Repeat steps 2-5 for additional Rectangle commands.  

7. To exit, right click or press Esc key.  

 a. If the command is incorrect, use Undo.  

 b. To add an arc/circle to a net, use Tools > Nets > Edit Nets.  

 c. To add an arc/circle to a composite, use Edit > Properties and locate Composite Level. 

Add > Ellipse  

Adds a filled Ellipse to the active design. 

1. Select Add > Ellipse.  

2. Assign the active layer. The active layer combo box is located in the toolbar.  

 a. New objects will be placed on the active layer. If active layer is turned off, you will not be  

  able to add the new object (until that layer is turned on). 

4. In the editor, select the first corner for the ellipse. 

5. In the editor, select the opposite corner for the ellipse. 

6. Repeat steps 2-5 for additional Ellipse commands.  

7. To exit, right click or press Esc key.  

 a. If the command is incorrect, use Undo.  

 b. To add an arc/circle to a net, use Tools > Nets > Edit Nets.  

 c. To add an arc/circle to a composite, use Edit > Properties and locate Composite Level. 
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Add > Wide Path  

Adds a wide path (polygon) to 
the active design. No defined 
aperture is required. 

1. Select Add > Wide Path. 

2. Select Path Width. Width 
 cannot be 0. 

3. Select Path style. Path styles 
 include: Truncate (no path 
 extension) and Extend (extend 
 by ½ path width). 

4. Assign the active layer in the 
 Layer Display.  

 

a. New objects will be displayed on the active layer. If the active layer is turned off, you will not be able to 
add the new object (until the layer is turned on). 

5. Select the first point for the trace. 

6. Select the next point for the trace. 

 a. Additional options are available: End, Close, & Back. 

   1. End: Ends point list. Press E key. 

   2. Close: End and close point. Press C key. 

   3. Back: Remove the last point from the current point list. Press B key. 

7. Once you have finished your trace, select either End or Close. 

8. Repeat steps 4-7 for additional wide paths. 

9. To exit, right click or press Esc. 

 a. If the command is incorrect, select Undo. 

 b. To add a wide path to a net, use Tools > Nets > Edit Nets.  
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 c. To add a wide path to a composite, use Edit > Properties and locate Composite Level. 

Add > Text 

Adds text to the active design. 

1. Select Add > Text. 

2. Assign the active layer by selecting a layer in the layer display panel. 

 a. New objects will be displayed on the active layer. If the active layer is turned off, you will  
  not be able to add the new object (until the layer is turned on). 

3. Enter Text in the String dropdown located at the top in the workspace menu bar. 

  

4. Enter Text Height in the dropdown located at the top in the workspace menu bar. 

5. Enter Text Style in the dropdown located at the top in the workspace menu bar. 

 a. The text style combo box includes all FAB 3000 compiled fonts located in the FAB 3000  
  folder  fonts.  If there is not a text style available that you want, you may create your own  
  FAB 3000 compiled font from any TrueType or AutoCAD SHX font.  To do this, go to Help >  
  Compile True Type Fonts.  

6. Enter Orientation in the dropdown located at the top in the workspace menu bar. 

7. In the editor, select an origin point for text.  

8. Repeat steps 2-7 for multiple text entries. 

 a. If the command is incorrect. Select Undo. 

9. To add Text to a composite, use Edit > Properties and locate Composite Level. 
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Add > Multi-Line  

Adds multi-line (paragraph) text to the active design. 

1. Select Add > Multi-Line Text. 

2. Assign the active layer by selecting a layer in the layer display panel. 

 a. New objects will be displayed on the active layer. If the active layer is turned off, you will  
  not be able to add the new object (until the layer is turned on). 

3. Select the first corner for multi-line text. 

4. Enter the opposite corner for multi-line text. The Add Multi-Line Text dialog box will appear. 

5.   Enter a Multi-Line text String. 

6.   Enter a text Height.  

7.  Select a text Style (font). 

 a. The text style combo box  
      includes all FAB 3000  
      compiled fonts located in  
      the FAB 3000 folder  
      fonts.  If there is not a text  
      style available that you  
      want, you may create your  
      own FAB 3000 compiled  
      font from any TrueType or  

               AutoCAD SHX font.  To do  
               this, go to Help > Compile  
               True Type Fonts.  

6. Select the Alignment to be used.  

 a. The alignment options are: upperLeft, centerLeft, upperCenter, centerCenter, lowerCenter, 
  upperRight, centerRight, lowerRight. 

7. Select the Orientation. 

Enter Orientation in the dropdown located at the top in the workspace menu bar. 

8. Select the Composite Level of the text.  

9. Press OK to create the text.  
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 a. If the command is incorrect, select Undo. 

 b. To add Multi-Line Text to a composite, use Edit > Properties and locate Composite Level. 

Add > Dimension  

This command adds a 
dimension value to the active 
design. Select from the 
following: Ordinate, 
Horizontal, Vertical, & 

Radius. You can also modify the settings of your dimension text by selecting 
Dimension Settings. 

Dimension Settings  

For dimension settings, choose from the following: 

Stroke Text With: Choose either Polygon or Line. 

Decimal Accuracy: Choose decimal accuracy to be 
displayed. 

Text Offset (inch): Enter offset value of text. 

 

 

 

Add > Markup  

Add lines, rectangles, ellipses, polygons, text, and arrows to your design. You can also markup layers. 

Markup Line: Adds a markup line to the active design. 

 1. Select Add > Markup > Markup Line. 

 2. In the editor, pick the first point. 

 3. In the editor, pick the next point. 

 4. Repeat the steps until complete. Use Close or  
  End to deactivate. 
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The markup line will be placed on the active layer. 

Markup Rectangle: Adds a markup rectangle to the active design. 

 1. Select Add > Markup > Markup Rectangle. 

 2. In the editor, pick the first corner. 

 3. In the editor, pick the opposite corner. 

The markup rectangle will be placed on the active layer. 

Markup Ellipse: Adds a markup ellipse to the active design. 

 1. Select Add > Markup > Markup Ellipse. 

 2. In the editor, pick the first corner. 

 3. In the editor, pick the opposite corner. 

The markup ellipse will be placed on the active layer. 

Markup Polygon: Adds a markup polygon to the active design. 

 1. Select Add > Markup > Markup Rectangle. 

 2. In the editor, pick the first point. 

 3. In the editor, pick the next point. 

 4. Repeat the steps until complete. Use Close or  End to deactivate. 

The markup polygon will be placed on the active layer. 

Markup Text: Adds markup text to the current 
markup layer.  

 1. Select Add > Markup > Markup Text. 

 2. Select bounding rectangle for markup  
  text.  

 3. A Markup Text dialog box appears.  
  Edit or verify Text options. 

 4. Select OK.  
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The markup text will be placed on the active layer. 

Markup Arrow: Adds a markup leader with an “arrow” at the first point, to the current markup layer.  

1. Select Add > Markup > Markup Arrow. 

2. In the editor, pick the first point (where the arrow will point to). 

3. In the editor, pick the next point. 

4. Repeat steps 2-3 or until finished. Right click to end.  

The markup arrow will be placed on the active markup layer.  

Markup Layers: Defines all markup layers. These 
layers only contain markup objects and are not 
included during export. 

 

 

 

 

 

 

Add > Markup > Markup Settings  

Defines all markup settings. 

Line Width (Pixels): The default line width to use 
for any new markup object.  The width is not set to 
a pure physical unit, instead is it assigned by the 
(Current zoom level) X (# of Pixels). 

Line Style: Choose the line style, and choose from 
either:  SOLID, ONOFF_DASH, DOUBLE_DASH. 

 Highlight Mode: Make any new markup object 
"see-through". 
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5.5 Job Menu 

The Job menu allows you to add, edit and delete Jobs. 

 

 

 

 

Job > Insert Job  

Adds an Insert in to the active Job. An 
Insert represents the inclusion of one 
Job as part of another.  

1. Select Job > Insert Job. 

2. Select the Job to Insert.  

3. Select a Job Orientation. Choose 
from Lower Left, Center, or Origin.  

4. Select OK.  

 

 Job > New Job  

Creates a new Job. The new Job will 
appear in the editor tab.  

1. Select Job > New Job. 

2. Enter a name for the Job. 

3. Select OK. 
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Job > Delete Job   

Deletes a Job from the workspace. 

1.   Select Job > Delete Job. 

2.   Choose which Job to delete   
   from the drop down menu. 

3.   Select OK. 

 

 

 

Job > Flatten Job Hierarchy  

Flattens all Inserts in a Job. 

1.  Select Job > Flatten Job Hierarchy.  

2.  Select a Hierarchy level from the dropdown      
menu. 

3.  Select OK. 

 

 

 

Job > Push-Pop Insert 

Allows the contents inside an Insert to be viewed and edited in place within the parent Job. 

Push-Pop Insert is divided into several actions: Push 
Into, Pop Out, and Quit PPJ. 

 

 Push Into: Allows the user to edit/analyze geometries inside a selected Insert. 

 Pop Out: Closes the Insert. 
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 Quit PPJ: Completely exits the Push/Pop Job. All changes will be ignored. 

Job > Opens Select Job  

Opens selected Insert master Job in a new editor window.  

5.6 Info Menu 

Info menu provides general information, reporting, and error details. 

 

 

 

 

 

 

Info > Query  

Info > Query actions display information about a 
selected object. 

 

 

 

Info > Query > All  

Displays information of a selected object. 
Depending on the object selected, Query reports 
different types of information.  

 1. Select Info > Query > Query All. 

 2. Select the object to query. Move the  
         cursor over the object and left click. 

3. A pop up will display the information for the selected object. 
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4. To exit, right click or press the Esc key. 

If you have more than one item in the same location and query does not display the object you wanted to 
view, simply click the left mouse button again and FAB 3000 will cycle through the other objects in the 
same location until you see the one you want.  

Info > Query > Dcode  

Displays the Dcode information only of a selected object. 

1.  Select Info > Query > Query Dcode.  

2. Select an object to query Dcode. Move the cursor over the 
 object and left click. 

3. The selected object information will be displayed within the editor window. 

4. To exit, right click or press the Esc key.  

If you have more than one item in the same location and query does not display the object you wanted to 
view, simply click the left mouse button again and FAB 3000 will cycle through the other objects in the 
same location until you see the one you want.  

Info > Query > Query Net  

Displays net information of a selected object. Depending on the object 
selected, Query Dcode reports different types of information.  

1. Select Info > Query > Query Net. 

2. Select an object to Query Net. Move the cursor over the object and 
 left click. 

3. The selected object information will be displayed within the editor      
 window. 

4. To exit, right click or press the Esc key. 

If you have more than one item in the same location and query does not display the object you wanted to 
view, simply click the left mouse button again and FAB 3000 will cycle through the other objects in the 
same location until you see the one you want.  
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Info > Find > Find Net  

Search active Jobs for defined Net.  

1. Select Info > Find > Find Net. The Find 
 Net dialog box will be displayed. 

2. Select the Net to find from the drop 
 down menu.   

 

3. Select View As. Choose from either Highlight 
 or Isolate. 

 a. Highlight: All net objects on visible  
  layers highlighted. 

 b. Isolate: All net objects are visible,  
  while all other objects are hidden. 

4. Select Zoom Extents. If checked, this zooms  
 out to view the entire net. 

5. To exit, right click or press Esc. 

 

Info > Find > Find Dcode  

Searches active Job for defined Dcode. 

1. Select Info > Find > Find Dcode. The Find 
 Dcode dialog box will be displayed. 

2. Select Dcode to find from the dropdown 
 menu.  

3. Select View As. Choose from either Highlight 
 or Isolate. 

  a. Highlight: All net objects on visible layers highlighted. 

  b. Isolate: All net objects are visible, while all other objects are hidden. 

4. Select Zoom Extents. If checked, this zooms out to view all Dcodes. 
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Info > Find > Find NC Tool  

Searches active Job for defined NC Tool. 

1. Select Info > Find > Find NC Tool. The Find  
  NC Tool dialog box will be displayed. 

2. Select NC Tool to find from the dropdown  
  menu.  

3. Select View As. Choose from either Highlight  
  or Isolate. 

  a. Highlight: All net objects on visible  
   layers highlighted. 

        b. Isolate: All net objects are visible,  
         while all other objects are hidden. 

4. Select Zoom Extents. If checked, this zooms out to view all NC Tools. 

5. To exit, right click or press Esc.  

Info > Find > Find Composite Level  

1. Select Info > Find > Find Composite Level. 
The Find Composite Level dialog box will be 
displayed. 

2. Select Composite Level to find from the 
dropdown   menu.  

3. Select View As. Choose from either Highlight  
 or Isolate. 

  a. Highlight: All net objects on  
   visible layers highlighted. 

         b. Isolate: All net objects are  
          visible, while all other objects  
          are hidden. 

4. Select Zoom Extents. If checked, this zooms out to view all composite level objects. 

5. To exit, right click or press Esc.  
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Info > Find > Find Text  

Searches active Job for defined Text. 

1. Select Info > Find > Find Text. The Find Text  
 dialog box will be displayed. 

2. Enter Text to find from the dialog box. 

3. Select View As. Choose from either Highlight  
 or Isolate. 

  a. Highlight: All net objects on  
   visible layers highlighted. 

       
  b. Isolate: All net objects are  

          visible, while all other objects  
          are hidden. 

4. Select Zoom Extents. If checked, this zooms out to view all composite level objects. 

5. To exit, right click or press Esc.  

Info > Find > Find Insert 

 Searches active Job for defined Insert.  

1. Select Info > Find > Find Insert. The Find 
 Insert dialog box will be displayed. 

2. Enter Name to find from the dialog box. 

3. Select View As. Choose from either Highlight  
 or Isolate. 

  a. Highlight: All net objects on  
   visible layers highlighted. 

       
  b. Isolate: All net objects are  

          visible, while all other objects  
          are hidden. 
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4. Select Zoom Extents. If checked, this zooms out to view all composite level objects. 

5. To exit, right click or press Esc.  

Info> Find > Find Component  

Search an active Job for defined Components.  

1. Select Info > Find > Find Component. The 
 Find Component dialog box will be displayed. 

2. Select a Component to find from the drop 
 down menu. 

3. Select View As. Choose from either Highlight  
 or Isolate. 

  a. Highlight: All net objects on  
   visible layers highlighted. 

       
         b. Isolate: All net objects are  
          visible, while all other objects  
          are hidden. 

4. Select Zoom Extents. If checked, this zooms out to view all composite level objects. 

5. To exit, right click or press Esc.  

Info > Measure  

 Provides interactive measurement readouts for selected Points, Objects, and Nets. 

 

Info > Measure > Point-Point 

Measurement readout between two selected points within the editor. 
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1. Select Info > Measure > Point-Point.  

2. Select the first point of measurement. 

3. Select the second point of measurement. 

4.  A pop up menu will display showing the distance information between these two points.  

 a. Distance: Distance between two selected points. 

 b. DX/DY: Horizontal and vertical displacement between the two selected points. 

 c. Angle: The angle (in degrees) between the two selected points. 

5.  To exit, right click or press Esc. 

 a. After you have selected the first point, an interactive measurement is continuously   
  calculated and displayed in the dynamic window. This helps to measure multiple distances  
  using the same base reference point. 

 b. Use snap for precise measurements between objects and grid points. 

Info > Measure > Object-Object 

Measurement readout between two objects, taking 
into account true width. 

1. Select Info > Measure > Object-Object.  

2. Select the first point of measurement. 

3. Select the second point of measurement. 

4.  A pop up menu will display showing the distance information between these two points.  

 a. Distance: Distance between two selected points. 

 b. DX/DY: Horizontal and vertical displacement between the two selected points. 

 c. Angle: The angle (in degrees) between the two selected points. 

5.  To exit, right click or press Esc. 

 a. After you have selected the first point, an interactive measurement is continuously   
  calculated and displayed in the dynamic window. This helps to measure multiple distances  
  using the same base reference point. 
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 b. Use snap for precise measurements between objects and grid points. 

 

 

Info > Measure > Net-Net 

Determines closest adjacent distance between two nets. 

1. Select Info > Measure > Object-Object.  

2. Select the first point of measurement. 

3. Select the second point of measurement. 

4.   A pop up menu will display showing the  
        distance information between these two  
        points.  

 a. Distance: Distance between two selected points. 

 b. DX/DY: Horizontal and vertical displacement between the two selected points. 

 c. Angle: The angle (in degrees) between the two selected points. 

5.  To exit, right click or press Esc. 

 a. After you have selected the first point, an interactive measurement is continuously   
  calculated and displayed in the dynamic window. This helps to measure multiple distances  
  using the same base reference point. 

 b. Use snap for precise measurements between objects and grid points. 

Info > Rulers  

Applies ruler measurements directly to the design. 

 

 

Info > Rulers > Add Ruler  

Adds a ruler and measurement information directly to the design by selecting two points.  
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Info > Rulers > Clear Ruler  

Clears all displayed rulers in the design.  

 

Info > Reports  

Generates detailed reports for the active design. This includes reports for: Apertures, NC Tools, Dcode, 
Drill, Composites, & Nets.  

 

 

These reports are presented in a table file and displayed 
in the editor.  

 

Info > Generate PDF Error  Report 

Generates a detailed report with graphics in PDF format. There are several PDF report types to choose 
from: 

 a. DRC/DFM Violations 

 b. Compare Net Errors 

 c. Join Errors 

 d. Sales RFQ 

 e. Fabrication Drawing 

Info > Generate Text Error Report  

Generates a detailed report in Text/ASCII format.  
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Info > Generate CSV Error Report 

Generates a detailed error report in CSV format which may be imported to various spreadsheet 
applications. 

Info > Generate Error Drawing  

Generates marker objects which may be imported into various CAD systems for concurrent verification. 

Info > List 

Displays all properties of selected objects in a separate command console. The command allows the 
complete display of multiple object properties simultaneously.  

1.  Select object(s) to list within the editor. 

2. Select Info > List. A command console will appear with all 
 object properties listed. 

3. If necessary, select Save to save the report to  a specific 
 directory. 

4. Select OK to exit.  

 

 

5.7 Fabrication Menu  
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The fabrication menu provides a number of tools for editing and 
updating your design prior to manufacturing.  

 

 

 

 

 

 

 

Fabrication > Silkscreen Optimizer  

When silkscreen data overlaps soldermask areas, it makes electrical testing and SMT soldering more 
difficult. Silkscreen optimizer removes the overlapping silkscreen data from soldermask pads. 

1. Select Fabrication > Silkscreen 
 Optimizer. 

2. Select the Silkscreen Layer from the 
 drop down men. 

3. Choose the Soldermask Layer or 
 “Mask” layer from the drop down 
 menu. 

 a. Make sure to select the  
  appropriate Silkscreen & Mask 
  layers. A common mistake  
  occurs when a user selects a  
  Top Silkscreen against a  

          Bottom Mask. 

4. Verify silkscreen Clearance from the soldermask area. 

5. Verify the Min. Stub Length for the silkscreen layer. 

6. Press OK to begin Silkscreen Optimizer. 

7. A results dialog box will be displayed.  
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   Video: Add Barcode to PCB Silkscreen using FAB 3000 

Video: Add Text to PCB Silkscreen before manufacturing using FAB 3000 

 

 

 

 

 

 

 

Fabrication > Copper Balancing  

Copper pour utility for FAB 3000. To perform this, the active layer must be displayed before activating 
Copper Balancing. You should only turn on one layer.  

http://www.youtube.com/watch?v=sQpvbsVICJs
http://www.youtube.com/watch?v=ZqiCziZtnj4
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1.  Select Fabrication > Copper   
  Balancing. 

2.  Verify the Clearance. This is the  
  distance the copper will keep   
  between itself and other objects. 

3.  Verify the Minimum Size.  

  a. Make sure to select the  
   appropriate Silkscreen & Mask 
   layers. A common mistake  
   occurs when a user selects a  
   Top Silkscreen against a  
   Bottom Mask. 

4.  Select OK and select the boundary to  
  use for Copper Balancing. All copper  
  will be placed on the active layer. 

 

 

 

 

 

 

Forum: Copper / Pour Balance 

 

 

 

 

Fabrication > Grow/Shrink  

Enlarge or reduce object sizes. This feature is excellent for adding compensation to geometries that will 
affected during manufacturing.  

http://forums.numericalinnovations.com/post/copper-pourbalance-5044532
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1. Select the object(s) to apply enlargement or 
 reduction. 

2. Select Fabrication > Grow/Shrink. 

3. Verify or edit the compensation size under 
 Size per side (inch). 

4. FAB 3000 will now apply to all selected 
 objects. 

 

For traces & flashes, FAB 3000 will replace the existing Dcode with a larger or reduced Dcode size. For 
polygons, it will offset the vertices. 

Fabrication > Pin Hole Elimination  

Increase yields by eliminating small openings and conductor-islands on metal layers (non-negative). 

1. Select Fabrication > Pin Hole Elimination. 

2. Enter a value for Fix Pin Holes less Than 
 (inch). 

3. Select OK.  

 a. Negative plane layers are not   
  processed. 

 

 

 

 

 

 

Fabrication > Teardrop Creation  

Creates a Teardrop/Snowman to improve Pad-Trace connections. 
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1. Select objects to be used for teardrop 
 creation. Any pads selected will also be used. 

2. Select Fabrication > Teardrop Creation. A 
 Teardrop/Snowman dialog box will appear. 

3. Select type from the dropdown menu. Choose 
 from either Teardrop or Snowman. 

 a. Teardrop is a standard teardrop  
  creation while snowman adds a small  
  flash in the appropriate location. 

4. Enter Teardrop Offset Multiple. This controls the length of the teardrop. 

5.  Select OK and the teardrops will be created. 

Fabrication > Remove Pads (Isolated/Stacked)  

Removes pads.  

1. Select objects for Pad removal. 

2. Select Fabrication > Remove Pads 
 (Isolated/Stacked). 

3. Use the checkboxes to select Isolated or 
 Stacked. 

4. Select OK. 

5.  A Pad Removal Report dialog box will appear 
 highlighting the number of pads removed. 

 

 

 

 

Fabrication > Remove Covered Data  

Removes covered or overlapping data. 
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1. Select objects for removal. 

2. Select Fabrication > Remove Covered Data. 

3. Select OK. 

Fabrication > Drill 

Conversion for Gerber and Drill Layers.  

 

 

Fabrication > Drill > Gerber Layer to Drill  

Converts Gerber flashed pads to Drill hits. 

1. Select Fabrication > Drill > Gerber 
 Layer to Drill. A Gerber to Drill dialog 
 box will appear. 

2. Verify and edit conversion 
 parameters. 

3. Select OK when finished. 

 

 

 

 

Forum: I don’t have a Drill file, is there a way I can create one? 

  Video: Sort Layers, Create Drill from Gerber file using FAB 3000 

http://forums.numericalinnovations.com/post/i-dont-have-a-drill-file-is-there-a-way-i-can-create-one-2530214
http://www.youtube.com/watch?v=zIUq8wd2umo
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Fabrication > Drill > Drill to Gerber  

Converts Drill hits to Gerber flashes. 

1. Select Fabrication > Drill > Drill to 
 Gerber. An NC to Gerber dialog 
 box will appear. 

2. Verify and edit conversion 
 parameters. 

3. Select OK when finished. 

 

 

Fabrication > SMT Stencil  

Apply SMT Stenciling for PCB solder based components. 

 

 

 

  Video: Using Homebase Pads to Create Groups and then Modify the Custom             

Aperture 

 Video: Modifying SMT Stencil Pads in Gerber Files 

 

 

 

http://www.youtube.com/watch?v=8ajDX5Bs-iU
http://www.youtube.com/watch?v=8ajDX5Bs-iU
http://www.youtube.com/watch?v=OG6gcx2Xv0s
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Fabrication > SMT Stencil > Homebase Pad Conversion 

Convert flashed pads to homebase pads. 

1. Select Fabrication > SMT Stencil > Homebase  
  Pad Conversion. 

2. Verify or edit conversion options.  

3. Select OK. 

 

 

 

 

 

 

 

 

Fabrication > SMT Stencil > C-Pad Conversion 

Convert flashed pads to C-Pads. 

1. Select Fabrication > SMT Stencil > C-Pad Conversion. 

2. Verify or edit conversion options. 

3. Select OK. 
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Fabrication > SMT Stencil > Split Pads  

Convert flashed pads to C-Pads.  

1. Select a pad. The pad must be a flash. 

2. Select Fabrication > SMT Stencil > Split Pads. 

3. The Split Pads dialog box will appear. 

4. Edit and verify split pad details. 

5. When finished, select OK. 

 

 

 

 

 

Fabrication > SMT Stencil > Scale Pads  

Converts flashed pads to scaled pads. 

1.    Select pads. 

2.    Select Fabrication > SMT Stencil >   
    Scale Pads. 

3.    The Scale Pads dialog box will appear. 

3.    Edit and verify scale pad details. 

4.    When finished, select OK. 
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Fabrication > SMT Stencil > Bowtie Pads  

Convert flashed pads to bowtie pads. 

1.  Select Fabrication > SMT Stencil >  
  Bowtie Pads. 

2.  The Bowtie Pad dialog box will  
  appear. 

3.  Edit and verify bowtie pad details. 

4.  When finished, select OK. 

 

 

 

 

 

Fabrication > SMT Stencil > Pad Pitch Adjustment  

Adjust pitch between flashed pads.  

1. Select Fabrication > SMT Stencil >   
 Pad Pitch Adjustment. 

2. The Pad Pitch Adjustment dialog box   
 will appear. 

3. Edit and verify pad pitch adjustment   
 details. 

4. When finished, select OK. 
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Fabrication > SMT Stencil > Heel and Toe Edits  

Adjusts flashed pad lengths. Requires 

rectangular pads with orthogonal rotations (0, 

90, 180, 270). Irregular pad rotations such as 

34.2 degrees are not recommended. 

1.  Select a Pad Pair. A Pad pair must   
  consist of two rectangular flashes.  

2.   Select Fabrication > SMT Stencil > Heel and  
   Toe Adjustment. 

3.    The Heel and Toe Adjustment dialog  
     box will appear. 

4.    Edit and verify Heel and Toe adjustment       
    details. 

5.    When finished, select OK. 

 

 

 

Fabrication > SMT Stencil > Add Epoxy Bars  

Adds epoxy bars between selected pads. 

1.  Select a Pad Pair. A Pad pair must consist of       
   two rectangular flashes.  

2.  Select Fabrication > SMT Stencil > Add Epoxy 
  Bars. 

3.  The Add Epoxy Bars dialog box will appear. 

4.  Edit and verify Add Epoxy Bar adjustment    
  details. 

5.   When finished, select OK. 
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Fabrication > Generate Missing Layers  

Generates missing layers using a variety of 
functions such as paste, mask, border, and Create 
Drill Layer (PTH).  

 

Fabrication > Generate Missing Layers > Paste (Layers)  

Creates paste layers from existing mask & drill layers. 

1. Select Fabrication > Generate Missing Layers  
 > Paste (Layers).  

2. Verify and edit paste settings in the dialog 
 box. 

3. Select OK.  

 

 

 

Fabrication > Generate Missing Layers > Mask (Layers)  

Creates mask layers from existing top and bottom layers. 

1. Select layers for mask. 

2. Select Fabrication > Generate Missing 
 Layers > Mask (Layers).  

3. Verify and edit mask settings in the 
 dialog box. 

4. Select OK.  
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Fabrication > Generate Missing Layers > Border  

Creates PCB border layers from existing data. 

1. Select Fabrication > Generate Missing Layers > Border.  

2. Select objects on PCB border.  

3. Right click to select End or Close. 

Fabrication > Generate Missing Layers > Create Drill Layer (PTH)  

Builds a plated-thru-hole drill template when no drill layer is available.  

1. Select Fabrication > Generate Missing Layers 
 > Create Drill Layer (PTH). If a drill layer has 
 already been defined, a dialog box will ask 
 you if you want to proceed anyway. 

2. Verify and edit drill layer settings. 

3. Select OK. A new layer will be created.  

 

 

 

Fabrication > Create Fabrication Drawing  

Creates a fabrication drawing 
from a dill layer and board 
outline layer. 

a. All layer types must be 
 defined. 

b. At least one drill layer 
 must be defined. 

          c. A border layer must be 
           defined. 
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1. Select Fabrication > Create 
 Fabrication Drawing.  

2. The Create Fabrication dialog 
 box will appear.  

3. Select a drill layer. For designs 
 with more than one drill layer, 
 repeat Create Fabrication 
 Drawing and select the other 
 drill file(s). Each time this 
 command is run a new 
 Fabrication Drawing is 
 created. 

4. Assign the required 
 information for the drawing 
 and include any necessary  

          notes. 

4. Select Next. 

5. Review and modify the Hole 
 Schedule. Change items such 
 as symbols, text, notes, etc. 
 for each drill hole. 

6. If changes other than symbols 
 are required, make these 
 changes in the NC Tools Table 
 first before proceeding. 

 

 

 

 

 

Video: Create Drill Holes and Slot using FAB 3000 

http://www.youtube.com/watch?v=h63UkK97C9w
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7. Select Next. A fabrication  
  drawing will be created. 

 

 

 

 

 

 

 

 

 

Fabrication > Copper Area Calculation  

Calculates copper area per layer.  

1. Select Fabrication > Copper 

 Area Calculation. 

2. Edit and verify area options. 

3. Select OK. The copper area 

 calculation will begin. 

 

 

 

 

 

 

 

 

4. Review the copper area calculations. This information can also be saved by selecting Save. 
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5. Copper Area calculations will 

 be highlighted within the 

 Finish page.  

6. Select Finish to close. 

 

 

 

 

 

 

 

 

 

 

 Video: Perform Copper Area Calculation on Gerber PCB 

 

 

 

 

 

 

 

 

 

 

 

 

http://www.youtube.com/watch?v=hOcztH66N3U
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Fabrication > PCB Fabrication Report 

Create detailed Sales/RFQ reports which include pricing, realistic finished photos, DFM and Netlist 

summaries, plus more.  It’s a perfect tool for any PCB fabrication sales team. 

a. All layer types must be 

defined. 

b. At least one drill layer must be 
defined. 

c. A border layer must be 
defined. 

1. Select Fabrication > PCB 
Fabrication Report.  

2. Review ‘Select Configuration’. 
Configuration files are used to 
store pricing information based on 
number of layers, area of PCB, 
quantity, delivery, promotion 
factors, and more.  

3. Enter Quantity and Delivery. 

4. Review PCB Dimensions to 
ensure they are correct. Note: Blank items such as Minimum Trace and Minimum Space will be 
automatically detected. 

5. Review General Requirements.  

6. Select tab ‘Options’.  You may verify Header options, and report features such as DFM Check, Netlist 
Check, Find Missing Layers, and more.  

7. Enter notes to be included in report. 

8. Press ‘Next’, and select file location to save PDF. 
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5.8 Assembly Menu  

Use this menu to build, Insert, find, and analyze components. 

 

 

 

 

 

 

Assembly > Build Component  

This adds components to the active Job. 

1. Turn on paste or mask layer (paste preferred).  

 a. If paste layer is not defined you must instruct FAB 3000 by going to the Setup > Layer Table. 

2. Locate a pad within the editor and select it.  

 a. FAB 3000 will try to guess Pin #1.  

 b. You may also select a different pad for Pin #1. 

3. Select Assembly > Build Component 

4. Select Pin One.  

 a. Usually pin one is the top-leftmost pin for top side (assuming  

  no rotation) and top right most for bottom side (assuming no  

  rotation). Pin #1 is needed as it helps orient the   

  placement of the component.  

 b. Once Pin #1 is chosen, right click to accept. 
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5. Assign component description. A Build 

 Components dialog box will appear. Select OK 

 when done. 

 a. Enter component rotation as it  

  appears on the board. If you have  

  selected a component  that is rotated  

  90 degrees on the board, than make  

  sure to enter that here. 

 b. If apply all is check (recommended),  

  FAB 3000 will go out and seek all  

  similar footprints. 

 

You will notice (if apply all is checked) that all similar 

footprints have been detected and assigned a generic 

reference designator value (for example “?21”). 

 

6. Repeat steps 2 thru 5, until all footprints on the paste 

  layer have been completed. 

 

 

 

7. Review the Footprint browser and verify  

  remaining components. Select Window >  

  Footprint Browser. 

   

8. Select the Footprint to open by clicking it.  

  Select OK. 
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8. In the Footprint browser you 

 may load external libraries 

 (containing footprints) or 

 make modifications here. 

 

 

 

 

 

 

 

Assembly > Insert Component 

Inserts a single component into an existing Job. 

 

Assembly > Find Component  

Searches the Job for defined components. 

 

 

Assembly > Component Detection Wizard  

Detects components automatically. Speeds up the process of building components.  
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Assembly > Component Analysis  

Detects components automatically. Speeds up the process of building components. 

 

Assembly > External Centroids 

Apply external centroid attributes to existing components.  

 

Assembly > External Centroids > View Top  

Top view centroid. 

Assembly > External Centroids > View Bottom  

Bottom view centroid. 

Assembly > External Centroids > Offset 

Offset external centroid by entering X and Y values. 
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Assembly > External Centroids > Scale  

Scales external centroids. 

 

 

 

 

 

 

 

Assembly > Components Table   

Display, add, remove, or modify components used in active Job/panel. 
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Assembly > BOM Table  

Displays Bill of Materials for active Job/panel.  

 

 

1. To add a BOM item, select Add BOM Item. 

2. Enter BOM details and select OK. 

3. The item will be listed in the BOM Table.  
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5.9 Tools Menu 

Tools > Panelize Wizard  

 

In order to activate the Panelize Wizard, you must first create a New Panel by selecting File > New > Panel. 

Once complete, the Panelize Wizard function will appear under Tools > Panelize Wizard. Panelize Wizard 

merges multiple Jobs onto a Panel to save on fabrication costs.  

Tools > Panelize Wizard > Smallest Possible Panel Size  

1. Select Tools > Panelize 

 Wizard > Smallest 

 Possible Panel Size. 

2. In the list, select the 

 Jobs you want to add 

 to the Panel.  

3. Enter the required 

 count in the Count 

 column. 

4. Edit or verify Job and 

 Panel Options. 

5. Select Next. 

 

 

 

If only one job is selected, a warning will appear with the following message: 

 

 

 

 

 

6. Select Yes to proceed or No to cancel.  
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7.  The Panelize Wizard 

 Options dialog box will 

 appear.  

8.  Verify or edit the 

 options you require. 

9.  Select Next to 

 calculate the merge. 

 

 

 

 

 

 

 

10.  The Select Panel  

   Layout dialog box will 

   appear.  

11.   Select a panel layout.  

12.  Select Finish. 
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Tools > Panelize Wizard > (Use Fixed Panel Size)  

1.  Select Tools > Panelize 

 Wizard > (Use Fixed 

 Panel Size) 

2.  In the list, select the 

 Jobs you want to add 

 to the Panel.  

3. Enter the required  

 count in the Count 

 column. 

4.  Edit or verify Job and 

 Panel Options. 

5.  Select Next. 

 

 

 

 

 

If only one job is selected, a warning will appear with the following message: 

 

 

 

 

 

6. Select Yes to proceed or No to cancel.  

 

Forum: FAB 3000 Panelize Feature 

Video: Automatically Panelize PCB Gerbers 

          Video: Panelize Gerber Files from Eagle PCB using FAB 3000 

http://forums.numericalinnovations.com/post/fab-3000-panelize-feature-6131444
http://www.youtube.com/watch?v=OguIXv5PjjU
http://www.youtube.com/watch?v=46BbmW-14Gs
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7.   The Panelize Wizard 

 Options dialog box will 

 appear.  

8.  Verify or edit the  

 options you require. 

9.  Select Next to 

 calculate the merge. 

 

 

 

 

 

 

 

 

10.   The Select Panel 

 Layout dialog box will 

 appear.  

11.  Select a panel layout.  

12.  Select Finish. 
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Tools > DFM Check  

 

DFM Check finds all DRC/DFM violations. In order to use this feature, you must have imported Gerber and 

drill file(s) into the workspace.  The following is required: 

 a. You must extract a Netlist before proceeding. If you haven’t run a Netlist extraction, DFM  

  Checker will perform it for you. 

 b. All layers must be defined. To define layers, use Setup > Layer Table. 

 c. You must have at least one drill file (2 or more for blind/buried Vias).  

 

1. Select Tools > DFM > DFM 

 Check. The DFM Check dialog 

 box will appear. 

2. Verify and edit the DFM rules 

 set. To do this, select the  

 available rules set from the 

 pull down menu under DFM 

 Rule Set.  

 a. You may also edit the  

  DFM Rules by pressing 

  the “…” button next to 

  the DFM Rule Set drop 

  down menu (See  

  Next Page, DFM Rules  

  Settings).         
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  b. DFM Rules Settings  

   dialog is used to verify  

   or edit rules  

   individually. 

3. Select Next. 

4. FAB 3000 will now perform an 

 extensive analysis of your PCB design. 

  

 a. Job Inserts are ignored. If you  

  wish to run a DRC/DFM check  

  on a specific child Job,   

  make sure to open the  

  child Job in a separate   

  window, and then   

  proceed. To open Jobs, go to  

  Window > Workspace   

  Browser. 

  

 

 

 b. Depending on the complexity  

  of the design and the checks  

  performed, processing time  

  can take anywhere from 30  

  seconds to 5 minutes. 
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5.  If any errors are detected, FAB 3000 

 will display them in the dialog box. If 

 there are no errors, the process is 

 complete.  

6. Select Finish. Any errors listed will 

 now appear in the DRC/DFM Violation 

 Browser. The browser will appear just 

 below the editor and provide you with 

 an easy to use navigation tool to 

 locate and describe each detected 

 error. 

 

 

 

 

7.    The browser contains a complete list of errors  

    organized in a hierarchy format. Selecting and       

    highlighting each error will provide a description of  

    the error and severity level for PCB fabrication. 

8.    For each error selected, you’ll be taken to the  

    location of that error within the drawing for closer  

    viewing and editing. 
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9.    Create reports in PDF, Text, or CSV 

 format by selecting the appropriate 

 icon next to Error List.  

10.  You can also generate an error 

 drawing which may be exported to 

 various formats such as Gerber, DXF, 

 or ODB++ and then imported back 

 into your PCB layout tool for 

 verification or to share with 

 colleagues. 

 

 

Tools > DFM Rules Management  

Use this setting to manage your DFM rules. 

1.   Select Tools > DFM Rules 

 Management.  

2. Select a DFM Rule Set from 

 the drop down menu or create 

 a new DFM Rule Set by 

 selecting New.  

3. Use the DFM Checks tabs to 

 edit individual rules. Tabs 

 include rules for Signal, Plane, 

 Silk, Mask, Drill, and Assembly. 

4. Select Finish. 
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Tools > Nets  

Extract, compare, and apply Netlists to your design. 

 

Tools > Nets > Netlist Extraction  

Extract a true interconnectivity map of any PCB design. 

1. Select Tools > Nets > Netlist 

 Extraction. 

2. Verify and select extraction 

 options.  

New! Slice Large Polygons to permit 

increased performance – sometimes 

up to 10X faster. 

3. Select Next. The extraction 

 will be performed. 
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4. In the Finish dialog box,  

  information will be included  

  regarding CAM Nets created  

  and elapsed time. 

 

 

 

 

 

 

Tools > Nets > Netlist Compare  

Compares extracted nets against an imported Netlist.  

1. Select Tools > Nets > Netlist 

 Compare. 

2. Verify and select compare 

 options.  

3. Select Next. The comparison 

 will be performed. 
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4. In the Finish dialog box, 

 information will be included 

 regarding comparison time 

 and any violations that were 

 detected during the 

 comparison. 

 

 

 

 

 

 

 

  Video: Check ODB++ Embedded Netlist Against the Artwork 

 Video: Performing Netlist Compare on Gerber Files 

 

Tools > Nets > Apply External Netlist 

After a Netlist is extracted from Gerber & Drill data, there is no way for FAB 3000 to know the net names 

used in your CAD design.  This allows you to import your CAD-generated Netlist, and apply the names to 

FAB 3000. After importing a Netlist into FAB 3000, perform the following: 

http://www.youtube.com/watch?v=fctYfaEsSps
http://www.youtube.com/watch?v=ml9IIdiA14M
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1. Extract a Netlist using Tools > 

Nets > Netlist Extraction (see 4.8: 

Extracting Netlists from Gerber 

and/or Drill Data). The extracted 

Netlist is pictured here. The 

Netlist information can be found 

at the bottom browser tab (below 

the editor) under “Nets”. 

You’ll notice FAB 3000 generates 

a generic Net name beginning 

with “$Net#”.  Usually, designers 

will want to use the actual design 

net names in FAB 3000. In this 

case, they will use Tools > Nets > 

Apply External Netlist. 

 

 

 

 

 

 

 

How to Apply External Net Names to CAM Net 

1. Select Tools > Nets > Apply External Netlist. 
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FAB 3000 will automatically update the existing 

CAM net names with the external net names.  

 

 

 

 

 

 

 

 

 

 

You’ll notice now in the Nets section 

tab that all Net names are no longer 

generic and refer back to the original 

names used in the CAD design.  

On some occasions you may find Nets 

in this list which may not have changed 

after running Apply External Netlist. 

This will most likely be the result of a 

Net flaw in the design.  

To identify this flaw, run Tools > Nets > 

Netlist Compare (see Section 4.11).  
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Tools > Nets > Netlist Table  

Create, delete, merge, transfer, and edit nets. 

1.   Select Tools > Nets > Netlist  

  Table. 

2.    The Netlist Table dialog box  

  will appear. 

 

 

 

 

 

 

 

 

 

 

3.  There are several options within the table. They are: 

  a. Create Net: Enter a Net name. 
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  b. Delete Net: Select a Net to  

   delete from the pull down  

   menu. 

   

 

 

 

   

 

  c. Merge Net: Select a Net to  

   merge from the pull down  

   menu. 

   

 

 

   

 

  d. Transfer Net: Transfer   

   between Nets. 
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Tools > Nets > Import Netlist (IPC-D-356/A) 

Imports an IPC-D-356/A formatted Netlist. These are generic Netlist formats used as a standard for the 

Bare-Board Testing environment.  

1.  Select Tools > Nets > Import   

  Netlist (IPC-D-356/A). 

2.  Choose a Netlist file to 

 import. Select OK. 

3. The Import Netlist dialog box 

 will appear. 

4. Select Netlist import options. 

5. Select OK. The Netlist 

 importation process will 

 begin.  

 

 

 

 

6. If there are any errors, they 

 will be displayed in the dialog 

 box.  

7. When complete, select Finish. 
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Tools > Compare Jobs and Layers 

Compares differences between layers. Overlays another Job over the active design. 

 

 

Tools > Compare Jobs and Layers > Compare Layers  

Compares differences between layers. 

1. Select Tools > Compare Jobs and    

  Layers > Compare Layers. 

2. Select layers by choosing the layer    

  name and assigning a layer color. 

3. Choose a compare method and    

  physical comparison type (optional). 

4. Select OK. 

 

 

 

 

 

 

5. The Compare Layers error browser will appear just 

 below the editor.  

6. Use the browser to compare and analyze each 

 layer.  

7. Use the browser to create a PDF, Text, or CSV 

 error list.  
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Tools > Compare Jobs and Layers > Compare Jobs 

1. Select Tools > Compare Jobs and    

  Layers > Compare Jobs. 

2. Select Jobs by choosing the name and assigning a  

  color. 

3. Choose a compare method and    

  physical comparison type (optional). 

4. Select OK. 

 

 

 

 

 

 

 

5. The Compare Jobs error browser will appear just 

 below the editor.  

6. Use the browser to compare and analyze each 

 Job.  

7. Use the browser to create a PDF, Text, or CSV 

 error list.  
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Tools > Draw To Flash  

Tools > Draw To Flash > Interactive  

Converts drawn pads to Gerber flashes.  

1. Select the drawn pads(s) that you want to convert to a flash. 

 a. You must have at least one object selected before proceeding. 

2. Select Tools > Draw To Flash > Interactive. 

3. Verify or edit settings for new flashes. Select OK. A 

 Convert to Flash dialog box will appear. 

4. FAB 3000 will now search for all objects similar to 

 your original selection and convert them to Gerber 

 flashes. 

 a. Turn off any layers that you do not want to  

  convert to flashes. 

 b. It’s a good idea to make sure that your draw  

  and flash colors are different colors   

  respectively. This will make it easier to  

  determine which draw pads have not been  

  converted to flashes. 

 

 

Tools > Draw To Flash > Automatic  

Automatically generate Round, Rectangular flashes. 
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1. Select all objects in an area that you 

 want to have round & rectangular 

 flashes detected. It does not matter if 

 pads are different sizes. 

 a. You must have at least one  

  object selected before   

  proceeding. 

2. Select Tools > Draw To Flash > 

Automatic. A Draw to Flash dialog 

 box will appear. 

3. Verify or edit settings for detecting 

 new flashes.  

4. Select OK. FAB 3000 will now detect round/rectangular pads and convert them to Gerber flashes. 

 a. It’s a good idea to make sure Draw and Flash colors are different colors    

 respectively. This will make it easier to determine which draw pads have not been    

 converted to flashes. 

Tools > Draw to Flash > Selective  

Converts a selected group of objects to Gerber flashes. 

1. Select the drawn pads(s) that you want to 

 convert to a flash. 

 a. You must have at least one object  

  selected before proceeding. 

2. Select Tools > Draw To Flash > Selective. A 

 Draw to Flash dialog box will appear. 

3. Verify or edit settings. 

4.  Select OK.   

 

It’s a good idea to make sure that your draw and flash colors are different colors respectively. This will 

make it easier to determine which draw pads have not been converted to flashes. 

 

Tools > Draw To Flash > Custom Aperture  

Converts selected objects to a custom aperture definition.  
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1. Select all the objects that you want to convert to a custom aperture. 

 a. You must have at least one object selected before proceeding. 

2. Select Tools > Draw To Flash > Custom Aperture. 

3. Enter the name you want to use as a 

 reference for this custom aperture. You can 

 determine if you want FAB 3000 to replace 

 the selected objects with a new custom 

 aperture or select “All” – FAB 3000 will search 

 for all similar object groups and replace them 

 with custom apertures. 

4. FAB 3000 will now create a new custom 

 aperture and add it to the Aperture Table. 

 

 a. Nothing has changed in the active Job. FAB 3000 has simply constructed a new custom  

  aperture based from the selected objects. 

 b. The new custom aperture is now current and may be added by using the command Add >  

  Flash. 

 c. FAB 3000 is intelligent enough to recognize objects with a composite attribute and construct 

  them with dark or clear fields (like a donut). 

Tools > Convert To  

Used for converting objects to flashes and polygons. 

 

 

 

 

 

 

Tools > Convert To > Polygon  

Converts selected objects to polygons. 

1. Select all the objects that you want to convert to a raster polygon.  

 a. You must have at least one object selected before proceeding. 
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2. Select Tools > Convert To > Polygon. 

3. FAB 3000 will now calculate all boundaries and construct clean raster polygons. 

 a. This is an excellent tool for optimizing large amounts of drawn data (like a plane layer).  

 b. FAB 3000 is intelligent enough to recognize objects with a composite attribute and construct 

  them with dark or clear fields (like a donut). 

 

Tools > Convert To > Rectangle  

 Converts selected objects to rectangles. 

1. Select all the objects that you want to convert to a rectangle.  

 a. You must have at least one object selected before proceeding. 

2. Select Tools > Convert To > Rectangle. 

3. FAB 3000 will now calculate all boundaries and construct rectangles. 

 a. This is an excellent tool for optimizing large amounts of drawn data (like a plane layer).  

 b. FAB 3000 is intelligent enough to recognize objects with a composite attribute and construct 

  them with dark or clear fields (like a donut). 

 

Tools > Convert To > Circle  

Converts selected objects to circles. 

1. Select all the objects that you want to convert to circles.  

 a. You must have at least one object selected before proceeding. 

2. Select Tools > Convert To > Circle. 

3. FAB 3000 will now calculate all boundaries and construct circle. 

 a. This is an excellent tool for optimizing large amounts of drawn data (like a plane layer).  

 b. FAB 3000 is intelligent enough to recognize objects with a composite attribute and construct 

  them with dark or clear fields (like a donut). 

 

Video: Move Vias and Parts in a Gerber File 

 

http://www.youtube.com/watch?v=0iLxJVFvseA
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Tools > Convert To > Job  

Converts selected objects to a new Job. 

1. Select all the objects that you want to convert 

 to a new Job.  

 a. You must have at least one object selected 

 before proceeding. 

2. Select Tools > Convert To > Job. A Convert to 

 New Job dialog box will appear. 

3. Verify or edit settings.  

4. FAB 3000 will now create a new Job. 

 

a. Nothing has changed in the active Job. FAB 3000 has simply constructed a new Job based on the 

 selected objects. 

b. You may now access the new Job from the Workspace Browser or Insert the new Job into another 

 Job (creating hierarchy).   

c. FAB 3000 is intelligent enough to recognize objects with a composite attribute and construct  

 them with dark or clear fields (like a donut). 

 

Tools > Join Wizard  

Automatically or interactively fix and close selected open boundaries. 

 

 

 

 

Video: Join Gerber Traces Lines PCB Border 

 

http://www.youtube.com/watch?v=jOLcr6760OE
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Tools > Join Wizard > Automatic  

Automatically fix and close selected open boundaries. 

1. Select the boundary objects 

 (lines, traces, arcs, etc.) you 

 want to join. 

 a. This function requires  

  that you select objects 

  before proceeding. 

2. Select Tools > Utilities > Join. 

 The Join wizard dialog box will 

 appear. 

3. Edit or verify settings. Select 

 Next. 

 

 

4. FAB 3000 will now attempt to join all selected objects. When complete, a report will appear within 

 the dialog box describing the number of open or closed boundaries created as well as the elapsed 

 time. 

 a. If there are any open boundaries that could not be joined, FAB 3000 will automatically  

  display their locations using the Tools > Join Wizard > View Join Errors command.  

Tools > Join Wizard > Join (Interactive)  

Selectively fixes and closes open boundaries. In 

many cases after running Join > Join Wizard > 

Join (Automatic), you may discover that several 

troublesome boundaries still cannot be joined 

and closed, this is where Join Interactive is 

used. 

 

 

 

1. Select Tools > Join Wizard > Join (Interactive).  
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2. Choose the Tolerance and resulting layer for the joined objects. Select OK. 

 a. Tolerance is used when join interactive attempts to join adjacent objects. 

3. Select an object (lines, arcs, traces, etc.) on the boundary you want to join. 

 a. Join Interactive will now attempt to join adjacent objects to form the closed    
  boundary.  When there is a gap or multiple objects, Join Interactive will stop and prompt  
  you to select the next object on the boundary. 

 b. Join Interactive will also accept any coordinate point to select.  This is handy when there  
  is a big gap (or missing section) of a boundary. 

 c. Join Interactive will also accept the following commands: 

   1. End – Stop and create an open boundary. 

   2. Close – Stop and create a closed polygon. 

   3. Back – Undo last object added to Join Interactive boundary. 

4. Once the boundary has been closed, it will be automatically converted to a polygon and placed on 

 the output layer. 

5. Repeat steps 3-4.  

 

Tools > Polygon Utilities  

Utilities to edit or modify existing polygons. 

 

 

Tools > Polygon Utilities > Remove Tiny Segments: Remove small and self-intersecting segments within a 
polygon that can cause problems downstream. 

 

 

 



FAB 3000 V7 

 

Page 237 

1. Select the objects you want to clean. 

 a. This function requires that you select  
  objects before proceeding. 

2. Select Tools > Utilities > Remove Tiny 
 Segments.  

3. Verify or edit the minimum segment length 
 value and select OK. 

4. FAB 3000 will automatically remove all tiny 
 segments. 

Tools > Polygon Utilities > Slice Polygons 

Splits large polygons with many vertices into many smaller polygons.  This features is very helpful when 
exporting data CAD/CAM systems that cannot handle polygons with many vertices. This function requires 

that you have already run Join beforehand and no 
error markers were detected. 

1. Select the polygon objects you want to chop. 

2. Select Tools > Polygon Utilities > Slice 

 Polygons. 

3. Verify the maximum polygon vertices value 

 and select OK. 

4. FAB 3000 will automatically chop all selected 

        polygons. 

Tools > Polygon Utilities > Fix Invalid Polygons  

Automatically finds self-intersecting polygons.  These invalid polygons usually go undetected, and can cause 

unexpected errors & violations that result in mask failure. 

1. Select Tools > Polygon Utilities > Fix Invalid Polygons.  

2. FAB 3000 will automatically fix invalid polygons. 

3. A small dialog box will appear showing the number of fixed or invalid polygons. 
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Tools > Composite Layers  

Creates, converts, builds, and separates composites from layers. 

 

Tools > Composite Layers > De-Embed Layer  

Performs polygon de-embedding per layer using the De-Embed Layer Wizard. 

1. Select Tools > Composite Layers > 

 De-Embed Layer. The De-Embed 

 Layer wizard dialog box will appear. 

2. Verify or edit layer options.  

3. Select Next.  

4. FAB 3000 will automatically perform 

 polygon De-Embedding. 
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Tools > Composite Layers > Build 

Composite Layer  

Creates a composite from existing 

layers. 

1.  Select Tools > Composite  

  Layers > Build Composite  

  Layer. The Build Composite  

  Layer dialog box will appear. 

2.  Verify and edit options.  

3.  Select Clear All to clear 

  selections or OK to finish. 

  

 

 

 

 

Tools > Composite Layers > 

Flatten Composite Layer  

Converts an existing Composite into a 

single level layer. 

1. Select the objects you want to 

  clean. 

  a. This function requires  

   you select a composite 

   layer (a layer that has  

   objects with a   

   composite level  

   greater than 0). 

 

2. Select Tools > Composite Layers > Flatten Composite Layer. 

3. Edit or verify layer options.  

4. Select Next. 
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Tools > Composite Layers > Separate  Composite Layer  

Converts an existing composite into multiple layers. One layer per composite level.  

 

 

Tools > Composite Layers > Open Composite Layer  for Editing  

Opens an existing composite layer for editing.  

 

Tools > Composite Layers > Close  

Closes a previously opened composite layer for editing. 

 

Tools > Boolean Wizard  
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Tools > Boolean Wizard > Add  

Performs Boolean operation OR. 

1.  Select Tools > Boolean Wizard 

  > Add. 

2.  Assign Operands A and B. 

3.  Select Next.  

 

 

 

 

 

 

4.  Verify and edit options.  

5.  Select Next. 

6.  FAB 3000 will perform   

  Boolean Add calculations. 

7.   Select Finish when complete. 
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Tools > Boolean Wizard > Subtract  

Performs Boolean operation Subtract. 

1.  Select Tools > Boolean Wizard 

  > Subtract. 

2.  Assign Operands A and B. 

3.  Select Next.  

 

 

 

 

 

 

4.  Verify and edit options.  

5.  Select Next. 

6.  FAB 3000 will perform   

  Boolean Subtract calculations. 

7.   Select Finish when complete. 
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Tools > Boolean Wizard > Intersect  

Performs Boolean operation Intersect. 

1.  Select Tools > Boolean 

  Wizard > Intersect. 

2.  Assign Operands A and 

  B. 

3.  Select Next.  

 

 

 

 

 

 

4.  Verify and edit   

  options.  

5.  Select Next. 

6.  FAB 3000 will perform  

  Boolean Intersect  

  calculations. 

7.   Select Finish when  

  complete. 
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Tools > Boolean Wizard > Intersect  

Performs Boolean operation XOR. 

1.  Select Tools > Boolean 

  Wizard > Difference. 

2.  Assign Operands A and 

  B. 

3.  Select Next.  

 

 

 

 

 

 

 

4.  Verify and edit   

  options.  

5.  Select Next. 

6.  FAB 3000 will perform  

  Boolean Difference  

  calculations. 

7.   Select Finish when  

  complete. 
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Tools > Boolean Wizard > Invert  

Performs Boolean operation 

Invert. 

1.  Select Tools > Boolean 

  Wizard > Invert. 

2.  Assign Operand A. 

3.  Select Next.  

 

 

 

 

 

 

 

4.  Verify and edit   

  options.  

5.  Select Next. 

6.  FAB 3000 will perform  

  Boolean Invert   

  calculations. 

7.   Select Finish when  

  complete. 
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Tools > Boolean Wizard > Size  

Performs Boolean operation Size. 

1.  Select Tools > Boolean 

  Wizard > Size. 

2.  Assign Operand A. 

3.  Select Next.  

 

 

 

 

 

 

 

4.  Verify and edit   

  options.  

5.  Select Next. 

6.  FAB 3000 will perform  

  Boolean Size   

  calculations. 

7.   Select Finish when  

  complete. 
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Tools > Boolean Wizard > Sequential Layer  

Performs Boolean operation Sequential Layer. 

1. Select Tools > Boolean  

  Wizard > Sequential   

  Layer. 

2. Assign a Sequence.   

  See the dialog box for   

  method and operator   

  format. 

3. Select Next.  

 

 

 

 

4. Verify and edit    

 options.  

5. Select Next. 

6. FAB 3000 will perform   

 Boolean Sequential   

 Layer calculations. 

7.  Select Finish when   

 complete. 

 

 

 

 

Tools > Boolean Wizard > Assign to Group A  

Assigns Boolean objects to a complete group (A). 

Tools > Boolean Wizard > Assign to Group B  

Assigns Boolean objects to a complete group (B). 
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Tools > Film Wizard  

This unique feature from FAB 3000 is guaranteed to SAVE YOU UP TO 50% OFF on your Photoplotting 

service expenses. It will eliminate any operator errors (due to someone else wrongly mirroring or using the 

wrong polarity - i.e. Negative/Positive) and gets faster Turn-Around times.   Within 4-5 Jobs, FAB 3000 Film 

Wizard will have already paid for itself. 

Film Wizard will automatically setup Gerber layers for optimal film 
output.   This is perfect for anyone who needs to create Gerber or 
Postscript photoplots from their artwork.  

 Here's how it works: 

You’ve just finished a design which contains 8 separate layers for 
photoplotting.  Let’s assume that your design image area is 5" X 7" 
(120mm X 175mm).  If you were to send this design to your 
photoplotting service for film, you would be charged about $160 total 

($20 per film X 8 layers = $160 total).  Film Wizard will group this design into 2 larger film layers - each 
containing 4 of your original layers. The cost of using film wizard will only be $80 total ($40 per larger film X 
2 film layers). 

 Photoplotting services take your design and edit (mirror/polarity) each layer per customer instructions. 
They group & setup the individual layers onto one or more larger pieces of film.  The larger film is sent 
directly to the photoplotter, and after plotting has completed, the large film is sliced up into smaller 
individual films which are then sold to you.  

Film Wizard performs all editing (mirror/polarity), grouping, and panelization steps automatically!   With 
just a few clicks you’ll save 50%; eliminate any potential operator errors and improve your film turn-around 
time.  

Using FAB 3000 Film Wizard 

1. Go to Tools > Film Wizard. 

Assuming you have an 8 layer design, with an area of 5"X7" (120mm X 175mm).  Choose a film size that will 
be able to hold at least 4 design layers.  In this example a film size of 16" X 20" will work perfect.  (You may  

Make sure to contact your photoplotting service to determine what acceptable film sizes to use for their 
photoplotting process.  
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2. Assign options that you want to appear on each film layer: 

Output Job:  Select the output job of either Same or New. 

Border Spacing:  Minimum spacing per each individual film. 

Add Cut Lines:  Check box to add cut lines to film. 

Add Crop Marks: Check this box to add cut lines so a photoplotting service can cut individual films. 

Add Header Text: Places separate text for each layer.  Text includes the layer name and time. 

Header Label: Apply a label to the header. 

3. Select Film Setup based on your required layer design and sizing. Select Next. 
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4. Assign polarity & mirror options for each individual layer. Select Next. 
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 You’re finished! Below is the screen 
capture of the outputted layer(s) from 
Film Wizard.  Notice that mirror and 
rotation have been included 
automatically!  

 

  

  

 

 

 

At this point all you need to do now is to export these "Film Wizard" layers to either Gerber or Postscript, 
and that's it!  

 You’ve just saved 50% on your photoplotter service expenses! 
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5.10 Setup Menu 

The Setup menu provides a number of customization tools for apertures, 

NC tools, layers, and more.  

 

 

 

 

 

 

 

 

 

Setup > Aperture Table  

Displays and edits all apertures used in the workspace.  

1. Select Setup > Aperture. The 

 Aperture Table dialog box will 

 appear. 

2. Select an aperture to edit 

 from the list. 

3. Edit or verify the aperture 

 details in the preview box on 

 the right. Use the Tab key to 

 cycle through each menu. 

4. Select OK when complete. 

 

 

 

 

Video: Create Aperture and then change Dcode of selected objects using FAB 3000 

http://www.youtube.com/watch?v=gY2pXZZHkV0
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Additional functions included in the aperture table are: 

Add Aperture: Add an aperture to the list. Enter a Dcode in the entry box. When finished select OK. 

 

Delete Aperture: Deletes an unused aperture from the list. This operation cannot be undone. 

Transcode Aperture(s): Used to transcode apertures by entering starting Dcode, swell, and selecting 

specific layers. 

 

Swell Aperture: Use this entry box to Swell 

apertures in mils or mm.  
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Aperture Information: Provides information on specific apertures. Highlight an 

aperture first, then select Information. Includes information such as Dcode 

selected, total count, flashes, draws and layer count.  

 

 

 

 

 

 

Delete Unused: Deletes unused apertures. This operation cannot be undone. 

Round to: Used to Round an aperture in mils or mm. 

 

Scale Aperture: Used to scale an aperture based on scale factor. 
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Notes:  

a. Use Aperture Units to select units in mil and mm.  

b. Select the Aperture Selection button to select all apertures in the list. The entire list will highlight in 

 blue.  

c. Under Aperture preview, use the Tab key to update the display after entering or selecting a value. 

 Alternatively, use the Enter or Reset keys to edit the values. 

Setup > NC Tools Table  

Displays and edits all NC Tools used in the workspace. 

1.  Select Setup > NC  

  Tools Table. 

2.  Choose Tool Units (mil  

  or mm) and Tool  

  Display (All or Used  

  Only). 

3.  Under the Basic  

  and/or Advanced tabs, 

  verify or edit settings  

  for each NC Tool. 

 

 

 

 

 

Notes:  

 a. To edit a row double click the entry box for Size, Final Size, Comments and Sort under  

  the Basic tab. Use the checkboxes for the Plated column.  

 b. To edit a row double click the entry box for Size, Comp, Plunge (IPM), Retract (IPM), Speed, 

 Depth (in), and Max Hits under the Advanced tab. 
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Setup > Layer Table  

Displays all layer properties for the active design. Verify, sort, and edit the layer options you want to use. 

1. To activate Layer Table 

 select Setup > Layer 

 Table. 

2. Verify, edit, and sort 

 layer options. 

3. Select Apply to 

 activate edits or OK 

 when finished. 

 

 

 

 

 

 

Layer Table Overview 

#: FAB 3000 Layer Number.  

Visibility (Light bulb): Determines if objects on the layer are visible. 

 a. If the layer is visible, the bulb icon is on. 

 b. If the layer is not visible, the bulb icon is off.  

Layer Name: Name of the layer. Double click the entry box to edit the name. 

Type: Type of layer. Double click to activate the drop down menu to change the layer type. 

Draw Color: Traces and polygons on the associate layer will display that color. Click the color icon to change 

color. 

Act: Active layer. Used when adding objects (i.e. polygons, flashes, etc.). Use the checkbox to activate. 

Neg: Negative polarity. Assign a negative polarity on output for this layer. Use the checkbox to activate. 

Mir: Mirror. Assign a minor attribute for this layer. Mirror will take effect on output. Use the checkbox to 

activate. 
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Flash Color: Select flash color. Choose from Same, Dim, Contrast, or User.  

Layer Display: Display all or used layers. 

Options: Check box to draw active layer last.  

All On: Turns all layers on. All light bulb icons will be lit.  

All Off: Turns all layers off. All light bulb icons will be unlit.  

Add Layer: Adds a new layer. A dialog box will 

appear. Choose a layer name and layer type, then 

select OK. 

 

 

 

 

 

 

Apply: Applies changes you make to layer table, but keeps layer table open for additional edits and 

verification. 

OK: Saves changes and closes Layer Table dialog box. 

Setup > Layer Sets  

Groups together layers for a purpose. You can 

assign any layers and define their stack 

(redraw) order. The system allows you to 

assign layer groups to each number hot key; 

starting with 1 (the 0 key represents layer set 

10).  You can create more than 10 layer groups 

but only 10 can be assigned as hot keys. This is 

an excellent feature for quickly references sets 

of layers. 
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 a. Layer Sets require you have already imported data into the workspace Via File > Import or  

  File > Import > AutoLoad. 

Layer Sets Overview 

The Layer Sets list box shows you the names of each layer set, and what ID or number key they are assigned 

to. If no layer sets exist, the system displays only an empty, default LyrSet_1. Only layer sets will appear in 

the list. (If layer sets have already been created the first available number appears.) The name of the 

highlighted layer set appears in Layer Name text box. 

1. To add a layer set, select Add Set. To remove a layer set, select Delete Set. When adding a new 

 layer set, a default name will appear in the text box. Type the desired layer set into the Layer Name 

 text box or use the default name assigned. To add a layer name, choose Add (see #2). To delete a  

 layer name, select Delete. 

2. Click the 'Add' button under the Layers list box. This opens the Add Layer to Set box. 

3. Choose a layer that you wish to assign to this  

  layer group, and click OK. The name of the  

  layer now appears in the Layers list box.  

  When you turn ON your layer group later, the 

  last layer in sequence will automatically be  

  the active layer. 

4. Choose Display Options located underneath  
  the layer set name text box. Options include  
  View Backside, View Translucent mode (see  
  through), or Show Objects Filled. 

 5. To change the sequence of the layers in a  
  set, select any layer, and use the down or  
  up arrows to change the layer order. 

  

6. Repeat the process until all desired layers and sequences are assigned to the set.  

7. Click the OK button when you are finished. You may turn ON any desired layer set by pressing 
 'Ctrl' + its associated number key on your keyboard. 

  a. You may go back into the Layer Sets dialog box and add more user layer   
   sets, or modify existing ones. After you have created layer sets for a    
   particular design, that information is saved in your workspace so that the sets are  
   accessible for future use. 
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Setup > Synchronize Layers  

Merges all Job Layers into a commons set of layers. When merging different Jobs together, chances are that 
each of those Jobs used a different name to describe the same layer types (i.e.  "top02.pho", "topside.gbr", 
"art01.ger").  Synchronize Layers combines those layers with same types into one layer that can then be 
easily exported. 

1. To synchronize layers, select 
 Setup > Synchronize Layers. 

2. Define all layer types for the 
 child Job. Select Next.  

 a. Synchronize Layers  
  requires that you  
  define the layer the  
  layer types for all Jobs. 
  If unsure, choose the  
  layer type called  
  “Graphic” to be  
  ignored.  

 

 

 

3. Review and verify the layer  
  synchronization output.  

4. Select Next. 

5. Layer Synchronization will  
  begin. 
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6. Repeat Step #2 for each child 
 Job.  

 a. Once you have defined 
  all layer types for child 
  Jobs, Synchronize  
  Layers will begin to  
  merge the layers into  
  one common set of  
  layers. 

7. Select Finish when complete. 

 

 

 

 

Setup > Synchronize Options  

Allows you to assign default name, color, and stack up order (by layer type).  

1.  Select Setup > Synchronize 

 Options. 

2.  Drag layer types up or down 

 to determine stack up order. 

3. Double click Layer Name to 

 edit the name.  

4. When complete, select Finish. 

 a. Use Open to open  

  layer technology files  

  from your computer. 

 b. Use Save As to save  

  layer technology files  

  to your computer 

 c. Use Reset All to reset  

  layer synchronization  

  options to default  

           settings. 
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Setup > Aperture Rules Editor  

Create custom “rules” to load any aperture list file. 

1.  Select Setup > 

 Aperture Rules Editor. 

2. Verify and edit rules 

 using the Settings and 

 Line Format tab 

 (below). 

 

 

 

 

 

 

 

 

Aperture Rules Editor Settings Tab 

Aperture Rule: This drop down contains all available aperture rules.  Each aperture rule is stored as a file 
(*.rul) in the FAB 3000 sub-folder "aptrules". 

File Extension: Aperture files generated from a CAD system usually have a defined file extension.   This 
helps FAB 3000 determine which Aperture rule to use during Gerber import. 

 Move To: Aperture files generally have non-essential text at the beginning (such as part number, time 
created, etc.).  This lets FAB 3000 ignore all text lines until the defined "Move To" text is found. If left 
empty, FAB 3000 will start reading apertures at the first line. 

 Skip Additional Lines: This allows FAB 3000 to additionally skip lines after Move To. 

 Stop At: Tells FAB 3000 to stop reading aperture lines once this text has been detected. 

 Units: Units for aperture sizes.  Choose from:  Inch, Mil, or Millimeter. 

 Scale: Scale value used for aperture sizes.  1 is default. 
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Tolerated Warnings: Determines how many warnings (per Aperture Rule File) FAB 3000 will allow before 
choosing to use another aperture rules files. 

Import Rules File (*.rul): Imports aperture rules file. 

Export Rules File (*.rul): Exports aperture rules file.  

Aperture Rules Line Format Tab 

FAB 3000 includes over 24 
default Aperture 
Rules.  Reviewing these default 
Aperture Rules is a great way 
to determine how parameters 
are used to create a successful 
Aperture Rules File.  

 

 

 

 

 

 

 

Line Parameters:  

[S] = Skip    [M] = Misc 

[D] = Dcode  

[X] = X-Size 

[Y] = Y-Size 

[R] = Rotation 

[T] = Thermal Tie Width 

[I] = ID 

[O] = OD 

Line Example #1: 

RECTANGLE     100.5      20      Flash     D100 

"RECTANGLE" [X] [Y] [S] D[D] 

 

 Line Example #2:  

D35     Thermal    80     Yes     55  

D[D] "Thermal" [O] [S] [I] 
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[A] = Aperture 

 Setup > Blind and Buried Via Setup  

Assign blind and buried layer group sets. In order to perform this operation, you must have at least one 
layer type defined as Drill BlindBuried. To define a layer type as Drill BlindBuried, perform the following: 

1. Select the Drill layer (*.drl) you wish to define in the 
Layer Display Panel.  

2. Right click and select Type > Drill BlindBuried.  

 

 

 

 

 

 

 

 

 

Setup Blind and Buried Via 

1. Select Setup > Blind and 
 Buried Setup. A dialog box will 
 appear. 

2. Select the Blind or Buried Drill 
 and select the Metal Layer(s). 

3. Select OK.  

 

 

Forum: Using the Setup > Blind and Buried Via Setup Command 

http://forums.numericalinnovations.com/post/im-having-trouble-using-the-setup-blind-and-buried-via-setup-command-6692246
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Setup > Set Grid  

Assign grid settings. 

1. Select Setup > Set Grid. The Set Grid dialog 
 box will appear. 

2. Verify or edit grid settings.  

 a. Display: Select from either Grid Off,  
  Quadrelle, or Point using the drop  
  down menu. 

 b. Units: Select from either mils or mm. 

 c. Enter Size for X and Y.  

d. Enter Major Count for X and Y.  

3. When finished, select OK. 

Setup > Set Origin  

Change the location of the origin.  

1. Select Setup > Set Origin. 

2. Specify an origin point by left clicking the mouse within the   
 editor. 

3. An X/Y axes origin point will appear in the selected region of   
 the editor. 

     a. You can also specify origin point by entering the   
      coordinates of the origin point in the command line   
      box below the editor using the format X, Y (where X   
      and Y are coordinate values). 

  

Video: Set Origin of Gerber Files 

http://www.youtube.com/watch?v=5a4XBjDPLMs
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Setup > Set Background Image(s)  

Assign images to be drawn over 
existing workspace data.  

1.  Select Setup > Set  
  Background Image(s).  
  The Set Background  
  Image dialog box will  
  appear. 

2. Select Add Image to  
  insert an image. The  
  Add Image dialog box  
  will appear. 

 

 

 

3.  Choose an image to add by  
  selecting “…” in the Image File 
  Name box.  

4.  Enter a Pixel Scale. 

5.  Select Pixel Units from either  
  dpi, micron, millimeter, inch,  
  or mil. 

6.  Enter X and Y (mil) values.  

7.  Select OK. 

8. The image will be loaded into the Set Background dialog box. To add additional images, repeat steps 
 2-7. 

9. To delete an image, click the image file name and select Delete Image.  

10. To delete all images, select Clear Table. 
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Setup > Customize  

Customize FAB 3000 user commands. 

 

1. Select Setup > Customize Image. The Customize dialog box will appear. 

2. To edit a command, select the command name.  

 a. You can edit the Command Name by clicking the Short Name text entry box and entering a  

  new command name. 

3. Click the Hot Key(s) text entry box to make it active.  

4. Select a new Hot Key which will appear in the text entry box.  

 a. Use the CTRL, SHIFT, or ALT checkboxes to add an additional hot key to that command. For  

  example, a new hot key would be the letter A while pressing down on the SHIFT key. 

5. Select OK when finished. The commands entered will be saved for future use.  

 a. To restore to FAB 3000 default user commands, select Restore.  

 b. Use the Languages tab to customize the default command language.  
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Setup > General  

General settings and preferences. There are four tabs: View, Misc, Default Values, and Film Box. 

View Options: Used for general view 

settings such as units, reticle type, 

reference colors, fonts, and more. 

 

 

 

 

 

 

 

 

 

 

Misc: Miscellaneous options such as 

default folders, contact information, 

and auto save settings. 
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Default Values: Default values 

settings for tolerance, angles, 

points, and more. 

 

 

 

 

 

 

 

 

 

 

Film Box: Default film box 

options. 
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Proxy (Connection Settings):  If 

FAB 3000 is installed behind a 

firewall, it may prevent 

communication with update 

servers. Use these options to 

configure, connect, and 

authenticate internet security 

settings. 
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5.11 Applications Menu  

Used to create, open, or run custom application files. Apps are created 

using FAB 3000’s LUA Scripting Engine and are in *.lua format.  

 

 

 

New App  

 Creates a new application file. 

This assumes you already have a 

blank LUA script application file 

created.  Use notepad or text 

editor and save the file in *.lua 

file format.  

1. Select Applications > New 

App. 

2. Select the *.lua file you’ve 

created from the windows dialog 

box. Select OK. 

3. The LUA application file editor you created will open in a new tab. 

 

4. Enter the code required for your LUA application.  
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5. Right click on the tab’s title then Save your *.lua file.  

Open App  

Opens an existing *.lua 

application file.  

1. Select Applications > 

 Open App. 

2. Select the *.lua file 

 you’ve created using 

 notepad or text editor. 

 Select OK. 

 

 

3. The LUA application file editor will open in a new tab with your opened file.   

 

4. Edit the *.lua file which opened in a new tab. 

5. Right click on the tab’s title, then Save your *.lua file edits. 

Run App  

Runs a *.lua application file. 

1. Select Applications > Run App.  

2. Select the LUA  application file you 

 would like to run.  

3. Select Open. 

4. The LUA application will begin. 
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5.12 Window Menu  

The Window menu enables various browsers and edit modes.  

 

 

 

 

 

Window > Workspace Browser  

Quickly preview all loaded Job(s)/panel(s) within the workspace without having to open each on into the 

editor. 

1. Select Window > 

 Workspace Browser. 

2. The Workspace 

 Browser dialog box 

 will appear with a 

 directory tree of your 

 current Jobs.  

 a.   A preview of each  

 Job will appear toward 

 the right side of the 

 dialog box. 

3. Double click a Job or select Open to open the Job within the workspace. 

4. The selected Job will open as a new tab in the editor. 
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Window > Custom Aperture Browser  

Quickly preview all loaded custom apertures within the workspace without having to open each one into 

the editor. 

1. Select Window > Custom Aperture Browser.  

  The Custom Aperture Browser dialog box will  

  appear. 

2. Choose the Custom Aperture to open. 

3. Select OK.  

 

 

 

 

 

 

 

4. The Custom Aperture  will open as a   

 new tab in the editor. 
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Window > Footprint Browser  

Requires footprints are defined in the workspace. Allows you to view whatever available footprints are 

active within FAB 3000 (generated or imported. 

Window > CAM Editor Mode  

Switches to CAM Editor Mode.  

Window > NC Editor Mode  

Switches to NC Editor Mode. 

Window > Close All Pages  

Closes all opened pages in the editor.  
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5.13 Help Menu 

FAB 3000 offers a number of resources for help, troubleshooting, and additional configuration. 

Help > Help Guide – Online  

Links to FAB 3000 online help manual. 

 

 

 

 

 

 

 

 

Help > Tutorials and Demos  

 Links to the FAB 3000 YouTube Channel with 

dozens of video tips and resources.  
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Help > CAM Support Forum  

Links directly to the Numerical 

Innovations support forum at 

www.numericalinnovations.com.  Use 

this forum for questions, tips, and 

support help. The FAB 3000 community 

users are available to answer beginner 

and veteran questions. 

Need Help? Type a Question in FAB 

3000! 

Use this question box in the top right 

corner of the FAB 3000 workspace as a 

shortcut to the Numerical Innovations 

support forum. 

 

Help > Visit FAB 3000 on Facebook  

Stay tuned for important updates, tips, and links 

on the FAB 3000 Facebook page.  

 

 

 

 

 

 

 

 

 

 

http://www.numericalinnovations.com/
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Help > Visit FAB 3000.com  

Directly links to the FAB 3000 home page. 

From here, you can access: 

- Downloads 

- Feature Comparison 

- PDF Help Guide 

- FAB 3000 User Forum 

- FAB 3000 YouTube Page 

- FAB 3000 Facebook Page 

 

 

 

 

 

 

 

Help > Become a Numerical Reseller or Partner  

Want to be a Reseller or Partner with Numerical Innovations? Select this menu option for more information 

on Numerical Innovations partnerships and alliances. 

 

Help > Compile TrueType Fonts  

  TrueType Font selector for FAB 3000.  

  

 

 

 

 

 

 

 

 

 

 

 

Help > Compile AutoCAD SHX Fonts 

Import and add AutoCAD SHX Fonts to the workspace. 
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Help > Enter License Key  

Enter FAB 3000 license keys. For more information on licensing and registration, see section 1.3: 

Understanding Licensing & Registration. 

 

Help > Check for Updates  

This feature will send you to the Numerical Innovations web page for FAB 3000 revision history. 

 

Help > About 

General information on FAB 3000, Numerical Innovations, Copyrights, Trademarks, and License Status. 
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SECTION 6: IMPORT MATRIX FILE 

The FAB 3000 Import Matrix File permits external tools (like PCB Design software) to predefine layers and 
Jobs. This creates intelligent loading with FAB 3000 for instant Gerber Viewing & Verification.  Import 
Matrix File prevents the monotonous steps of loading Gerber & drill files, assigning layer colors & layer 
types, defining layer stack ups, and defining blind/buried drill layers (if required). It allows PCB designers to 
easily use Gerber/CAM software for its primary purpose - to quickly verify that Gerbers & drills are correct 
and ready for manufacturing.  

The FAB 3000 Import Matrix file also supports PANEL arrays which allow the merging of several PCB Jobs 
together so they can be manufactured simultaneously. This creates a significant savings in fabrication costs. 
In addition, FAB 3000 will automatically performs all necessary object transformations, Dcode, & drill tool 
transcoding. 

6.1 Import Matrix File Overview  

Simply call FAB 3000 and pass the matrix file as the first argument. 

All FAB 3000 import matrix files must end with *.fm6. 

RULE #1: LAYER arrays are always defined first. 

RULE #2: JOB arrays are defined after LAYER arrays. 

RULE #3: PANEL arrays are defined last. 

LAYER { 

   TYPE=MASK_TOP 

   NAME=smt 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=223,100,100 

   FLASH_COLOR=223,100,100 

} 

LAYER { 

   TYPE=TOP 
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   NAME=layer_1 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,223,0 

   FLASH_COLOR=100,223,0 

} 

... 

JOB { 

   NAME=test-odb++-Gerber 

   LAYER=layer_1,C:\temp\examples\274X\Art0121.pho 

   LAYER=layer_2,C:\temp\examples\274X\Art02.pho    

   LAYER=layer_4,C:\temp\examples\274X\Pgp2529.pho 

   LAYER=layer_3,C:\temp\examples\274X\gnd2530.pho    

   LAYER=sst,C:\temp\examples\274X\Sst0126.pho 

   LAYER=spt,C:\temp\examples\274X\Sp0128.pho 

   LAYER=smb,C:\temp\examples\274X\Sm0227.pho 

   LAYER=smt,C:\temp\examples\274X\Sm0128.pho 

   LAYER=d_1_2,C:\temp\examples\274X\Drill.drl 

} 

JOB { 

   NAME=board1 

   LAYER=smb,C:\temp\examples\Board1\Bottom Mask.gbr 

   LAYER=layer_4,C:\temp\examples\Board1\Bottom.gbr 
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   LAYER=smt,C:\temp\examples\Board1\Top Mask.gbr 

   LAYER=layer_1,C:\temp\examples\Board1\Top.gbr 

   LAYER=sst,C:\temp\examples\Board1\Top Silk.gbr 

   LAYER=d_1_2,C:\temp\examples\Board1\drill.drl 

} 

... 

PANEL { 

   NAME=mypanel 

   UNITS=INCH 

   WIDTH=18 

   HEIGHT=18.5 

   STEPREPEAT=board1,17.0,4,3.8,3.4,2,5,90,No 

   STEPREPEAT=test-odb++-Gerber,17.85,11.5,7,6,1,3,90,No 

} 

... 

Fields in the LAYER array 

TYPE Describes the purpose of the layer and must be one of these defined layer types. 

NAME The name of the layer.  This will be directly referenced in the JOB array. 

START_DRILL 

END_DRILL 

These fields are only used for drill layers. They specify the span of the drill, in case it 
is a blind or buried Via layers. Each field must be a valid layer name. When the fields 
are empty, the drill is assumed to be thru hole (i.e. START_DRILL is assumed to be 
the first board layer and END_DRILL is assumed to be the last board layer). 

DRAW_COLOR The RGB representation of the draw color for display of the layer. Note: RGB values 
are separated by commas. 

FLASH_COLOR The RGB representation of the flash color for display of the layer. Note: RGB values 
are separated by commas. 
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Fields in the JOB array 

NAME The name of the Job.  This will be directly referenced in the PANEL array. 

LAYER This field contains the layer name and Gerber file location, separated by a comma. 

Note: The Gerber file location must be an actual location on your system and not 
localized path (i.e. .../Gerbers/top.gbr)  

Note: For DRILL and ROUT layer types, the file location must point to a NC file (not 
Gerber).  The NC file must contain tool number, sizes in the header.  If not, we 
recommend that you define a NCTOOLS array in the FAB 3000 Import Matrix before 
the JOB array.   

Fields in the PANEL array 

NAME The name of the panel.  This will be the name FAB 3000 uses when it creates the 
panel. 

UNITS Units to use for this panel array.  Must be either: INCH or MM 

WIDTH Panel Width.  Note: The value is defined in the panel units.  

HEIGHT Panel Height.  Note: The value is defined in the panel units.  

STEPREPEAT This field contains the Job Name, X and Y Origin, X and Y Spacing, X and Y Count, Job 
Angle (must be 0, 90, 180, 270), and Mirror (must be either: YES or NO) all separated 
by a commas. 

Note: Origin and Spacing values are defined in the panel units. 

Note: If you only require a 1 up (no array) assign X and Y Spacing to 0; X and Y Count 
to 1. 

Note: Jobs must be referenced before Panel 

Fields in the NCTOOLS array 

UNITS Units to use for this nctools array.  Must be either: INCH or MM 

INTEGER 

DECIMAL 

Integer digits for drill or rout file between (0-6). 

Decimal digits for drill or rout file between (0-6). 

TYPE Drill or rout file type. 

ABSOLUTE                -- Use Absolute coordinates during NC Import 

INCREMENTAL                -- Use Incremental coordinates during NC Import 
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SUPPRESSION Drill or rout file zero suppression.  

LEADING                -- Suppress Leading Zeros during NC Import 

TRAILING                -- Suppress Trailing Zeros during NC Import 

NONE                        -- No Zero Suppression during NC Import 

TOOL This field contains the Tool # (between 1 to 1000), Diameter (in Tool Units), and 
Plated (either: YES or NO); all separated by a commas. 

Note: NCTOOLS array is optional.  It is only intended for NC files that don't include tool definitions in the 
header.  Must be called before Job 

# - Comment Line (Ignored by FAB 3000). Any line that begins with the pound character (#) will be 
ignored by FAB 3000. 

6.2 Example Matrix File #1 

This sample FAB 3000 Matrix file defines several layers and creates a single Job. 

Note: All FAB 3000 Import Matrix Files must end with *.fm6.   

# SAMPLE FAB 3000 - MATRIX FILE 

LAYER { 

   TYPE=SILK_TOP 

   NAME=sst 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=255,0,0 

   FLASH_COLOR=255,0,0 

}  

LAYER { 

   TYPE=PASTE_TOP 

   NAME=spt 



FAB 3000 V7 

 

Page 284 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,223,223 

   FLASH_COLOR=100,223,223 

} 

  

LAYER { 

   TYPE=MASK_TOP 

   NAME=smt 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=223,100,100 

   FLASH_COLOR=223,100,100 

} 

  

 LAYER { 

   TYPE=TOP 

   NAME=layer_1 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,223,0 

   FLASH_COLOR=100,223,0 

} 
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LAYER { 

   TYPE=neg_plane 

   NAME=layer_2 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=50,100,50 

   FLASH_COLOR=50,100,50 

} 

  

LAYER { 

   TYPE=neg_plane 

   NAME=layer_3 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,223,200 

   FLASH_COLOR=100,223,200 

} 

  

LAYER { 

   TYPE=BOTTOM 

   NAME=layer_4 

   START_DRILL= 
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   END_DRILL= 

   DRAW_COLOR=223,100,223 

   FLASH_COLOR=223,100,223 

} 

  

 LAYER { 

   TYPE=MASK_BOTTOM 

   NAME=smb 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=173,173,173 

   FLASH_COLOR=173,173,173 

} 

  

 LAYER { 

   TYPE=PASTE_BOTTOM 

   NAME=spb 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=192,32,32 

   FLASH_COLOR=192,32,32 

} 
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LAYER { 

   TYPE=SILK_BOTTOM 

   NAME=ssb 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,192,128 

   FLASH_COLOR=100,192,128 

} 

  

 LAYER { 

   TYPE=DRILL 

   NAME=d_1_2 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=192,192,100 

   FLASH_COLOR=192,192,100 

} 

  

 LAYER { 

   TYPE=ROUT 

   NAME=rout 

   START_DRILL= 
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   END_DRILL= 

   DRAW_COLOR=30,128,96 

   FLASH_COLOR=30,128,96 

} 

  

 LAYER { 

   TYPE=GRAPHIC 

   NAME=assemt 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=32,96,100 

   FLASH_COLOR=32,96,100 

} 

  

 LAYER { 

   TYPE=GRAPHIC 

   NAME=assemb 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=32,100,96 

   FLASH_COLOR=32,100,96 

} 
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LAYER { 

   TYPE=GRAPHIC 

   NAME=ddt 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=128,96,32 

   FLASH_COLOR=128,96,32 

} 

  

 LAYER { 

   TYPE=GRAPHIC 

   NAME=c-nummer 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=64,128,64 

   FLASH_COLOR=64,128,64 

} 

  

 LAYER { 

   TYPE=GRAPHIC 

   NAME=peel_off 

   START_DRILL= 
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   END_DRILL= 

   DRAW_COLOR=32,192,192 

   FLASH_COLOR=32,192,192 

} 

  

 JOB { 

   NAME=test-odb++-Gerber 

   LAYER=layer_1,C:\temp\examples\274X\Art0121.pho 

   LAYER=layer_2,C:\temp\examples\274X\Art02.pho    

   LAYER=layer_4,C:\temp\examples\274X\Pgp2529.pho 

   LAYER=layer_3,C:\temp\examples\274X\gnd2530.pho    

   LAYER=sst,C:\temp\examples\274X\Sst0126.pho 

   LAYER=spt,C:\temp\examples\274X\Sp0128.pho 

   LAYER=smb,C:\temp\examples\274X\Sm0227.pho 

   LAYER=smt,C:\temp\examples\274X\Sm0128.pho 

   LAYER=d_1_2,C:\temp\examples\274X\Drill.drl 

} 
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6.3 Example Matrix File #2  

This sample matrix file defines several layers, loads 3 separate Jobs, and creates a panel. 

Note: All FAB 3000 Import Matrix Files must end with *.fm6.   

# SAMPLE FAB 3000 - MATRIX FILE  

LAYER { 

   TYPE=SILK_TOP 

   NAME=sst 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=255,0,0 

   FLASH_COLOR=255,0,0 

} 

  

LAYER { 

   TYPE=PASTE_TOP 

   NAME=spt 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,223,223 

   FLASH_COLOR=100,223,223 

} 

  

LAYER { 
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   TYPE=MASK_TOP 

   NAME=smt 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=223,100,100 

   FLASH_COLOR=223,100,100 

} 

   

LAYER { 

   TYPE=TOP 

   NAME=layer_1 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,223,0 

   FLASH_COLOR=100,223,0 

} 

  

LAYER { 

   TYPE=neg_plane 

   NAME=layer_2 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=50,100,50 
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   FLASH_COLOR=50,100,50 

} 

LAYER { 

   TYPE=neg_plane 

   NAME=layer_3 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,223,200 

   FLASH_COLOR=100,223,200 

} 

  

LAYER { 

   TYPE=BOTTOM 

   NAME=layer_4 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=223,100,223 

   FLASH_COLOR=223,100,223 

} 

  

LAYER { 

   TYPE=MASK_BOTTOM 

   NAME=smb 
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   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=173,173,173 

   FLASH_COLOR=173,173,173 

} 

   

LAYER { 

   TYPE=PASTE_BOTTOM 

   NAME=spb 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=192,32,32 

   FLASH_COLOR=192,32,32 

} 

  

LAYER { 

   TYPE=SILK_BOTTOM 

   NAME=ssb 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,192,128 

   FLASH_COLOR=100,192,128 

} 
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LAYER { 

   TYPE=DRILL 

   NAME=d_1_2 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=192,192,100 

   FLASH_COLOR=192,192,100 

} 

  

LAYER { 

   TYPE=ROUT 

   NAME=rout 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=30,128,96 

   FLASH_COLOR=30,128,96 

} 

  

LAYER { 

   TYPE=GRAPHIC 

   NAME=assemt 

   START_DRILL= 
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   END_DRILL= 

   DRAW_COLOR=32,96,100 

   FLASH_COLOR=32,96,100 

} 

  

LAYER { 

   TYPE=GRAPHIC 

   NAME=assemb 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=32,100,96 

   FLASH_COLOR=32,100,96 

} 

   

LAYER { 

   TYPE=GRAPHIC 

   NAME=ddt 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=128,96,32 

   FLASH_COLOR=128,96,32 

} 
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LAYER { 

   TYPE=GRAPHIC 

   NAME=c-nummer 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=64,128,64 

   FLASH_COLOR=64,128,64 

} 

  

LAYER { 

   TYPE=GRAPHIC 

   NAME=peel_off 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=32,192,192 

   FLASH_COLOR=32,192,192 

} 

###################################################### 

#Job - 1 

JOB { 

   NAME=test-odb++-Gerber 

   LAYER=layer_1,C:\temp\examples\274X\Art0121.pho 

   LAYER=layer_2,C:\temp\examples\274X\Art02.pho    
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   LAYER=layer_4,C:\temp\examples\274X\Pgp2529.pho 

   LAYER=layer_3,C:\temp\examples\274X\gnd2530.pho    

   LAYER=sst,C:\temp\examples\274X\Sst0126.pho 

   LAYER=spt,C:\temp\examples\274X\Sp0128.pho 

   LAYER=smb,C:\temp\examples\274X\Sm0227.pho 

   LAYER=smt,C:\temp\examples\274X\Sm0128.pho 

   LAYER=d_1_2,C:\temp\examples\274X\Drill.drl 

} 

#Job - 2 

JOB { 

   NAME=board1 

   LAYER=smb,C:\temp\examples\Board1\Bottom Mask.gbr 

   LAYER=layer_4,C:\temp\examples\Board1\Bottom.gbr 

   LAYER=smt,C:\temp\examples\Board1\Top Mask.gbr 

   LAYER=layer_1,C:\temp\examples\Board1\Top.gbr 

   LAYER=sst,C:\temp\examples\Board1\Top Silk.gbr 

   LAYER=d_1_2,C:\temp\examples\Board1\drill.drl 

}  

#Job - 3 

JOB { 

   NAME=board4 

   LAYER=smb,C:\temp\examples\Board4\Bottom Mask.gbr 

   LAYER=layer_4,C:\temp\examples\Board4\Bottom.gbr 
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   LAYER=smt,C:\temp\examples\Board4\Top Mask.gbr 

   LAYER=layer_1,C:\temp\examples\Board4\Top.gbr 

   LAYER=sst,C:\temp\examples\Board4\Top Silk.gbr 

   LAYER=d_1_2,C:\temp\examples\Board4\drill.drl 

} 

#################################################### 

#Panel - 1 

PANEL { 

   NAME=mypanel 

   UNITS=INCH 

   WIDTH=18 

   HEIGHT=18.5 

   STEPREPEAT=board4,17.5,0,0,2.5,1,7,90,No 

   STEPREPEAT=board1,17.0,4,3.8,3.4,2,5,90,No 

   STEPREPEAT=test-odb++-Gerber,17.85,11.5,7,6,1,3,90,No 

} 

6.4 Example Matrix File #3 

This sample matrix file defines several layers, loads 3 separate Jobs, and creates a panel.  This Import Matrix 
also makes use of the NCTOOLS array which define tool sizes (since the drill files don't contain tool 
information inside the file header) before each JOB array. 

Note: All FAB 3000 Import Matrix Files must end with *.fm6.   

# SAMPLE FAB 3000 - MATRIX FILE 

LAYER { 

   TYPE=SILK_TOP 
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   NAME=sst 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=255,0,0 

   FLASH_COLOR=255,0,0 

} 

  

LAYER { 

   TYPE=PASTE_TOP 

   NAME=spt 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,223,223 

   FLASH_COLOR=100,223,223 

} 

  

LAYER { 

   TYPE=MASK_TOP 

   NAME=smt 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=223,100,100 

   FLASH_COLOR=223,100,100 
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} 

  

LAYER { 

   TYPE=TOP 

   NAME=layer_1 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,223,0 

   FLASH_COLOR=100,223,0 

} 

LAYER { 

   TYPE=neg_plane 

   NAME=layer_2 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=50,100,50 

   FLASH_COLOR=50,100,50 

} 

 

LAYER { 

   TYPE=neg_plane 

   NAME=layer_3 

   START_DRILL= 



FAB 3000 V7 

 

Page 302 

   END_DRILL= 

   DRAW_COLOR=100,223,200 

   FLASH_COLOR=100,223,200 

} 

 

LAYER { 

   TYPE=BOTTOM 

   NAME=layer_4 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=223,100,223 

   FLASH_COLOR=223,100,223 

} 

   

LAYER { 

   TYPE=MASK_BOTTOM 

   NAME=smb 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=173,173,173 

   FLASH_COLOR=173,173,173 

} 
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LAYER { 

   TYPE=PASTE_BOTTOM 

   NAME=spb 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=192,32,32 

   FLASH_COLOR=192,32,32 

} 

  

LAYER { 

   TYPE=SILK_BOTTOM 

   NAME=ssb 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=100,192,128 

   FLASH_COLOR=100,192,128 

} 

  

LAYER { 

   TYPE=DRILL 

   NAME=d_1_2 

   START_DRILL= 

   END_DRILL= 
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   DRAW_COLOR=192,192,100 

   FLASH_COLOR=192,192,100 

} 

  

LAYER { 

   TYPE=ROUT 

   NAME=rout 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=30,128,96 

   FLASH_COLOR=30,128,96 

} 

  

LAYER { 

   TYPE=GRAPHIC 

   NAME=assemt 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=32,96,100 

   FLASH_COLOR=32,96,100 

} 

   

LAYER { 
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   TYPE=GRAPHIC 

   NAME=assemb 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=32,100,96 

   FLASH_COLOR=32,100,96 

} 

  

LAYER { 

   TYPE=GRAPHIC 

   NAME=ddt 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=128,96,32 

   FLASH_COLOR=128,96,32 

} 

  

LAYER { 

   TYPE=GRAPHIC 

   NAME=c-nummer 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=64,128,64 
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   FLASH_COLOR=64,128,64 

} 

  

LAYER { 

   TYPE=GRAPHIC 

   NAME=peel_off 

   START_DRILL= 

   END_DRILL= 

   DRAW_COLOR=32,192,192 

   FLASH_COLOR=32,192,192 

} 

 

###################################################### 

NCTOOLS { 

   UNITS=INCH 

   INTEGER=2 

   DECIMAL=4 

   TYPE=ABSOLUTE 

   SUPPRESSION=TRAILING 

   TOOL=1,0.02,YES 

   TOOL=2,0.04,YES 

   TOOL=4,0.055,YES 

   TOOL=5,0.07,YES 
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   TOOL=10,0.105,NO 

} 

  

JOB { 

   NAME=test-odb++-Gerber 

   LAYER=layer_1,C:\temp\examples\274X\Art0121.pho 

   LAYER=layer_2,C:\temp\examples\274X\Art02.pho    

   LAYER=layer_4,C:\temp\examples\274X\Pgp2529.pho 

   LAYER=layer_3,C:\temp\examples\274X\gnd2530.pho    

   LAYER=sst,C:\temp\examples\274X\Sst0126.pho 

   LAYER=spt,C:\temp\examples\274X\Sp0128.pho 

   LAYER=smb,C:\temp\examples\274X\Sm0227.pho 

   LAYER=smt,C:\temp\examples\274X\Sm0128.pho 

   LAYER=d_1_2,C:\temp\examples\274X\Drill.drl 

} 

  

############################################## 

NCTOOLS { 

   UNITS=INCH 

   INTEGER=2 

   DECIMAL=4 

   TYPE=ABSOLUTE 

   SUPPRESSION=TRAILING 
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   TOOL=2,0.042,YES 

   TOOL=3,0.044,YES 

   TOOL=5,0.045,YES 

   TOOL=6,0.074,YES 

   TOOL=10,0.105,NO 

} 

  

JOB { 

   NAME=board1 

   LAYER=smb,C:\temp\examples\Board1\Bottom Mask.gbr 

   LAYER=layer_4,C:\temp\examples\Board1\Bottom.gbr 

   LAYER=smt,C:\temp\examples\Board1\Top Mask.gbr 

   LAYER=layer_1,C:\temp\examples\Board1\Top.gbr 

   LAYER=sst,C:\temp\examples\Board1\Top Silk.gbr 

   LAYER=d_1_2,C:\temp\examples\Board1\drill.drl 

} 

  

############################################## 

# If the drill file does not contain tool information in the header 

# the tool sizes from the previous NCTOOLS array will be used 

# for this Job also. 

  

JOB { 
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   NAME=board4 

   LAYER=smb,C:\temp\examples\Board4\Bottom Mask.gbr 

   LAYER=layer_4,C:\temp\examples\Board4\Bottom.gbr 

   LAYER=smt,C:\temp\examples\Board4\Top Mask.gbr 

   LAYER=layer_1,C:\temp\examples\Board4\Top.gbr 

   LAYER=sst,C:\temp\examples\Board4\Top Silk.gbr 

   LAYER=d_1_2,C:\temp\examples\Board4\drill.drl 

} 

  

#################################################### 

#Panel - 1 

PANEL { 

   NAME=mypanel 

   UNITS=INCH 

   WIDTH=18 

   HEIGHT=18.5 

   STEPREPEAT=board4,17.5,0,0,2.5,1,7,90,No 

   STEPREPEAT=board1,17.0,4,3.8,3.4,2,5,90,No 

   STEPREPEAT=test-odb++-Gerber,17.85,11.5,7,6,1,3,90,No 

} 

6.5 C++ Source Example for calling Matrix Fi le  

This sample shows how to call FAB 3000 and then add the matrix file as the first argument.  We're assuming 
the external tool has already created a successful matrix file called "matrix.fm6" located in the C:\Temp 
folder. 
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Note:  Simply call FAB 3000 and pass the matrix file as the first argument. 

Note:  All FAB 3000 Import Matrix Files must end with *.fm6.   

Note: This sample below is using MFC in Visual C++ 2005. 

Note:  This sample assumes that you installed FAB 3000 to "C:\Program File\Numerical 
 Innovations\FAB 3000" 

 //Start 

 STARTUPINFO si; 

 PROCESS_INFORMATION pi; 

 GetStartupInfo(&si); 

 SetCurrentDirectory( "C:\\Temp" ); 

 CString CamPath = "C:\\Program Files\\Numerical Innovations\\FAB 3000\\FAB 3000.exe"; 

 CamPath += " \"C:\\Temp\\matrix.fm6\""; 

 if( !CreateProcess( NULL,(LPCTSTR)CamPath,NULL,NULL,FALSE,0,NULL,NULL,&si,&pi)) 

 { 

         printf( "Unable to Start FAB 3000" ); 

6.6 Layer Types  

Below are a listing of the available layer types which can be used in the LAYER array, TYPE field. 

TOP Top Side Metal 

BOTTOM Bottom Side Metal 

INTERNAL Internal Metal (Positive Polarity) 

NEG_PLANE Plane (Negative Polarity -- Usually contains Thermal Dcodes) 

POS_PLANE Plane (Positive) 

DRILL NC Drill (Should have tools sizes & format embedded inside file) 

SILK_TOP Top Side Silkscreen 

SILK_BOTTOM Bottom Side Silkscreen 

MASK_TOP Top Side SolderMask 

MASK_BOTTOM Bottom Side SolderMask 
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PASTE_TOP Top Side Paste 

PASTE_BOTTOM Bottom Side Paste 

ROUT NC Rout (Should have tools sizes & format embedded inside file) 

INSULATOR Insulator Layer 

COMPONENTS_TOP Top side Components (Must be CSV Format Centroid & it will be renamed to 
"comp_+_top" 

COMPONENTS_BOTTOM Bottom side Components (Must be CSV Format Centroid & it will be renamed to 
"comp_+_bot" 

TEMPORARY Temporary Layer (Used when the Gerber type is unknown) 

FAB_DRAWING Fab Drawing (Used for reference only) 

BORDER PCB Boarder Layer 

SCORE         Score Layer used for Panel Snap-Outs 

GRAPHIC Default Layer (Used when the Gerber type is unknown) 

6.7 NCTools Array 

NCTools array is optional.  It is only intended for NC files that don't include tool definitions in the 
header.  Must be called before Job 

Fields in the NCTOOLS array 

UNITS Units to use for this nctools array.  Must be either: INCH or MM 

INTEGER 

DECIMAL 

Integer digits for drill or rout file between (0-6). 

Decimal digits for drill or rout file between (0-6). 

TYPE Drill or rout file type. 

ABSOLUTE                -- Use Absolute coordinates during NC Import 

INCREMENTAL                -- Use Incremental coordinates during NC Import 

SUPPRESSION Drill or rout file zero suppression.  

LEADING                -- Suppress Leading Zeros during NC Import 

TRAILING                -- Suppress Trailing Zeros during NC Import 

NONE                        -- No Zero Suppression during NC Import 

TOOL This field contains the Tool # (between 1 and 1000), Diameter (in Tool Units), and 
Plated (either: YES or NO); all separated by a commas. 
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Note: NCTOOLS array is optional.  It is only intended for NC files that don't include tool definitions in the 
header.  Must be called before Job  

NCTOOLS { 

   UNITS=INCH 

   INTEGER=2 

   DECIMAL=4 

   TYPE=ABSOLUTE 

   SUPPRESSION=TRAILING 

   TOOL=1,0.02,YES 

   TOOL=2,0.04,YES 

   TOOL=4,0.055,YES 

   TOOL=5,0.07,YES 

   TOOL=10,0.105,YES 

} 

JOB { 

   NAME=board1 

   LAYER=smb,C:\temp\examples\Board1\Bottom Mask.gbr 

   LAYER=layer_4,C:\temp\examples\Board1\Bottom.gbr 

   LAYER=smt,C:\temp\examples\Board1\Top Mask.gbr 

   LAYER=layer_1,C:\temp\examples\Board1\Top.gbr 

   LAYER=sst,C:\temp\examples\Board1\Top Silk.gbr 

   LAYER=d_1_2,C:\temp\examples\Board1\drill.drl 

} 
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6.8 DFMChecker Array 

DFMCHECKER array is optional. It is used to run the DFM Checker on an imported Job.  Must be called after 
Job and will only run on the previous Job loaded. 

Fields in the DFMCHECKER array 

UNITS MIL or MM Units to use for this dfmchecker array 

minimum_padsize positive 
number 

Minimum Pad size allowed 

minimum_smtpadwidth positive 
number 

Minimum SMT pad width allowed 

minimum_tracewidth positive 
number 

Minimum trace width allowed 

minimum_outer_tracespacing positive 
number 

Minimum spacing on top or bottom layers 

minimum_inner_tracespacing positive 
number 

Minimum spacing for innerlayers 

minimum_drill_pad_annularring positive 
number 

Minimum drill to pad annular ring 

minimum_border_clearance positive 
number 

Minimum clearance from board edge 

find_acidtraps positive 
number 

Locate Acid Traps 

find_nonfunctional_internalpads   Find non-functional pads on internal layers 

minimum_drillsize positive 
number 

Minimum drill hole diameter 

find_drill_doublehits   Find drill double hits 

find_drill_missinghits   Find missing drill hits 

find_missingpads   Find missing pads 

find_touchingholes   Find drill holes that touch 

minimum_silkscreen_linewidth positive 
number 

Find minimum silkscreen line width 

find_silkscreen_overmask positive 
number 

Locate silkscreen over soldermask 

silkscreen_border_clearance positive 
number 

Minimum clearance allowed from Silkscreen to 
board edge 

undersize_mask_clearance positive 
number 

Locate small mask openings 

missing_mask_clearances   Find missing mask clearances 
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find_mask_slivers   Find mask slivers 

find_solder_bridges positive 
number 

Find solder bridges 

inner_clearance positive 
number 

Inner clearance on plane layers 

power_ground_minimum_annularring positive 
number 

Minimum annular ring on plane layers 

find_starved_thermals positive 
number 

Locate starved thermals 

find_power_ground_shorts   Find power/ground shorts 

check_negplane_thermal_conflicts   Find thermal conflicts on neg. planes 

find_isolated_connections   Find isolated connections 

output_drc_pdf_file   Location for resulting PDF file, 

ipc_Netlist_file   Location of IPC-D-356 Netlist file used for 
Netlist comparison 

x_Netlist_offset   Offset IPC Netlist file in X direction 

y_Netlist_offset   Offset IPC Netlist file in Y direction 

Netlist_scale_factor positive 
number 

Scale IPC Netlist 

Note: If you do not wish to check for all of the above violations, simply omit them in the import matrix file. 

 JOB { 

   NAME=test-odb++-Gerber 

   LAYER=layer_1,274X\Art0121.pho 

   LAYER=layer_4,274X\Art02.pho    

   LAYER=layer_2,274X\Pgp2529.pho 

   LAYER=layer_3,274X\gnd2530.pho    

   LAYER=sst,274X\Sst0126.pho 

   LAYER=spt,274X\Sp0128.pho 

   LAYER=smb,274X\Sm0227.pho 

   LAYER=smt,274X\Sm0128.pho 
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   LAYER=d_1_2,274X\Drill.drl 

} 

DFMCHECKER { 

   units=mil 

   minimum_padsize=15.0 

   minimum_smtpadwidth=5.0 

   minimum_tracewidth=4.0 

   minimum_outer_tracespacing=4.0 

   minimum_inner_tracespacing=6.0 

   minimum_drill_pad_annularring=4.0 

   minimum_border_clearance=10.0 

   find_acidtraps=7.0 

   find_nonfunctional_internalpads 

   minimum_drillsize=7.0 

   find_drill_doublehits 

   find_drill_missinghits 

   find_missingpads 

   find_touchingholes 

   minimum_silkscreen_linewidth=4.0 

   find_silkscreen_overmask=1.0 

   silkscreen_border_clearance=10.0 

   undersize_mask_clearance=4.0 

   missing_mask_clearances 
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   find_mask_slivers 

   find_solder_bridges=8.0 

   inner_clearance=7.0 

   power_ground_minimum_annularring=4.0 

   find_starved_thermals=8.0 

   find_power_ground_shorts 

   check_negplane_thermal_conflicts 

   find_isolated_connections    

   output_drc_pdf_file=C:\output\mydrcfile.pdf 

   ipc_Netlist_file=C:\Netlist\testNetlist.ipc 

   x_Netlist_offset=0.0 

   y_Netlist_offset=15.0 

   Netlist_scale_factor=1.0 

} 
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SECTION 7: FAB 3000 DATA FORMAT OVERVIEW 

FAB 3000 supports many file formats, such a GDSII, DXF, OASIS, Postscript, Gerber, and more. 

7.1 Gerber Format  

Bi-directional translation of Gerber format (RS-274D, RS-274X, Fire9000, BarcoDPF) files into the 
Workspace.   Excellent for anyone who needs to make photoplots from their artwork.  

Sample Gerber screen capture inside the workspace. 

 

Gerber data is a simple, generic means of transferring printed circuit board information to a wide variety of 
devices that convert the electronic PCB data to artwork produced by a photoplotter. Virtually every PCB 
CAD system generates Gerber data because all photoplotters read it. It is a file structure consisting of X,Y 
coordinates supplemented by commands that define where the PCB image starts, what shape it will take, 
and where it ends. In addition to the coordinates, Gerber data contains aperture information, which defines 
the shapes and sizes of lines, holes, and other features.  

Gerber RS-274X: 

Extended Gerber Format, which is also called RS-274X, provides enhancements that handle polygon fill 
codes, positive/negative image compositing, and custom apertures, and other features. RS-274X also 
encapsulates the aperture list in the header of the Gerber data file and therefore allows files to pass from 
one system to another without the need to re-input the aperture table. RS-274X produces a variety of 
Gerber data called X data. 
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The Problem - Gerber files can be Difficult to Handle: 

Gerber data is unique in the fact that each file usually represents a single layer, something different from 
most other EDA formats that may contain multiple layers & designs/blocks all inside a single file.  Many 
Gerber files are not written to specification; thus many "unwritten rules" must be made to properly load in 
these files to the author’s intention. 

Here is a list of some common difficulties found inside Gerber files: 

 Transcoding of apertures - when multiple Gerber files define the same aperture Dcode, but require 
 different shapes,  

 Handle complex custom aperture definitions. 

 Handle 'user-defined' custom aperture macros ($). 

 Circular Interpolation: Arcs (G75), & Quadrant Arcs (G74) 

 Poly-Fill routines (G36, G37) 

 Support composite merging (LPD/LPC) 

 Photo Expose mode (G55) 

 Step/repeat codes (SR) 

 Offsets (OF), Units (G70, G71), Mirror(MI) 

 Zero Suppression with leading or trailing zeroes. 

 Format type: Incremental (G91) 

 Most software products have a hard time loading, & rendering Gerber files attributes properly (i.e. 
 rounded paths, custom flashes, composite layers, and step/repeat). 

Why FAB 3000 is the Perfect Solution 

FAB 3000 successfully handles all features of the Gerber (RS-274X) format.  Custom apertures, composite 
layers, and step/repeat are all correctly processed.  

 Video: Import old 274D Gerber files and Export as Embedded 

 Video: Load RS-274D Gerber file. Create Aperture List Template 

  Video: How to Easily Change the Field (i.e. reverse polarity) for Gerber files 

http://www.youtube.com/watch?v=pHxKMdwAmc0
http://www.youtube.com/watch?v=-DPAxONskrY
http://www.youtube.com/watch?v=e4mbsJlpNY4
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7.2 ODB++ Format  

ODB++ is the most intelligent CAD/CAM data exchange format available today. It captures all CAD/EDA, 
assembly, and PCB fabrication knowledge in one single, unified database. Originally developed by Valor 
Computerized Systems for use in its own PCB CAD/CAM systems, Genesis 2000, Enterprise 3000 and 
Trilogy , ODB++ has already become widely accepted as the de facto industry standard providing 
unprecedented power to PCB design, fabrication, and assembly with the flexibility to expand as required. In 
parallel, ODB++ is providing most of the technological basis for the new IPC2581 standard for data 
exchange in the PCB fabrication and assembly industry. 

 

Video: ODB++ PCB to 3D STL Conversion, view in VisCAM or Solidworks 

 

7.3 DXF Format  

DXF stands for Drawing Exchange Format, and it is a format for transferring drawings between Computer 
Aided Design systems.  DXF is widely used as the de facto standard in the engineering and construction 
industries.  The DXF format is a tagged data representation of all the information contained in an AutoCAD® 
drawing file. Tagged data means that each data element in the file is preceded by an integer number that is 
called a group code. A group code's value indicates what type of data element follows. This value also 
indicates the meaning of a data element for a given object (or record) type. Virtually all user-specified 
information in a drawing file can be represented in DXF format. 

Bi-directional translation of DXF files into the Workspace.  Excellent for anyone using software products 
such as AutoCAD, SolidWorks or ProEngineer to design complex masks, MEMs, RF/Microwave, MCM, 
Hybrid Packages, etc. 

Standard AutoCAD DXF File:                                Same DXF file Imported into FAB 3000: 

    -  

http://www.youtube.com/watch?v=vv34Y9fGMYQ
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 The Problem:  DXF files can be tricky to handle 

DXF data is probably the most extensive and difficult format to work with; especially when converting to 
other EDA formats. However it is the de facto standard file format among most engineering CAD tools. 

Here is a list of some common difficulties found inside DXF files: 

 Entities found in a Block that are drawn on layer '0', usually need to be moved to the blocks new 
 Inserted layer. If the block is Inserted onto multiple layers, the '0' layer entities from that block must 
 be moved each time. 

 A solid hatch with internal geometries, does not explicitly define the polarity of the internal 
 geometries. 

 Non-Manhattan geometries, angles, and non-uniform scaling are permitted. 

 Invalid, self-intersecting polygons are permitted. 

 Identical, overlapping entities on the same layer can be stacked on top of each other. These 
 identical entities are impossible to see, and can cause problems during conversions, etc. 

 The DXF format specifications change almost every year, with the latest releases of AutoCAD. 

 Nested Non-Manhattan transformations. 

 Tapered polylines with non-uniform widths are permitted. 

 Some boundaries may appear closed, but internally are still open. 

 Filled pads are drawn as outlines of circles, donuts, or rectangular. 

 Extraneous data such as UCS, and 3D object extrusions can be found in many files. 

 AutoCAD will not display filled areas on-screen, such as polygons, and other closed boundaries (only 
 solid hatch). Making it tough to determine the final results. 

 Fonts can be difficult to handle, especially MText (Multi-line text) 

Most vendors and mask houses stay away from accepting DXF files as input. They have a hard time dealing 
with this data and there are only a few decent software products on the market today that can reliably 
handle DXF. 
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Why FAB 3000 is the Perfect Solution 

 Since Software products such as AutoCAD, SolidWorks or ProEngineer provide an excellent way to draw 
complex masks, MEMs, RF/Microwave, MCM, Hybrid Packages, as well as drafting mechanical information 
related to the design; FAB 3000 was developed with this in mind. 

Here's how DXF Plug-In handles common difficulties found inside DXF files: 

 Block entities drawn on layer '0', are automatically handled by the option: ByBlock/ByLayer.  

 Polygon De-Embedding is used to process entity polarity for solid hatches with internal geometries. 

 All angles, and non-uniform scaling are supported. 

 Invalid, self-intersecting polygons are either automatically corrected or may be fixed using the 
 editor. 

 Identical overlapping entities are either automatically deleted, or may be fixed using the editor. 

 Every year the DXF Plug-In is updated to support the latest versions of DXF. 

 Unlimited nested transforms are supported. 

 Outlines are generated for tapered polylines with non-uniform width. 

 Open boundaries will be automatically closed when it is possible. 

 Recognizes outlined pads: round, donut & rectangular. When requested these pads are 
 automatically filled & flashed. 

 Most extraneous 3D data is ignored. 

 Direct support for TrueType fonts 

FAB 3000 is powerful, yet very easy to use, and it operates seamlessly inside of the platform.  If you design 
or work with complex masks, MEMs, RF/Microwave, MCM, Hybrid Packages, as well as mechanical drafting, 
then FAB 3000 is for you! 

 FAB 3000 also supports polygon de-embedding for solid hatches. 
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7.4 DWG Format  

FAB 3000 supports bi-directional translation of native AutoCAD DWG format. Similar to the DXF format 
except in a binary file. 

7.5 IGES Format  

IGES (Initial Graphics Exchange Specification) is a neutral graphics database format designed primarily for 
data exchange between mechanical CAD systems. The IGES file format links mechanical CAD systems to the 
2D EDA design world. Two-dimensional geometry can be used to interchange layout, or package outline 
information.  The IGES format can represent both mechanical and electrical design data in two and three 
dimensions. 

IGES requires the Add-On: “3D Formats”. 

7.6 Image Format  

FAB 3000 supports bi-directional translation of image (TIFF, PNG, GIF, BMP, etc.) files into the Workspace. 
Once these image pixels are imported into the workspace, they can be handled just as any other geometry 
(i.e. change layers, copy, export to GDSII, DXF, etc.). This is perfect for anyone who wishes to produce 
optical filters, convert company logos into a common EDA format, create grey scales, or plot images to a 
higher resolution than on an image setter. 

7.7 GDSII Format  

GDSII is a binary file format which is classified as a "data interchange format" and used for transferring 
mask-design data between the IC designer and the fabrication facility ("Fab"). 

7.8 Postscript Format  

PostScript is the industry standard for sending documents to high-resolution printers. 

Please note that Ghostscript must be installed on your workstation or server to import PostScript!  

Ghostscript is freely available and distributed under the GNU General Public License.  If you do not 
have Ghostscript installed you may download it from the following websites (or from other available 
mirrors):  

http://www.cs.wisc.edu/~ghost/doc/gnu/index.htm 

http://www.ghostscript.com/ 

 

http://www.cs.wisc.edu/~ghost/doc/gnu/index.htm
http://www.ghostscript.com/
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7.9 Large Monochrome Bitmap Format  

 

FAB 3000 bi-directionally translates large sized Bitmap files (*.bmp) with unlimited pixels.  This is very 

useful when someone wants to convert a high-resolution image into a true vector format.   

 

Image files are unit-less. A pixel can theoretically represent any physical size. It is important that you specify 

the proposed units and scale for a pixel’s physical size. Choose from DPI, Micron, Inch, Millimeter, 

Centimeter, and more. Logical pixel size is defined by Pixel Units * Image Scale. 

 

Large Monochrome Bitmap requires the Add-On: “Large Bitmap”. 

7.10 Drill/Rout Format  

NC code used to control Drill and Rout CNC machines. 

7.11 STL Format  

STL is a file format native to the stereolithography CAD software created by 3D Systems. This file format is 
supported by many other software packages and is widely used for rapid prototyping and computer-aided 
manufacturing. STL files describe only the surface geometry of a three dimensional object without any 
representation of color, texture, or other common CAD model attributes. The STL format specifies both 
ASCII and binary representations. Binary files are more common since they are more compact. ACE only 
supports the binary formats. 

STL (Stereolithography) binary format is outputted by almost every 3D design/modeling software tool. This 
includes SolidWorks, ProEngineer, and many other design packages.  STL files are unit-less and objects can 
be assigned any scale. It is important that you are aware of the imported STL file units & scale.  ACE needs 
to know what physical unit and scale to use for 1 STL unit. 

 

 

Forum: DXF to 3D STL Conversion 

 

 

 

 

 

http://forums.numericalinnovations.com/post/dxf-to-3d-stl-conversion-6487924


FAB 3000 V7 

 

Page 324 

SECTION 8: LUA SCRIPTING ENGINE 
To visit the FAB 3000 LUA API Guide, please visit: 

http://numerical-help-guide.s3.amazonaws.com/fab3000v7api/HTML/index.html 

SECTION 9: PURCHASE & SUPPORT 

9.1 How to order FAB 3000 

For product pricing, please contact our sales team below: 

Phone: 1-866-528-9274  

Hours of Operation: Monday – Friday 9:00 AM to 5:00 PM PST 

Email: sales@numericalinnovations.com 

Payment Options 

Credit Cards: We accept Paypal, VISA, MasterCard, Discover, and American Express cards. This is our 
preferred method of payment.  Additional payment methods accepted include: AMEX, Cirrus, Western 
Union, Visa (Electron), Switch, Solo, Maestro, Direct Debit, Delta, & Google Checkout. 

Purchase Orders: Company Purchase Orders are accepted. We verify company information through D&B, 
and may request trade references before processing. Terms are: Net 30 days, and the minimum order must 
exceed $750 USD. You may submit your purchase orders to our sales team by e-mail: 
sales@numericalinnovations.com or fax: (++1) 858-430-2705. 

Bank Wire Transfer: Contact us, and we will e-mail an invoice with our bank details. 

9.2 License Options  

Single User License:  A permanent license key (or activation code) that is assigned to an individual user. 

Floating (Network):  Centralized server based licensing using FLEXnet License manager (formerly FLEXlm). 
The software can be run on as many computers as needed which are connected to a centralized server 
location. The number of licenses purchased determines the number of concurrent users. 

Enterprise License (Site):  Receive a master license key that grants your company the right to install 
UNLIMITED seats of onto your workstations, networks, or on laptops without any restrictions - provided 
that our software is only used inside your company (at one Site). 

Upgrade (Existing Customers only): We offer special pricing for users who have already purchased an older 
version of our software products and now wish to upgrade to the latest version. 

http://numerical-help-guide.s3.amazonaws.com/fab3000v7api/HTML/index.html
mailto:sales@numericalinnovations.com
mailto:sales@numericalinnovations.com
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9.3 What is the Numerical  Maintenance Plan?  

We offer two support/maintenance solutions:  STANDARD and LIFETIME. Standard Maintenance is 
provided free and LIFETIME Maintenance is optional. The LIFETIME Maintenance Plan is sold at a 
discounted rate during your initial order placement. Please contact our sales team for more assistance 
sales@numericalinnovations.com 

 

 

 

 

 

LIFETIME MAINTENANCE PLAN:  

At the time of your order placement, you may optionally purchase our Lifetime Maintenance Plan (LMP) 
for the following benefits: 

 Secure Login Access to our website. 

 Receive every Upgrade, Update, & Bug-Fixes for life! 

 Unlimited & Priority Technical support from our staff. 

 Unlimited License Assistance in the event of a lost license, computer transfer, crash, etc. 

 Download Access 24/7. 

 Access to Pre-Released & Special Versions of all our software products.  

 Ability to Transfer your LIFETIME Maintenance to another user. 

STANDARD MAINTENANCE PLAN: 

 12-month Email Support for from the date of your purchase. 

 Access to the User Support Forum, and have the ability to post any questions directly on the User 
Support Forum. 

 A pay-as-you-need On-Demand Support is also available for additional assistance. 

mailto:sales@numericalinnovations.com
http://www.numericalinnovations.com/pages/support-ticket-on-demand
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9.4 FAB 3000 Customer Support 

There are several ways to get support for FAB 3000: 

Numerical Innovations User Forums 

Click one of the links below for direct access to the FAB 3000 User Forums. 

Forum: Sales and General Questions 

Sales and pre-purchase queries. 

Forum: FAB 3000 Questions & Answers 

Gerber and CAM software related queries. 

Forum: ACE 3000 Questions & Answers 

Online Support and FAQ for CAD conversions. 

Forum: EasyGerb Questions & Answers 

AutoCAD ARX Gerber conversion queries. 

Submit a support ticket 

Can’t find an answer you’re looking for? Fill out a support ticket to receive personal assistance from our 
team. 

http://www.numericalinnovations.com/pages/customer-support 

Please include a detailed explanation of the problem. Include a sample file if possible. 

Response time is within one business day or sooner. 

License Key / Activation Code Problems 

Having issues with your license? Contact sales@numericalinnovations.com 

 

General Questions 

We welcome your questions, comments, and suggestions as one critical way to continuously improve our 

services to you. For general information, use our contact form at: 

 

http://www.numericalinnovations.com/pages/contact-us 

 

 

 

http://forums.numericalinnovations.com/?forum=106296
http://forums.numericalinnovations.com/?forum=106290
http://forums.numericalinnovations.com/?forum=106289
http://forums.numericalinnovations.com/?forum=106292
http://www.numericalinnovations.com/pages/customer-support
mailto:sales@numericalinnovations.com
http://www.numericalinnovations.com/pages/contact-us
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9.5 Numerical Innovations 30 Day Guarantee  

Numerical Innovations (a Division of Caneberra Technologies, Inc.), offers you a risk free for 30 day money 

back guarantee on all of our software products. We are sure you will be pleased with its features, ease of 

use and reliability. If you are not completely satisfied, let us know within 30 days and if we cannot correct 

the problem, we will refund your money. Guaranteed. 

 

9.6 Additional Contact Information  

 

 

 

A division of Caneberra Technologies Inc. 

1888 Kalakaua Ave, Suite #C312 

Honolulu, Hawaii 96815 

Phone: 1-866-528-9274 

Fax: 1-858-430-2705 

http://www.numericalinnovations.com 

Sales Department: sales@numericalinnovations.com 

Tech. Support: support@numericalinnovations.com 

Career Opportunities: careers@numericalinnovations.com 

Partnerships / Alliances: partners@numericalnnovations.com 

 

 

 

 

 

http://www.numericalinnovations.com/
mailto:sales@numericalinnovations.com
mailto:support@numericalinnovations.com
mailto:careers@numericalinnovations.com
mailto:partners@numericalnnovations.com
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9.7 Company History 

Numerical Innovations (a division of Caneberra Technologies, Inc.) was 
founded by Simon Garrison and Steve Geiger, two veterans of the PCB 
industry with nearly 20 years of software development experience. 

Back in 1993, Simon started in the PCB industry doing CAD conversions for 
a small PCB photoplotting company in Santa Clara, California. Steve met 
Simon from a mutual friend while they were both attending San Jose State 
University – Simon in the School of Engineering, and Steve in the Business 
(Marketing) School. They immediately hit it off and became friends and 
business partners. Simon had been running his company Innovative CAD 
(Computations and Design) doing his conversion work, and Steve was 
helping with the marketing. When he explained to Steve that he was 
disappointed in how cumbersome the translation software in the market 
was, they decided to join forces to create Innovative CAD Software, Inc. 

(ICD) and they rest is history! 

Innovative CAD grew from a two man operation to one of the most recognized companies in the PCB CAM 
market with its tools AutoGERB (world's first exporting of Gerber data directly from AutoCAD) and 
CAMtastic! (CAM viewer which morphed into the first PCB DFM tool of its kind). They were the first in the 
industry to do some “cutting-edge” marketing by offering their products to be downloaded directly from 
the Web with a full 45 day trial, as well as offering complete online support. This and other sound business 
strategies positioned them for explosive growth and success. The ease of use, comprehensiveness and 
accuracy of their software tools started attracting big industry attention. ICD did a promotion with Altium, 
in which a seat of CAMtastic! was included with the purchase of their Protel software; up to that date it was 
the most successful promotion 'ever' for Altium, and subsequently ICD was acquired by Altium in 2000 for 
its remarkable technology. 

Simon (now one of the leading experts in PCB CAM software development, as well as CAD conversion 
software) went on to work with Altium for several years developing its CAM division, then started a new 
firm developing custom OEM solutions and tools for the IC/MEMs industry. Steve started a successful 
advertising and public relations firm, which he eventually sold as well. Missing that spark and passion for 
the PCB market they joined forces once again to start NI with a vision to change the landscape of the PCB 
marketplace. 

With tools like DFM Now! and FAB 3000 they are revolutionizing the way CAM and DFM are done for PCB – 
again with the philosophy of being easy to use, comprehensive and accurate, while providing exceptional 
value for their customers. 

Mission Statement:  We have become a leader in the EDA software industry by empowering electronic 
designers and engineers with clever, high quality software tools which facilitate their designs for 
manufacturing.  
 

 


